remove unused patch
This commit is contained in:
parent
dc80994b3a
commit
3db1996868
@ -1,173 +0,0 @@
|
||||
Index: jnalib/build.xml
|
||||
===================================================================
|
||||
--- jnalib/build.xml (revision 1138)
|
||||
+++ jnalib/build.xml (revision 1139)
|
||||
@@ -22,6 +22,7 @@
|
||||
<property name="dynlink.native" value="false"/>
|
||||
<property name="native" location="native"/>
|
||||
<property name="src" location="src"/>
|
||||
+ <property name="platform.src" location="contrib/platform/src"/>
|
||||
<property name="contrib" location="contrib"/>
|
||||
<property name="dist" location="dist"/>
|
||||
<property name="test.src" location="test"/>
|
||||
@@ -526,6 +527,14 @@
|
||||
</target>
|
||||
|
||||
<target name="javadoc" depends="-setup">
|
||||
+ <path id="javadoc.src.path">
|
||||
+ <path refid="src.path"/>
|
||||
+ <pathelement location="${platform.src}"/>
|
||||
+ </path>
|
||||
+ <path id="javadoc.compile.path">
|
||||
+ <path refid="compile.path"/>
|
||||
+ <pathelement location="${classes}"/>
|
||||
+ </path>
|
||||
<property name="header"
|
||||
value="<b>JNA API</><font size="-1"> ${jna.version}</font>"/>
|
||||
<property name="footer"
|
||||
@@ -534,10 +543,10 @@
|
||||
<mkdir dir="${javadoc}"/>
|
||||
<javadoc package="true"
|
||||
windowtitle="JNA API"
|
||||
- sourcepathref="src.path"
|
||||
- classpathref="compile.path"
|
||||
+ sourcepathref="javadoc.src.path"
|
||||
+ classpathref="javadoc.compile.path"
|
||||
maxmemory="256m"
|
||||
- packagenames="com.sun.jna,com.sun.jna.ptr,com.sun.jna.types,com.sun.jna.platform,com.sun.jna.platform.win32,com.sun.jna.exmaples.unix"
|
||||
+ packagenames="com.sun.jna,com.sun.jna.ptr,com.sun.jna.types,com.sun.jna.platform,com.sun.jna.platform.win32"
|
||||
overview="${src}/com/sun/jna/overview.html"
|
||||
destdir="${javadoc}">
|
||||
<!-- stylesheetfile="${stylesheet}" -->
|
||||
@@ -551,15 +560,18 @@
|
||||
<include name="com/sun/jna/**/*"/>
|
||||
</patternset>
|
||||
</packageset>
|
||||
+ <packageset dir="${platform.src}" defaultexcludes="yes">
|
||||
+ <patternset>
|
||||
+ <include name="com/sun/jna/platform/**/*"/>
|
||||
+ </patternset>
|
||||
+ </packageset>
|
||||
|
||||
<group title="Java Native Access" packages="com.sun.jna,com.sun.jna.ptr,com.sun.jna.types,com.sun.jna.win32"/>
|
||||
- <group title="Platform Specific" packages="com.sun.jna.platform"/>
|
||||
+ <group title="Platform Utilities" packages="com.sun.jna.platform,com.sun.jna.platform.dnd"/>
|
||||
+ <group title="Platform Specific" packages="com.sun.jna.platform.*"/>
|
||||
|
||||
<arg value="-notimestamp"/>
|
||||
</javadoc>
|
||||
- <subant target="javadoc">
|
||||
- <fileset dir="${contrib}" includes="platform/build.xml"/>
|
||||
- </subant>
|
||||
</target>
|
||||
|
||||
<target name="dist" depends="jar,contrib-jars,compile-tests,native,javadoc"
|
||||
@@ -632,11 +644,10 @@
|
||||
</copy>
|
||||
<zip zipfile="${dist}/doc.zip">
|
||||
<zipfileset dir="${javadoc}" prefix="javadoc"/>
|
||||
- <zipfileset dir="${contrib}/platform/dist/javadoc" prefix="platform/javadoc"/>
|
||||
</zip>
|
||||
<!-- JNA sources only, for use in Linux build from source/shared libffi -->
|
||||
<zip zipfile="${dist}/src.zip">
|
||||
- <zipfileset dir="." includes="build.xml,LICENSE.txt"/>
|
||||
+ <zipfileset dir="." includes="build.xml,pom.xml,LICENSE.txt"/>
|
||||
<zipfileset dir="${src}" includes="**/*.java" prefix="src"/>
|
||||
<zipfileset dir="${test.src}" includes="**/*.java" prefix="test"/>
|
||||
<zipfileset dir="${native}" excludes="libffi,libffi/**/*,build,build/**/*" prefix="native"/>
|
||||
Index: jnalib/contrib/platform/src/com/sun/jna/platform/mac/package.html
|
||||
===================================================================
|
||||
--- jnalib/contrib/platform/src/com/sun/jna/platform/mac/package.html (revision 0)
|
||||
+++ jnalib/contrib/platform/src/com/sun/jna/platform/mac/package.html (revision 1139)
|
||||
@@ -0,0 +1,13 @@
|
||||
+<html>
|
||||
+<head>
|
||||
+<!--
|
||||
+ Copyright (c) 2010 Timothy Wall
|
||||
+-->
|
||||
+</head>
|
||||
+<body bgcolor="white">
|
||||
+
|
||||
+<!-- One sentence summary -->
|
||||
+Provides common library mappings for the OS X platform.
|
||||
+
|
||||
+</body>
|
||||
+</html>
|
||||
\ No newline at end of file
|
||||
Index: jnalib/contrib/platform/src/com/sun/jna/platform/win32/package.html
|
||||
===================================================================
|
||||
--- jnalib/contrib/platform/src/com/sun/jna/platform/win32/package.html (revision 0)
|
||||
+++ jnalib/contrib/platform/src/com/sun/jna/platform/win32/package.html (revision 1139)
|
||||
@@ -0,0 +1,13 @@
|
||||
+<html>
|
||||
+<head>
|
||||
+<!--
|
||||
+ Copyright (c) 2010 Timothy Wall
|
||||
+-->
|
||||
+</head>
|
||||
+<body bgcolor="white">
|
||||
+
|
||||
+<!-- One sentence summary -->
|
||||
+Provides common library mappings for the Windows platform.
|
||||
+
|
||||
+</body>
|
||||
+</html>
|
||||
\ No newline at end of file
|
||||
Index: jnalib/contrib/platform/src/com/sun/jna/platform/unix/package.html
|
||||
===================================================================
|
||||
--- jnalib/contrib/platform/src/com/sun/jna/platform/unix/package.html (revision 0)
|
||||
+++ jnalib/contrib/platform/src/com/sun/jna/platform/unix/package.html (revision 1139)
|
||||
@@ -0,0 +1,13 @@
|
||||
+<html>
|
||||
+<head>
|
||||
+<!--
|
||||
+ Copyright (c) 2010 Timothy Wall
|
||||
+-->
|
||||
+</head>
|
||||
+<body bgcolor="white">
|
||||
+
|
||||
+<!-- One sentence summary -->
|
||||
+Provides common library mappings for Unix and X11-based platforms.
|
||||
+
|
||||
+</body>
|
||||
+</html>
|
||||
\ No newline at end of file
|
||||
Index: jnalib/contrib/platform/src/com/sun/jna/platform/dnd/package.html
|
||||
===================================================================
|
||||
--- jnalib/contrib/platform/src/com/sun/jna/platform/dnd/package.html (revision 0)
|
||||
+++ jnalib/contrib/platform/src/com/sun/jna/platform/dnd/package.html (revision 1139)
|
||||
@@ -0,0 +1,14 @@
|
||||
+<html>
|
||||
+<head>
|
||||
+<!--
|
||||
+ Copyright (c) 2010 Timothy Wall
|
||||
+-->
|
||||
+</head>
|
||||
+<body bgcolor="white">
|
||||
+
|
||||
+<!-- One sentence summary -->
|
||||
+Provides integrated, extended drag and drop functionality,
|
||||
+allowing ghosted drag images to be used on all platforms.
|
||||
+
|
||||
+</body>
|
||||
+</html>
|
||||
\ No newline at end of file
|
||||
Index: jnalib/contrib/platform/src/com/sun/jna/platform/package.html
|
||||
===================================================================
|
||||
--- jnalib/contrib/platform/src/com/sun/jna/platform/package.html (revision 0)
|
||||
+++ jnalib/contrib/platform/src/com/sun/jna/platform/package.html (revision 1139)
|
||||
@@ -0,0 +1,13 @@
|
||||
+<html>
|
||||
+<head>
|
||||
+<!--
|
||||
+ Copyright (c) 2010 Timothy Wall
|
||||
+-->
|
||||
+</head>
|
||||
+<body bgcolor="white">
|
||||
+
|
||||
+<!-- One sentence summary -->
|
||||
+Provides cross-platform utilities based on platform-specific libraries.
|
||||
+
|
||||
+</body>
|
||||
+</html>
|
||||
\ No newline at end of file
|
8
jna.spec
8
jna.spec
@ -25,9 +25,9 @@ Patch1: jna-3.4.0-loadlibrary.patch
|
||||
# for problems.
|
||||
Patch2: jna-3.4.0-tests-headless.patch
|
||||
# Build using GCJ javadoc
|
||||
Patch4: jna-3.2.7-gcj-javadoc.patch
|
||||
Patch3: jna-3.2.7-gcj-javadoc.patch
|
||||
# junit cames from rpm
|
||||
Patch5: jna-3.4.0-junit.patch
|
||||
Patch4: jna-3.4.0-junit.patch
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
|
||||
# We manually require libffi because find-requires doesn't work
|
||||
@ -84,8 +84,8 @@ This package contains the contributed examples for %{name}.
|
||||
sed -e 's|@JNIPATH@|%{_libdir}/%{name}|' %{PATCH1} | patch -p1
|
||||
%patch2 -p1 -b .tests-headless
|
||||
chmod -Rf a+rX,u+w,g-w,o-w .
|
||||
%patch4 -p0 -b .gcj-javadoc
|
||||
%patch5 -p1 -b .junit
|
||||
%patch3 -p0 -b .gcj-javadoc
|
||||
%patch4 -p1 -b .junit
|
||||
cp %{SOURCE1} %{SOURCE2} ./
|
||||
|
||||
# UnloadTest fail during build since we modify class loading
|
||||
|
Loading…
Reference in New Issue
Block a user