Update depmap calls and fix tests compilation issue.
This commit is contained in:
parent
78cc21ba97
commit
0e0f84cac6
13
jna-4.0.0-fix-native-test.patch
Normal file
13
jna-4.0.0-fix-native-test.patch
Normal file
@ -0,0 +1,13 @@
|
||||
diff --git a/test/com/sun/jna/NativeTest.java b/test/com/sun/jna/NativeTest.java
|
||||
index a946ca8..b71c9ec 100644
|
||||
--- a/test/com/sun/jna/NativeTest.java
|
||||
+++ b/test/com/sun/jna/NativeTest.java
|
||||
@@ -410,7 +410,7 @@ public class NativeTest extends TestCase {
|
||||
for (int i=0;i < args.length;i++) {
|
||||
System.out.println("Running tests on class " + args[i]);
|
||||
try {
|
||||
- junit.textui.TestRunner.run(Class.forName(args[i]));
|
||||
+ junit.textui.TestRunner.run((Class) Class.forName(args[i]));
|
||||
}
|
||||
catch(Throwable e) {
|
||||
e.printStackTrace();
|
13
jna.spec
13
jna.spec
@ -2,7 +2,7 @@
|
||||
|
||||
Name: jna
|
||||
Version: 4.0.0
|
||||
Release: 2%{?dist}
|
||||
Release: 3%{?dist}
|
||||
Summary: Pure Java access to native libraries
|
||||
|
||||
Group: Development/Libraries
|
||||
@ -32,6 +32,7 @@ Patch3: jna-3.5.2-gcj-javadoc.patch
|
||||
Patch4: jna-4.0.0-junit.patch
|
||||
Patch5: jna-4.0.0-charfix.patch
|
||||
Patch6: jna-4.0.0-ffi.patch
|
||||
Patch7: jna-4.0.0-fix-native-test.patch
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
|
||||
# We manually require libffi because find-requires doesn't work
|
||||
@ -98,6 +99,7 @@ chmod -Rf a+rX,u+w,g-w,o-w .
|
||||
%patch4 -p1 -b .junit
|
||||
%patch5 -p1 -b .charfix
|
||||
%patch6 -p1 -b .ffi
|
||||
%patch7 -p1
|
||||
|
||||
# all java binaries must be removed from the sources
|
||||
#find . -name '*.jar' -delete
|
||||
@ -137,12 +139,12 @@ install -m 755 build/native*/libjnidispatch*.so %{buildroot}%{_libdir}/%{name}/
|
||||
%if 0%{?fedora} >= 9 || 0%{?rhel} > 5
|
||||
# install maven pom file
|
||||
install -Dm 644 pom-%{name}.xml %{buildroot}%{_mavenpomdir}/JPP-%{name}.pom
|
||||
install -Dm 644 pom-%{name}-platform.xml %{buildroot}%{_mavenpomdir}/JPP.%{name}-platform.pom
|
||||
install -Dm 644 pom-%{name}-platform.xml %{buildroot}%{_mavenpomdir}/JPP.%{name}-%{name}-platform.pom
|
||||
|
||||
# ... and maven depmap
|
||||
%if 0%{?fedora} >= 9
|
||||
%add_maven_depmap JPP-%{name}.pom %{name}.jar
|
||||
%add_maven_depmap JPP.%{name}-platform.pom -f platform %{name}/platform.jar
|
||||
%add_maven_depmap JPP.%{name}-%{name}-platform.pom -f platform %{name}/%{name}-platform.jar
|
||||
%else
|
||||
%add_to_maven_depmap net.java.dev.jna jna-platform %{version} JPP jna-platform
|
||||
mv %{buildroot}%{_mavendepmapfragdir}/%{name} %{buildroot}%{_mavendepmapfragdir}/%{name}-platform
|
||||
@ -204,12 +206,15 @@ rm -rf %{buildroot}
|
||||
%defattr(-,root,root,-)
|
||||
%{_javadir}/%{name}
|
||||
%if 0%{?fedora} >= 9 || 0%{?rhel} > 5
|
||||
%{_mavenpomdir}/JPP.%{name}-platform.pom
|
||||
%{_mavenpomdir}/JPP.%{name}-%{name}-platform.pom
|
||||
%{_mavendepmapfragdir}/%{name}-platform
|
||||
%endif
|
||||
|
||||
|
||||
%changelog
|
||||
* Fri Jan 10 2014 Roland Grunberg <rgrunber@redhat.com> - 4.0.0-3
|
||||
- Update depmap calls and fix tests compilation issue.
|
||||
|
||||
* Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.0.0-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user