Update to upstream version 4.5.0
This commit is contained in:
parent
f5623bca30
commit
02b3586320
1
.gitignore
vendored
1
.gitignore
vendored
@ -11,3 +11,4 @@ jna-3.2.7.tar.bz2
|
|||||||
/jna-4.2.2-clean.tar.xz
|
/jna-4.2.2-clean.tar.xz
|
||||||
/jna-4.3.0-clean.tar.xz
|
/jna-4.3.0-clean.tar.xz
|
||||||
/jna-4.4.0-clean.tar.xz
|
/jna-4.4.0-clean.tar.xz
|
||||||
|
/jna-4.5.0-clean.tar.xz
|
||||||
|
@ -1,4 +1,4 @@
|
|||||||
From c72c148b343d0071cb89bb71caa56ce8c73cdd8f Mon Sep 17 00:00:00 2001
|
From d9b409e9d7cf16a8bb109f3336cb8c8f4e8a3531 Mon Sep 17 00:00:00 2001
|
||||||
From: Michael Simacek <msimacek@redhat.com>
|
From: Michael Simacek <msimacek@redhat.com>
|
||||||
Date: Mon, 16 Jan 2017 11:29:06 +0100
|
Date: Mon, 16 Jan 2017 11:29:06 +0100
|
||||||
Subject: [PATCH 1/5] Adapt build
|
Subject: [PATCH 1/5] Adapt build
|
||||||
@ -8,10 +8,10 @@ Subject: [PATCH 1/5] Adapt build
|
|||||||
1 file changed, 1 insertion(+), 2 deletions(-)
|
1 file changed, 1 insertion(+), 2 deletions(-)
|
||||||
|
|
||||||
diff --git a/native/Makefile b/native/Makefile
|
diff --git a/native/Makefile b/native/Makefile
|
||||||
index a465660..1325d8c 100644
|
index 6f9ad25..3712a9e 100644
|
||||||
--- a/native/Makefile
|
--- a/native/Makefile
|
||||||
+++ b/native/Makefile
|
+++ b/native/Makefile
|
||||||
@@ -107,7 +107,7 @@ CDEFINES=-D_REENTRANT
|
@@ -97,7 +97,7 @@ CDEFINES=-D_REENTRANT
|
||||||
PCFLAGS=-W -Wall -Wno-unused -Wno-parentheses
|
PCFLAGS=-W -Wall -Wno-unused -Wno-parentheses
|
||||||
CFLAGS=$(PCFLAGS) $(CFLAGS_EXTRA) $(COPT) $(CDEBUG) $(CDEFINES) $(CINCLUDES) \
|
CFLAGS=$(PCFLAGS) $(CFLAGS_EXTRA) $(COPT) $(CDEBUG) $(CDEFINES) $(CINCLUDES) \
|
||||||
-DJNA_JNI_VERSION='"$(JNA_JNI_VERSION)"' -DCHECKSUM='"$(CHECKSUM)"'
|
-DJNA_JNI_VERSION='"$(JNA_JNI_VERSION)"' -DCHECKSUM='"$(CHECKSUM)"'
|
||||||
@ -20,7 +20,7 @@ index a465660..1325d8c 100644
|
|||||||
ifeq ($(DYNAMIC_LIBFFI),true)
|
ifeq ($(DYNAMIC_LIBFFI),true)
|
||||||
CFLAGS += $(shell pkg-config --cflags libffi 2>/dev/null || echo)
|
CFLAGS += $(shell pkg-config --cflags libffi 2>/dev/null || echo)
|
||||||
LIBS += $(shell pkg-config --libs libffi 2>/dev/null || echo -lffi)
|
LIBS += $(shell pkg-config --libs libffi 2>/dev/null || echo -lffi)
|
||||||
@@ -432,7 +432,6 @@ $(BUILD)/$(JNA_JNI_VERSION).stamp:
|
@@ -455,7 +455,6 @@ $(BUILD)/$(JNA_JNI_VERSION).stamp:
|
||||||
|
|
||||||
$(LIBRARY): $(JNIDISPATCH_OBJS) $(FFI_LIB)
|
$(LIBRARY): $(JNIDISPATCH_OBJS) $(FFI_LIB)
|
||||||
$(LD) $(LDFLAGS) $(JNIDISPATCH_OBJS) $(FFI_LIB) $(LIBS)
|
$(LD) $(LDFLAGS) $(JNIDISPATCH_OBJS) $(FFI_LIB) $(LIBS)
|
||||||
@ -29,5 +29,5 @@ index a465660..1325d8c 100644
|
|||||||
$(TESTLIB): $(BUILD)/testlib.o
|
$(TESTLIB): $(BUILD)/testlib.o
|
||||||
$(LD) $(LDFLAGS) $< $(LIBS)
|
$(LD) $(LDFLAGS) $< $(LIBS)
|
||||||
--
|
--
|
||||||
2.9.3
|
2.13.5
|
||||||
|
|
||||||
|
@ -1,4 +1,4 @@
|
|||||||
From a94220ca2121dc886a2f1f643bc53ac56575701d Mon Sep 17 00:00:00 2001
|
From d16fea5f0fb7720ca4d7b58d4facfb36eb293ef4 Mon Sep 17 00:00:00 2001
|
||||||
From: Michael Simacek <msimacek@redhat.com>
|
From: Michael Simacek <msimacek@redhat.com>
|
||||||
Date: Mon, 16 Jan 2017 11:31:32 +0100
|
Date: Mon, 16 Jan 2017 11:31:32 +0100
|
||||||
Subject: [PATCH 2/5] Load system library
|
Subject: [PATCH 2/5] Load system library
|
||||||
@ -8,7 +8,7 @@ Subject: [PATCH 2/5] Load system library
|
|||||||
1 file changed, 4 insertions(+), 93 deletions(-)
|
1 file changed, 4 insertions(+), 93 deletions(-)
|
||||||
|
|
||||||
diff --git a/src/com/sun/jna/Native.java b/src/com/sun/jna/Native.java
|
diff --git a/src/com/sun/jna/Native.java b/src/com/sun/jna/Native.java
|
||||||
index 274bb78..39c57f4 100644
|
index 91b195f..9ac3815 100644
|
||||||
--- a/src/com/sun/jna/Native.java
|
--- a/src/com/sun/jna/Native.java
|
||||||
+++ b/src/com/sun/jna/Native.java
|
+++ b/src/com/sun/jna/Native.java
|
||||||
@@ -829,101 +829,12 @@ public final class Native implements Version {
|
@@ -829,101 +829,12 @@ public final class Native implements Version {
|
||||||
@ -118,5 +118,5 @@ index 274bb78..39c57f4 100644
|
|||||||
|
|
||||||
static final String JNA_TMPLIB_PREFIX = "jna";
|
static final String JNA_TMPLIB_PREFIX = "jna";
|
||||||
--
|
--
|
||||||
2.9.3
|
2.13.5
|
||||||
|
|
||||||
|
@ -1,4 +1,4 @@
|
|||||||
From 22264992b93d5f0d92cef180fa491311b53dcd19 Mon Sep 17 00:00:00 2001
|
From 02150119b13f944ed40ab9b6335eb1540de52516 Mon Sep 17 00:00:00 2001
|
||||||
From: Michael Simacek <msimacek@redhat.com>
|
From: Michael Simacek <msimacek@redhat.com>
|
||||||
Date: Mon, 16 Jan 2017 11:32:32 +0100
|
Date: Mon, 16 Jan 2017 11:32:32 +0100
|
||||||
Subject: [PATCH 3/5] Tests headless
|
Subject: [PATCH 3/5] Tests headless
|
||||||
@ -8,10 +8,10 @@ Subject: [PATCH 3/5] Tests headless
|
|||||||
1 file changed, 1 insertion(+)
|
1 file changed, 1 insertion(+)
|
||||||
|
|
||||||
diff --git a/build.xml b/build.xml
|
diff --git a/build.xml b/build.xml
|
||||||
index 051bdaa..121d7c8 100644
|
index b956b6e..10fdab2 100644
|
||||||
--- a/build.xml
|
--- a/build.xml
|
||||||
+++ b/build.xml
|
+++ b/build.xml
|
||||||
@@ -1088,6 +1088,7 @@ osname=macosx;processor=x86;processor=x86-64;processor=ppc
|
@@ -1118,6 +1118,7 @@ osname=macosx;processor=x86;processor=x86-64;processor=ppc
|
||||||
<sysproperty key="jna.builddir" file="${build}"/>
|
<sysproperty key="jna.builddir" file="${build}"/>
|
||||||
<sysproperty key="jna.nativedir" file="${build.native}"/>
|
<sysproperty key="jna.nativedir" file="${build.native}"/>
|
||||||
<jvmarg value="${vmopt.arch}"/>
|
<jvmarg value="${vmopt.arch}"/>
|
||||||
@ -20,5 +20,5 @@ index 051bdaa..121d7c8 100644
|
|||||||
<formatter type="brief" usefile="false"/>
|
<formatter type="brief" usefile="false"/>
|
||||||
<formatter type="xml"/>
|
<formatter type="xml"/>
|
||||||
--
|
--
|
||||||
2.9.3
|
2.13.5
|
||||||
|
|
||||||
|
@ -1,4 +1,4 @@
|
|||||||
From cbcbf6e6e47a1a9b6548314c2981290da4737c9c Mon Sep 17 00:00:00 2001
|
From 5c45622fff4f2f4ed80b4619f4b575af6bac6a22 Mon Sep 17 00:00:00 2001
|
||||||
From: Michael Simacek <msimacek@redhat.com>
|
From: Michael Simacek <msimacek@redhat.com>
|
||||||
Date: Tue, 31 Jan 2017 14:21:19 +0100
|
Date: Tue, 31 Jan 2017 14:21:19 +0100
|
||||||
Subject: [PATCH 4/5] Fix javadoc build
|
Subject: [PATCH 4/5] Fix javadoc build
|
||||||
@ -8,10 +8,10 @@ Subject: [PATCH 4/5] Fix javadoc build
|
|||||||
1 file changed, 1 insertion(+)
|
1 file changed, 1 insertion(+)
|
||||||
|
|
||||||
diff --git a/build.xml b/build.xml
|
diff --git a/build.xml b/build.xml
|
||||||
index 121d7c8..457e0fb 100644
|
index 10fdab2..56f2b6e 100644
|
||||||
--- a/build.xml
|
--- a/build.xml
|
||||||
+++ b/build.xml
|
+++ b/build.xml
|
||||||
@@ -1193,6 +1193,7 @@ osname=macosx;processor=x86;processor=x86-64;processor=ppc
|
@@ -1223,6 +1223,7 @@ osname=macosx;processor=x86;processor=x86-64;processor=ppc
|
||||||
<group title="Platform Specific" packages="com.sun.jna.platform.*"/>
|
<group title="Platform Specific" packages="com.sun.jna.platform.*"/>
|
||||||
|
|
||||||
<arg value="-notimestamp"/>
|
<arg value="-notimestamp"/>
|
||||||
@ -20,5 +20,5 @@ index 121d7c8..457e0fb 100644
|
|||||||
<jar jarfile="${platform-javadoc-jar}">
|
<jar jarfile="${platform-javadoc-jar}">
|
||||||
<fileset dir="${javadoc}" />
|
<fileset dir="${javadoc}" />
|
||||||
--
|
--
|
||||||
2.9.3
|
2.13.5
|
||||||
|
|
||||||
|
@ -1,4 +1,4 @@
|
|||||||
From 2f4dd94744a4367b5022837f64b7b113923580e8 Mon Sep 17 00:00:00 2001
|
From 3e50e65e9139587414959e89e7721eff5c38552b Mon Sep 17 00:00:00 2001
|
||||||
From: Mikolaj Izdebski <mizdebsk@redhat.com>
|
From: Mikolaj Izdebski <mizdebsk@redhat.com>
|
||||||
Date: Mon, 10 Jul 2017 11:48:43 +0200
|
Date: Mon, 10 Jul 2017 11:48:43 +0200
|
||||||
Subject: [PATCH 5/5] Fix duplicate manifest entry
|
Subject: [PATCH 5/5] Fix duplicate manifest entry
|
||||||
@ -9,10 +9,10 @@ Resolves https://bugzilla.redhat.com/show_bug.cgi?id=1469022
|
|||||||
1 file changed, 2 insertions(+), 2 deletions(-)
|
1 file changed, 2 insertions(+), 2 deletions(-)
|
||||||
|
|
||||||
diff --git a/build.xml b/build.xml
|
diff --git a/build.xml b/build.xml
|
||||||
index 457e0fb..366cba2 100644
|
index 56f2b6e..f9713da 100644
|
||||||
--- a/build.xml
|
--- a/build.xml
|
||||||
+++ b/build.xml
|
+++ b/build.xml
|
||||||
@@ -541,9 +541,9 @@ osname=macosx;processor=x86;processor=x86-64;processor=ppc
|
@@ -561,9 +561,9 @@ osname=macosx;processor=x86;processor=x86-64;processor=ppc
|
||||||
includes="*jnidispatch*"
|
includes="*jnidispatch*"
|
||||||
prefix="com/sun/jna/w32ce-arm"/>
|
prefix="com/sun/jna/w32ce-arm"/>
|
||||||
</jar>
|
</jar>
|
||||||
@ -25,5 +25,5 @@ index 457e0fb..366cba2 100644
|
|||||||
|
|
||||||
<target name="aar" depends="jar" description="Build Android Archive">
|
<target name="aar" depends="jar" description="Build Android Archive">
|
||||||
--
|
--
|
||||||
2.9.3
|
2.13.5
|
||||||
|
|
||||||
|
7
jna.spec
7
jna.spec
@ -1,6 +1,6 @@
|
|||||||
Name: jna
|
Name: jna
|
||||||
Version: 4.4.0
|
Version: 4.5.0
|
||||||
Release: 7%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: Pure Java access to native libraries
|
Summary: Pure Java access to native libraries
|
||||||
# Most of code is dual-licensed under either LGPL 2.1 only or Apache
|
# Most of code is dual-licensed under either LGPL 2.1 only or Apache
|
||||||
# License 2.0. WeakIdentityHashMap.java was taken from Apache CXF,
|
# License 2.0. WeakIdentityHashMap.java was taken from Apache CXF,
|
||||||
@ -126,6 +126,9 @@ install -m 755 build/native*/libjnidispatch*.so %{buildroot}%{_libdir}/%{name}/
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Sep 19 2017 Michael Simacek <msimacek@redhat.com> - 4.5.0-1
|
||||||
|
- Update to upstream version 4.5.0
|
||||||
|
|
||||||
* Thu Aug 03 2017 Fedora Release Engineering <releng@fedoraproject.org> - 4.4.0-7
|
* Thu Aug 03 2017 Fedora Release Engineering <releng@fedoraproject.org> - 4.4.0-7
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
|
||||||
|
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (jna-4.4.0-clean.tar.xz) = b3be08b309efc05c168901aab51358f1ad8c7feba7335745da685dc6afad3b5c12ba9d4198f139dbf9abe5d0bfa5947219edcbdf94d0350e6cb1ce4d40ae2570
|
SHA512 (jna-4.5.0-clean.tar.xz) = 7d9e009bdc708ac139feec2eac994937bff5ae962b1fa4d684b0a824cc6f694a7e958a0df9e5949f2cdfd3e7e9f828ec174f3b304b0eb94db47131fa76a6a38e
|
||||||
|
Loading…
Reference in New Issue
Block a user