import jetty-9.4.30-2.v20200611.module+el8.2.1+7436+4afdca1f
This commit is contained in:
commit
4d0a8f0dd8
1
.gitignore
vendored
Normal file
1
.gitignore
vendored
Normal file
@ -0,0 +1 @@
|
||||
SOURCES/jetty-9.4.30.v20200611.tar.gz
|
1
.jetty.metadata
Normal file
1
.jetty.metadata
Normal file
@ -0,0 +1 @@
|
||||
45ff99f15d38a07462f614dfaffbd578ba91de3a SOURCES/jetty-9.4.30.v20200611.tar.gz
|
25
SOURCES/0001-Distro-jetty.home.patch
Normal file
25
SOURCES/0001-Distro-jetty.home.patch
Normal file
@ -0,0 +1,25 @@
|
||||
From 7e9bed1ca10901a3cf28775d9563570e94e2280b Mon Sep 17 00:00:00 2001
|
||||
From: Mat Booth <mat.booth@redhat.com>
|
||||
Date: Mon, 9 Sep 2019 12:42:10 +0100
|
||||
Subject: [PATCH] Distro jetty.home
|
||||
|
||||
---
|
||||
.../org/eclipse/jetty/start/config/CommandLineConfigSource.java | 2 ++
|
||||
1 file changed, 2 insertions(+)
|
||||
|
||||
diff --git a/jetty-start/src/main/java/org/eclipse/jetty/start/config/CommandLineConfigSource.java b/jetty-start/src/main/java/org/eclipse/jetty/start/config/CommandLineConfigSource.java
|
||||
index 792413e..5e5cab9 100644
|
||||
--- a/jetty-start/src/main/java/org/eclipse/jetty/start/config/CommandLineConfigSource.java
|
||||
+++ b/jetty-start/src/main/java/org/eclipse/jetty/start/config/CommandLineConfigSource.java
|
||||
@@ -120,6 +120,8 @@ public class CommandLineConfigSource implements ConfigSource
|
||||
try
|
||||
{
|
||||
Path home = new File(new URI(m.group(1))).getParentFile().toPath();
|
||||
+ if (home.endsWith("/usr/share/java/jetty"))
|
||||
+ home = new File(home.toString().replaceAll("java/jetty$", "jetty")).toPath();
|
||||
setProperty(BaseHome.JETTY_HOME, home.toString(), ORIGIN_INTERNAL_FALLBACK);
|
||||
return home;
|
||||
}
|
||||
--
|
||||
2.20.1
|
||||
|
10
SOURCES/LICENSE-MIT
Normal file
10
SOURCES/LICENSE-MIT
Normal file
@ -0,0 +1,10 @@
|
||||
Copyright (c) 2008-2009 Bjoern Hoehrmann <bjoern@hoehrmann.de>
|
||||
Permission is hereby granted, free of charge, to any person obtaining a copy of this software and associated documentation files (the "Software"), to deal
|
||||
in the Software without restriction, including without limitation the rights to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
|
||||
copies of the Software, and to permit persons to whom the Software is furnished to do so, subject to the following conditions:
|
||||
|
||||
The above copyright notice and this permission notice shall be included in all copies or substantial portions of the Software.
|
||||
|
||||
THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS
|
||||
FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER
|
||||
IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
|
7
SOURCES/jetty.logrotate
Normal file
7
SOURCES/jetty.logrotate
Normal file
@ -0,0 +1,7 @@
|
||||
/var/log/jetty/jetty-console.log {
|
||||
copytruncate
|
||||
weekly
|
||||
rotate 52
|
||||
compress
|
||||
missingok
|
||||
}
|
18
SOURCES/jetty.service
Normal file
18
SOURCES/jetty.service
Normal file
@ -0,0 +1,18 @@
|
||||
# Systemd unit file for jetty
|
||||
#
|
||||
# Multiple copies of this service (i.e. multiple concurrently running
|
||||
# jetty servers) are not supported right now. Expect this to come with
|
||||
# future updates
|
||||
|
||||
[Unit]
|
||||
Description=Jetty Web Application Server
|
||||
After=syslog.target network.target
|
||||
|
||||
[Service]
|
||||
Type=simple
|
||||
ExecStart=/usr/share/jetty/bin/jetty.sh
|
||||
User=jetty
|
||||
Group=jetty
|
||||
|
||||
[Install]
|
||||
WantedBy=multi-user.target
|
135
SOURCES/jetty.sh
Normal file
135
SOURCES/jetty.sh
Normal file
@ -0,0 +1,135 @@
|
||||
#!/usr/bin/env bash
|
||||
# Configuration files
|
||||
#
|
||||
# /etc/default/jetty
|
||||
# If it exists, this is read at the start of script. It may perform any
|
||||
# sequence of shell commands, like setting relevant environment variables.
|
||||
#
|
||||
# /etc/jetty.conf
|
||||
# If found, and no configurations were given on the command line,
|
||||
# the file will be used as this script's configuration.
|
||||
# Each line in the file may contain:
|
||||
# - A comment denoted by the pound (#) sign as first non-blank character.
|
||||
# - The path to a regular file, which will be passed to jetty as a
|
||||
# config.xml file.
|
||||
# - The path to a directory. Each *.xml file in the directory will be
|
||||
# passed to jetty as a config.xml file.
|
||||
# - All other lines will be passed, as-is to the start.jar
|
||||
#
|
||||
# The files will be checked for existence before being passed to jetty.
|
||||
#
|
||||
# Configuration variables
|
||||
#
|
||||
# JAVA
|
||||
# Command to invoke Java. If not set, java (from the PATH) will be used.
|
||||
#
|
||||
# JAVA_OPTIONS
|
||||
# Extra options to pass to the JVM
|
||||
#
|
||||
# JETTY_HOME
|
||||
# Where Jetty is installed. If not set, the script will try go
|
||||
# guess it by first looking at the invocation path for the script,
|
||||
# and then by looking in standard locations as $HOME/opt/jetty
|
||||
# and /opt/jetty. The java system property "jetty.home" will be
|
||||
# set to this value for use by configure.xml files, f.e.:
|
||||
#
|
||||
# <Arg><Property name="jetty.home" default="."/>/webapps/jetty.war</Arg>
|
||||
#
|
||||
# JETTY_BASE
|
||||
# Where your Jetty base directory is. If not set, the value from
|
||||
# $JETTY_HOME will be used.
|
||||
#
|
||||
# JETTY_ARGS
|
||||
# The default arguments to pass to jetty.
|
||||
# For example
|
||||
# JETTY_ARGS=jetty.port=8080 jetty.spdy.port=8443 jetty.secure.port=443
|
||||
#
|
||||
|
||||
set -e -C
|
||||
|
||||
readConfig()
|
||||
{
|
||||
echo "Reading $1.."
|
||||
source "$1"
|
||||
}
|
||||
|
||||
CONFIGS=()
|
||||
|
||||
if [ -f /etc/default/jetty ]; then
|
||||
readConfig /etc/default/jetty
|
||||
fi
|
||||
|
||||
if [ -z "$JETTY_HOME" ]; then
|
||||
JETTY_HOME=/usr/share/jetty
|
||||
fi
|
||||
|
||||
if [ -z "$JETTY_BASE" ]; then
|
||||
JETTY_BASE="$JETTY_HOME"
|
||||
fi
|
||||
|
||||
cd "$JETTY_BASE"
|
||||
JETTY_BASE="$PWD"
|
||||
|
||||
if [ -z "$JETTY_CONF" ]
|
||||
then
|
||||
JETTY_CONF=/etc/jetty.conf
|
||||
fi
|
||||
|
||||
if [ -f "$JETTY_CONF" ] && [ -r "$JETTY_CONF" ]
|
||||
then
|
||||
while read -r CONF
|
||||
do
|
||||
if expr "$CONF" : '#' >/dev/null ; then
|
||||
continue
|
||||
fi
|
||||
|
||||
if [ -d "$CONF" ]
|
||||
then
|
||||
# assume it's a directory with configure.xml files
|
||||
# for example: /etc/jetty.d/
|
||||
# sort the files before adding them to the list of JETTY_ARGS
|
||||
for XMLFILE in "$CONF/"*.xml
|
||||
do
|
||||
if [ -r "$XMLFILE" ] && [ -f "$XMLFILE" ]
|
||||
then
|
||||
JETTY_ARGS+=("$XMLFILE")
|
||||
else
|
||||
echo "** WARNING: Cannot read '$XMLFILE' specified in '$JETTY_CONF'"
|
||||
fi
|
||||
done
|
||||
else
|
||||
# assume it's a command line parameter (let start.jar deal with its validity)
|
||||
JETTY_ARGS+=("$CONF")
|
||||
fi
|
||||
done < "$JETTY_CONF"
|
||||
fi
|
||||
|
||||
if [ -z "$JAVA" ]
|
||||
then
|
||||
. /usr/share/java-utils/java-functions
|
||||
set_jvm
|
||||
set_javacmd
|
||||
JAVA="$JAVACMD"
|
||||
fi
|
||||
|
||||
if [ -z "$JETTY_LOGS" ] && [ -d $JETTY_BASE/logs ]
|
||||
then
|
||||
JETTY_LOGS=/var/log/jetty/logs
|
||||
fi
|
||||
JAVA_OPTIONS+=("-Djetty.logs=$JETTY_LOGS")
|
||||
|
||||
JAVA_OPTIONS+=("-Djetty.home=$JETTY_HOME" "-Djetty.base=$JETTY_BASE")
|
||||
|
||||
JETTY_START="$JETTY_HOME/start.jar"
|
||||
START_INI="$JETTY_BASE/start.ini"
|
||||
if [ ! -f "$START_INI" ]
|
||||
then
|
||||
echo "Cannot find a start.ini in your JETTY_BASE directory: $JETTY_BASE" 2>&2
|
||||
exit 1
|
||||
fi
|
||||
|
||||
RUN_ARGS=(${JAVA_OPTIONS[@]} -jar "$JETTY_START" ${JETTY_ARGS[*]})
|
||||
RUN_CMD=("$JAVA" ${RUN_ARGS[@]})
|
||||
|
||||
echo -n "Starting Jetty: "
|
||||
${RUN_CMD[*]}
|
1786
SPECS/jetty.spec
Normal file
1786
SPECS/jetty.spec
Normal file
File diff suppressed because it is too large
Load Diff
Loading…
Reference in New Issue
Block a user