ship license in correct tag
This commit is contained in:
parent
c12530534b
commit
8074600908
30
jbigkit-covscan.patch
Normal file
30
jbigkit-covscan.patch
Normal file
@ -0,0 +1,30 @@
|
||||
diff --git a/libjbig/jbig.c b/libjbig/jbig.c
|
||||
index 751ceff..3c76e07 100644
|
||||
--- a/libjbig/jbig.c
|
||||
+++ b/libjbig/jbig.c
|
||||
@@ -889,7 +889,7 @@ void jbg_enc_options(struct jbg_enc_state *s, int order, int options,
|
||||
if (order >= 0 && order <= 0x0f) s->order = order;
|
||||
if (options >= 0) s->options = options;
|
||||
if (l0 > 0) s->l0 = l0;
|
||||
- if (mx >= 0 && my < 128) s->mx = mx;
|
||||
+ if (mx >= 0 && mx < 128) s->mx = mx;
|
||||
if (my >= 0 && my < 256) s->my = my;
|
||||
|
||||
return;
|
||||
diff --git a/pbmtools/Makefile b/pbmtools/Makefile
|
||||
index 85e1783..6ae2d33 100644
|
||||
--- a/pbmtools/Makefile
|
||||
+++ b/pbmtools/Makefile
|
||||
@@ -56,9 +56,9 @@ test82: pbmtojbg jbgtopbm
|
||||
make IMG=sandra "OPTIONSP=-o 2" OPTIONSJ= dotest2g
|
||||
make IMG=multi OPTIONSP= OPTIONSJ= dotest2g
|
||||
make IMG=multi OPTIONSP=-b OPTIONSJ=-b dotest2g
|
||||
- make IMG=mx "OPTIONSP=-q -s 3 -m 128" dotest1
|
||||
- make IMG=mx "OPTIONSP=-q -s 3 -m 128" dotest2b
|
||||
- make IMG=mx "OPTIONSP=-q -s 3 -m 128 -p 92" dotest2b
|
||||
+ make IMG=mx "OPTIONSP=-q -s 3 -m 127" dotest1
|
||||
+ make IMG=mx "OPTIONSP=-q -s 3 -m 127" dotest2b
|
||||
+ make IMG=mx "OPTIONSP=-q -s 3 -m 127 -p 92" dotest2b
|
||||
make IMG=mx "OPTIONSP=-q -Y -1" dotest2b
|
||||
make IMG=mx "OPTIONSP=-Y -1" dotest2b
|
||||
rm -f test-*.jbg test-*.pbm test-*.pgm
|
@ -1,6 +1,6 @@
|
||||
Name: jbigkit
|
||||
Version: 2.1
|
||||
Release: 14%{?dist}
|
||||
Release: 15%{?dist}
|
||||
Summary: JBIG1 lossless image compression tools
|
||||
|
||||
License: GPLv2+
|
||||
@ -9,6 +9,8 @@ Source0: http://www.cl.cam.ac.uk/~mgk25/download/jbigkit-%{version}.tar.g
|
||||
Patch0: jbigkit-2.1-shlib.patch
|
||||
Patch1: jbigkit-2.0-warnings.patch
|
||||
Patch2: jbigkit-ldflags.patch
|
||||
# patch for coverity issues - backported from upstream
|
||||
Patch3: jbigkit-covscan.patch
|
||||
|
||||
# gcc is no longer in buildroot by default
|
||||
# gcc needed for libjbig library and several filters - jbigtopbm, pbmtojbig e.g.
|
||||
@ -52,6 +54,8 @@ formats.
|
||||
%patch1 -p1 -b .warnings
|
||||
# jbigkit: Partial Fedora build flags injection (bug #1548546)
|
||||
%patch2 -p1 -b .ldflags
|
||||
# covscan issues - backported from upstream
|
||||
%patch3 -p1 -b .covscan
|
||||
|
||||
%build
|
||||
# get the correct redhat build flags
|
||||
@ -99,6 +103,9 @@ make test
|
||||
%{_includedir}/jbig*.h
|
||||
|
||||
%changelog
|
||||
* Thu Oct 25 2018 Zdenek Dohnal <zdohnal@redhat.com> - 2.1-15
|
||||
- fixed typo found by coverity
|
||||
|
||||
* Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 2.1-14
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user