Build with $RPM_OPT_FLAGS again
This commit is contained in:
parent
1e1ecfd6db
commit
4b65f6577e
@ -6,7 +6,7 @@ diff -Naur jbigkit-2.1.old/libjbig/Makefile jbigkit-2.1/libjbig/Makefile
|
||||
|
||||
# Options for the compiler: A high optimization level is suggested
|
||||
-CFLAGS = -g -O -W -Wall -ansi -pedantic # --coverage
|
||||
+CFLAGS ?= -g -O -W -Wall -ansi -pedantic # --coverage
|
||||
+CFLAGS = $(RPM_OPT_FLAGS) -W -Wall -ansi -pedantic # --coverage
|
||||
+PICFLAGS := -fPIC -DPIC
|
||||
|
||||
-all: libjbig.a libjbig85.a tstcodec tstcodec85
|
||||
@ -61,11 +61,18 @@ diff -Naur jbigkit-2.1.old/libjbig/Makefile jbigkit-2.1/libjbig/Makefile
|
||||
diff -Naur jbigkit-2.1.old/Makefile jbigkit-2.1/Makefile
|
||||
--- jbigkit-2.1.old/Makefile 2014-03-27 19:47:15.000000000 +0100
|
||||
+++ jbigkit-2.1/Makefile 2014-08-04 10:52:09.242027746 +0200
|
||||
@@ -10,19 +10,20 @@
|
||||
@@ -4,25 +4,26 @@
|
||||
CC = gcc
|
||||
|
||||
# Options for the compiler: A high optimization level is suggested
|
||||
-CFLAGS = -O2 -W -Wno-unused-result
|
||||
+CFLAGS = $(RPM_OPT_FLAGS) -W -Wno-unused-result
|
||||
# CFLAGS = -O -g -W -Wall -Wno-unused-result -ansi -pedantic # -DDEBUG
|
||||
|
||||
export CC CFLAGS
|
||||
|
||||
VERSION=2.1
|
||||
+export VERSION CFLAGS CC
|
||||
+export VERSION
|
||||
|
||||
all: lib pbm
|
||||
@echo "Enter 'make test' in order to start some automatic tests."
|
||||
@ -105,7 +112,7 @@ diff -Naur jbigkit-2.1.old/pbmtools/Makefile jbigkit-2.1/pbmtools/Makefile
|
||||
|
||||
# Options for the compiler
|
||||
-CFLAGS = -g -O -W -Wall -Wno-unused-result -ansi -pedantic # --coverage
|
||||
+CFLAGS ?= -g -O -W -Wall -Wno-unused-result -ansi -pedantic # --coverage
|
||||
+CFLAGS = $(RPM_OPT_FLAGS) -W -Wall -Wno-unused-result -ansi -pedantic # --coverage
|
||||
CPPFLAGS = -I../libjbig
|
||||
|
||||
.SUFFIXES: .1 .5 .txt $(SUFFIXES)
|
||||
|
@ -1,6 +1,6 @@
|
||||
Name: jbigkit
|
||||
Version: 2.1
|
||||
Release: 2%{?dist}
|
||||
Release: 3%{?dist}
|
||||
Summary: JBIG1 lossless image compression tools
|
||||
|
||||
Group: Development/Libraries
|
||||
@ -50,7 +50,7 @@ formats.
|
||||
%patch1 -p1 -b .warnings
|
||||
|
||||
%build
|
||||
make %{?_smp_mflags} CCFLAGS="$RPM_OPT_FLAGS"
|
||||
make %{?_smp_mflags}
|
||||
|
||||
%install
|
||||
mkdir -p $RPM_BUILD_ROOT%{_libdir}
|
||||
@ -92,6 +92,9 @@ make test
|
||||
%{_includedir}/jbig*.h
|
||||
|
||||
%changelog
|
||||
* Sun Sep 7 2014 Ville Skyttä <ville.skytta@iki.fi> - 2.1-3
|
||||
- Build with $RPM_OPT_FLAGS again
|
||||
|
||||
* Sat Aug 16 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.1-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user