diff --git a/jaxb.spec b/jaxb.spec
index 465de00..4b5c40f 100644
--- a/jaxb.spec
+++ b/jaxb.spec
@@ -1,8 +1,6 @@
-%bcond_with bootstrap
-
Name: jaxb
Version: 4.0.1
-Release: 3%{?dist}
+Release: 4%{?dist}
Summary: JAXB Reference Implementation
# EDL-1.0 license is BSD-3-clause
License: BSD
@@ -13,22 +11,19 @@ ExclusiveArch: %{java_arches} noarch
Source0: %{url}/archive/%{version}-RI/%{name}-%{version}.tar.gz
BuildRequires: maven-local
-BuildRequires: mvn(org.apache.ant:ant)
-BuildRequires: mvn(org.apache.maven.plugins:maven-assembly-plugin)
-BuildRequires: mvn(org.apache.maven.plugins:maven-dependency-plugin)
-BuildRequires: mvn(org.apache.felix:maven-bundle-plugin)
-BuildRequires: mvn(org.apache.maven.plugins:maven-source-plugin)
-BuildRequires: mvn(org.codehaus.mojo:build-helper-maven-plugin)
-%if %{without bootstrap}
BuildRequires: mvn(com.sun.istack:istack-commons-runtime)
BuildRequires: mvn(com.sun.istack:istack-commons-tools)
BuildRequires: mvn(com.sun.xml.dtd-parser:dtd-parser)
BuildRequires: mvn(com.sun.xml.fastinfoset:FastInfoset)
BuildRequires: mvn(jakarta.activation:jakarta.activation-api)
BuildRequires: mvn(jakarta.xml.bind:jakarta.xml.bind-api)
+BuildRequires: mvn(org.apache.ant:ant)
+BuildRequires: mvn(org.apache.felix:maven-bundle-plugin)
+BuildRequires: mvn(org.apache.maven.plugins:maven-assembly-plugin)
+BuildRequires: mvn(org.apache.maven.plugins:maven-dependency-plugin)
+BuildRequires: mvn(org.apache.maven.plugins:maven-source-plugin)
+BuildRequires: mvn(org.codehaus.mojo:build-helper-maven-plugin)
BuildRequires: mvn(org.jvnet.staxex:stax-ex)
-BuildRequires: mvn(xml-resolver:xml-resolver)
-%endif
%description
GlassFish JAXB Reference Implementation.
@@ -61,7 +56,6 @@ easily parse XML Schema documents and inspect information in them. It is
expected to be useful for applications that need to take XML Schema as an
input.
-%if %{without bootstrap}
%package core
Summary: JAXB Core
@@ -69,6 +63,8 @@ Summary: JAXB Core
JAXB Core module. Contains sources required by XJC, JXC and Runtime modules.
%package rngom
+# pom.xml and module-info.java are under BSD, rest is MIT
+License: MIT and BSD
Summary: RELAX NG Object Model/Parser
%description rngom
@@ -87,6 +83,8 @@ Summary: TXW2 Runtime
TXW is a library that allows you to write XML documents.
%package xjc
+# jaxb-ri/xjc/src/main/java/com/sun/tools/xjc/reader/internalizer/NamespaceContextImpl.java is under ASL 2.0
+License: BSD and ASL 2.0
Summary: JAXB XJC
%description xjc
@@ -99,7 +97,6 @@ Summary: TXW2 Compiler
%description txwc2
JAXB schema generator. The tool to generate XML schema based on java classes.
-%endif
%prep
%setup -q -n jaxb-ri-%{version}-RI
@@ -115,16 +112,6 @@ pushd jaxb-ri
# Skip docs generation because of missing dependencies
%pom_xpath_remove "pom:profiles/pom:profile[pom:id='default-profile']/pom:modules"
-%if %{with bootstrap}
-%pom_xpath_set 'pom:modules' '
- codemodel
- external
- xsom
-'
-%pom_xpath_set 'pom:modules' '
- relaxng-datatype
-' external
-%else
# Disable unneeded extra OSGi bundles
%pom_disable_module bundles
@@ -132,7 +119,6 @@ pushd jaxb-ri
%pom_disable_module jxc
%pom_remove_dep org.eclipse.angus:angus-activation core
-%endif
# Don't install aggregator and parent poms
%mvn_package :jaxb-bom __noinstall
@@ -164,7 +150,6 @@ popd
%files relaxng-datatype -f jaxb-ri/.mfiles-relaxng-datatype
%license LICENSE.md NOTICE.md
%files xsom -f jaxb-ri/.mfiles-xsom
-%if %{without bootstrap}
%files core -f jaxb-ri/.mfiles-jaxb-core
%files rngom -f jaxb-ri/.mfiles-rngom
%files runtime -f jaxb-ri/.mfiles-jaxb-runtime
@@ -172,9 +157,11 @@ popd
%license LICENSE.md NOTICE.md
%files txwc2 -f jaxb-ri/.mfiles-txwc2
%files xjc -f jaxb-ri/.mfiles-jaxb-xjc
-%endif
%changelog
+* Wed Feb 08 2023 Marian Koncek - 4.0.1-4
+- Change license, remove bootstrap macro
+
* Thu Jan 19 2023 Fedora Release Engineering - 4.0.1-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_38_Mass_Rebuild