First import after review (#796201)

This commit is contained in:
Juan Hernandez 2012-03-12 13:36:45 +01:00
parent e5fe81b3af
commit 313bef32f6
14 changed files with 822 additions and 0 deletions

1
.gitignore vendored
View File

@ -0,0 +1 @@
/glassfish-jaxb-2.2.5.tar.gz

17
build-javadoc.xml Normal file
View File

@ -0,0 +1,17 @@
<?xml version="1.0"?>
<project name="javadoc" default="build">
<target name="build">
<mkdir dir="apidocs" />
<javadoc destdir="apidocs">
<fileset dir="runtime/src" includes="**/*.java"/>
<fileset dir="xjc/src" includes="**/*.java"/>
</javadoc>
<copy todir="apidocs">
<fileset dir="runtime/src" includes="**/doc-files/**/*"/>
<fileset dir="xjc/src" includes="**/doc-files/**/*"/>
</copy>
</target>
</project>

View File

@ -0,0 +1,106 @@
--- a/jaxb-impl.pom
+++ b/jaxb-impl.pom
@@ -43,12 +43,6 @@
<project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/maven-v4_0_0.xsd">
- <parent>
- <groupId>net.java</groupId>
- <artifactId>jvnet-parent</artifactId>
- <version>1</version>
- </parent>
-
<modelVersion>4.0.0</modelVersion>
<groupId>com.sun.xml.bind</groupId>
<artifactId>jaxb-impl</artifactId>
@@ -91,6 +85,37 @@
<url>http://java.net/projects/jaxb/sources/version2/show/branches/jaxb-2_2-branch/jaxb-ri</url>
</scm>
+ <dependencies>
+ <dependency>
+ <groupId>isorelax</groupId>
+ <artifactId>isorelax</artifactId>
+ <scope>system</scope>
+ <systemPath>/usr/share/java/isorelax.jar</systemPath>
+ </dependency>
+ <dependency>
+ <groupId>msv-msv</groupId>
+ <artifactId>msv-msv</artifactId>
+ <scope>system</scope>
+ <systemPath>/usr/share/java/msv-msv.jar</systemPath>
+ </dependency>
+ <dependency>
+ <groupId>relaxngDatatype</groupId>
+ <artifactId>relaxngDatatype</artifactId>
+ <scope>system</scope>
+ <systemPath>/usr/share/java/relaxngDatatype.jar</systemPath>
+ </dependency>
+ <dependency>
+ <groupId>com.sun.istack</groupId>
+ <artifactId>istack-commons-runtime</artifactId>
+ <version>2.6.1</version>
+ </dependency>
+ <dependency>
+ <groupId>com.sun.xml.txw2</groupId>
+ <artifactId>txw2</artifactId>
+ <version>20110809</version>
+ </dependency>
+ </dependencies>
+
<dependencyManagement>
<dependencies>
<dependency>
--- a/jaxb-xjc.pom
+++ b/jaxb-xjc.pom
@@ -43,12 +43,6 @@
<project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/maven-v4_0_0.xsd">
- <parent>
- <groupId>net.java</groupId>
- <artifactId>jvnet-parent</artifactId>
- <version>1</version>
- </parent>
-
<modelVersion>4.0.0</modelVersion>
<groupId>com.sun.xml.bind</groupId>
<artifactId>jaxb-xjc</artifactId>
@@ -91,6 +85,37 @@
<url>http://java.net/projects/jaxb/sources/version2/show/branches/jaxb-2_2-branch/jaxb-ri</url>
</scm>
+ <dependencies>
+ <dependency>
+ <groupId>isorelax</groupId>
+ <artifactId>isorelax</artifactId>
+ <scope>system</scope>
+ <systemPath>/usr/share/java/isorelax.jar</systemPath>
+ </dependency>
+ <dependency>
+ <groupId>msv-msv</groupId>
+ <artifactId>msv-msv</artifactId>
+ <scope>system</scope>
+ <systemPath>/usr/share/java/msv-msv.jar</systemPath>
+ </dependency>
+ <dependency>
+ <groupId>relaxngDatatype</groupId>
+ <artifactId>relaxngDatatype</artifactId>
+ <scope>system</scope>
+ <systemPath>/usr/share/java/relaxngDatatype.jar</systemPath>
+ </dependency>
+ <dependency>
+ <groupId>com.sun.istack</groupId>
+ <artifactId>istack-commons-runtime</artifactId>
+ <version>2.6.1</version>
+ </dependency>
+ <dependency>
+ <groupId>com.sun.xml.txw2</groupId>
+ <artifactId>txw2</artifactId>
+ <version>20110809</version>
+ </dependency>
+ </dependencies>
+
<dependencyManagement>
<dependencies>
<dependency>

View File

@ -0,0 +1,37 @@
From bc4b149aa582d1663db86141533477a3a7ca937e Mon Sep 17 00:00:00 2001
From: Juan Hernandez <juan.hernandez@redhat.com>
Date: Sat, 10 Mar 2012 18:04:52 +0100
Subject: [PATCH 7/7] Don't build examples
---
build.xml | 14 --------------
1 files changed, 0 insertions(+), 14 deletions(-)
diff --git a/build.xml b/build.xml
index 7b18a8e..4da31cb 100644
--- a/build.xml
+++ b/build.xml
@@ -880,20 +880,6 @@
</parallel>
- <antcall target="process-sample.notinwspack"/>
- <!-- copy samples -->
- <mkdir dir="${jaxb.dist}/samples"/>
- <copy todir="${jaxb.dist}/samples">
- <fileset dir="${jaxb.root}/samples/work" defaultexcludes="yes">
- <exclude name="CHANGELOG.txt"/>
- <exclude name="**/build.golden.regexp"/>
- <exclude name="**/.cvsignore"/>
- <exclude name="**/sample.meta"/>
- <exclude name="**/gen-src/**/*"/>
- <exclude name="**/classes/**/*"/>
- </fileset>
- </copy>
-
</target>
<target name="push-snapshot-to-maven">
--
1.7.9

View File

@ -0,0 +1,44 @@
From a954f6d671b5c3f334a80e803db77362500c1e48 Mon Sep 17 00:00:00 2001
From: Juan Hernandez <juan.hernandez@redhat.com>
Date: Sat, 10 Mar 2012 17:20:13 +0100
Subject: [PATCH 4/5] Don't bundle other jars
---
build.xml | 7 -------
1 files changed, 0 insertions(+), 7 deletions(-)
diff --git a/build.xml b/build.xml
index 12631a1..4dda9ef 100644
--- a/build.xml
+++ b/build.xml
@@ -830,7 +830,6 @@
<fileset dir="${runtime-fi.classes}"/>
<fileset dir="${runtime-staxex.classes}"/>
<fileset dir="${runtime.src}" includes="META-INF/**/*" />
- <zipgroupfileset dir="${jaxb.libs.runtime2}" includes="*.jar" />
</jar>
</sequential>
@@ -854,19 +853,13 @@ Class-Path: ${manifest.classpath}
<mapper type="glob" from="*.java" to="*.java_" />
</copy>
- <mkdir dir="${jaxb.root}/build/jaxb-xjc-rejar"/>
- <unzip dest="${jaxb.root}/build/jaxb-xjc-rejar">
- <fileset dir="${jaxb.libs.compiler}" includes="*.jar" />
- </unzip>
<jar jarfile="${jaxb.dist}/lib/jaxb-xjc.jar"
manifest="${xjc.root}/manifest.xjc"
duplicate="fail">
<!-- can't use zipgroupfileset because of the duplicate LICENSE.txt -->
- <fileset dir="${jaxb.root}/build/jaxb-xjc-rejar"/>
<fileset dir="${xjc.classes}"/>
<metainf dir="${xjc.src}/META-INF" />
</jar>
- <delete dir="${jaxb.root}/build/jaxb-xjc-rejar"/>
</sequential>
<!-- copy bin scripts -->
--
1.7.9

View File

@ -0,0 +1,60 @@
From 2dd0e1c44601db267fab47fa903c3f478d624d53 Mon Sep 17 00:00:00 2001
From: Juan Hernandez <juan.hernandez@redhat.com>
Date: Sat, 10 Mar 2012 17:11:14 +0100
Subject: [PATCH 2/5] Don't generate 1.0 runtime
---
build.xml | 23 +----------------------
1 files changed, 1 insertions(+), 22 deletions(-)
diff --git a/build.xml b/build.xml
index 7e95870..12631a1 100644
--- a/build.xml
+++ b/build.xml
@@ -798,7 +798,7 @@
<!-- generate a distribution -->
<target name="dist"
- depends="compile, integrate-1.0-compiler"
+ depends="compile"
description="create a distribution in jaxb-ri/dist">
<mkdir dir="${jaxb.dist}" />
<mkdir dir="${jaxb.dist}/bin" />
@@ -834,25 +834,6 @@
</jar>
</sequential>
- <!-- JAXB 1.0 runtime jar -->
- <!-- generate jaxb1-impl.jar for 1.0 runtime -->
- <!-- include the contents of the old jaxb-libs.jar -->
- <sequential>
- <createManifest file="${runtime.root}/build/manifest.rt1" extensionName="com.sun.xml.bind" />
- <mkdir dir="${jaxb.root}/build/jaxb-1-impl-rejar"/>
- <unzip dest="${jaxb.root}/build/jaxb-1-impl-rejar">
- <fileset dir="${jaxb.libs.runtime}" includes="*.jar" />
- </unzip>
- <jar jarfile="${jaxb.dist}/lib/jaxb1-impl.jar"
- manifest="${runtime.root}/build/manifest.rt1">
- <!-- can't use zipgroupfileset because of the duplicate version.properties -->
- <fileset dir="${jaxb.root}/build/jaxb-1-impl-rejar"/>
- <fileset dir="${runtime-deprecated.classes}"/>
- </jar>
- <delete dir="${jaxb.root}/build/jaxb-1-impl-rejar"/>
- </sequential>
-
-
<!-- generate jaxb-xjc.jar: xjc, and schemagen subprojects -->
<sequential>
<createManifest file="${xjc.root}/manifest.xjc" extensionName="com.sun.tools.xjc" />
@@ -884,8 +865,6 @@ Class-Path: ${manifest.classpath}
<fileset dir="${jaxb.root}/build/jaxb-xjc-rejar"/>
<fileset dir="${xjc.classes}"/>
<metainf dir="${xjc.src}/META-INF" />
- <!-- bundle the 1.0 compiler in the side directory -->
- <zipfileset dir="${xjc10.classes}/.." />
</jar>
<delete dir="${jaxb.root}/build/jaxb-xjc-rejar"/>
</sequential>
--
1.7.9

View File

@ -0,0 +1,31 @@
From 2fad64699dd922ae6c78575b4b32f621461544a5 Mon Sep 17 00:00:00 2001
From: Juan Hernandez <juan.hernandez@redhat.com>
Date: Sat, 10 Mar 2012 17:16:56 +0100
Subject: [PATCH 3/5] Don't generate Jing RNC driver
---
tools/build.xml | 2 --
1 files changed, 0 insertions(+), 2 deletions(-)
diff --git a/tools/build.xml b/tools/build.xml
index d304db4..0723987 100644
--- a/tools/build.xml
+++ b/tools/build.xml
@@ -53,14 +53,12 @@
<target name="compile" depends="compile-for-source"
description="build tools and deploy them into necessary locations">
<ant dir="${jaxb.root}/tools/pretty-printer" />
- <ant dir="${jaxb.root}/tools/jing-rnc-driver"/>
</target>
<target name="clean">
<ant dir="${jaxb.root}/tools/source-tidy" target="clean"/>
<ant dir="${jaxb.root}/tools/webapp-commons" target="clean"/>
<ant dir="${jaxb.root}/tools/pretty-printer" target="clean"/>
- <ant dir="${jaxb.root}/tools/jing-rnc-driver" target="clean"/>
<ant dir="${jaxb.root}/tools/xmllint" target="clean"/>
</target>
</project>
--
1.7.9

View File

@ -0,0 +1,27 @@
From 5f4055b0b8792440e3f004ff189e08e05c5a1d44 Mon Sep 17 00:00:00 2001
From: Juan Hernandez <juan.hernandez@redhat.com>
Date: Sat, 10 Mar 2012 17:08:06 +0100
Subject: [PATCH 1/5] Don't use internal resolver
---
xjc/src/com/sun/tools/xjc/Options.java | 4 ++--
1 files changed, 2 insertions(+), 2 deletions(-)
diff --git a/xjc/src/com/sun/tools/xjc/Options.java b/xjc/src/com/sun/tools/xjc/Options.java
index 78c9cf4..d8247de 100644
--- a/xjc/src/com/sun/tools/xjc/Options.java
+++ b/xjc/src/com/sun/tools/xjc/Options.java
@@ -67,8 +67,8 @@ import com.sun.codemodel.CodeWriter;
import com.sun.codemodel.JPackage;
import com.sun.codemodel.writer.FileCodeWriter;
import com.sun.codemodel.writer.PrologCodeWriter;
-import com.sun.org.apache.xml.internal.resolver.CatalogManager;
-import com.sun.org.apache.xml.internal.resolver.tools.CatalogResolver;
+import org.apache.xml.resolver.CatalogManager;
+import org.apache.xml.resolver.tools.CatalogResolver;
import com.sun.tools.xjc.api.ClassNameAllocator;
import com.sun.tools.xjc.api.SpecVersion;
import com.sun.tools.xjc.generator.bean.field.FieldRendererFactory;
--
1.7.9

View File

@ -0,0 +1,26 @@
From 463def43292b22ba9137b79fe98a96fe545725ed Mon Sep 17 00:00:00 2001
From: Juan Hernandez <juan.hernandez@redhat.com>
Date: Sat, 10 Mar 2012 18:04:19 +0100
Subject: [PATCH 6/7] Don't use prebuilt javadocs
---
build.xml | 3 ---
1 files changed, 0 insertions(+), 3 deletions(-)
diff --git a/build.xml b/build.xml
index a0759eb..7b18a8e 100644
--- a/build.xml
+++ b/build.xml
@@ -880,9 +880,6 @@
</parallel>
- <unzip src="${jaxb.libs.redist}/jaxb-api-doc.zip" dest="${jaxb.dist}/docs/api"/>
- <antcall target="docs" />
-
<antcall target="process-sample.notinwspack"/>
<!-- copy samples -->
<mkdir dir="${jaxb.dist}/samples"/>
--
1.7.9

View File

@ -0,0 +1,34 @@
From 1bcc5546d6100f1cc41f6e1cb9be113ce967d737 Mon Sep 17 00:00:00 2001
From: Juan Hernandez <juan.hernandez@redhat.com>
Date: Sat, 10 Mar 2012 17:24:00 +0100
Subject: [PATCH 5/5] Remove classpath from manifests
---
build.xml | 4 ----
1 files changed, 0 insertions(+), 4 deletions(-)
diff --git a/build.xml b/build.xml
index 4dda9ef..a0759eb 100644
--- a/build.xml
+++ b/build.xml
@@ -820,9 +820,6 @@
<!-- generate jaxb-impl.jar for 2.0 runtime -->
<sequential>
<createManifest file="${runtime.root}/build/manifest.rt" extensionName="com.sun.xml.bind" />
- <manifest mode="update" file="${runtime.root}/build/manifest.rt">
- <attribute name="Class-Path" value="jaxb-api.jar activation.jar jsr173_1.0_api.jar jaxb1-impl.jar" /> <!-- added for JES4 script compatibility -->
- </manifest>
<jar jarfile="${jaxb.dist}/lib/jaxb-impl.jar"
manifest="${runtime.root}/build/manifest.rt"
duplicate="fail">
@@ -845,7 +842,6 @@
<property name="manifest.classpath" value="jaxb-api.jar jaxb-impl.jar jsr173_1.0_api.jar activation.jar" />
<echo file="${xjc.root}/manifest.xjc" append="true"
>Main-Class: com.sun.tools.xjc.XJCFacade
-Class-Path: ${manifest.classpath}
</echo>
<copy todir="${xjc.classes}">
--
1.7.9

220
glassfish-jaxb.spec Normal file
View File

@ -0,0 +1,220 @@
Name: glassfish-jaxb
Version: 2.2.5
Release: 1%{?dist}
Summary: JAXB Reference Implementation
Group: Development/Libraries
License: CDDL and GPLv2 with exceptions
URL: http://jaxb.java.net
# svn export https://svn.java.net/svn/jaxb~version2/tags/jaxb-2_2_5/ glassfish-jaxb-2.2.5
# find glassfish-jaxb-2.2.5/ -name '*.class' -delete
# find glassfish-jaxb-2.2.5/ -name '*.jar' -delete
# find glassfish-jaxb-2.2.5/ -name '*.zip' -delete
# find glassfish-jaxb-2.2.5/ -name '*.dll' -delete
# tar czf glassfish-jaxb-2.2.5.tar.gz glassfish-jaxb-2.2.5
Source0: %{name}-%{version}.tar.gz
# JAXB implementation POM:
Source1: http://repo1.maven.org/maven2/com/sun/xml/bind/jaxb-impl/2.2.5/jaxb-impl-2.2.5.pom
# JAXB XJC POM:
Source2: http://repo1.maven.org/maven2/com/sun/xml/bind/jaxb-xjc/2.2.5/jaxb-xjc-2.2.5.pom
# Ant build file used to generate the Javadoc (this is not part of the original
# source but written on purpose for the packaging):
Source3: build-javadoc.xml
# Use resolver from xml-commons-resolver instead of an internal rebundled one:
Patch0: %{name}-dont-use-internal-resolver.patch
# Don't try to generate the 1.0 runtime:
Patch1: %{name}-dont-generate-1.0-runtime.patch
# Removing Jing driver because of incompatibility issues:
Patch2: %{name}-dont-generate-jing-rnc-driver.patch
# Don't bundle the contents of other jar files in the XJC compiler jar file:
Patch3: %{name}-dont-bundle-other-jars.patch
# Remove the class-path entry from the generated manifest files:
Patch4: %{name}-remove-classpath-from-manifests.patch
# Patch the POM files to include the dependencies corresponding to the jar
# files that we aren't bundling within the jat files of this package:
Patch5: %{name}-add-dependencies.patch
# Don't use the prebuilt javadocs:
Patch6: %{name}-dont-use-prebuilt-javadocs.patch
# Don't build the examples as they need additional dependencies:
Patch7: %{name}-dont-build-examples.patch
BuildArch: noarch
BuildRequires: jpackage-utils
BuildRequires: java-devel
BuildRequires: ant
BuildRequires: codemodel
BuildRequires: istack-commons
BuildRequires: relaxngcc
BuildRequires: xml-commons-resolver
BuildRequires: txw2
BuildRequires: relaxngDatatype
BuildRequires: glassfish-dtd-parser
BuildRequires: glassfish-jaxb-api
BuildRequires: glassfish-fastinfoset
BuildRequires: jing
BuildRequires: stax-ex
BuildRequires: isorelax
BuildRequires: xsom
Requires: glassfish-dtd-parser
Requires: xml-commons-resolver
Requires: xsom
Requires: isorelax
Requires: jing
Requires: stax-ex
Requires: glassfish-fastinfoset
Requires: glassfish-jaxb-api
Requires: relaxngDatatype
Requires: txw2
Requires: relaxngcc
Requires: istack-commons
Requires: codemodel
Requires: jpackage-utils
Requires: java
%description
GlassFish JAXB Reference Implementation.
%package javadoc
Summary: Javadocs for %{name}
Group: Documentation
Requires: jpackage-utils
%description javadoc
This package contains the API documentation for %{name}.
%prep
# Unpack the sources:
%setup -q
# Put the POM files in place (we do this before patching because we need to
# patch the POMs in order to add the dependencies for the artifacts that we are
# not bundling):
cp %{SOURCE1} jaxb-impl.pom
cp %{SOURCE2} jaxb-xjc.pom
# Apply the patches:
%patch0 -p1
%patch1 -p1
%patch2 -p1
%patch3 -p1
%patch4 -p1
%patch5 -p1
%patch6 -p1
%patch7 -p1
# Link the libraries where the build script expects them:
ln -s $(build-classpath codemodel) tools/lib/rebundle/compiler/codemodel.jar
ln -s $(build-classpath glassfish-dtd-parser) tools/lib/rebundle/compiler/dtd-parser.jar
ln -s $(build-classpath istack-commons-tools) tools/lib/rebundle/compiler/istack-commons-tools.jar
ln -s $(build-classpath relaxngDatatype) tools/lib/rebundle/compiler/relaxngDatatype.jar
ln -s $(build-classpath xml-resolver) tools/lib/rebundle/compiler/resolver.jar
ln -s $(build-classpath rngom) tools/lib/rebundle/compiler/rngom.jar
ln -s $(build-classpath xsom) tools/lib/rebundle/compiler/xsom.jar
ln -s $(build-classpath isorelax) tools/lib/rebundle/runtime/isorelax.jar
ln -s $(build-classpath msv-msv) tools/lib/rebundle/runtime/msv.jar
ln -s $(build-classpath relaxngDatatype) tools/lib/rebundle/runtime/relaxngDatatype.jar
ln -s $(build-classpath istack-commons-runtime) tools/lib/rebundle/runtime2/istack-commons-runtime.jar
ln -s $(build-classpath txw2) tools/lib/rebundle/runtime2/txw2.jar
ln -s $(build-classpath jaxb-api) tools/lib/redist/jaxb-api.jar
ln -s $(build-classpath FastInfoset) tools/lib/util/FastInfoset.jar
ln -s $(build-classpath args4j) tools/lib/util/args4j.jar
ln -s $(build-classpath codemodel-annotation-compiler) tools/lib/util/codemodel-annotation-compiler.jar
ln -s $(build-classpath dom4j) tools/lib/util/dom4j.jar
ln -s $(build-classpath jing) tools/lib/util/jing.jar
ln -s $(build-classpath relaxngcc) tools/lib/util/relaxngcc.jar
ln -s $(build-classpath stax-ex) tools/lib/util/stax-ex.jar
ln -s $(build-classpath txwc2) tools/lib/util/txwc2.jar
# Put the Javadoc build file in place (no patching needed here, as this is not
# part of the original source):
cp %{SOURCE3} build-javadoc.xml
%build
# Build the binaries:
ant \
-Dbuild.sysclasspath=last \
-Dbuild.number=1 \
dist
# Build the javadoc for the runtime and the compiler:
ant \
-Dbuild.sysclasspath=last \
-f build-javadoc.xml
%install
# Jar files:
install -d -m 755 %{buildroot}%{_javadir}/%{name}
install -m 644 dist/lib/jaxb-impl.jar %{buildroot}%{_javadir}/%{name}/jaxb-impl.jar
install -m 644 dist/lib/jaxb-xjc.jar %{buildroot}%{_javadir}/%{name}/jaxb-xjc.jar
install -m 644 tools/pretty-printer/build/pretty-printer.jar %{buildroot}%{_javadir}/%{name}/pretty-printer.jar
install -m 644 tools/xmllint/build/xmllint.jar %{buildroot}%{_javadir}/%{name}/xmllint.jar
# POM files:
install -d -m 755 %{buildroot}%{_mavenpomdir}
install -m 644 jaxb-impl.pom %{buildroot}%{_mavenpomdir}/JPP.%{name}-jaxb-impl.pom
install -m 644 jaxb-xjc.pom %{buildroot}%{_mavenpomdir}/JPP.%{name}-jaxb-xjc.pom
# Javadoc files:
install -d -m 755 %{buildroot}%{_javadocdir}/%{name}
cp -rp apidocs/* %{buildroot}%{_javadocdir}/%{name}/.
# Dependencies map:
%add_maven_depmap JPP.%{name}-jaxb-impl.pom %{name}/jaxb-impl.jar
%add_maven_depmap JPP.%{name}-jaxb-xjc.pom %{name}/jaxb-xjc.jar
%files
%{_mavenpomdir}/*
%{_mavendepmapfragdir}/*
%{_javadir}/*
%doc License.txt
%doc License.html
%files javadoc
%{_javadocdir}/%{name}
%doc License.txt
%doc License.html
%changelog
* Sat Mar 10 2012 Juan Hernandez <juan.hernandez@redhat.com> 2.2.5-1
- Updated to upstream version 2.2.5
- Removed classpath from manifest files
* Wed Mar 7 2012 Juan Hernandez <juan.hernandez@redhat.com> 2.2.4u1-4
- Updated to reflect the change from glassfish-fi to glassfish-fastinfoset
* Wed Feb 22 2012 Juan Hernandez <juan.hernandez@redhat.com> 2.2.4u1-3
- Updated to reflect the changes of the jar names in txw2
* Wed Feb 22 2012 Juan Hernandez <juan.hernandez@redhat.com> 2.2.4u1-2
- Cleanup of the spec file
* Sat Jan 21 2012 Marek Goldmann <mgoldman@redhat.com> 2.2.4u1-1
- Initial packaging

114
jaxb-impl-2.2.5.pom Normal file
View File

@ -0,0 +1,114 @@
<?xml version="1.0" encoding="UTF-8"?>
<!--
DO NOT ALTER OR REMOVE COPYRIGHT NOTICES OR THIS HEADER.
Copyright (c) 1997-2011 Oracle and/or its affiliates. All rights reserved.
The contents of this file are subject to the terms of either the GNU
General Public License Version 2 only ("GPL") or the Common Development
and Distribution License("CDDL") (collectively, the "License"). You
may not use this file except in compliance with the License. You can
obtain a copy of the License at
https://glassfish.dev.java.net/public/CDDL+GPL_1_1.html
or packager/legal/LICENSE.txt. See the License for the specific
language governing permissions and limitations under the License.
When distributing the software, include this License Header Notice in each
file and include the License file at packager/legal/LICENSE.txt.
GPL Classpath Exception:
Oracle designates this particular file as subject to the "Classpath"
exception as provided by Oracle in the GPL Version 2 section of the License
file that accompanied this code.
Modifications:
If applicable, add the following below the License Header, with the fields
enclosed by brackets [] replaced by your own identifying information:
"Portions Copyright [year] [name of copyright owner]"
Contributor(s):
If you wish your version of this file to be governed by only the CDDL or
only the GPL Version 2, indicate your decision by adding "[Contributor]
elects to include this software in this distribution under the [CDDL or GPL
Version 2] license." If you don't indicate a single choice of license, a
recipient has the option to distribute your version of this file under
either the CDDL, the GPL Version 2 or to extend the choice of license to
its licensees as provided above. However, if you add GPL Version 2 code
and therefore, elected the GPL Version 2 license, then the option applies
only if the new code is made subject to such option by the copyright
holder.
-->
<project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/maven-v4_0_0.xsd">
<parent>
<groupId>net.java</groupId>
<artifactId>jvnet-parent</artifactId>
<version>1</version>
</parent>
<modelVersion>4.0.0</modelVersion>
<groupId>com.sun.xml.bind</groupId>
<artifactId>jaxb-impl</artifactId>
<version>2.2.5</version>
<packaging>jar</packaging>
<name>JAXB Reference Implementation</name>
<description>JAXB (JSR 222) Reference Implementation</description>
<url>http://jaxb.java.net/</url>
<organization>
<name>Oracle Corporation</name>
<url>http://www.oracle.com/</url>
</organization>
<developers>
<developer>
<name>Martin Grebac</name>
<email>martin.grebac@oracle.com</email>
<organization>Oracle Corporation</organization>
</developer>
</developers>
<licenses>
<license>
<name>CDDL 1.1</name>
<url>https://glassfish.java.net/public/CDDL+GPL_1_1.html</url>
<distribution>repo</distribution>
</license>
<license>
<name>GPL2 w/ CPE</name>
<url>https://glassfish.java.net/public/CDDL+GPL_1_1.html</url>
<distribution>repo</distribution>
</license>
</licenses>
<scm>
<connection>scm:svn:http://svn.java.net/svn/jaxb~version2/branches/jaxb-2_2-branch/jaxb-ri</connection>
<developerConnection>scm:svn:https://svn.java.net/svn/jaxb~version2/branches/jaxb-2_2-branch/jaxb-ri</developerConnection>
<url>http://java.net/projects/jaxb/sources/version2/show/branches/jaxb-2_2-branch/jaxb-ri</url>
</scm>
<dependencyManagement>
<dependencies>
<dependency>
<groupId>javax.xml.bind</groupId>
<artifactId>jaxb-api</artifactId>
<version>2.2.6</version>
</dependency>
<dependency>
<groupId>com.sun.istack</groupId>
<artifactId>istack-commons-runtime</artifactId>
<version>2.6.1</version>
</dependency>
<dependency>
<groupId>com.sun.xml.fastinfoset</groupId>
<artifactId>FastInfoset</artifactId>
<version>1.2.12</version>
</dependency>
</dependencies>
</dependencyManagement>
</project>

104
jaxb-xjc-2.2.5.pom Normal file
View File

@ -0,0 +1,104 @@
<?xml version="1.0" encoding="UTF-8"?>
<!--
DO NOT ALTER OR REMOVE COPYRIGHT NOTICES OR THIS HEADER.
Copyright (c) 1997-2011 Oracle and/or its affiliates. All rights reserved.
The contents of this file are subject to the terms of either the GNU
General Public License Version 2 only ("GPL") or the Common Development
and Distribution License("CDDL") (collectively, the "License"). You
may not use this file except in compliance with the License. You can
obtain a copy of the License at
https://glassfish.dev.java.net/public/CDDL+GPL_1_1.html
or packager/legal/LICENSE.txt. See the License for the specific
language governing permissions and limitations under the License.
When distributing the software, include this License Header Notice in each
file and include the License file at packager/legal/LICENSE.txt.
GPL Classpath Exception:
Oracle designates this particular file as subject to the "Classpath"
exception as provided by Oracle in the GPL Version 2 section of the License
file that accompanied this code.
Modifications:
If applicable, add the following below the License Header, with the fields
enclosed by brackets [] replaced by your own identifying information:
"Portions Copyright [year] [name of copyright owner]"
Contributor(s):
If you wish your version of this file to be governed by only the CDDL or
only the GPL Version 2, indicate your decision by adding "[Contributor]
elects to include this software in this distribution under the [CDDL or GPL
Version 2] license." If you don't indicate a single choice of license, a
recipient has the option to distribute your version of this file under
either the CDDL, the GPL Version 2 or to extend the choice of license to
its licensees as provided above. However, if you add GPL Version 2 code
and therefore, elected the GPL Version 2 license, then the option applies
only if the new code is made subject to such option by the copyright
holder.
-->
<project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/maven-v4_0_0.xsd">
<parent>
<groupId>net.java</groupId>
<artifactId>jvnet-parent</artifactId>
<version>1</version>
</parent>
<modelVersion>4.0.0</modelVersion>
<groupId>com.sun.xml.bind</groupId>
<artifactId>jaxb-xjc</artifactId>
<version>2.2.5</version>
<packaging>jar</packaging>
<name>JAXB XJC</name>
<description>JAXB (JSR 222) reference implementation - Schema compiler</description>
<url>http://jaxb.java.net/</url>
<organization>
<name>Oracle Corporation</name>
<url>http://www.oracle.com/</url>
</organization>
<developers>
<developer>
<name>Martin Grebac</name>
<email>martin.grebac@oracle.com</email>
<organization>Oracle Corporation</organization>
</developer>
</developers>
<licenses>
<license>
<name>CDDL 1.1</name>
<url>https://glassfish.java.net/public/CDDL+GPL_1_1.html</url>
<distribution>repo</distribution>
</license>
<license>
<name>GPL2 w/ CPE</name>
<url>https://glassfish.java.net/public/CDDL+GPL_1_1.html</url>
<distribution>repo</distribution>
</license>
</licenses>
<scm>
<connection>scm:svn:http://svn.java.net/svn/jaxb~version2/branches/jaxb-2_2-branch/jaxb-ri</connection>
<developerConnection>scm:svn:https://svn.java.net/svn/jaxb~version2/branches/jaxb-2_2-branch/jaxb-ri</developerConnection>
<url>http://java.net/projects/jaxb/sources/version2/show/branches/jaxb-2_2-branch/jaxb-ri</url>
</scm>
<dependencyManagement>
<dependencies>
<dependency>
<groupId>com.sun.xml.bind</groupId>
<artifactId>jaxb-impl</artifactId>
<version>2.2.5</version>
</dependency>
</dependencies>
</dependencyManagement>
</project>

View File

@ -0,0 +1 @@
141e9f0e9c8fc76b263898627e627131 glassfish-jaxb-2.2.5.tar.gz