diff --git a/.gitignore b/.gitignore
index 797c136..86fbd03 100644
--- a/.gitignore
+++ b/.gitignore
@@ -2,3 +2,4 @@
/*.src.rpm
/jaxb-istack-commons-3.0.11.tar.gz
+/jaxb-istack-commons-3.0.12.tar.gz
diff --git a/jaxb-istack-commons.spec b/jaxb-istack-commons.spec
index fe6c42a..ba1b4f0 100644
--- a/jaxb-istack-commons.spec
+++ b/jaxb-istack-commons.spec
@@ -1,8 +1,10 @@
-%global obs_vr 3.0.11-2
+%global commit 7ed1368ef26d2b4ef752b35ae33a98ec372ef3f8
+%global _buildNumber %(c=%{commit}; echo ${c:0:7})
+%global _scmBranch %{version}
Name: jaxb-istack-commons
-Version: 3.0.11
-Release: 7%{?dist}
+Version: 3.0.12
+Release: 1%{?dist}
Summary: iStack Common Utility Code
License: BSD
URL: https://github.com/eclipse-ee4j/jaxb-istack-commons
@@ -31,9 +33,6 @@ BuildRequires: mvn(org.codehaus.plexus:plexus-utils)
BuildRequires: mvn(org.glassfish.jaxb:codemodel)
BuildRequires: mvn(org.testng:testng)
-# javadoc subpackage is currently not built
-Obsoletes: istack-commons-javadoc < %{obs_vr}
-
%description
Code shared between JAXP, JAXB, SAAJ, and JAX-WS projects.
@@ -90,27 +89,17 @@ sed -i -e '/Xlint:all/d' pom.xml
%pom_remove_plugin :maven-source-plugin
%pom_remove_plugin :spotbugs-maven-plugin
-%pom_xpath_replace 'pom:plugin[pom:artifactId = "maven-compiler-plugin"]/pom:configuration/pom:release' '
-
- 9'
-
-%pom_xpath_replace 'pom:execution[pom:id = "base-compile"]/pom:configuration/pom:release' '
-
- 8'
-
-%pom_xpath_inject 'pom:execution[pom:id = "default-compile"]/pom:configuration' '
-
- module-info.java
- ' test tools
-
%mvn_package :istack-commons __noinstall
+
+# Compatibility
+%mvn_alias :istack-commons-maven-plugin com.sun.istack:maven-istack-commons-plugin
popd
%build
pushd istack-commons
# - skip javadoc build due to https://github.com/fedora-java/xmvn/issues/58
-# - ignore test failures due to faulty JVM version detection
-%mvn_build -f -j -s -- -Dmaven.compiler.source=1.8 -Dmaven.compiler.target=1.8
+# - ignore test
+%mvn_build -f -j -s -- -Dmaven.compiler.source=1.8 -Dmaven.compiler.target=1.8 -DscmBranch=%{_scmBranch} -DbuildNumber=%{_buildNumber}
popd
%install
@@ -140,6 +129,10 @@ popd
%license LICENSE.md NOTICE.md
%changelog
+* Fri Nov 05 2021 Didik Supriadi - 3.0.12-1
+- New upstream release 3.0.12
+- Remove workaround for SUREFIRE-1897
+
* Fri Oct 29 2021 Didik Supriadi - 3.0.11-7
- Include buildtolls, test, and soimp module
- Don't install parent module
diff --git a/sources b/sources
index 0b6fd4b..38dcde1 100644
--- a/sources
+++ b/sources
@@ -1 +1 @@
-SHA512 (jaxb-istack-commons-3.0.11.tar.gz) = 7106d83c79bba992b93523fd98c6e9395d9edb194b524276e3fe31ff70f549ee74cc6f494c7e0839ea5a97b5c7701b38146ae870899f3b16bd87db10fe5935aa
+SHA512 (jaxb-istack-commons-3.0.12.tar.gz) = 41193fbc20e9332f66754fc4dd52b7e98bd905c4a5dbca8adc46cb9b29f3e5fe39a684d9ca08b38c5ba15e54acb69dc289b72e2885946349bb48f4e9c2e34dfb