diff --git a/jaxb-istack-commons.spec b/jaxb-istack-commons.spec
index 8ca33b0..fe6c42a 100644
--- a/jaxb-istack-commons.spec
+++ b/jaxb-istack-commons.spec
@@ -1,14 +1,17 @@
+%global obs_vr 3.0.11-2
+
Name: jaxb-istack-commons
Version: 3.0.11
-Release: 6%{?dist}
+Release: 7%{?dist}
Summary: iStack Common Utility Code
License: BSD
-
URL: https://github.com/eclipse-ee4j/jaxb-istack-commons
-Source0: %{url}/archive/%{version}/%{name}-%{version}.tar.gz
BuildArch: noarch
+Source0: %{url}/archive/%{version}/%{name}-%{version}.tar.gz
+
BuildRequires: maven-local
+BuildRequires: mvn(args4j:args4j)
BuildRequires: mvn(jakarta.activation:jakarta.activation-api)
BuildRequires: mvn(junit:junit)
BuildRequires: mvn(org.apache.ant:ant)
@@ -28,61 +31,49 @@ BuildRequires: mvn(org.codehaus.plexus:plexus-utils)
BuildRequires: mvn(org.glassfish.jaxb:codemodel)
BuildRequires: mvn(org.testng:testng)
-%global obs_vr 3.0.11-2
-
-# package renamed in fedora 33, remove in fedora 35
-Provides: istack-commons = %{version}-%{release}
-Obsoletes: istack-commons < %{obs_vr}
-
# javadoc subpackage is currently not built
Obsoletes: istack-commons-javadoc < %{obs_vr}
%description
Code shared between JAXP, JAXB, SAAJ, and JAX-WS projects.
-
%package -n istack-commons-maven-plugin
Summary: istack-commons Maven Mojo
-
-# package renamed in fedora 33, remove in fedora 35
-Provides: maven-istack-commons-plugin = %{version}-%{release}
-Obsoletes: maven-istack-commons-plugin < %{obs_vr}
-
%description -n istack-commons-maven-plugin
This package contains the istack-commons Maven Mojo.
-
%package -n import-properties-plugin
Summary: istack-commons import properties plugin
-
%description -n import-properties-plugin
This package contains the istack-commons import properties Maven Mojo.
-
-%package runtime
+%package -n istack-commons-runtime
Summary: istack-commons runtime
-
-# package renamed in fedora 33, remove in fedora 35
-Provides: istack-commons-runtime = %{version}-%{release}
-Obsoletes: istack-commons-runtime < %{obs_vr}
-
-%description runtime
+%description -n istack-commons-runtime
This package contains istack-commons runtime.
-
-%package tools
+%package -n istack-commons-tools
Summary: istack-commons tools
-
-# package renamed in fedora 33, remove in fedora 35
-Provides: istack-commons-tools = %{version}-%{release}
-Obsoletes: istack-commons-tools < %{obs_vr}
-
-%description tools
+%description -n istack-commons-tools
This package contains istack-commons tools.
+%package -n istack-commons-buildtools
+Summary: istack-commons buildtools
+%description -n istack-commons-buildtools
+This package contains istack-commons buildtools.
+
+%package -n istack-commons-soimp
+Summary: istack-commons soimp
+%description -n istack-commons-soimp
+This package contains istack-commons soimp.
+
+%package -n istack-commons-test
+Summary: istack-commons test
+%description -n istack-commons-test
+This package contains istack-commons test.
%prep
-%setup -q
+%autosetup
pushd istack-commons
# disable very verbose warnings
@@ -95,47 +86,64 @@ sed -i -e '/Xlint:all/d' pom.xml
%pom_remove_plugin :buildnumber-maven-plugin
%pom_remove_plugin :glassfish-copyright-maven-plugin
%pom_remove_plugin :maven-enforcer-plugin
-%pom_remove_plugin :maven-javadoc-plugin
+%pom_remove_plugin :maven-javadoc-plugin . test tools
%pom_remove_plugin :maven-source-plugin
%pom_remove_plugin :spotbugs-maven-plugin
-popd
-%pom_disable_module buildtools istack-commons
-%pom_disable_module soimp istack-commons
-%pom_disable_module test istack-commons
+%pom_xpath_replace 'pom:plugin[pom:artifactId = "maven-compiler-plugin"]/pom:configuration/pom:release' '
+
+ 9'
+
+%pom_xpath_replace 'pom:execution[pom:id = "base-compile"]/pom:configuration/pom:release' '
+
+ 8'
+
+%pom_xpath_inject 'pom:execution[pom:id = "default-compile"]/pom:configuration' '
+
+ module-info.java
+ ' test tools
+
+%mvn_package :istack-commons __noinstall
+popd
%build
pushd istack-commons
# - skip javadoc build due to https://github.com/fedora-java/xmvn/issues/58
# - ignore test failures due to faulty JVM version detection
-%mvn_build -f -j -s -- -DscmBranch=%{version} -DbuildNumber=unknown -Dmaven.test.failure.ignore=true
+%mvn_build -f -j -s -- -Dmaven.compiler.source=1.8 -Dmaven.compiler.target=1.8
popd
-
%install
pushd istack-commons
%mvn_install
popd
-
-%files -f istack-commons/.mfiles-istack-commons
-%license LICENSE.md NOTICE.md
-%doc README.md
-
%files -n istack-commons-maven-plugin -f istack-commons/.mfiles-istack-commons-maven-plugin
%license LICENSE.md NOTICE.md
%files -n import-properties-plugin -f istack-commons/.mfiles-import-properties-plugin
%license LICENSE.md NOTICE.md
-%files runtime -f istack-commons/.mfiles-istack-commons-runtime
+%files -n istack-commons-runtime -f istack-commons/.mfiles-istack-commons-runtime
%license LICENSE.md NOTICE.md
-%files tools -f istack-commons/.mfiles-istack-commons-tools
+%files -n istack-commons-tools -f istack-commons/.mfiles-istack-commons-tools
%license LICENSE.md NOTICE.md
+%files -n istack-commons-buildtools -f istack-commons/.mfiles-istack-commons-buildtools
+%license LICENSE.md NOTICE.md
+
+%files -n istack-commons-test -f istack-commons/.mfiles-istack-commons-test
+%license LICENSE.md NOTICE.md
+
+%files -n istack-commons-soimp -f istack-commons/.mfiles-istack-commons-soimp
+%license LICENSE.md NOTICE.md
%changelog
+* Fri Oct 29 2021 Didik Supriadi - 3.0.11-7
+- Include buildtolls, test, and soimp module
+- Don't install parent module
+
* Thu Jul 22 2021 Fedora Release Engineering - 3.0.11-6
- Rebuilt for https://fedoraproject.org/wiki/Fedora_35_Mass_Rebuild