Update to upstream version 2.1.0
This commit is contained in:
parent
c22e94c5f4
commit
6fb4f0bbeb
1
.gitignore
vendored
1
.gitignore
vendored
@ -2,3 +2,4 @@
|
|||||||
/+.src.rpm
|
/+.src.rpm
|
||||||
|
|
||||||
/jaxb-fi-1.2.18.tar.gz
|
/jaxb-fi-1.2.18.tar.gz
|
||||||
|
/jaxb-fi-2.1.0.tar.gz
|
||||||
|
71
0001-Port-to-jaxb-xsom-4.0.1.patch
Normal file
71
0001-Port-to-jaxb-xsom-4.0.1.patch
Normal file
@ -0,0 +1,71 @@
|
|||||||
|
From 7e16acad31d6a546375a110207e03c1d1703cbb6 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Marian Koncek <mkoncek@redhat.com>
|
||||||
|
Date: Mon, 16 Jan 2023 15:38:39 +0100
|
||||||
|
Subject: [PATCH] Port to jaxb-xsom 4.0.1
|
||||||
|
|
||||||
|
---
|
||||||
|
.../com/sun/xml/analysis/frequency/SchemaProcessor.java | 7 ++++++-
|
||||||
|
.../java/com/sun/xml/analysis/types/SchemaProcessor.java | 7 ++++++-
|
||||||
|
2 files changed, 12 insertions(+), 2 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/utilities/src/main/java/com/sun/xml/analysis/frequency/SchemaProcessor.java b/utilities/src/main/java/com/sun/xml/analysis/frequency/SchemaProcessor.java
|
||||||
|
index 32532fa..497255a 100644
|
||||||
|
--- a/utilities/src/main/java/com/sun/xml/analysis/frequency/SchemaProcessor.java
|
||||||
|
+++ b/utilities/src/main/java/com/sun/xml/analysis/frequency/SchemaProcessor.java
|
||||||
|
@@ -42,6 +42,7 @@ import com.sun.xml.xsom.XSUnionSimpleType;
|
||||||
|
import com.sun.xml.xsom.XSWildcard;
|
||||||
|
import com.sun.xml.xsom.XSXPath;
|
||||||
|
import com.sun.xml.xsom.parser.XSOMParser;
|
||||||
|
+import com.sun.xml.xsom.parser.JAXPParser;
|
||||||
|
import com.sun.xml.xsom.visitor.XSSimpleTypeVisitor;
|
||||||
|
import com.sun.xml.xsom.visitor.XSVisitor;
|
||||||
|
import java.io.File;
|
||||||
|
@@ -56,6 +57,7 @@ import java.util.Map;
|
||||||
|
import java.util.Set;
|
||||||
|
import javax.xml.XMLConstants;
|
||||||
|
import javax.xml.namespace.QName;
|
||||||
|
+import javax.xml.parsers.SAXParserFactory;
|
||||||
|
import org.xml.sax.ErrorHandler;
|
||||||
|
import org.xml.sax.InputSource;
|
||||||
|
import org.xml.sax.SAXException;
|
||||||
|
@@ -415,7 +417,10 @@ public class SchemaProcessor {
|
||||||
|
* information items.
|
||||||
|
*/
|
||||||
|
public void process() throws Exception {
|
||||||
|
- XSOMParser parser = new XSOMParser();
|
||||||
|
+ SAXParserFactory factory = SAXParserFactory.newInstance();
|
||||||
|
+ factory.setNamespaceAware(true);
|
||||||
|
+ factory.setFeature(XMLConstants.FEATURE_SECURE_PROCESSING, true);
|
||||||
|
+ XSOMParser parser = new XSOMParser(factory);
|
||||||
|
parser.setErrorHandler(new ErrorHandlerImpl());
|
||||||
|
|
||||||
|
for (URL u : _schema) {
|
||||||
|
diff --git a/utilities/src/main/java/com/sun/xml/analysis/types/SchemaProcessor.java b/utilities/src/main/java/com/sun/xml/analysis/types/SchemaProcessor.java
|
||||||
|
index 81e1c17..596b130 100644
|
||||||
|
--- a/utilities/src/main/java/com/sun/xml/analysis/types/SchemaProcessor.java
|
||||||
|
+++ b/utilities/src/main/java/com/sun/xml/analysis/types/SchemaProcessor.java
|
||||||
|
@@ -56,7 +56,9 @@ import java.util.Iterator;
|
||||||
|
import java.util.List;
|
||||||
|
import java.util.Map;
|
||||||
|
import java.util.Set;
|
||||||
|
+import javax.xml.XMLConstants;
|
||||||
|
import javax.xml.namespace.QName;
|
||||||
|
+import javax.xml.parsers.SAXParserFactory;
|
||||||
|
import org.xml.sax.ErrorHandler;
|
||||||
|
import org.xml.sax.InputSource;
|
||||||
|
import org.xml.sax.SAXException;
|
||||||
|
@@ -334,7 +336,10 @@ public class SchemaProcessor {
|
||||||
|
public void process(Set<XSDataType> filter) throws Exception {
|
||||||
|
_filter = filter;
|
||||||
|
|
||||||
|
- XSOMParser parser = new XSOMParser();
|
||||||
|
+ SAXParserFactory factory = SAXParserFactory.newInstance();
|
||||||
|
+ factory.setNamespaceAware(true);
|
||||||
|
+ factory.setFeature(XMLConstants.FEATURE_SECURE_PROCESSING, true);
|
||||||
|
+ XSOMParser parser = new XSOMParser(factory);
|
||||||
|
parser.setErrorHandler(new ErrorHandlerImpl());
|
||||||
|
|
||||||
|
for (URL u : _schema) {
|
||||||
|
--
|
||||||
|
2.39.0
|
||||||
|
|
44
jaxb-fi.spec
44
jaxb-fi.spec
@ -1,6 +1,6 @@
|
|||||||
Name: jaxb-fi
|
Name: jaxb-fi
|
||||||
Version: 1.2.18
|
Version: 2.1.0
|
||||||
Release: 9%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: Implementation of the Fast Infoset Standard for Binary XML
|
Summary: Implementation of the Fast Infoset Standard for Binary XML
|
||||||
# jaxb-fi is licensed ASL 2.0 and EDL-1.0 (BSD)
|
# jaxb-fi is licensed ASL 2.0 and EDL-1.0 (BSD)
|
||||||
# bundled org.apache.xerces.util.XMLChar.java is licensed ASL 1.1
|
# bundled org.apache.xerces.util.XMLChar.java is licensed ASL 1.1
|
||||||
@ -11,21 +11,18 @@ ExclusiveArch: %{java_arches} noarch
|
|||||||
|
|
||||||
Source0: %{url}/archive/%{version}/%{name}-%{version}.tar.gz
|
Source0: %{url}/archive/%{version}/%{name}-%{version}.tar.gz
|
||||||
|
|
||||||
|
Patch1: 0001-Port-to-jaxb-xsom-4.0.1.patch
|
||||||
|
|
||||||
BuildRequires: maven-local
|
BuildRequires: maven-local
|
||||||
BuildRequires: mvn(com.sun.xml.stream.buffer:streambuffer)
|
BuildRequires: mvn(com.sun.xml.stream.buffer:streambuffer)
|
||||||
BuildRequires: mvn(jakarta.activation:jakarta.activation-api)
|
BuildRequires: mvn(jakarta.activation:jakarta.activation-api)
|
||||||
BuildRequires: mvn(junit:junit)
|
BuildRequires: mvn(junit:junit)
|
||||||
BuildRequires: mvn(org.apache.felix:maven-bundle-plugin)
|
BuildRequires: mvn(org.apache.felix:maven-bundle-plugin)
|
||||||
|
BuildRequires: mvn(org.apache.maven.plugins:maven-assembly-plugin)
|
||||||
|
BuildRequires: mvn(org.apache.maven.plugins:maven-dependency-plugin)
|
||||||
BuildRequires: mvn(org.codehaus.mojo:build-helper-maven-plugin)
|
BuildRequires: mvn(org.codehaus.mojo:build-helper-maven-plugin)
|
||||||
BuildRequires: mvn(org.glassfish.jaxb:xsom)
|
BuildRequires: mvn(org.glassfish.jaxb:xsom)
|
||||||
|
|
||||||
# package renamed in fedora 33, remove in fedora 35
|
|
||||||
Provides: glassfish-fastinfoset = %{version}-%{release}
|
|
||||||
Obsoletes: glassfish-fastinfoset < 1.2.15-5
|
|
||||||
|
|
||||||
# javadoc subpackage is currently not built
|
|
||||||
Obsoletes: glassfish-fastinfoset-javadoc < 1.2.15-5
|
|
||||||
|
|
||||||
%description
|
%description
|
||||||
Fast Infoset Project, an Open Source implementation of the Fast Infoset
|
Fast Infoset Project, an Open Source implementation of the Fast Infoset
|
||||||
Standard for Binary XML.
|
Standard for Binary XML.
|
||||||
@ -55,45 +52,41 @@ Summary: FastInfoset Utilities
|
|||||||
%{summary}.
|
%{summary}.
|
||||||
|
|
||||||
%prep
|
%prep
|
||||||
%autosetup
|
%setup -q
|
||||||
|
%patch1 -p1
|
||||||
|
|
||||||
pushd code
|
|
||||||
# remove unnecessary dependency on parent POM
|
|
||||||
# org.eclipse.ee4j:project is not packaged and not required
|
|
||||||
%pom_remove_parent
|
%pom_remove_parent
|
||||||
|
|
||||||
# disable unnecessary plugins
|
|
||||||
%pom_remove_plugin :buildnumber-maven-plugin
|
%pom_remove_plugin :buildnumber-maven-plugin
|
||||||
%pom_remove_plugin :glassfish-copyright-maven-plugin
|
%pom_remove_plugin :glassfish-copyright-maven-plugin
|
||||||
|
%pom_remove_plugin :maven-enforcer-plugin
|
||||||
|
|
||||||
# disable parent
|
|
||||||
%mvn_package :fastinfoset-project __noinstall
|
%mvn_package :fastinfoset-project __noinstall
|
||||||
popd
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
pushd code
|
# Javadoc fails: error: too many module declarations found
|
||||||
%mvn_build -s -f -j -- -DbuildNumber=unknown -Dmaven.compiler.source=1.8 -Dmaven.compiler.target=1.8
|
%mvn_build -s -j
|
||||||
popd
|
|
||||||
|
|
||||||
%install
|
%install
|
||||||
pushd code
|
|
||||||
%mvn_install
|
%mvn_install
|
||||||
popd
|
|
||||||
|
|
||||||
%files -n FastInfoset -f code/.mfiles-FastInfoset
|
%files -n FastInfoset -f .mfiles-FastInfoset
|
||||||
%license LICENSE NOTICE.md
|
%license LICENSE NOTICE.md
|
||||||
%doc README.md
|
%doc README.md
|
||||||
|
|
||||||
%files -n FastInfosetRoundTripTests -f code/.mfiles-FastInfosetRoundTripTests
|
%files -n FastInfosetRoundTripTests -f .mfiles-FastInfosetRoundTripTests
|
||||||
%license LICENSE NOTICE.md
|
%license LICENSE NOTICE.md
|
||||||
|
|
||||||
%files -n FastInfosetSamples -f code/.mfiles-FastInfosetSamples
|
%files -n FastInfosetSamples -f .mfiles-FastInfosetSamples
|
||||||
%license LICENSE NOTICE.md
|
%license LICENSE NOTICE.md
|
||||||
|
|
||||||
%files -n FastInfosetUtilities -f code/.mfiles-FastInfosetUtilities
|
%files -n FastInfosetUtilities -f .mfiles-FastInfosetUtilities
|
||||||
%license LICENSE NOTICE.md
|
%license LICENSE NOTICE.md
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Nov 21 2022 Marian Koncek <mkoncek@redhat.com> - 2.1.0-1
|
||||||
|
- Update to upstream version 2.1.0
|
||||||
|
|
||||||
* Thu Jul 21 2022 Fedora Release Engineering <releng@fedoraproject.org> - 1.2.18-9
|
* Thu Jul 21 2022 Fedora Release Engineering <releng@fedoraproject.org> - 1.2.18-9
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild
|
||||||
|
|
||||||
@ -122,4 +115,3 @@ popd
|
|||||||
|
|
||||||
* Tue Aug 11 2020 Fabio Valentini <decathorpe@gmail.com> - 1.2.18-1
|
* Tue Aug 11 2020 Fabio Valentini <decathorpe@gmail.com> - 1.2.18-1
|
||||||
- Initial package renamed from glassfish-fastinfoset.
|
- Initial package renamed from glassfish-fastinfoset.
|
||||||
|
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (jaxb-fi-1.2.18.tar.gz) = 2db5c363b7e4166b24e79e4b1b6e9b5b9016dfa62552b3807d9323baa3f6c459a04591c064f7acb4206756ae9f0653a27e926fa887462cd6902b9f989b17656a
|
SHA512 (jaxb-fi-2.1.0.tar.gz) = 807926fe90f97a72e5d6f8abcbad8639b424d7938ab2afc7dc8107070db216167aada859acd041ba17566a33e277330d9ee51bdc10d16aa19a6ea07d4ae858aa
|
||||||
|
Loading…
Reference in New Issue
Block a user