diff --git a/java-17-openjdk.spec b/java-17-openjdk.spec
index f94fc9c..f0b72bd 100644
--- a/java-17-openjdk.spec
+++ b/java-17-openjdk.spec
@@ -2492,6 +2492,7 @@ cjc.mainProgram(args)
 - Explain patchN syntax situation in a comment
 - Sync generate_source_tarball.sh
 - Require tzdata 2023d (JDK-8322725)
+- openjdk_news.sh: Use grep -E instead of egrep
 - Related: RHEL-30941
 
 * Thu Jan 11 2024 Andrew Hughes <gnu.andrew@redhat.com> - 1:17.0.10.0.7-1
diff --git a/openjdk_news.sh b/openjdk_news.sh
index 386aa53..d1bd061 100755
--- a/openjdk_news.sh
+++ b/openjdk_news.sh
@@ -58,12 +58,12 @@ for repos in . $(${SCRIPT_DIR}/discover_trees.sh ${REPO});
 do
     if test "x$TYPE" = "xhg"; then
 	hg log -r "tag('$NEW_RELEASE'):tag('$OLD_RELEASE') - tag('$OLD_RELEASE')" -R $REPO/$repos -G -M ${REPO}/${SUBDIR} | \
-	    egrep '^[o:| ]*summary'|grep -v 'Added tag'|sed -r 's#^[o:| ]*summary:\W*([0-9])#  - JDK-\1#'| \
+	    grep -E '^[o:| ]*summary'|grep -v 'Added tag'|sed -r 's#^[o:| ]*summary:\W*([0-9])#  - JDK-\1#'| \
 	    sed 's#^[o:| ]*summary:\W*#  - #' >> ${TMPDIR}/fixes2;
 	hg log -v -r "tag('$NEW_RELEASE'):tag('$OLD_RELEASE') - tag('$OLD_RELEASE')" -R $REPO/$repos -G -M ${REPO}/${SUBDIR} | \
-	    egrep '^[o:| ]*[0-9]{7}'|sed -r 's#^[o:| ]*([0-9]{7})#  - JDK-\1#' >> ${TMPDIR}/fixes3;
+	    grep -E '^[o:| ]*[0-9]{7}'|sed -r 's#^[o:| ]*([0-9]{7})#  - JDK-\1#' >> ${TMPDIR}/fixes3;
     else
-	git -C ${REPO} log --no-merges --pretty=format:%B ${NEW_RELEASE}...${OLD_RELEASE} -- ${SUBDIR} |egrep '^[0-9]{7}' | \
+	git -C ${REPO} log --no-merges --pretty=format:%B ${NEW_RELEASE}...${OLD_RELEASE} -- ${SUBDIR} |grep -E '^[0-9]{7}' | \
 	    sed -r 's#^([0-9])#  - JDK-\1#' >> ${TMPDIR}/fixes2;
 	touch ${TMPDIR}/fixes3 ; # unused
     fi