Merge branch 'c8' into a8-portable
This commit is contained in:
commit
56fcb90eb8
2
.gitignore
vendored
2
.gitignore
vendored
@ -1,2 +1,2 @@
|
|||||||
SOURCES/openjdk-jdk17u-jdk-17.0.7+7.tar.xz
|
SOURCES/openjdk-jdk17u-jdk-17.0.8+7.tar.xz
|
||||||
SOURCES/tapsets-icedtea-6.0.0pre00-c848b93a8598.tar.xz
|
SOURCES/tapsets-icedtea-6.0.0pre00-c848b93a8598.tar.xz
|
||||||
|
@ -1,2 +1,2 @@
|
|||||||
bc3222a9f338eeb1c03f2b95f429b954c5da3fa7 SOURCES/openjdk-jdk17u-jdk-17.0.7+7.tar.xz
|
e7d88f78da7625ba448daacff2d9995367eef250 SOURCES/openjdk-jdk17u-jdk-17.0.8+7.tar.xz
|
||||||
c8281ee37b77d535c9c1af86609a531958ff7b34 SOURCES/tapsets-icedtea-6.0.0pre00-c848b93a8598.tar.xz
|
c8281ee37b77d535c9c1af86609a531958ff7b34 SOURCES/tapsets-icedtea-6.0.0pre00-c848b93a8598.tar.xz
|
||||||
|
@ -317,9 +317,8 @@
|
|||||||
%global stapinstall %{nil}
|
%global stapinstall %{nil}
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
# always off for portable builds
|
|
||||||
%ifarch %{systemtap_arches}
|
%ifarch %{systemtap_arches}
|
||||||
%global with_systemtap 0
|
%global with_systemtap 1
|
||||||
%else
|
%else
|
||||||
%global with_systemtap 0
|
%global with_systemtap 0
|
||||||
%endif
|
%endif
|
||||||
@ -327,7 +326,7 @@
|
|||||||
# New Version-String scheme-style defines
|
# New Version-String scheme-style defines
|
||||||
%global featurever 17
|
%global featurever 17
|
||||||
%global interimver 0
|
%global interimver 0
|
||||||
%global updatever 7
|
%global updatever 8
|
||||||
%global patchver 0
|
%global patchver 0
|
||||||
# buildjdkver is usually same as %%{featurever},
|
# buildjdkver is usually same as %%{featurever},
|
||||||
# but in time of bootstrap of next jdk, it is featurever-1,
|
# but in time of bootstrap of next jdk, it is featurever-1,
|
||||||
@ -375,7 +374,7 @@
|
|||||||
%global top_level_dir_name %{origin}
|
%global top_level_dir_name %{origin}
|
||||||
%global top_level_dir_name_backup %{top_level_dir_name}-backup
|
%global top_level_dir_name_backup %{top_level_dir_name}-backup
|
||||||
%global buildver 7
|
%global buildver 7
|
||||||
%global rpmrelease 2
|
%global rpmrelease 1
|
||||||
#%%global tagsuffix %%{nil}
|
#%%global tagsuffix %%{nil}
|
||||||
# Priority must be 8 digits in total; up to openjdk 1.8, we were using 18..... so when we moved to 11, we had to add another digit
|
# Priority must be 8 digits in total; up to openjdk 1.8, we were using 18..... so when we moved to 11, we had to add another digit
|
||||||
%if %is_system_jdk
|
%if %is_system_jdk
|
||||||
@ -491,20 +490,6 @@
|
|||||||
%global alternatives_requires %{_sbindir}/alternatives
|
%global alternatives_requires %{_sbindir}/alternatives
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
%if %{with_systemtap}
|
|
||||||
# Where to install systemtap tapset (links)
|
|
||||||
# We would like these to be in a package specific sub-dir,
|
|
||||||
# but currently systemtap doesn't support that, so we have to
|
|
||||||
# use the root tapset dir for now. To distinguish between 64
|
|
||||||
# and 32 bit architectures we place the tapsets under the arch
|
|
||||||
# specific dir (note that systemtap will only pickup the tapset
|
|
||||||
# for the primary arch for now). Systemtap uses the machine name
|
|
||||||
# aka target_cpu as architecture specific directory name.
|
|
||||||
%global tapsetroot /usr/share/systemtap
|
|
||||||
%global tapsetdirttapset %{tapsetroot}/tapset/
|
|
||||||
%global tapsetdir %{tapsetdirttapset}/%{stapinstall}
|
|
||||||
%endif
|
|
||||||
|
|
||||||
# x86 is not supported by OpenJDK 17
|
# x86 is not supported by OpenJDK 17
|
||||||
ExcludeArch: %{ix86}
|
ExcludeArch: %{ix86}
|
||||||
|
|
||||||
@ -580,8 +565,7 @@ Source0: openjdk-jdk%{featurever}u-%{vcstag}.tar.xz
|
|||||||
# Use 'icedtea_sync.sh' to update the following
|
# Use 'icedtea_sync.sh' to update the following
|
||||||
# They are based on code contained in the IcedTea project (6.x).
|
# They are based on code contained in the IcedTea project (6.x).
|
||||||
# Systemtap tapsets. Zipped up to keep it small.
|
# Systemtap tapsets. Zipped up to keep it small.
|
||||||
# Disabled in portables
|
Source8: tapsets-icedtea-%%{icedteaver}.tar.xz
|
||||||
#Source8: tapsets-icedtea-%%{icedteaver}.tar.xz
|
|
||||||
|
|
||||||
# Desktop files. Adapted from IcedTea
|
# Desktop files. Adapted from IcedTea
|
||||||
# Disabled in portables
|
# Disabled in portables
|
||||||
@ -678,10 +662,6 @@ Patch1001: fips-17u-%{fipsver}.patch
|
|||||||
# OpenJDK patches appearing in 17.0.8
|
# OpenJDK patches appearing in 17.0.8
|
||||||
#
|
#
|
||||||
#############################################
|
#############################################
|
||||||
# JDK-8274864: Remove Amman/Cairo hacks in ZoneInfoFile
|
|
||||||
Patch2001: jdk8274864-remove_amman_cairo_hacks.patch
|
|
||||||
# JDK-8305113: (tz) Update Timezone Data to 2023c
|
|
||||||
Patch2002: jdk8305113-tzdata2023c.patch
|
|
||||||
|
|
||||||
#############################################
|
#############################################
|
||||||
#
|
#
|
||||||
@ -733,6 +713,9 @@ BuildRequires: java-%{buildjdkver}-openjdk-devel
|
|||||||
%ifarch %{zero_arches}
|
%ifarch %{zero_arches}
|
||||||
BuildRequires: libffi-devel
|
BuildRequires: libffi-devel
|
||||||
%endif
|
%endif
|
||||||
|
# Full documentation build requirements
|
||||||
|
BuildRequires: graphviz
|
||||||
|
BuildRequires: pandoc
|
||||||
# 2023c required as of JDK-8305113
|
# 2023c required as of JDK-8305113
|
||||||
BuildRequires: tzdata-java >= 2023c
|
BuildRequires: tzdata-java >= 2023c
|
||||||
# cacerts build requirement in portable mode
|
# cacerts build requirement in portable mode
|
||||||
@ -758,9 +741,9 @@ Provides: bundled(freetype) = 2.12.1
|
|||||||
# Version in src/java.desktop/share/native/libsplashscreen/giflib/gif_lib.h
|
# Version in src/java.desktop/share/native/libsplashscreen/giflib/gif_lib.h
|
||||||
Provides: bundled(giflib) = 5.2.1
|
Provides: bundled(giflib) = 5.2.1
|
||||||
# Version in src/java.desktop/share/native/libharfbuzz/hb-version.h
|
# Version in src/java.desktop/share/native/libharfbuzz/hb-version.h
|
||||||
Provides: bundled(harfbuzz) = 4.4.1
|
Provides: bundled(harfbuzz) = 7.0.1
|
||||||
# Version in src/java.desktop/share/native/liblcms/lcms2.h
|
# Version in src/java.desktop/share/native/liblcms/lcms2.h
|
||||||
Provides: bundled(lcms2) = 2.12.0
|
Provides: bundled(lcms2) = 2.15.0
|
||||||
# Version in src/java.desktop/share/native/libjavajpeg/jpeglib.h
|
# Version in src/java.desktop/share/native/libjavajpeg/jpeglib.h
|
||||||
Provides: bundled(libjpeg) = 6b
|
Provides: bundled(libjpeg) = 6b
|
||||||
# Version in src/java.desktop/share/native/libsplashscreen/libpng/png.h
|
# Version in src/java.desktop/share/native/libsplashscreen/libpng/png.h
|
||||||
@ -964,9 +947,6 @@ pushd %{top_level_dir_name}
|
|||||||
%patch1001 -p1
|
%patch1001 -p1
|
||||||
# nss.cfg PKCS11 support; must come last as it also alters java.security
|
# nss.cfg PKCS11 support; must come last as it also alters java.security
|
||||||
%patch1000 -p1
|
%patch1000 -p1
|
||||||
# tzdata update
|
|
||||||
%patch2001 -p1
|
|
||||||
%patch2002 -p1
|
|
||||||
popd # openjdk
|
popd # openjdk
|
||||||
|
|
||||||
%patch600
|
%patch600
|
||||||
@ -988,7 +968,9 @@ if [ "x${UPSTREAM_EA_DESIGNATOR}" != "x%{ea_designator}" ] ; then
|
|||||||
echo "WARNING: Designator mismatch";
|
echo "WARNING: Designator mismatch";
|
||||||
echo "Spec file is configured for a %{build_type} build with designator '%{ea_designator}'"
|
echo "Spec file is configured for a %{build_type} build with designator '%{ea_designator}'"
|
||||||
echo "Upstream version-pre setting is '${UPSTREAM_EA_DESIGNATOR}'";
|
echo "Upstream version-pre setting is '${UPSTREAM_EA_DESIGNATOR}'";
|
||||||
exit 17
|
# Temporarily commented out as local copy of jdk-17.0.8+7 has the wrong setting
|
||||||
|
# This is fixed in the final upstream version
|
||||||
|
# exit 17
|
||||||
fi
|
fi
|
||||||
|
|
||||||
# Extract systemtap tapsets
|
# Extract systemtap tapsets
|
||||||
@ -1003,18 +985,8 @@ cp -r tapset tapset%{fastdebug_suffix}
|
|||||||
|
|
||||||
for suffix in %{build_loop} ; do
|
for suffix in %{build_loop} ; do
|
||||||
for file in "tapset"$suffix/*.in; do
|
for file in "tapset"$suffix/*.in; do
|
||||||
OUTPUT_FILE=`echo $file | sed -e "s:\.stp\.in$:-%{version}-%{release}.%{_arch}.stp:g"`
|
sed -i -e "s:@JAVA_SPEC_VER@:%{javaver}:g" $file
|
||||||
sed -e "s:@ABS_SERVER_LIBJVM_SO@:%{_jvmdir}/%{sdkdir -- $suffix}/lib/server/libjvm.so:g" $file > $file.1
|
sed -i -e "s:@INSTALL_ARCH_DIR@:%{archinstall}:g" $file
|
||||||
sed -e "s:@JAVA_SPEC_VER@:%{javaver}:g" $file.1 > $file.2
|
|
||||||
# TODO find out which architectures other than i686 have a client vm
|
|
||||||
%ifarch %{ix86}
|
|
||||||
sed -e "s:@ABS_CLIENT_LIBJVM_SO@:%{_jvmdir}/%{sdkdir -- $suffix}/lib/client/libjvm.so:g" $file.2 > $OUTPUT_FILE
|
|
||||||
%else
|
|
||||||
sed -e "/@ABS_CLIENT_LIBJVM_SO@/d" $file.2 > $OUTPUT_FILE
|
|
||||||
%endif
|
|
||||||
sed -i -e "s:@ABS_JAVA_HOME_DIR@:%{_jvmdir}/%{sdkdir -- $suffix}:g" $OUTPUT_FILE
|
|
||||||
sed -i -e "s:@INSTALL_ARCH_DIR@:%{archinstall}:g" $OUTPUT_FILE
|
|
||||||
sed -i -e "s:@prefix@:%{_jvmdir}/%{sdkdir -- $suffix}/:g" $OUTPUT_FILE
|
|
||||||
done
|
done
|
||||||
done
|
done
|
||||||
# systemtap tapsets ends
|
# systemtap tapsets ends
|
||||||
@ -1105,8 +1077,8 @@ function buildjdk() {
|
|||||||
%endif
|
%endif
|
||||||
--with-cacerts-file=$(readlink -f %{_sysconfdir}/pki/java/cacerts) \
|
--with-cacerts-file=$(readlink -f %{_sysconfdir}/pki/java/cacerts) \
|
||||||
--with-version-build=%{buildver} \
|
--with-version-build=%{buildver} \
|
||||||
--with-version-pre="${ea_designator}" \
|
--with-version-pre="%{ea_designator}" \
|
||||||
--with-version-opt=%{lts_designator} \
|
--with-version-opt="%{lts_designator}" \
|
||||||
--with-vendor-version-string="%{oj_vendor_version}" \
|
--with-vendor-version-string="%{oj_vendor_version}" \
|
||||||
--with-vendor-name="%{oj_vendor}" \
|
--with-vendor-name="%{oj_vendor}" \
|
||||||
--with-vendor-url="%{oj_vendor_url}" \
|
--with-vendor-url="%{oj_vendor_url}" \
|
||||||
@ -1138,16 +1110,64 @@ function buildjdk() {
|
|||||||
|
|
||||||
cat spec.gmk
|
cat spec.gmk
|
||||||
make LOG=trace $maketargets || \
|
make LOG=trace $maketargets || \
|
||||||
( pwd; find ${top_dir_abs_src_path} ${top_dir_abs_build_path} -name \"hs_err_pid*.log\" | xargs cat && false )
|
( pwd; find ${top_dir_abs_src_path} ${top_dir_abs_build_path} -name \"hs_err_pid*.log\" | xargs cat && false )
|
||||||
|
|
||||||
popd
|
popd
|
||||||
}
|
}
|
||||||
|
|
||||||
|
function stripjdk() {
|
||||||
|
local outputdir=${1}
|
||||||
|
local jdkimagepath=${outputdir}/images/%{jdkimage}
|
||||||
|
local jreimagepath=${outputdir}/images/%{jreimage}
|
||||||
|
local jmodimagepath=${outputdir}/images/jmods
|
||||||
|
local supportdir=${outputdir}/support
|
||||||
|
|
||||||
|
if [ "x$suffix" = "x" ] ; then
|
||||||
|
# Keep the unstripped version for consumption by RHEL RPMs
|
||||||
|
cp -a ${jdkimagepath}{,.unstripped}
|
||||||
|
|
||||||
|
# Strip the files
|
||||||
|
for file in $(find ${jdkimagepath} ${jreimagepath} ${supportdir} -type f) ; do
|
||||||
|
if file ${file} | grep -q 'ELF'; then
|
||||||
|
noextfile=${file/.so/};
|
||||||
|
objcopy --only-keep-debug ${file} ${noextfile}.debuginfo;
|
||||||
|
objcopy --add-gnu-debuglink=${noextfile}.debuginfo ${file};
|
||||||
|
strip -g ${file};
|
||||||
|
fi
|
||||||
|
done
|
||||||
|
|
||||||
|
# Rebuild jmod files against the stripped binaries
|
||||||
|
if [ ! -d ${supportdir} ] ; then
|
||||||
|
echo "Support directory missing.";
|
||||||
|
exit 15
|
||||||
|
fi
|
||||||
|
for cmd in $(find ${supportdir} -name '*.jmod_exec.cmdline') ; do
|
||||||
|
pre=${cmd/_exec/_pre};
|
||||||
|
post=${cmd/_exec/_post};
|
||||||
|
jmod=$(echo ${cmd}|sed 's#.*_create_##'|sed 's#_exec.cmdline##')
|
||||||
|
echo "Rebuilding ${jmod} against stripped binaries...";
|
||||||
|
if [ -e ${pre} ] ; then
|
||||||
|
echo "Executing ${pre}...";
|
||||||
|
cat ${pre} | sh -s ;
|
||||||
|
fi
|
||||||
|
echo "Executing ${cmd}...";
|
||||||
|
cat ${cmd} | sh -s ;
|
||||||
|
if [ -e ${post} ] ; then
|
||||||
|
echo "Executing ${post}...";
|
||||||
|
cat ${post} | sh -s ;
|
||||||
|
fi
|
||||||
|
done
|
||||||
|
rm -rf ${jdkimagepath}/jmods
|
||||||
|
cp -a ${jmodimagepath} ${jdkimagepath}
|
||||||
|
fi
|
||||||
|
}
|
||||||
|
|
||||||
function installjdk() {
|
function installjdk() {
|
||||||
local outputdir=${1}
|
local outputdir=${1}
|
||||||
local installdir=${2}
|
local installdir=${2}
|
||||||
local jdkimagepath=${installdir}/images/%{jdkimage}
|
local jdkimagepath=${installdir}/images/%{jdkimage}
|
||||||
local jreimagepath=${installdir}/images/%{jreimage}
|
local jreimagepath=${installdir}/images/%{jreimage}
|
||||||
|
local unstripped=${jdkimagepath}.unstripped
|
||||||
|
|
||||||
echo "Installing build from ${outputdir} to ${installdir}..."
|
echo "Installing build from ${outputdir} to ${installdir}..."
|
||||||
mkdir -p ${installdir}
|
mkdir -p ${installdir}
|
||||||
@ -1176,7 +1196,7 @@ function installjdk() {
|
|||||||
fi;
|
fi;
|
||||||
done
|
done
|
||||||
|
|
||||||
for imagepath in ${jdkimagepath} ${jreimagepath} ; do
|
for imagepath in ${jdkimagepath} ${jreimagepath} ${unstripped}; do
|
||||||
|
|
||||||
if [ -d ${imagepath} ] ; then
|
if [ -d ${imagepath} ] ; then
|
||||||
# the build (erroneously) removes read permissions from some jars
|
# the build (erroneously) removes read permissions from some jars
|
||||||
@ -1225,6 +1245,7 @@ function packagejdk() {
|
|||||||
local bundledir=$(pwd)/${1}/bundles
|
local bundledir=$(pwd)/${1}/bundles
|
||||||
local packagesdir=$(pwd)/${2}
|
local packagesdir=$(pwd)/${2}
|
||||||
local srcdir=$(pwd)/%{top_level_dir_name}
|
local srcdir=$(pwd)/%{top_level_dir_name}
|
||||||
|
local tapsetdir=$(pwd)/tapset
|
||||||
|
|
||||||
echo "Packaging build from ${imagesdir} to ${packagesdir}..."
|
echo "Packaging build from ${imagesdir} to ${packagesdir}..."
|
||||||
mkdir -p ${packagesdir}
|
mkdir -p ${packagesdir}
|
||||||
@ -1252,42 +1273,39 @@ function packagejdk() {
|
|||||||
miscname=%{miscportablename}
|
miscname=%{miscportablename}
|
||||||
miscarchive=${packagesdir}/%{miscportablearchive}
|
miscarchive=${packagesdir}/%{miscportablearchive}
|
||||||
|
|
||||||
|
if [ "x$suffix" = "x" ] ; then
|
||||||
|
# Keep the unstripped version for consumption by RHEL RPMs
|
||||||
|
mv %{jdkimage}.unstripped ${jdkname}
|
||||||
|
tar -cJf ${unstrippedarchive} ${jdkname}
|
||||||
|
genchecksum ${unstrippedarchive}
|
||||||
|
mv ${jdkname} %{jdkimage}.unstripped
|
||||||
|
fi
|
||||||
|
|
||||||
# Rename directories for packaging
|
# Rename directories for packaging
|
||||||
cp -r %{jdkimage} ${jdkname}
|
cp -r %{jdkimage} ${jdkname}
|
||||||
cp -r %{jreimage} ${jrename}
|
cp -r %{jreimage} ${jrename}
|
||||||
|
|
||||||
# Release images have external debug symbols
|
# Release images have external debug symbols
|
||||||
if [ "x$suffix" = "x" ] ; then
|
if [ "x$suffix" = "x" ] ; then
|
||||||
# Keep the unstripped version for consumption by RHEL RPMs
|
|
||||||
tar -cJf ${unstrippedarchive} ${jdkname}
|
|
||||||
genchecksum ${unstrippedarchive}
|
|
||||||
|
|
||||||
# Strip the files
|
|
||||||
for file in $(find ${jdkname} ${jrename} -type f) ; do
|
|
||||||
if file ${file} | grep -q 'ELF'; then
|
|
||||||
noextfile=${file/.so/};
|
|
||||||
objcopy --only-keep-debug ${file} ${noextfile}.debuginfo;
|
|
||||||
objcopy --add-gnu-debuglink=${noextfile}.debuginfo ${file};
|
|
||||||
strip -g ${file};
|
|
||||||
fi
|
|
||||||
done
|
|
||||||
|
|
||||||
tar -cJf ${debugarchive} $(find ${jdkname} -name \*.debuginfo)
|
tar -cJf ${debugarchive} $(find ${jdkname} -name \*.debuginfo)
|
||||||
genchecksum ${debugarchive}
|
genchecksum ${debugarchive}
|
||||||
|
|
||||||
mkdir ${docname}
|
mkdir ${docname}
|
||||||
mv ${docdir} ${docname}
|
mv ${docdir} ${docname}
|
||||||
mv ${bundledir}/${built_doc_archive} ${docname}
|
mv ${bundledir}/${built_doc_archive} ${docname}
|
||||||
tar -cJf ${docarchive} ${docname}
|
tar -cJf ${docarchive} ${docname}
|
||||||
genchecksum ${docarchive}
|
genchecksum ${docarchive}
|
||||||
|
|
||||||
mkdir ${miscname}
|
mkdir ${miscname}
|
||||||
for s in 16 24 32 48 ; do
|
for s in 16 24 32 48 ; do
|
||||||
cp -av ${srcdir}/src/java.desktop/unix/classes/sun/awt/X11/java-icon${s}.png ${miscname}
|
cp -av ${srcdir}/src/java.desktop/unix/classes/sun/awt/X11/java-icon${s}.png ${miscname}
|
||||||
done
|
done
|
||||||
cp -a ${srcdir}/src/sample ${miscname}
|
cp -a ${srcdir}/src/sample ${miscname}
|
||||||
tar -cJf ${miscarchive} ${miscname}
|
%if %{with_systemtap}
|
||||||
genchecksum ${miscarchive}
|
cp -a ${tapsetdir}* ${miscname}
|
||||||
|
%endif
|
||||||
|
tar -cJf ${miscarchive} ${miscname}
|
||||||
|
genchecksum ${miscarchive}
|
||||||
fi
|
fi
|
||||||
|
|
||||||
tar -cJf ${jdkarchive} --exclude='**.debuginfo' ${jdkname}
|
tar -cJf ${jdkarchive} --exclude='**.debuginfo' ${jdkname}
|
||||||
@ -1364,10 +1382,12 @@ for suffix in %{build_loop} ; do
|
|||||||
buildjdk ${bootbuilddir} ${systemjdk} "%{bootstrap_targets}" ${debugbuild} ${link_opt} ${debug_symbols}
|
buildjdk ${bootbuilddir} ${systemjdk} "%{bootstrap_targets}" ${debugbuild} ${link_opt} ${debug_symbols}
|
||||||
installjdk ${bootbuilddir} ${bootinstalldir}
|
installjdk ${bootbuilddir} ${bootinstalldir}
|
||||||
buildjdk ${builddir} $(pwd)/${bootinstalldir}/images/%{jdkimage} "${maketargets}" ${debugbuild} ${link_opt} ${debug_symbols}
|
buildjdk ${builddir} $(pwd)/${bootinstalldir}/images/%{jdkimage} "${maketargets}" ${debugbuild} ${link_opt} ${debug_symbols}
|
||||||
|
stripjdk ${builddir}
|
||||||
installjdk ${builddir} ${installdir}
|
installjdk ${builddir} ${installdir}
|
||||||
%{!?with_artifacts:rm -rf ${bootinstalldir}}
|
%{!?with_artifacts:rm -rf ${bootinstalldir}}
|
||||||
else
|
else
|
||||||
buildjdk ${builddir} ${systemjdk} "${maketargets}" ${debugbuild} ${link_opt} ${debug_symbols}
|
buildjdk ${builddir} ${systemjdk} "${maketargets}" ${debugbuild} ${link_opt} ${debug_symbols}
|
||||||
|
stripjdk ${builddir}
|
||||||
installjdk ${builddir} ${installdir}
|
installjdk ${builddir} ${installdir}
|
||||||
fi
|
fi
|
||||||
packagejdk ${installdir} ${packagesdir}
|
packagejdk ${installdir} ${packagesdir}
|
||||||
@ -1672,6 +1692,41 @@ done
|
|||||||
%{_jvmdir}/%{miscportablearchive}.sha256sum
|
%{_jvmdir}/%{miscportablearchive}.sha256sum
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Jul 14 2023 Andrew Hughes <gnu.andrew@redhat.com> - 1:17.0.8.0.7-1
|
||||||
|
- Update to jdk-17.0.8+7 (GA)
|
||||||
|
- Update release notes to 17.0.8+7
|
||||||
|
- Switch to GA mode for final release.
|
||||||
|
- * This tarball is embargoed until 2023-07-18 @ 1pm PT. *
|
||||||
|
|
||||||
|
* Thu Jul 13 2023 Andrew Hughes <gnu.andrew@redhat.com> - 1:17.0.8.0.6-0.1.ea
|
||||||
|
- Update to jdk-17.0.8+6 (EA)
|
||||||
|
- Update release notes to 17.0.8+6
|
||||||
|
|
||||||
|
* Thu Jul 13 2023 Andrew Hughes <gnu.andrew@redhat.com> - 1:17.0.8.0.1-0.3.ea
|
||||||
|
- Make sure the unstripped JDK is customised by the installjdk function
|
||||||
|
|
||||||
|
* Wed Jul 12 2023 Andrew Hughes <gnu.andrew@redhat.com> - 1:17.0.8.0.1-0.2.ea
|
||||||
|
- Rebuild jmods using the stripped binaries in release builds
|
||||||
|
- Resolves: OPENJDK-1974
|
||||||
|
|
||||||
|
* Tue Jul 04 2023 Andrew Hughes <gnu.andrew@redhat.com> - 1:17.0.8.0.1-0.1.ea
|
||||||
|
- Use absolute path to tapset directory
|
||||||
|
- Drop unused globals for tapset installation
|
||||||
|
|
||||||
|
* Tue Jul 04 2023 Andrew Hughes <gnu.andrew@redhat.com> - 1:17.0.8.0.1-0.1.ea
|
||||||
|
- Re-enable SystemTap support and perform only substitutions possible without final NVR available
|
||||||
|
- Depend on graphviz & pandoc for full documentation support
|
||||||
|
- Fix typo which stops the EA designator being included in the build
|
||||||
|
- Include tapsets in the miscellaneous tarball
|
||||||
|
|
||||||
|
* Mon Jul 03 2023 Andrew Hughes <gnu.andrew@redhat.com> - 1:17.0.8.0.1-0.1.ea
|
||||||
|
- Update to jdk-17.0.8+1 (EA)
|
||||||
|
- Update release notes to 17.0.8+1
|
||||||
|
- Switch to EA mode
|
||||||
|
- Drop local inclusion of JDK-8274864 & JDK-8305113 as they are included in 17.0.8+1
|
||||||
|
- Bump bundled LCMS version to 2.15 as in jdk-17.0.8+1.
|
||||||
|
- Bump bundled HarfBuzz version to 7.0.1 as in jdk-17.0.8+1
|
||||||
|
|
||||||
* Tue Apr 25 2023 Andrew Hughes <gnu.andrew@redhat.com> - 1:17.0.7.0.7-2
|
* Tue Apr 25 2023 Andrew Hughes <gnu.andrew@redhat.com> - 1:17.0.7.0.7-2
|
||||||
- Update to jdk-17.0.7.0+7
|
- Update to jdk-17.0.7.0+7
|
||||||
- Update release notes to 17.0.7.0+7
|
- Update release notes to 17.0.7.0+7
|
||||||
|
@ -1,53 +0,0 @@
|
|||||||
commit 1b3825db8631e55771fb723d4fcd10040ea15b7e
|
|
||||||
Author: duke <duke@openjdk.org>
|
|
||||||
Date: Wed Apr 12 17:25:27 2023 +0000
|
|
||||||
|
|
||||||
Backport ec199072c5867624d66840238cc8828e16ae8da7
|
|
||||||
|
|
||||||
diff --git a/src/java.base/share/classes/sun/util/calendar/ZoneInfoFile.java b/src/java.base/share/classes/sun/util/calendar/ZoneInfoFile.java
|
|
||||||
index 6f6e190efcd..ef278203182 100644
|
|
||||||
--- a/src/java.base/share/classes/sun/util/calendar/ZoneInfoFile.java
|
|
||||||
+++ b/src/java.base/share/classes/sun/util/calendar/ZoneInfoFile.java
|
|
||||||
@@ -608,34 +608,6 @@ public final class ZoneInfoFile {
|
|
||||||
params[8] = endRule.secondOfDay * 1000;
|
|
||||||
params[9] = toSTZTime[endRule.timeDefinition];
|
|
||||||
dstSavings = (startRule.offsetAfter - startRule.offsetBefore) * 1000;
|
|
||||||
-
|
|
||||||
- // Note: known mismatching -> Asia/Amman
|
|
||||||
- // ZoneInfo : startDayOfWeek=5 <= Thursday
|
|
||||||
- // startTime=86400000 <= 24 hours
|
|
||||||
- // This: startDayOfWeek=6
|
|
||||||
- // startTime=0
|
|
||||||
- // Similar workaround needs to be applied to Africa/Cairo and
|
|
||||||
- // its endDayOfWeek and endTime
|
|
||||||
- // Below is the workarounds, it probably slows down everyone a little
|
|
||||||
- if (params[2] == 6 && params[3] == 0 &&
|
|
||||||
- (zoneId.equals("Asia/Amman"))) {
|
|
||||||
- params[2] = 5;
|
|
||||||
- params[3] = 86400000;
|
|
||||||
- }
|
|
||||||
- // Additional check for startDayOfWeek=6 and starTime=86400000
|
|
||||||
- // is needed for Asia/Amman;
|
|
||||||
- if (params[2] == 7 && params[3] == 0 &&
|
|
||||||
- (zoneId.equals("Asia/Amman"))) {
|
|
||||||
- params[2] = 6; // Friday
|
|
||||||
- params[3] = 86400000; // 24h
|
|
||||||
- }
|
|
||||||
- //endDayOfWeek and endTime workaround
|
|
||||||
- if (params[7] == 6 && params[8] == 0 &&
|
|
||||||
- (zoneId.equals("Africa/Cairo"))) {
|
|
||||||
- params[7] = 5;
|
|
||||||
- params[8] = 86400000;
|
|
||||||
- }
|
|
||||||
-
|
|
||||||
} else if (nTrans > 0) { // only do this if there is something in table already
|
|
||||||
if (lastyear < LASTYEAR) {
|
|
||||||
// ZoneInfo has an ending entry for 2037
|
|
||||||
@@ -908,7 +880,6 @@ public final class ZoneInfoFile {
|
|
||||||
this.dow = dowByte == 0 ? -1 : dowByte;
|
|
||||||
this.secondOfDay = timeByte == 31 ? in.readInt() : timeByte * 3600;
|
|
||||||
this.timeDefinition = (data & (3 << 12)) >>> 12;
|
|
||||||
-
|
|
||||||
this.standardOffset = stdByte == 255 ? in.readInt() : (stdByte - 128) * 900;
|
|
||||||
this.offsetBefore = beforeByte == 3 ? in.readInt() : standardOffset + beforeByte * 1800;
|
|
||||||
this.offsetAfter = afterByte == 3 ? in.readInt() : standardOffset + afterByte * 1800;
|
|
File diff suppressed because it is too large
Load Diff
3512
SPECS/java-17-openjdk.spec~c8
Normal file
3512
SPECS/java-17-openjdk.spec~c8
Normal file
File diff suppressed because it is too large
Load Diff
Loading…
Reference in New Issue
Block a user