diff --git a/generate_source_tarball.sh b/generate_source_tarball.sh
index cdeabbd..575df62 100755
--- a/generate_source_tarball.sh
+++ b/generate_source_tarball.sh
@@ -1,4 +1,20 @@
#!/bin/bash
+
+# Copyright (C) 2024 Red Hat, Inc.
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU Affero General Public License as
+# published by the Free Software Foundation, either version 3 of the
+# License, or (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU Affero General Public License for more details.
+#
+# You should have received a copy of the GNU Affero General Public License
+# along with this program. If not, see .
+
# Generates the 'source tarball' for JDK projects.
#
# Example 1:
diff --git a/java-17-openjdk.spec b/java-17-openjdk.spec
index c34b030..f60b2fb 100644
--- a/java-17-openjdk.spec
+++ b/java-17-openjdk.spec
@@ -2498,6 +2498,7 @@ require "copy_jdk_configs.lua"
- generate_source_tarball.sh: Remove trailing period in echo
- generate_source_tarball.sh: Add indentation instructions for Emacs
- Require tzdata 2023d (JDK-8322725)
+- generate_source_tarball.sh: Add license
- Related: RHEL-27133
* Thu Jan 11 2024 Andrew Hughes - 1:17.0.10.0.7-2