Merged update from upstream sources

This is an automated DistroBaker update from upstream sources.
If you do not know what this is about or would like to opt out,
contact the OSCI team.

Source: https://src.fedoraproject.org/rpms/java-11-openjdk.git#e474513f0429a9bd77597aa2706f9324e48d1e7e
This commit is contained in:
DistroBaker 2020-12-23 23:00:25 +00:00
parent d898dbf94e
commit 33ebc08a1c
6 changed files with 424 additions and 2142 deletions

1
.gitignore vendored
View File

@ -70,3 +70,4 @@
/jdk-updates-jdk11u-jdk-11.0.9+9-4curve.tar.xz
/jdk-updates-jdk11u-jdk-11.0.9+10-4curve.tar.xz
/jdk-updates-jdk11u-jdk-11.0.9+11-4curve.tar.xz
/jdk-updates-jdk11u-jdk-11.0.10+1-4curve.tar.xz

137
NEWS
View File

@ -3,6 +3,143 @@ Key:
JDK-X - https://bugs.openjdk.java.net/browse/JDK-X
CVE-XXXX-YYYY: https://cve.mitre.org/cgi-bin/cvename.cgi?name=XXXX-YYYY
New in release OpenJDK 11.0.10 (2021-01-19):
=============================================
Live versions of these release notes can be found at:
* https://bitly.com/openjdk11010
* https://builds.shipilev.net/backports-monitor/release-notes-11.0.10.txt
* Other changes
- JDK-7185258: [macosx] Deadlock in SunToolKit.realSync()
- JDK-8152332: [macosx] JFileChooser cannot be serialized on Mac OS X
- JDK-8161684: [testconf] Add VerifyOops' testing into compiler tiers
- JDK-8191006: hsdis disassembler plugin does not compile with binutils 2.29+
- JDK-8198334: java/awt/FileDialog/8003399/bug8003399.java fails in headless mode
- JDK-8200151: Add 8 JNDI tests to com/sun/jndi/dns/ConfigTests/
- JDK-8208279: Add 8 JNDI tests to com/sun/jndi/dns/EnvTests/
- JDK-8208483: Add 5 JNDI tests to com/sun/jndi/dns/FactoryTests/
- JDK-8208542: Add 4 JNDI tests to com/sun/jndi/dns/ListTests/
- JDK-8208665: Amend cross-compilation docs with qemu-debootstrap recipe
- JDK-8210088: ProblemList gc/epsilon/TestMemoryMXBeans.java
- JDK-8210339: Add 10 JNDI tests to com/sun/jndi/dns/FedTests/
- JDK-8212226: SurfaceManager throws "Invalid Image variant" for MultiResolutionImage (Windows)
- JDK-8213400: Support choosing group name in keytool keypair generation
- JDK-8213535: Windows HiDPI html lightweight tooltips are truncated
- JDK-8213698: Improve devkit creation and add support for linux/ppc64/ppc64le/s390x
- JDK-8216012: Infinite loop in RSA KeyPairGenerator
- JDK-8216324: GetClassMethods is confused by the presence of default methods in super interfaces
- JDK-8217429: WebSocket over authenticating proxy fails to send Upgrade headers
- JDK-8217976: test/jdk/java/net/httpclient/websocket/WebSocketProxyTest.java fails intermittently
- JDK-8218851: JVM crash in custom classloader stress test, JDK 12 & 13
- JDK-8220420: Cleanup c1_LinearScan
- JDK-8222286: Fix for JDK-8213419 is broken on s390
- JDK-8222533: jtreg test jdk/internal/platform/cgroup/TestCgroupMetrics.java fails on SLES12.3 linux ppc64le machine
- JDK-8224506: [TESTBUG] TestDockerMemoryMetrics.java fails with exitValue = 137
- JDK-8224555: vmTestbase/nsk/jvmti/scenarios/contention/TC02/tc02t001/TestDescription.java failed
- JDK-8225329: -XX:+PrintBiasedLockingStatistics causes crash during initialization on Windows platforms
- JDK-8227006: [linux] Runtime.availableProcessors execution time increased by factor of 100
- JDK-8227647: [Graal] Test8009761.java fails due to "RuntimeException: static java.lang.Object compiler.uncommontrap.Test8009761.m3(boolean,boolean) not compiled"
- JDK-8232114: JVM crashed at imjpapi.dll in native code
- JDK-8234147: Avoid looking up standard charsets in core libraries
- JDK-8236512: PKCS11 Connection closed after Cipher.doFinal and NoPadding
- JDK-8236944: The legVecZ operand should be limited to zmm0-zmm15 registers
- JDK-8237186: Fix typo in copyright header of java/io/Reader/TransferTo.java
- JDK-8237499: JFR: Include stack trace in the ThreadStart event
- JDK-8237512: AArch64: aarch64TestHook leaks a BufferBlob
- JDK-8237524: AArch64: String.compareTo() may return incorrect result
- JDK-8237950: C2 compilation fails with "Live Node limit exceeded limit" during ConvI2L::Ideal optimization
- JDK-8239105: Add exception for expiring Digicert root certificates to VerifyCACerts test
- JDK-8239477: jdk/jfr/jcmd/TestJcmdStartStopDefault.java fails -XX:+VerifyOops with "verify_oop: rsi: broken oop"
- JDK-8239886: Minimal VM build fails after JDK-8237499
- JDK-8240633: Memory leaks in the implementations of FileChooserUI
- JDK-8240690: Race condition between EDT and BasicDirectoryModel.FilesLoader.run0()
- JDK-8241234: Unify monitor enter/exit runtime entries.
- JDK-8241311: Move some charset mapping tests from closed to open
- JDK-8241797: Add some tests to the problem list
- JDK-8242029: AArch64: skip G1 array copy pre-barrier if marking not active
- JDK-8242335: Additional Tests for RSASSA-PSS
- JDK-8242480: Negative value may be returned by getFreeSwapSpaceSize() in the docker
- JDK-8242614: cleanup duplicated test ldap server in some com/sun/jndi/ldap/ tests
- JDK-8242846: Bring back test/jdk/tools/jlink/plugins/OrderResourcesPluginTest.java
- JDK-8243114: Implement montgomery{Multiply,Square}intrinsics on Windows
- JDK-8243290: Improve diagnostic messages for class verification and redefinition failures
- JDK-8243617: compiler/onSpinWait/TestOnSpinWaitC1.java test uses wrong class
- JDK-8243619: compiler/codecache/CheckSegmentedCodeCache.java test misses -version
- JDK-8244142: some hotspot/runtime tests don't check exit code of forked JVM
- JDK-8244278: Excessive code cache flushes and sweeps
- JDK-8244819: hsdis does not compile with binutils 2.34+
- JDK-8245400: Upgrade to LittleCMS 2.11
- JDK-8246381: VM crashes with "Current BasicObjectLock* below than low_mark"
- JDK-8246434: Threads::print_on_error assumes that the heap has been set up
- JDK-8246648: issue with OperatingSystemImpl getFreeSwapSpaceSize in docker after 8242480
- JDK-8247201: Print potential pointer value of readable stack memory in hs_err file
- JDK-8247763: assert(outer->outcnt() == 2) failed: 'only phis' failure in LoopNode::verify_strip_mined()
- JDK-8247867: Upgrade to freetype 2.10.2
- JDK-8248190: Enable Power10 system and implement new byte-reverse instructions
- JDK-8248226: TestCloneAccessStressGCM fails with -XX:-ReduceBulkZeroing
- JDK-8248347: windows build broken by JDK-8243114
- JDK-8248532: Every time I change keyboard language at my MacBook, Java crashes
- JDK-8248552: C2 crashes with SIGFPE due to division by zero
- JDK-8248596: [TESTBUG] compiler/loopopts/PartialPeelingUnswitch.java times out with Graal enabled
- JDK-8248745: Add jarsigner and keytool tests for restricted algorithms
- JDK-8248791: sun/util/resources/cldr/TimeZoneNamesTest.java fails with -XX:-ReduceInitialCardMarks -XX:-ReduceBulkZeroing
- JDK-8248845: AArch64: stack corruption after spilling vector register
- JDK-8249176: Update GlobalSignR6CA test certificates
- JDK-8249183: JVM crash in "AwtFrame::WmSize" method
- JDK-8249192: MonitorInfo stores raw oops across safepoints
- JDK-8249602: C2: assert(cnt == _outcnt) failed: no insertions allowed
- JDK-8249603: C1: assert(has_error == false) failed: register allocation invalid
- JDK-8249605: C2: assert(no_dead_loop) failed: dead loop detected
- JDK-8249607: C2: assert(!had_error) failed: bad dominance
- JDK-8249608: Vector register used by C2 compiled method corrupted at safepoint
- JDK-8249672: Include microcode revision in features_string on x86
- JDK-8249821: Separate libharfbuzz from libfontmanager
- JDK-8250598: Hyper-V is detected in spite of running on host OS
- JDK-8250605: Linux x86_32 builds fail after JDK-8249821
- JDK-8250665: Wrong translation for the month name of May in ar_JO,LB,SY
- JDK-8250772: Test com/sun/jndi/ldap/NamingExceptionMessageTest.java fails intermittently with javax.naming.ServiceUnavailableException
- JDK-8250894: Provide a configure option to build and run against the platform libharfbuzz
- JDK-8250928: JFR: Improve hash algorithm for stack traces
- JDK-8251118: BiasedLocking::preserve_marks should not have a HandleMark
- JDK-8251189: com/sun/jndi/ldap/LdapDnsProviderTest.java failed due to timeout
- JDK-8251397: NPE on ClassValue.ClassValueMap.cacheArray
- JDK-8251456: [TESTBUG] compiler/vectorization/TestVectorsNotSavedAtSafepoint.java failed OutOfMemoryError
- JDK-8251458: Parse::do_lookupswitch fails with "assert(_cnt >= 0) failed"
- JDK-8251949: ZGC: Set explicit heap size for compiler/gcbarriers tests
- JDK-8252090: JFR: StreamWriterHost::write_unbuffered() stucks in an infinite loop OpenJDK (build 13.0.1+9)
- JDK-8252415: Bump update version for OpenJDK: jdk-11.0.10
- JDK-8252470: java/awt/dnd/DisposeFrameOnDragCrash/DisposeFrameOnDragTest.java fails on Windows
- JDK-8252497: Incorrect numeric currency code for ROL
- JDK-8252660: Shenandoah: support manageable SoftMaxHeapSize option
- JDK-8252696: Loop unswitching may cause out of bound array load to be executed
- JDK-8252754: Hash code calculation of JfrStackTrace is inconsistent
- JDK-8253224: Shenandoah: ShenandoahStrDedupQueue destructor calls virtual num_queues()
- JDK-8253226: Shenandoah: remove unimplemented ShenandoahStrDedupQueue::verify
- JDK-8253284: Zero OrderAccess barrier mappings are incorrect
- JDK-8253375: OSX build fails with Xcode 12.0 (12A7209)
- JDK-8253778: ShenandoahSafepoint::is_at_shenandoah_safepoint should not access VMThread state from other threads
- JDK-8253791: Issue with useAppleColor check in CSystemColors.m
- JDK-8254081: java/security/cert/PolicyNode/GetPolicyQualifiers.java fails due to an expired certificate
- JDK-8254166: Zero: return-type warning in zeroInterpreter_zero.cpp
- JDK-8254177: (tz) Upgrade time-zone data to tzdata2020b
- JDK-8254185: Fix Code cache sweeper heuristics for JDK 11
- JDK-8254190: [s390] interpreter misses exception check after calling monitorenter
- JDK-8254790: SIGSEGV in string_indexof_char and stringL_indexof_char intrinsics
Notes on individual issues:
===========================
security-libs/java.security:
JDK-8213821: -groupname Option Added to keytool Key Pair Generation
===================================================================
A new `-groupname` option has been added to `keytool -genkeypair` so
that a user can specify a named group when generating a key pair. For
example, `keytool -genkeypair -keyalg EC -groupname secp384r1` will
generate an EC key pair by using the `secp384r1` curve. Because there
might be multiple curves with the same size, using the `-groupname`
option is preferred over the `-keysize` option.
New in release OpenJDK 11.0.9.1 (2020-10-20):
=============================================
Live versions of these release notes can be found at:

View File

@ -4,18 +4,20 @@
#
# Examples:
#
# Produce release *and* slowdebug builds on x86_64 (default):
# Produce release, fastdebug *and* slowdebug builds on x86_64 (default):
# $ rpmbuild -ba java-1.8.0-openjdk.spec
#
# Produce only release builds (no slowdebug builds) on x86_64:
# $ rpmbuild -ba java-1.8.0-openjdk.spec --without slowdebug
# $ rpmbuild -ba java-1.8.0-openjdk.spec --without slowdebug --without fastdebug
#
# Only produce a release build on x86_64:
# $ fedpkg mockbuild --without slowdebug
# $ fedpkg mockbuild --without slowdebug --without fastdebug
#
# Only produce a debug build on x86_64:
# $ fedpkg local --without release
#
# Enable fastdebug builds by default on relevant arches.
%bcond_without fastdebug
# Enable slowdebug builds by default on relevant arches.
%bcond_without slowdebug
# Enable release builds by default on relevant arches.
@ -35,14 +37,18 @@
# See https://github.com/rpm-software-management/rpm/issues/127 to comments at "pmatilai commented on Aug 18, 2017"
# (initiated in https://bugzilla.redhat.com/show_bug.cgi?id=1482192)
%global debug_suffix_unquoted -slowdebug
%global fastdebug_suffix_unquoted -fastdebug
# quoted one for shell operations
%global debug_suffix "%{debug_suffix_unquoted}"
%global fastdebug_suffix "%{fastdebug_suffix_unquoted}"
%global normal_suffix ""
# if you want only debug build but providing java build only normal build but set normalbuild_parameter
%global debug_warning This package has full debug on. Install only in need and remove asap.
%global debug_on with full debug on
%global for_debug for packages with debug on
%global debug_warning This package is unoptimised with full debugging. Install only as needed and remove ASAP.
%global debug_on with full debugging on
%global fastdebug_on with minimal debugging on
%global fastdebug_warning This package is optimised with full debugging. Install only as needed and remove ASAP.
%global for_fastdebug_on for packages with minimal debugging on
%global for_debug for packages with debugging on
%if %{with release}
%global include_normal_build 1
@ -51,9 +57,9 @@
%endif
%if %{include_normal_build}
%global build_loop1 %{normal_suffix}
%global normal_build %{normal_suffix}
%else
%global build_loop1 %{nil}
%global normal_build %{nil}
%endif
# We have hardcoded list of files, which is appearing in alternatives, and in files
@ -69,7 +75,7 @@
# == rpm -ql java-11-openjdk-headless-slowdebug-11.0.1.13-8.fc29.x86_64.rpm | grep bin
# != rpm -ql java-11-openjdk-headless-11.0.1.13-8.fc29.x86_64.rpm | grep bin
# similarly for other %%{_jvmdir}/{jre,java} and %%{_javadocdir}/{java,java-zip}
%define is_release_build() %( if [ "%{?1}" == "%{debug_suffix_unquoted}" ]; then echo "0" ; else echo "1"; fi )
%define is_release_build() %( if [ "%{?1}" == "%{debug_suffix_unquoted}" -o "%{?1}" == "%{fastdebug_suffix_unquoted}" ]; then echo "0" ; else echo "1"; fi )
# while JDK is a techpreview(is_system_jdk=0), some provides are turned off. Once jdk stops to be an techpreview, move it to 1
# as sytem JDK, we mean any JDK which can run whole system java stack without issues (like bytecode issues, module issues, dependencies...)
@ -91,6 +97,7 @@
%global systemtap_arches %{jit_arches}
# Set of architectures with a Ahead-Of-Time (AOT) compiler
%global aot_arches x86_64 %{aarch64}
%global fastdebug_arches x86_64 ppc64le aarch64
# Set of architectures which support the serviceability agent
%global sa_arches %{ix86} x86_64 sparcv9 sparc64 %{aarch64} %{power64} %{arm}
# Set of architectures which support class data sharing
@ -133,17 +140,34 @@
%global zgc_feature -zgc
%endif
%if %{include_debug_build}
%global build_loop2 %{debug_suffix}
# By default, we build a fastdebug build during main build only on fastdebug architectures
%if %{with fastdebug}
%ifarch %{fastdebug_arches}
%global include_fastdebug_build 1
%else
%global build_loop2 %{nil}
%global include_fastdebug_build 0
%endif
%else
%global include_fastdebug_build 0
%endif
# if you disable both builds, then the build fails
%global build_loop %{build_loop1} %{build_loop2}
# note: that order: normal_suffix debug_suffix, in case of both enabled
# is expected in one single case at the end of the build
%global rev_build_loop %{build_loop2} %{build_loop1}
%if %{include_debug_build}
%global slowdebug_build %{debug_suffix}
%else
%global slowdebug_build %{nil}
%endif
%if %{include_fastdebug_build}
%global fastdebug_build %{fastdebug_suffix}
%else
%global fastdebug_build %{nil}
%endif
# If you disable both builds, then the build fails
# Note that the debug build requires the normal build for docs
%global build_loop %{normal_build} %{fastdebug_build} %{slowdebug_build}
# Test slowdebug first as it provides the best diagnostics
%global rev_build_loop %{slowdebug_build} %{fastdebug_build} %{normal_build}
%ifarch %{bootstrap_arches}
%global bootstrap_build 1
@ -233,16 +257,18 @@
%endif
# New Version-String scheme-style defines
# If you bump majorver, you must bump also vendor_version_string
%global majorver 11
%global featurever 11
%global interimver 0
%global updatever 10
%global patchver 0
# If you bump featurever, you must bump also vendor_version_string
# Used via new version scheme. JDK 11 was
# GA'ed in September 2018 => 18.9
%global vendor_version_string 18.9
%global securityver 9
# buildjdkver is usually same as %%{majorver},
# but in time of bootstrap of next jdk, it is majorver-1,
# buildjdkver is usually same as %%{featurever},
# but in time of bootstrap of next jdk, it is featurever-1,
# and this it is better to change it here, on single place
%global buildjdkver %{majorver}
%global buildjdkver %{featurever}
# Add LTS designator for RHEL builds
%if 0%{?rhel}
%global lts_designator "LTS"
@ -259,26 +285,37 @@
%global origin openjdk
%global origin_nice OpenJDK
%global top_level_dir_name %{origin}
%global minorver 0
%global buildver 11
%global rpmrelease 6
%global buildver 1
%global rpmrelease 0
#%%global tagsuffix ""
# priority must be 8 digits in total; untill openjdk 1.8 we were using 18..... so when moving to 11 we had to add another digit
# Priority must be 8 digits in total; up to openjdk 1.8, we were using 18..... so when we moved to 11, we had to add another digit
%if %is_system_jdk
%global priority %( printf '%02d%02d%02d%02d' %{majorver} %{minorver} %{securityver} %{buildver} )
# Using 10 digits may overflow the int used for priority, so we combine the patch and build versions
# It is very unlikely we will ever have a patch version > 4 or a build version > 20, so we combine as (patch * 20) + build.
# This means 11.0.9.0+11 would have had a priority of 11000911 as before
# A 11.0.9.1+1 would have had a priority of 11000921 (20 * 1 + 1), thus ensuring it is bigger than 11.0.9.0+11
%global combiver $( expr 20 '*' %{patchver} + %{buildver} )
%global priority %( printf '%02d%02d%02d%02d' %{featurever} %{interimver} %{updatever} %{combiver} )
%else
# for techpreview, using 1, so slowdebugs can have 0
%global priority %( printf '%08d' 1 )
%endif
%global newjavaver %{majorver}.%{minorver}.%{securityver}
%global newjavaver %{featurever}.%{interimver}.%{updatever}.%{patchver}
%global javaver %{majorver}
# Omit trailing 0 in filenames when the patch version is 0
%if 0%{?patchver} > 0
%global filever %{newjavaver}
%else
%global filever %{featurever}.%{interimver}.%{updatever}
%endif
%global javaver %{featurever}
# Define milestone (EA for pre-releases, GA for releases)
# Release will be (where N is usually a number starting at 1):
# - 0.N%%{?extraver}%%{?dist} for EA releases,
# - N%%{?extraver}{?dist} for GA releases
%global is_ga 1
%global is_ga 0
%if %{is_ga}
%global ea_designator ""
%global ea_designator_zip ""
@ -309,7 +346,7 @@
%endif
# parametrized macros are order-sensitive
%global compatiblename java-%{majorver}-%{origin}
%global compatiblename java-%{featurever}-%{origin}
%global fullversion %{compatiblename}-%{version}-%{release}
# images directories from upstream build
%global jdkimage jdk
@ -333,6 +370,8 @@
# Never generate lib-style provides/requires for slowdebug packages
%global __provides_exclude_from ^.*/%{uniquesuffix -- %{debug_suffix_unquoted}}/.*$
%global __requires_exclude_from ^.*/%{uniquesuffix -- %{debug_suffix_unquoted}}/.*$
%global __provides_exclude_from ^.*/%{uniquesuffix -- %{fastdebug_suffix_unquoted}}/.*$
%global __requires_exclude_from ^.*/%{uniquesuffix -- %{fastdebug_suffix_unquoted}}/.*$
%else
# Don't generate provides/requires for JDK provided shared libraries at all.
%global __provides_exclude ^(%{_privatelibs}|%{_publiclibs})$
@ -533,7 +572,7 @@ alternatives \\
--slave %{_mandir}/man1/rmic.1$ext rmic.1$ext \\
%{_mandir}/man1/rmic-%{uniquesuffix -- %{?1}}.1$ext \\
--slave %{_mandir}/man1/serialver.1$ext serialver.1$ext \\
%{_mandir}/man1/serialver-%{uniquesuffix -- %{?1}}.1$ext \\
%{_mandir}/man1/serialver-%{uniquesuffix -- %{?1}}.1$ext
for X in %{origin} %{javaver} ; do
alternatives \\
@ -717,7 +756,7 @@ exit 0
%config(noreplace) %{etcjavadir -- %{?1}}/conf/logging.properties
%config(noreplace) %{etcjavadir -- %{?1}}/conf/security/nss.cfg
%config(noreplace) %{etcjavadir -- %{?1}}/conf/management/jmxremote.access
# this is conifg template, thus not config-noreplace
# these are config templates, thus not config-noreplace
%config %{etcjavadir -- %{?1}}/conf/management/jmxremote.password.template
%config(noreplace) %{etcjavadir -- %{?1}}/conf/management/management.properties
%config(noreplace) %{etcjavadir -- %{?1}}/conf/net.properties
@ -1045,7 +1084,7 @@ Release: %{?eaprefix}%{rpmrelease}%{?extraver}%{?dist}
# provides >= 1.6.0 must specify the epoch, "java >= 1:1.6.0".
Epoch: 1
Summary: %{origin_nice} Runtime Environment %{majorver}
Summary: %{origin_nice} %{featurever} Runtime Environment
# HotSpot code is licensed under GPLv2
# JDK library code is licensed under GPLv2 with the Classpath exception
@ -1067,7 +1106,7 @@ URL: http://openjdk.java.net/
# to regenerate source0 (jdk) run update_package.sh
# update_package.sh contains hard-coded repos, revisions, tags, and projects to regenerate the source archives
Source0: jdk-updates-jdk%{majorver}u-jdk-%{newjavaver}+%{buildver}%{?tagsuffix:-%{tagsuffix}}-4curve.tar.xz
Source0: jdk-updates-jdk%{featurever}u-jdk-%{filever}+%{buildver}%{?tagsuffix:-%{tagsuffix}}-4curve.tar.xz
# Use 'icedtea_sync.sh' to update the following
# They are based on code contained in the IcedTea project (3.x).
@ -1141,10 +1180,6 @@ Patch7: pr3695-toggle_system_crypto_policy.patch
# able to be removed once that release is out
# and used by this RPM.
#############################################
# JDK-8222286: S390 ambiguous log2_intptr call
Patch8: s390-8214206_fix.patch
# JDK-8254177: (tz) Upgrade time-zone data to tzdata2020b
Patch9: jdk8254177-tzdata2020b.patch
# JDK-8250861: Crash in MinINode::Ideal(PhaseGVN*, bool)
Patch10: jdk8250861-crash_in_MinINode_Ideal.patch
@ -1161,6 +1196,7 @@ BuildRequires: freetype-devel
BuildRequires: giflib-devel
BuildRequires: gcc-c++
BuildRequires: gdb
BuildRequires: harfbuzz-devel
BuildRequires: lcms2-devel
BuildRequires: libjpeg-devel
BuildRequires: libpng-devel
@ -1198,186 +1234,280 @@ BuildRequires: systemtap-sdt-devel
%{java_rpo %{nil}}
%description
The %{origin_nice} runtime environment.
The %{origin_nice} %{featurever} runtime environment.
%if %{include_debug_build}
%package slowdebug
Summary: %{origin_nice} Runtime Environment %{majorver} %{debug_on}
Summary: %{origin_nice} %{featurever} Runtime Environment %{debug_on}
%{java_rpo -- %{debug_suffix_unquoted}}
%description slowdebug
The %{origin_nice} runtime environment.
The %{origin_nice} %{featurever} runtime environment.
%{debug_warning}
%endif
%if %{include_fastdebug_build}
%package fastdebug
Summary: %{origin_nice} %{featurever} Runtime Environment %{fastdebug_on}
Group: Development/Languages
%{java_rpo -- %{fastdebug_suffix_unquoted}}
%description fastdebug
The %{origin_nice} %{featurever} runtime environment.
%{fastdebug_warning}
%endif
%if %{include_normal_build}
%package headless
Summary: %{origin_nice} Headless Runtime Environment %{majorver}
Summary: %{origin_nice} %{featurever} Headless Runtime Environment
%{java_headless_rpo %{nil}}
%description headless
The %{origin_nice} runtime environment %{majorver} without audio and video support.
The %{origin_nice} %{featurever} runtime environment without audio and video support.
%endif
%if %{include_debug_build}
%package headless-slowdebug
Summary: %{origin_nice} Runtime Environment %{debug_on}
Summary: %{origin_nice} %{featurever} Runtime Environment %{debug_on}
%{java_headless_rpo -- %{debug_suffix_unquoted}}
%description headless-slowdebug
The %{origin_nice} runtime environment %{majorver} without audio and video support.
The %{origin_nice} %{featurever} runtime environment without audio and video support.
%{debug_warning}
%endif
%if %{include_fastdebug_build}
%package headless-fastdebug
Summary: %{origin_nice} %{featurever} Runtime Environment %{fastdebug_on}
Group: Development/Languages
%{java_headless_rpo -- %{fastdebug_suffix_unquoted}}
%description headless-fastdebug
The %{origin_nice} %{featurever} runtime environment without audio and video support.
%{fastdebug_warning}
%endif
%if %{include_normal_build}
%package devel
Summary: %{origin_nice} Development Environment %{majorver}
Summary: %{origin_nice} %{featurever} Development Environment
%{java_devel_rpo %{nil}}
%description devel
The %{origin_nice} development tools %{majorver}.
The %{origin_nice} %{featurever} development tools.
%endif
%if %{include_debug_build}
%package devel-slowdebug
Summary: %{origin_nice} Development Environment %{majorver} %{debug_on}
Summary: %{origin_nice} %{featurever} Development Environment %{debug_on}
%{java_devel_rpo -- %{debug_suffix_unquoted}}
%description devel-slowdebug
The %{origin_nice} development tools %{majorver}.
The %{origin_nice} %{featurever} development tools.
%{debug_warning}
%endif
%if %{include_fastdebug_build}
%package devel-fastdebug
Summary: %{origin_nice} %{featurever} Development Environment %{fastdebug_on}
Group: Development/Tools
%{java_devel_rpo -- %{fastdebug_suffix_unquoted}}
%description devel-fastdebug
The %{origin_nice} %{featurever} development tools .
%{fastdebug_warning}
%endif
%if %{include_normal_build}
%package static-libs
Summary: %{origin_nice} libraries for static linking %{majorver}
Summary: %{origin_nice} %{featurever} libraries for static linking
%{java_static_libs_rpo %{nil}}
%description static-libs
The %{origin_nice} libraries for static linking %{majorver}.
The %{origin_nice} %{featurever} libraries for static linking.
%endif
%if %{include_debug_build}
%package static-libs-slowdebug
Summary: %{origin_nice} libraries for static linking %{majorver} %{debug_on}
Summary: %{origin_nice} %{featurever} libraries for static linking %{debug_on}
%{java_static_libs_rpo -- %{debug_suffix_unquoted}}
%description static-libs-slowdebug
The %{origin_nice} libraries for static linking %{majorver}.
The %{origin_nice} %{featurever} libraries for static linking.
%{debug_warning}
%endif
%if %{include_fastdebug_build}
%package static-libs-fastdebug
Summary: %{origin_nice} %{featurever} libraries for static linking %{fastdebug_on}
%{java_static_libs_rpo -- %{fastdebug_suffix_unquoted}}
%description static-libs-fastdebug
The %{origin_nice} %{featurever} libraries for static linking.
%{fastdebug_warning}
%endif
%if %{include_normal_build}
%package jmods
Summary: JMods for %{origin_nice} %{majorver}
Summary: JMods for %{origin_nice} %{featurever}
%{java_jmods_rpo %{nil}}
%description jmods
The JMods for %{origin_nice}.
The JMods for %{origin_nice} %{featurever}.
%endif
%if %{include_debug_build}
%package jmods-slowdebug
Summary: JMods for %{origin_nice} %{majorver} %{debug_on}
Summary: JMods for %{origin_nice} %{featurever} %{debug_on}
%{java_jmods_rpo -- %{debug_suffix_unquoted}}
%description jmods-slowdebug
The JMods for %{origin_nice} %{majorver}.
The JMods for %{origin_nice} %{featurever}.
%{debug_warning}
%endif
%if %{include_fastdebug_build}
%package jmods-fastdebug
Summary: JMods for %{origin_nice} %{featurever} %{fastdebug_on}
Group: Development/Tools
%{java_jmods_rpo -- %{fastdebug_suffix_unquoted}}
%description jmods-fastdebug
The JMods for %{origin_nice} %{featurever}.
%{fastdebug_warning}
%endif
%if %{include_normal_build}
%package demo
Summary: %{origin_nice} Demos %{majorver}
Summary: %{origin_nice} %{featurever} Demos
%{java_demo_rpo %{nil}}
%description demo
The %{origin_nice} demos %{majorver}.
The %{origin_nice} %{featurever} demos.
%endif
%if %{include_debug_build}
%package demo-slowdebug
Summary: %{origin_nice} Demos %{majorver} %{debug_on}
Summary: %{origin_nice} %{featurever} Demos %{debug_on}
%{java_demo_rpo -- %{debug_suffix_unquoted}}
%description demo-slowdebug
The %{origin_nice} demos %{majorver}.
The %{origin_nice} %{featurever} demos.
%{debug_warning}
%endif
%if %{include_fastdebug_build}
%package demo-fastdebug
Summary: %{origin_nice} %{featurever} Demos %{fastdebug_on}
Group: Development/Languages
%{java_demo_rpo -- %{fastdebug_suffix_unquoted}}
%description demo-fastdebug
The %{origin_nice} %{featurever} demos.
%{fastdebug_warning}
%endif
%if %{include_normal_build}
%package src
Summary: %{origin_nice} Source Bundle %{majorver}
Summary: %{origin_nice} %{featurever} Source Bundle
%{java_src_rpo %{nil}}
%description src
The java-%{origin}-src sub-package contains the complete %{origin_nice} %{majorver}
The %{compatiblename}-src sub-package contains the complete %{origin_nice} %{featurever}
class library source code for use by IDE indexers and debuggers.
%endif
%if %{include_debug_build}
%package src-slowdebug
Summary: %{origin_nice} Source Bundle %{majorver} %{for_debug}
Summary: %{origin_nice} %{featurever} Source Bundle %{for_debug}
%{java_src_rpo -- %{debug_suffix_unquoted}}
%description src-slowdebug
The java-%{origin}-src-slowdebug sub-package contains the complete %{origin_nice} %{majorver}
class library source code for use by IDE indexers and debuggers. Debugging %{for_debug}.
The %{compatiblename}-src-slowdebug sub-package contains the complete %{origin_nice} %{featurever}
class library source code for use by IDE indexers and debuggers, %{for_debug}.
%endif
%if %{include_fastdebug_build}
%package src-fastdebug
Summary: %{origin_nice} %{featurever} Source Bundle %{for_fastdebug}
Group: Development/Languages
%{java_src_rpo -- %{fastdebug_suffix_unquoted}}
%description src-fastdebug
The %{compatiblename}-src-fastdebug sub-package contains the complete %{origin_nice} %{featurever}
class library source code for use by IDE indexers and debuggers, %{for_fastdebug}.
%endif
%if %{include_normal_build}
%package javadoc
Summary: %{origin_nice} %{majorver} API documentation
Summary: %{origin_nice} %{featurever} API documentation
Requires: javapackages-filesystem
Obsoletes: javadoc-slowdebug < 1:11.0.3.7-4
%{java_javadoc_rpo %{nil}}
%description javadoc
The %{origin_nice} %{majorver} API documentation.
The %{origin_nice} %{featurever} API documentation.
%endif
%if %{include_normal_build}
%package javadoc-zip
Summary: %{origin_nice} %{majorver} API documentation compressed in a single archive
Summary: %{origin_nice} %{featurever} API documentation compressed in a single archive
Requires: javapackages-filesystem
Obsoletes: javadoc-zip-slowdebug < 1:11.0.3.7-4
%{java_javadoc_rpo %{nil}}
%description javadoc-zip
The %{origin_nice} %{majorver} API documentation compressed in a single archive.
The %{origin_nice} %{featurever} API documentation compressed in a single archive.
%endif
%prep
if [ %{include_normal_build} -eq 0 -o %{include_normal_build} -eq 1 ] ; then
echo "include_normal_build is %{include_normal_build}"
else
echo "include_normal_build is %{include_normal_build}, thats invalid. Use 1 for yes or 0 for no"
echo "include_normal_build is %{include_normal_build}, that is invalid. Use 1 for yes or 0 for no"
exit 11
fi
if [ %{include_debug_build} -eq 0 -o %{include_debug_build} -eq 1 ] ; then
echo "include_debug_build is %{include_debug_build}"
else
echo "include_debug_build is %{include_debug_build}, thats invalid. Use 1 for yes or 0 for no"
echo "include_debug_build is %{include_debug_build}, that is invalid. Use 1 for yes or 0 for no"
exit 12
fi
if [ %{include_debug_build} -eq 0 -a %{include_normal_build} -eq 0 ] ; then
echo "You have disabled both include_debug_build and include_normal_build. That is a no go."
if [ %{include_fastdebug_build} -eq 0 -o %{include_fastdebug_build} -eq 1 ] ; then
echo "include_fastdebug_build is %{include_fastdebug_build}"
else
echo "include_fastdebug_build is %{include_fastdebug_build}, that is invalid. Use 1 for yes or 0 for no"
exit 13
fi
if [ %{include_debug_build} -eq 0 -a %{include_normal_build} -eq 0 -a %{include_fastdebug_build} -eq 0 ] ; then
echo "You have disabled all builds (normal,fastdebug,slowdebug). That is a no go."
exit 14
fi
if [ %{include_normal_build} -eq 0 ] ; then
echo "You have disabled the normal build, but this is required to provide docs for the debug build."
exit 15
fi
%setup -q -c -n %{uniquesuffix ""} -T -a 0
# https://bugzilla.redhat.com/show_bug.cgi?id=1189084
prioritylength=`expr length %{priority}`
@ -1396,8 +1526,6 @@ pushd %{top_level_dir_name}
%patch3 -p1
%patch4 -p1
%patch7 -p1
%patch8 -p1
%patch9 -p1
%patch10 -p1
popd # openjdk
@ -1410,6 +1538,9 @@ tar --strip-components=1 -x -I xz -f %{SOURCE8}
%if %{include_debug_build}
cp -r tapset tapset%{debug_suffix}
%endif
%if %{include_fastdebug_build}
cp -r tapset tapset%{fastdebug_suffix}
%endif
for suffix in %{build_loop} ; do
@ -1502,11 +1633,9 @@ bash ../configure \
%ifarch %{ppc64le}
--with-jobs=1 \
%endif
--with-version-build=1 \
--with-version-build=%{buildver} \
--with-version-pre="%{ea_designator}" \
--with-version-opt=%{lts_designator} \
--with-version-patch=1 \
--with-version-date="2020-11-04" \
--with-vendor-version-string="%{vendor_version_string}" \
--with-vendor-name="Red Hat, Inc." \
--with-vendor-url="https://www.redhat.com/" \
@ -1521,6 +1650,7 @@ bash ../configure \
--with-giflib=system \
--with-libpng=system \
--with-lcms=system \
--with-harfbuzz=system \
--with-stdc++lib=dynamic \
--with-extra-cxxflags="$EXTRA_CPP_FLAGS" \
--with-extra-cflags="$EXTRA_CFLAGS" \
@ -1676,6 +1806,7 @@ quit
end
run -version
EOF
# This fails on s390x for some reason. Disable for now. See:
# https://koji.fedoraproject.org/koji/taskinfo?taskID=41499227
%ifnarch s390x
@ -1756,13 +1887,13 @@ mkdir -p $RPM_BUILD_ROOT%{_jvmdir}/%{sdkdir -- $suffix}/lib/static/linux-%{archi
cp -a %{buildoutputdir -- $suffix}/images/%{static_libs_image}/lib/*.a \
$RPM_BUILD_ROOT%{_jvmdir}/%{sdkdir -- $suffix}/lib/static/linux-%{archinstall}/glibc
if ! echo $suffix | grep -q "debug" ; then
# Install Javadoc documentation
install -d -m 755 $RPM_BUILD_ROOT%{_javadocdir}
cp -a %{buildoutputdir -- $suffix}/images/docs $RPM_BUILD_ROOT%{_javadocdir}/%{uniquejavadocdir -- $suffix}
#cp -a %{buildoutputdir -- $suffix}/bundles/jdk-%{newjavaver}%{ea_designator_zip}+%{buildver}%{lts_designator_zip}-docs.zip $RPM_BUILD_ROOT%{_javadocdir}/%{uniquejavadocdir -- $suffix}.zip
cp -a %{buildoutputdir -- $suffix}/bundles/jdk-11.0.9.1+1%{lts_designator_zip}-docs.zip $RPM_BUILD_ROOT%{_javadocdir}/%{uniquejavadocdir -- $suffix}.zip
built_doc_archive=jdk-%{filever}%{ea_designator_zip}+%{buildver}%{lts_designator_zip}-docs.zip
cp -a %{buildoutputdir -- $suffix}/bundles/${built_doc_archive} \
$RPM_BUILD_ROOT%{_javadocdir}/%{uniquejavadocdir -- $suffix}.zip || ls -l %{buildoutputdir -- $suffix}/bundles/
fi
# Install release notes
@ -1919,6 +2050,33 @@ require "copy_jdk_configs.lua"
%{posttrans_devel -- %{debug_suffix_unquoted}}
%endif
%if %{include_fastdebug_build}
%post fastdebug
%{post_script -- %{fastdebug_suffix_unquoted}}
%post headless-fastdebug
%{post_headless -- %{fastdebug_suffix_unquoted}}
%postun fastdebug
%{postun_script -- %{fastdebug_suffix_unquoted}}
%postun headless-fastdebug
%{postun_headless -- %{fastdebug_suffix_unquoted}}
%posttrans fastdebug
%{posttrans_script -- %{fastdebug_suffix_unquoted}}
%post devel-fastdebug
%{post_devel -- %{fastdebug_suffix_unquoted}}
%postun devel-fastdebug
%{postun_devel -- %{fastdebug_suffix_unquoted}}
%posttrans devel-fastdebug
%{posttrans_devel -- %{fastdebug_suffix_unquoted}}
%endif
%if %{include_normal_build}
%files
# main package builds always
@ -1953,9 +2111,8 @@ require "copy_jdk_configs.lua"
%files javadoc
%{files_javadoc %{nil}}
# this puts huge file to /usr/share
# unluckily ti is really a documentation file
# and unluckily it really is architecture-dependent, as eg. aot and grail are now x86_64 only
# This puts a huge documentation file in /usr/share
# It is now architecture-dependent, as eg. AOT and Graal are now x86_64 only
# same for debug variant
%files javadoc-zip
%{files_javadoc_zip %{nil}}
@ -1984,8 +2141,48 @@ require "copy_jdk_configs.lua"
%{files_src -- %{debug_suffix_unquoted}}
%endif
%if %{include_fastdebug_build}
%files fastdebug
%{files_jre -- %{fastdebug_suffix_unquoted}}
%files headless-fastdebug
%{files_jre_headless -- %{fastdebug_suffix_unquoted}}
%files devel-fastdebug
%{files_devel -- %{fastdebug_suffix_unquoted}}
%files static-libs-fastdebug
%{files_static_libs -- %{fastdebug_suffix_unquoted}}
%files jmods-fastdebug
%{files_jmods -- %{fastdebug_suffix_unquoted}}
%files demo-fastdebug
%{files_demo -- %{fastdebug_suffix_unquoted}}
%files src-fastdebug
%{files_src -- %{fastdebug_suffix_unquoted}}
%endif
%changelog
* Tue Dec 22 2020 Andrew John Hughes <gnu.andrew@redhat.com> - 1:11.0.10.0.1-0.0.ea
- Update to jdk-11.0.10.0+1
- Update release notes to 11.0.10.0+1
- Use JEP-322 Time-Based Versioning so we can handle a future 11.0.9.1-like release correctly.
- Still use 11.0.x rather than 11.0.x.0 for file naming, as the trailing zero is omitted from tags.
- Revert configure and built_doc_archive hacks to build 11.0.9.1 from 11.0.9.0 sources, and synced with RHEL version.
- Cleanup debug package descriptions and version number placement.
- Switch to EA mode for 11.0.10 pre-release builds.
- Drop JDK-8222286 & JDK-8254177 as applied upstream
- Use system harfbuzz now this is supported.
* Tue Dec 22 2020 Jiri Vanek <jvanek@redhat.com> - 1:11.0.9.11-9
- fixed missing condition for fastdebug packages being counted as debug ones
* Sat Dec 19 2020 Jiri Vanek <jvanek@redhat.com> - 1:11.0.9.11-8
- removed lib-style provides for fastdebug_suffix_unquoted
* Thu Dec 17 2020 Andrew Hughes <gnu.andrew@redhat.com> - 1:11.0.9.11-6
- introduced nm based check to verify alt-java on x86_64 is patched, and no other alt-java or java is patched
- patch600 rh1750419-redhat_alt_java.patch amended to die, if it is used wrongly

File diff suppressed because it is too large Load Diff

View File

@ -1,12 +0,0 @@
diff --git openjdk.orig/jdk/src/hotspot/share/runtime/os.cpp openjdk/jdk/src/hotspot/share/runtime/os.cpp
--- openjdk.orig/src/hotspot/share/runtime/os.cpp
+++ openjdk/src/hotspot/share/runtime/os.cpp
@@ -1368,7 +1368,7 @@
}
void os::set_memory_serialize_page(address page) {
- int count = log2_intptr(sizeof(class JavaThread)) - log2_int(64);
+ int count = log2_intptr((uintptr_t) sizeof(class JavaThread)) - log2_int(64);
_mem_serialize_page = (volatile int32_t *)page;
// We initialize the serialization page shift count here
// We assume a cache line size of 64 bytes

View File

@ -1,2 +1,2 @@
SHA512 (tapsets-icedtea-3.15.0.tar.xz) = c752a197cb3d812d50c35e11e4722772be40096c81d2a57933e0d9b8a3c708b9c157b8108a4e33a06ca7bb81648170994408c75d6f69d5ff12785d0c31009671
SHA512 (jdk-updates-jdk11u-jdk-11.0.9+11-4curve.tar.xz) = 09234290f4e285e921082fb7ddfed3000155f08cb8e63970f2f123cf1c2e1980aebae2ca71faa76a6ba2c0836937ed8ee0b7ab0f53b73a712a00e777a7b2d4ac
SHA512 (jdk-updates-jdk11u-jdk-11.0.10+1-4curve.tar.xz) = 6217deaf76a9fe314f7ab2b7255b93d35ef32f68ebf7b2000a6526c04bc7ecf28dc08c77bb27f221872ee19e4cbd8a1f44dc45f3b3b8c660e226fd9ce47b4d01