From 44396cf66a787520d18cc04801cf6082d1e08744 Mon Sep 17 00:00:00 2001
From: Jiri Vanek <jvanek@redhat.com>
Date: Wed, 27 Aug 2014 15:28:10 +0200
Subject: [PATCH] updated to u40-b01, remved applet-hole - adapted 
 java-1.8.0-openjdk-accessible-toolkit.patch - adapted  system-lcms.patch -
 removed patch8 set-active-window.patch - removed patch9
 javadoc-error-jdk-8029145.patch - removed patch10
 javadoc-error-jdk-8037484.patch - remopved patch99 applet-hole.patch - itw
 1.5.1 is able to ive without it

---
 .gitignore                                  |   2 +
 applet-hole.patch                           | 108 -------------
 generate_tarballs.sh                        |   5 +-
 java-1.8.0-openjdk-accessible-toolkit.patch |  26 +--
 java-1.8.0-openjdk.spec                     |  29 ++--
 javadoc-error-jdk-8029145.patch             |  93 -----------
 javadoc-error-jdk-8037484.patch             | 171 --------------------
 set-active-window.patch                     |  77 ---------
 sources                                     |   2 +-
 system-lcms.patch                           |   3 +-
 10 files changed, 33 insertions(+), 483 deletions(-)
 delete mode 100644 applet-hole.patch
 delete mode 100644 javadoc-error-jdk-8029145.patch
 delete mode 100644 javadoc-error-jdk-8037484.patch
 delete mode 100644 set-active-window.patch

diff --git a/.gitignore b/.gitignore
index 606b199..66459fe 100644
--- a/.gitignore
+++ b/.gitignore
@@ -25,3 +25,5 @@
 /jdk8u-jdk8u5-b13.tar.xz
 /jdk8u-jdk8u11-b12.tar.xz
 /aarch64-hotspot-jdk8-b128-aarch64-992.tar.xz
+/jdk8u-jdk8u20-b23.tar.xz
+/jdk8u-jdk8u40-b01.tar.xz
diff --git a/applet-hole.patch b/applet-hole.patch
deleted file mode 100644
index 6f163e9..0000000
--- a/applet-hole.patch
+++ /dev/null
@@ -1,108 +0,0 @@
-diff --git jdk8/jdk/src/share/classes/sun/applet/AppletPanel.java jdk8/jdk/src/share/classes/sun/applet/AppletPanel.java
---- jdk8/jdk/src/share/classes/sun/applet/AppletPanel.java
-+++ jdk8/jdk/src/share/classes/sun/applet/AppletPanel.java
-@@ -68,7 +68,7 @@
-     /**
-      * The applet (if loaded).
-      */
--    Applet applet;
-+    protected Applet applet;
- 
-     /**
-      * Applet will allow initialization.  Should be
-@@ -162,7 +162,8 @@
-      * Creates a thread to run the applet. This method is called
-      * each time an applet is loaded and reloaded.
-      */
--    synchronized void createAppletThread() {
-+	//Overridden by NetxPanel.
-+    protected synchronized void createAppletThread() {
-         // Create a thread group for the applet, and start a new
-         // thread to load the applet.
-         String nm = "applet-" + getCode();
-@@ -306,7 +307,7 @@
-     /**
-      * Get an event from the queue.
-      */
--    synchronized AppletEvent getNextEvent() throws InterruptedException {
-+    protected synchronized AppletEvent getNextEvent() throws InterruptedException {
-         while (queue == null || queue.isEmpty()) {
-             wait();
-         }
-@@ -692,7 +693,8 @@
-      * applet event processing so that it can be gracefully interrupted from
-      * things like HotJava.
-      */
--    private void runLoader() {
-+	//Overridden by NetxPanel.
-+    protected void runLoader() {
-         if (status != APPLET_DISPOSE) {
-             showAppletStatus("notdisposed");
-             return;
-diff --git jdk8/jdk/src/share/classes/sun/applet/AppletViewerPanel.java jdk8/jdk/src/share/classes/sun/applet/AppletViewerPanel.java
---- jdk8/jdk/src/share/classes/sun/applet/AppletViewerPanel.java
-+++ jdk8/jdk/src/share/classes/sun/applet/AppletViewerPanel.java
-@@ -42,25 +42,25 @@
-  *
-  * @author      Arthur van Hoff
-  */
--class AppletViewerPanel extends AppletPanel {
-+public class AppletViewerPanel extends AppletPanel {
- 
-     /* Are we debugging? */
--    static boolean debug = false;
-+    protected static boolean debug = false;
- 
-     /**
-      * The document url.
-      */
--    URL documentURL;
-+    protected URL documentURL;
- 
-     /**
-      * The base url.
-      */
--    URL baseURL;
-+    protected URL baseURL;
- 
-     /**
-      * The attributes of the applet.
-      */
--    Hashtable atts;
-+    protected Hashtable<String,String> atts;
- 
-     /*
-      * JDK 1.1 serialVersionUID
-@@ -70,7 +70,7 @@
-     /**
-      * Construct an applet viewer and start the applet.
-      */
--    AppletViewerPanel(URL documentURL, Hashtable atts) {
-+    protected AppletViewerPanel(URL documentURL, Hashtable<String,String> atts) {
-         this.documentURL = documentURL;
-         this.atts = atts;
- 
-@@ -106,7 +106,7 @@
-      * Get an applet parameter.
-      */
-     public String getParameter(String name) {
--        return (String)atts.get(name.toLowerCase());
-+        return atts.get(name.toLowerCase());
-     }
- 
-     /**
-@@ -202,12 +202,12 @@
-         return (AppletContext)getParent();
-     }
- 
--    static void debug(String s) {
-+    protected static void debug(String s) {
-         if(debug)
-             System.err.println("AppletViewerPanel:::" + s);
-     }
- 
--    static void debug(String s, Throwable t) {
-+    protected static void debug(String s, Throwable t) {
-         if(debug) {
-             t.printStackTrace();
-             debug(s);
diff --git a/generate_tarballs.sh b/generate_tarballs.sh
index 577e98b..0c5930d 100755
--- a/generate_tarballs.sh
+++ b/generate_tarballs.sh
@@ -9,8 +9,9 @@ rm -f icedtea7.tar.gz
 pushd icedtea7-${VERSION}
 
 # desktop files
-mv jconsole.desktop ../jconsole.desktop.in
-mv policytool.desktop ../policytool.desktop.in
+#mv jconsole.desktop ../jconsole.desktop.in
+#mv policytool.desktop ../policytool.desktop.in
+# Icons were generally cloned fromicedtea, but now are mucvh more specific
 
 # tapsets
 mv tapset/hotspot{,-1.8.0}.stp.in || exit 1
diff --git a/java-1.8.0-openjdk-accessible-toolkit.patch b/java-1.8.0-openjdk-accessible-toolkit.patch
index c177305..bddd702 100644
--- a/java-1.8.0-openjdk-accessible-toolkit.patch
+++ b/java-1.8.0-openjdk-accessible-toolkit.patch
@@ -1,16 +1,16 @@
 diff -uNr openjdk-orig/jdk/src/share/classes/java/awt/Toolkit.java jdk8/jdk/src/share/classes/java/awt/Toolkit.java
 --- openjdk-orig/jdk/src/share/classes/java/awt/Toolkit.java	2009-01-23 11:59:47.000000000 -0500
 +++ jdk8/jdk/src/share/classes/java/awt/Toolkit.java	2009-01-23 12:05:20.000000000 -0500
-@@ -871,7 +871,11 @@
-                         return null;
-                     }
-                 });
--                loadAssistiveTechnologies();
-+                try {
-+                    loadAssistiveTechnologies();
-+                } catch ( AWTError error) {
-+                    // ignore silently
-+                }
-             } finally {
-                 // Make sure to always re-enable the JIT.
-                 java.lang.Compiler.enable();
+@@ -883,7 +883,11 @@
+                     return null;
+                 }
+             });
+-            loadAssistiveTechnologies();
++         try {
++                 loadAssistiveTechnologies();
++             } catch ( AWTError error) {
++                 // ignore silently
++             }
+         }
+         return toolkit;
+     }
diff --git a/java-1.8.0-openjdk.spec b/java-1.8.0-openjdk.spec
index 4fa32af..364d411 100644
--- a/java-1.8.0-openjdk.spec
+++ b/java-1.8.0-openjdk.spec
@@ -96,8 +96,8 @@
 
 # Standard JPackage naming and versioning defines.
 %global origin          openjdk
-%global updatever       11
-%global buildver        b12
+%global updatever       40
+%global buildver        b01
 %global aarch64_updatever 0
 %global aarch64_buildver b128
 # priority must be 6 digits in total
@@ -137,7 +137,7 @@
 
 Name:    java-%{javaver}-%{origin}
 Version: %{javaver}.%{updatever}
-Release: 19.%{buildver}%{?dist}
+Release: 1.%{buildver}%{?dist}
 # java-1.5.0-ibm from jpackage.org set Epoch to 1 for unknown reasons,
 # and this change was brought into RHEL-4.  java-1.5.0-ibm packages
 # also included the epoch in their virtual provides.  This created a
@@ -203,12 +203,6 @@ Patch5: multiple-pkcs11-library-init.patch
 Patch6: disable-doclint-by-default.patch
 # Include all sources in src.zip
 Patch7: include-all-srcs.patch
-# Fix window activation in gnome-shell
-Patch8: set-active-window.patch
-# Fix javadoc. Backport from upstream.
-Patch9: javadoc-error-jdk-8029145.patch
-# More javadoc. Backport from upstream.
-Patch10: javadoc-error-jdk-8037484.patch
 # Problem discovered with make 4.0
 Patch11: hotspot-build-j-directive.patch
 
@@ -216,8 +210,6 @@ Patch11: hotspot-build-j-directive.patch
 # OpenJDK specific patches
 #
 
-# Allow icedtea-web to build
-Patch99: applet-hole.patch
 
 # JVM heap size changes for s390 (thanks to aph)
 Patch100: %{name}-s390-java-opts.patch
@@ -471,7 +463,6 @@ sh %{SOURCE12}
 %patch202
 %patch203
 
-
 %patch1
 %patch2
 %patch3
@@ -479,13 +470,8 @@ sh %{SOURCE12}
 %patch5
 %patch6
 %patch7
-%patch8
-%patch9
-%patch10
 %patch11
 
-%patch99
-
 # s390 build fixes
 %ifarch s390
 %patch100
@@ -1350,6 +1336,15 @@ exit 0
 %{_jvmdir}/%{jredir}/lib/accessibility.properties
 
 %changelog
+* Wed Aug 27 2014 Jiri Vanek <jvanek@redhat.com> - 1:1.8.0.40-1.b01
+- updated to u40-b01
+- adapted  java-1.8.0-openjdk-accessible-toolkit.patch
+- adapted  system-lcms.patch
+- removed patch8 set-active-window.patch
+- removed patch9 javadoc-error-jdk-8029145.patch
+- removed patch10 javadoc-error-jdk-8037484.patch
+- remopved patch99 applet-hole.patch - itw 1.5.1 is able to ive without it
+
 * Tue Aug 19 2014 Jiri Vanek <jvanek@redhat.com> - 1:1.8.0.11-19.b12
 - fixed desktop icons
 - Icon set to java-1.8.0
diff --git a/javadoc-error-jdk-8029145.patch b/javadoc-error-jdk-8029145.patch
deleted file mode 100644
index 4749ca1..0000000
--- a/javadoc-error-jdk-8029145.patch
+++ /dev/null
@@ -1,93 +0,0 @@
-# HG changeset patch
-# User ksrini
-# Date 1392427687 28800
-# Node ID 4c09a8dd09b37f17f186e575978e0dc5de6c84d3
-# Parent  37cf13ea5cf99b04638660d6c91038f2ce210885
-8029145: javadoc fails with java.lang.IllegalStateException: endPosTable already set
-Reviewed-by: jjg
-
-diff -r 37cf13ea5cf9 -r 4c09a8dd09b3 src/share/classes/com/sun/tools/javadoc/JavadocTool.java
---- jdk8/langtools/src/share/classes/com/sun/tools/javadoc/JavadocTool.java	Thu Feb 13 14:58:10 2014 +0100
-+++ jdk8/langtools/src/share/classes/com/sun/tools/javadoc/JavadocTool.java	Fri Feb 14 17:28:07 2014 -0800
-@@ -1,5 +1,5 @@
- /*
-- * Copyright (c) 2001, 2013, Oracle and/or its affiliates. All rights reserved.
-+ * Copyright (c) 2001, 2014, Oracle and/or its affiliates. All rights reserved.
-  * DO NOT ALTER OR REMOVE COPYRIGHT NOTICES OR THIS FILE HEADER.
-  *
-  * This code is free software; you can redistribute it and/or modify it
-@@ -30,6 +30,7 @@
- import java.util.Collection;
- import java.util.EnumSet;
- import java.util.HashMap;
-+import java.util.HashSet;
- import java.util.Map;
- import java.util.Set;
- import javax.tools.JavaFileManager.Location;
-@@ -238,10 +239,13 @@
-             files = lb.toList();
-         }
- 
-+        Set<JavaFileObject> ufiles = new HashSet<>();
-         for (JavaFileObject fo : files) {
--            // messager.notice("main.Loading_source_file", fn);
--            trees.append(parse(fo));
--            hasFiles = true;
-+            if (ufiles.add(fo)) { // ignore duplicates
-+                // messager.notice("main.Loading_source_file", fn);
-+                trees.append(parse(fo));
-+                hasFiles = true;
-+            }
-         }
- 
-         if (!hasFiles) {
-diff -r 37cf13ea5cf9 -r 4c09a8dd09b3 test/tools/javadoc/parser/7091528/T7091528.java
---- jdk8/langtools/test/tools/javadoc/parser/7091528/T7091528.java	Thu Feb 13 14:58:10 2014 +0100
-+++ jdk8/langtools/test/tools/javadoc/parser/7091528/T7091528.java	Fri Feb 14 17:28:07 2014 -0800
-@@ -1,5 +1,5 @@
- /*
-- * Copyright (c) 2009, 2011, Oracle and/or its affiliates. All rights reserved.
-+ * Copyright (c) 2009, 2014, Oracle and/or its affiliates. All rights reserved.
-  * DO NOT ALTER OR REMOVE COPYRIGHT NOTICES OR THIS FILE HEADER.
-  *
-  * This code is free software; you can redistribute it and/or modify it
-@@ -23,8 +23,8 @@
- 
- /**
-  * @test
-- * @bug     7091528
-- * @summary javadoc attempts to parse .class files
-+ * @bug     7091528 8029145
-+ * @summary ensures javadoc parses unique source files and ignores all class files
-  * @compile p/C1.java p/q/C2.java
-  * @run main T7091528
-  */
-@@ -37,17 +37,22 @@
-     public static void main(String... args) {
-         new T7091528().run();
-     }
--
-     void run() {
-         File testSrc = new File(System.getProperty("test.src"));
-         File testClasses = new File(System.getProperty("test.classes"));
--        String[] args = {
--            "-d", ".",
-+        // 7091528, tests if class files are being ignored
-+        runTest("-d", ".",
-             "-sourcepath", testClasses + File.pathSeparator + testSrc,
-             "-subpackages",
--            "p"
--        };
-+            "p");
-+        // 8029145, tests if unique source files are parsed
-+        runTest("-d", ".",
-+            "-sourcepath", testSrc.getAbsolutePath(),
-+            "-subpackages",
-+            "p:p.q");
- 
-+    }
-+    void runTest(String... args) {
-         StringWriter sw = new StringWriter();
-         PrintWriter pw = new PrintWriter(sw);
-         String doclet = com.sun.tools.doclets.standard.Standard.class.getName();
-
diff --git a/javadoc-error-jdk-8037484.patch b/javadoc-error-jdk-8037484.patch
deleted file mode 100644
index 7f8cc09..0000000
--- a/javadoc-error-jdk-8037484.patch
+++ /dev/null
@@ -1,171 +0,0 @@
-# HG changeset patch
-# User ksrini
-# Date 1397697348 25200
-# Node ID 6acecb34d1bc345579b4ddb8c38ddbe7df27ca2c
-# Parent  3d8d9f0df99909403f5edfeb33804f704d228f0f
-8037484: [javadoc] fails with java.lang.IllegalStateException: endPosTable already set
-Reviewed-by: jjg
-
-diff -r 3d8d9f0df999 -r 6acecb34d1bc src/share/classes/com/sun/tools/javadoc/JavadocTool.java
---- jdk8/langtools/src/share/classes/com/sun/tools/javadoc/JavadocTool.java	Wed Apr 16 18:36:43 2014 -0700
-+++ jdk8/langtools/src/share/classes/com/sun/tools/javadoc/JavadocTool.java	Wed Apr 16 18:15:48 2014 -0700
-@@ -68,6 +68,7 @@
-     final Messager messager;
-     final JavadocClassReader javadocReader;
-     final JavadocEnter javadocEnter;
-+    final Set<JavaFileObject> uniquefiles;
- 
-     /**
-      * Construct a new JavaCompiler processor, using appropriately
-@@ -78,6 +79,7 @@
-         messager = Messager.instance0(context);
-         javadocReader = JavadocClassReader.instance0(context);
-         javadocEnter = JavadocEnter.instance0(context);
-+        uniquefiles = new HashSet<>();
-     }
- 
-     /**
-@@ -148,9 +150,7 @@
-                 String name = it.head;
-                 if (!docClasses && fm != null && name.endsWith(".java") && new File(name).exists()) {
-                     JavaFileObject fo = fm.getJavaFileObjects(name).iterator().next();
--                    docenv.notice("main.Loading_source_file", name);
--                    JCCompilationUnit tree = parse(fo);
--                    classTrees.append(tree);
-+                    parse(fo, classTrees, true);
-                 } else if (isValidPackageName(name)) {
-                     names = names.append(name);
-                 } else if (name.endsWith(".java")) {
-@@ -163,9 +163,7 @@
-                 }
-             }
-             for (JavaFileObject fo: fileObjects) {
--                docenv.notice("main.Loading_source_file", fo.getName());
--                JCCompilationUnit tree = parse(fo);
--                classTrees.append(tree);
-+                parse(fo, classTrees, true);
-             }
- 
-             if (!docClasses) {
-@@ -213,7 +211,7 @@
-      * .java files found in such a directory to args.
-      */
-     private void parsePackageClasses(String name,
--            Iterable<JavaFileObject> files,
-+            List<JavaFileObject> files,
-             ListBuffer<JCCompilationUnit> trees,
-             List<String> excludedPackages)
-             throws IOException {
-@@ -221,7 +219,6 @@
-             return;
-         }
- 
--        boolean hasFiles = false;
-         docenv.notice("main.Loading_source_files_for_package", name);
- 
-         if (files == null) {
-@@ -238,19 +235,22 @@
-             }
-             files = lb.toList();
-         }
-+        if (files.nonEmpty()) {
-+            for (JavaFileObject fo : files) {
-+                parse(fo, trees, false);
-+            }
-+        } else {
-+            messager.warning(Messager.NOPOS, "main.no_source_files_for_package",
-+                             name.replace(File.separatorChar, '.'));
-+        }
-+    }
- 
--        Set<JavaFileObject> ufiles = new HashSet<>();
--        for (JavaFileObject fo : files) {
--            if (ufiles.add(fo)) { // ignore duplicates
--                // messager.notice("main.Loading_source_file", fn);
--                trees.append(parse(fo));
--                hasFiles = true;
--            }
--        }
--
--        if (!hasFiles) {
--            messager.warning(Messager.NOPOS, "main.no_source_files_for_package",
--                    name.replace(File.separatorChar, '.'));
-+    private void parse(JavaFileObject fo, ListBuffer<JCCompilationUnit> trees,
-+                       boolean trace) {
-+        if (uniquefiles.add(fo)) { // ignore duplicates
-+            if (trace)
-+                docenv.notice("main.Loading_source_file", fo.getName());
-+            trees.append(parse(fo));
-         }
-     }
- 
-diff -r 3d8d9f0df999 -r 6acecb34d1bc test/tools/javadoc/parser/7091528/T7091528.java
---- jdk8/langtools/test/tools/javadoc/parser/7091528/T7091528.java	Wed Apr 16 18:36:43 2014 -0700
-+++ jdk8/langtools/test/tools/javadoc/parser/7091528/T7091528.java	Wed Apr 16 18:15:48 2014 -0700
-@@ -23,7 +23,7 @@
- 
- /**
-  * @test
-- * @bug     7091528 8029145
-+ * @bug     7091528 8029145 8037484
-  * @summary ensures javadoc parses unique source files and ignores all class files
-  * @compile p/C1.java p/q/C2.java
-  * @run main T7091528
-@@ -50,6 +50,16 @@
-             "-sourcepath", testSrc.getAbsolutePath(),
-             "-subpackages",
-             "p:p.q");
-+        File testPkgDir = new File(testSrc, "p");
-+        File testFile = new File(testPkgDir, "C3.java");
-+        runTest("-d", ".",
-+            "-sourcepath", testSrc.getAbsolutePath(),
-+            testFile.getAbsolutePath(),
-+            "p");
-+        runTest("-d", ".",
-+            "-classpath", testSrc.getAbsolutePath(),
-+            testFile.getAbsolutePath(),
-+            "p");
- 
-     }
-     void runTest(String... args) {
-@@ -65,7 +75,7 @@
-         }
- 
-         if (rc != 0)
--            System.err.println("javadoc failed: exit code = " + rc);
-+            throw new Error("javadoc failed: exit code = " + rc);
- 
-         if (out.matches("(?s).*p/[^ ]+\\.class.*"))
-             throw new Error("reading .class files");
-diff -r 3d8d9f0df999 -r 6acecb34d1bc test/tools/javadoc/parser/7091528/p/C3.java
---- /dev/null	Thu Jan 01 00:00:00 1970 +0000
-+++ jdk8/langtools/test/tools/javadoc/parser/7091528/p/C3.java	Wed Apr 16 18:15:48 2014 -0700
-@@ -0,0 +1,27 @@
-+/*
-+ * Copyright (c) 2014, Oracle and/or its affiliates. All rights reserved.
-+ * DO NOT ALTER OR REMOVE COPYRIGHT NOTICES OR THIS FILE HEADER.
-+ *
-+ * This code is free software; you can redistribute it and/or modify it
-+ * under the terms of the GNU General Public License version 2 only, as
-+ * published by the Free Software Foundation.
-+ *
-+ * This code is distributed in the hope that it will be useful, but WITHOUT
-+ * ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or
-+ * FITNESS FOR A PARTICULAR PURPOSE.  See the GNU General Public License
-+ * version 2 for more details (a copy is included in the LICENSE file that
-+ * accompanied this code).
-+ *
-+ * You should have received a copy of the GNU General Public License version
-+ * 2 along with this work; if not, write to the Free Software Foundation,
-+ * Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301 USA.
-+ *
-+ * Please contact Oracle, 500 Oracle Parkway, Redwood Shores, CA 94065 USA
-+ * or visit www.oracle.com if you need additional information or have any
-+ * questions.
-+ */
-+
-+
-+/** This is class C3, and no package for me please */
-+public class C3 {}
-+
-
diff --git a/set-active-window.patch b/set-active-window.patch
deleted file mode 100644
index 923b9f2..0000000
--- a/set-active-window.patch
+++ /dev/null
@@ -1,77 +0,0 @@
-# HG changeset patch
-# User azvegint
-# Date 1395070254 -14400
-#      Mon Mar 17 19:30:54 2014 +0400
-# Node ID 6406059d2620c8241f6e04398ee0c4591e8820ac
-# Parent  37099d54a1483fffb9e51552cfda8ac956bd97ee
-8012224: AWT_TopLevels/TopLevelEvents/Automated/WindowIconifyDeiconifyEventsTest02 fails on Ubuntu 12.04 Unity shell
-Reviewed-by: anthony, serb
-
-diff --git jdk8/jdk/src/solaris/classes/sun/awt/X11/XFramePeer.java jdk8/jdk/src/solaris/classes/sun/awt/X11/XFramePeer.java
---- jdk8/jdk/src/solaris/classes/sun/awt/X11/XFramePeer.java
-+++ jdk8/jdk/src/solaris/classes/sun/awt/X11/XFramePeer.java
-@@ -284,6 +284,11 @@
-             if (stateLog.isLoggable(PlatformLogger.Level.FINER)) {
-                 stateLog.finer("DeIconifying " + this);
-             }
-+
-+            XNETProtocol net_protocol = XWM.getWM().getNETProtocol();
-+            if (net_protocol != null) {
-+                net_protocol.setActiveWindow(this);
-+            }
-             xSetVisible(true);
-         }
-     }
-diff --git jdk8/jdk/src/solaris/classes/sun/awt/X11/XNETProtocol.java jdk8/jdk/src/solaris/classes/sun/awt/X11/XNETProtocol.java
---- jdk8/jdk/src/solaris/classes/sun/awt/X11/XNETProtocol.java
-+++ jdk8/jdk/src/solaris/classes/sun/awt/X11/XNETProtocol.java
-@@ -213,7 +213,7 @@
-      * If window is showing then it uses ClientMessage, otherwise adjusts NET_WM_STATE list
-      * @param window Window which NET_WM_STATE property is being modified
-      * @param state State atom to be set/reset
--     * @param reset Indicates operation, 'set' if false, 'reset' if true
-+     * @param set Indicates operation, 'set' if false, 'reset' if true
-      */
-     private void setStateHelper(XWindowPeer window, XAtom state, boolean set) {
-         if (log.isLoggable(PlatformLogger.Level.FINER)) {
-@@ -249,6 +249,7 @@
-     XAtom XA_UTF8_STRING = XAtom.get("UTF8_STRING");   /* like STRING but encoding is UTF-8 */
-     XAtom XA_NET_SUPPORTING_WM_CHECK = XAtom.get("_NET_SUPPORTING_WM_CHECK");
-     XAtom XA_NET_SUPPORTED = XAtom.get("_NET_SUPPORTED");      /* list of protocols (property of root) */
-+    XAtom XA_NET_ACTIVE_WINDOW = XAtom.get("_NET_ACTIVE_WINDOW");
-     XAtom XA_NET_WM_NAME = XAtom.get("_NET_WM_NAME");  /* window property */
-     XAtom XA_NET_WM_STATE = XAtom.get("_NET_WM_STATE");/* both window property and request */
- 
-@@ -325,6 +326,32 @@
-         return res;
-     }
- 
-+    public void setActiveWindow(XWindow window) {
-+        if (!active() || !checkProtocol(XA_NET_SUPPORTED, XA_NET_ACTIVE_WINDOW)) {
-+            return;
-+        }
-+
-+        XClientMessageEvent msg = new XClientMessageEvent();
-+        msg.zero();
-+        msg.set_type(XConstants.ClientMessage);
-+        msg.set_message_type(XA_NET_ACTIVE_WINDOW.getAtom());
-+        msg.set_display(XToolkit.getDisplay());
-+        msg.set_window(window.getWindow());
-+        msg.set_format(32);
-+        msg.set_data(0, 1);
-+        msg.set_data(1, XToolkit.getCurrentServerTime());
-+        msg.set_data(2, 0);
-+
-+        XToolkit.awtLock();
-+        try {
-+            XlibWrapper.XSendEvent(XToolkit.getDisplay(), XToolkit.getDefaultRootWindow(), false,
-+                    XConstants.SubstructureRedirectMask | XConstants.SubstructureNotifyMask, msg.getPData());
-+        } finally {
-+            XToolkit.awtUnlock();
-+            msg.dispose();
-+        }
-+    }
-+
-     boolean isWMName(String name) {
-         if (!active()) {
-             return false;
diff --git a/sources b/sources
index 9a44096..71244e6 100644
--- a/sources
+++ b/sources
@@ -1,3 +1,3 @@
-84eed2615ebcf518ad92c88c280ede9e  jdk8u-jdk8u11-b12.tar.xz
+35130478f55ef3b57381486f0053d61d  jdk8u-jdk8u40-b01.tar.xz
 94ca5a45c3cb3b85c4577d0891166007  systemtap-tapset.tar.gz
 8c0436da8098f15c7bda2fa4f927e525  aarch64-hotspot-jdk8-b128-aarch64-992.tar.xz
diff --git a/system-lcms.patch b/system-lcms.patch
index f8430f3..c098f3a 100644
--- a/system-lcms.patch
+++ b/system-lcms.patch
@@ -62,12 +62,13 @@ diff -ruN jdk8/jdk/make/lib/Awt2dLibraries.gmk jdk8/jdk/make/lib/Awt2dLibraries.
      OUTPUT_DIR := $(INSTALL_LIBRARIES_HERE), \
      SRC := $(JDK_TOPDIR)/src/share/native/sun/java2d/cmm/lcms, \
      LANG := C, \
-@@ -680,18 +680,18 @@
+@@ -680,19 +680,19 @@
      LDFLAGS_windows := $(WIN_AWT_LIB) $(WIN_JAVA_LIB), \
      LDFLAGS_SUFFIX_solaris := -lawt -ljava -ljvm -lc, \
      LDFLAGS_SUFFIX_macosx := $(LIBM) -lawt -ljava -ljvm, \
 -    LDFLAGS_SUFFIX_linux := -lm -lawt -ljava -ljvm, \
 +    LDFLAGS_SUFFIX_linux := -lm -lawt -ljava -ljvm -llcms2, \
+     LDFLAGS_SUFFIX_aix := -lm -lawt -ljava -ljvm,\
      VERSIONINFO_RESOURCE := $(JDK_TOPDIR)/src/windows/resource/version.rc, \
      RC_FLAGS := $(RC_FLAGS) \
 -        -D "JDK_FNAME=lcms.dll" \