Detect FIPS using SECMOD_GetSystemFIPSEnabled in the new libsystemconf JDK library.
Port FIPS system detection support to OpenJDK 8u Minor code cleanups on FIPS detection patch and check for SECMOD_GetSystemFIPSEnabled in configure. Remove unneeded Requires on NSS as it will now be dynamically linked and detected by RPM. Resolves: rhbz#1971696
This commit is contained in:
parent
19e706d505
commit
3034306917
@ -289,7 +289,7 @@
|
||||
%global updatever %(VERSION=%{whole_update}; echo ${VERSION##*u})
|
||||
# eg jdk8u60-b27 -> b27
|
||||
%global buildver %(VERSION=%{version_tag}; echo ${VERSION##*-})
|
||||
%global rpmrelease 1
|
||||
%global rpmrelease 2
|
||||
# Define milestone (EA for pre-releases, GA ("fcs") for releases)
|
||||
# Release will be (where N is usually a number starting at 1):
|
||||
# - 0.N%%{?extraver}%%{?dist} for EA releases,
|
||||
@ -332,7 +332,7 @@
|
||||
# fix for https://bugzilla.redhat.com/show_bug.cgi?id=1111349
|
||||
# https://bugzilla.redhat.com/show_bug.cgi?id=1590796#c14
|
||||
# https://bugzilla.redhat.com/show_bug.cgi?id=1655938
|
||||
%global _privatelibs libattach[.]so.*|libawt_headless[.]so.*|libawt[.]so.*|libawt_xawt[.]so.*|libdt_socket[.]so.*|libfontmanager[.]so.*|libhprof[.]so.*|libinstrument[.]so.*|libj2gss[.]so.*|libj2pcsc[.]so.*|libj2pkcs11[.]so.*|libjaas_unix[.]so.*|libjava_crw_demo[.]so.*|libjavajpeg[.]so.*|libjdwp[.]so.*|libjli[.]so.*|libjsdt[.]so.*|libjsoundalsa[.]so.*|libjsound[.]so.*|liblcms[.]so.*|libmanagement[.]so.*|libmlib_image[.]so.*|libnet[.]so.*|libnio[.]so.*|libnpt[.]so.*|libsaproc[.]so.*|libsctp[.]so.*|libsplashscreen[.]so.*|libsunec[.]so.*|libunpack[.]so.*|libzip[.]so.*|lib[.]so\\(SUNWprivate_.*
|
||||
%global _privatelibs libattach[.]so.*|libawt_headless[.]so.*|libawt[.]so.*|libawt_xawt[.]so.*|libdt_socket[.]so.*|libfontmanager[.]so.*|libhprof[.]so.*|libinstrument[.]so.*|libj2gss[.]so.*|libj2pcsc[.]so.*|libj2pkcs11[.]so.*|libjaas_unix[.]so.*|libjava_crw_demo[.]so.*|libjavajpeg[.]so.*|libjdwp[.]so.*|libjli[.]so.*|libjsdt[.]so.*|libjsoundalsa[.]so.*|libjsound[.]so.*|liblcms[.]so.*|libmanagement[.]so.*|libmlib_image[.]so.*|libnet[.]so.*|libnio[.]so.*|libnpt[.]so.*|libsaproc[.]so.*|libsctp[.]so.*|libsplashscreen[.]so.*|libsunec[.]so.*|libsystemconf[.]so.*|libunpack[.]so.*|libzip[.]so.*|lib[.]so\\(SUNWprivate_.*
|
||||
%global _publiclibs libjawt[.]so.*|libjava[.]so.*|libjvm[.]so.*|libverify[.]so.*|libjsig[.]so.*
|
||||
%if %is_system_jdk
|
||||
%global __provides_exclude ^(%{_privatelibs})$
|
||||
@ -784,6 +784,7 @@ exit 0
|
||||
%endif
|
||||
%{_jvmdir}/%{jredir -- %{?1}}/lib/%{archinstall}/libsctp.so
|
||||
%{_jvmdir}/%{jredir -- %{?1}}/lib/%{archinstall}/libsunec.so
|
||||
%{_jvmdir}/%{jredir -- %{?1}}/lib/%{archinstall}/libsystemconf.so
|
||||
%{_jvmdir}/%{jredir -- %{?1}}/lib/%{archinstall}/libunpack.so
|
||||
%{_jvmdir}/%{jredir -- %{?1}}/lib/%{archinstall}/libverify.so
|
||||
%{_jvmdir}/%{jredir -- %{?1}}/lib/%{archinstall}/libzip.so
|
||||
@ -1091,8 +1092,6 @@ Requires: copy-jdk-configs >= 4.0
|
||||
OrderWithRequires: copy-jdk-configs
|
||||
# for printing support
|
||||
Requires: cups-libs
|
||||
# for FIPS PKCS11 provider
|
||||
Requires: nss
|
||||
# Post requires alternatives to install tool alternatives
|
||||
Requires(post): %{alternatives_requires}
|
||||
# Postun requires alternatives to uninstall tool alternatives
|
||||
@ -1287,6 +1286,9 @@ Patch1002: rh1760838-fips_default_keystore_type.patch
|
||||
Patch1004: rh1860986-disable_tlsv1.3_in_fips_mode.patch
|
||||
# RH1906862: Always initialise JavaSecuritySystemConfiguratorAccess
|
||||
Patch1005: rh1906862-always_initialise_configurator_access.patch
|
||||
# RH1929465: Improve system FIPS detection
|
||||
Patch1006: rh1929465-improve_system_FIPS_detection-root.patch
|
||||
Patch1007: rh1929465-improve_system_FIPS_detection-jdk.patch
|
||||
|
||||
#############################################
|
||||
#
|
||||
@ -1433,8 +1435,8 @@ BuildRequires: libXinerama-devel
|
||||
BuildRequires: libXrender-devel
|
||||
BuildRequires: libXt-devel
|
||||
BuildRequires: libXtst-devel
|
||||
# Requirements for setting up the nss.cfg
|
||||
BuildRequires: nss-devel
|
||||
# Requirements for setting up the nss.cfg and FIPS support
|
||||
BuildRequires: nss-devel >= 3.53
|
||||
BuildRequires: pkgconfig
|
||||
BuildRequires: xorg-x11-proto-devel
|
||||
BuildRequires: zip
|
||||
@ -1758,6 +1760,8 @@ sh %{SOURCE12}
|
||||
%patch1003
|
||||
%patch1004
|
||||
%patch1005
|
||||
%patch1006
|
||||
%patch1007
|
||||
|
||||
# RHEL-only patches
|
||||
%if ! 0%{?fedora} && 0%{?rhel} <= 7
|
||||
@ -1889,6 +1893,7 @@ function buildjdk() {
|
||||
--with-vendor-vm-bug-url="%{oj_vendor_bug_url}" \
|
||||
--with-boot-jdk=${buildjdk} \
|
||||
--with-debug-level=${debuglevel} \
|
||||
--enable-sysconf-nss \
|
||||
--enable-unlimited-crypto \
|
||||
--with-zlib=system \
|
||||
--with-libjpeg=system \
|
||||
@ -2452,6 +2457,16 @@ cjc.mainProgram(args)
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Fri Aug 27 2021 Andrew Hughes <gnu.andrew@redhat.com> - 1:1.8.0.302.b08-2
|
||||
- Port FIPS system detection support to OpenJDK 8u
|
||||
- Minor code cleanups on FIPS detection patch and check for SECMOD_GetSystemFIPSEnabled in configure.
|
||||
- Remove unneeded Requires on NSS as it will now be dynamically linked and detected by RPM.
|
||||
- Resolves: rhbz#1971696
|
||||
|
||||
* Fri Aug 27 2021 Martin Balao <mbalao@redhat.com> - 1:1.8.0.302.b08-2
|
||||
- Detect FIPS using SECMOD_GetSystemFIPSEnabled in the new libsystemconf JDK library.
|
||||
- Resolves: rhbz#1971696
|
||||
|
||||
* Wed Aug 25 2021 Florian Weimer <fweimer@redhat.com> - 1:1.8.0.302.b08-1
|
||||
- Rebuild for libffi transition (#1891914)
|
||||
|
||||
|
344
rh1929465-improve_system_FIPS_detection-jdk.patch
Normal file
344
rh1929465-improve_system_FIPS_detection-jdk.patch
Normal file
@ -0,0 +1,344 @@
|
||||
diff --git openjdk.orig/jdk/make/lib/SecurityLibraries.gmk openjdk/jdk/make/lib/SecurityLibraries.gmk
|
||||
--- openjdk.orig/jdk/make/lib/SecurityLibraries.gmk
|
||||
+++ openjdk/jdk/make/lib/SecurityLibraries.gmk
|
||||
@@ -289,3 +289,34 @@
|
||||
|
||||
endif
|
||||
endif
|
||||
+
|
||||
+################################################################################
|
||||
+# Create the systemconf library
|
||||
+
|
||||
+LIBSYSTEMCONF_CFLAGS :=
|
||||
+LIBSYSTEMCONF_CXXFLAGS :=
|
||||
+
|
||||
+ifeq ($(USE_SYSCONF_NSS), true)
|
||||
+ LIBSYSTEMCONF_CFLAGS += $(NSS_CFLAGS) -DSYSCONF_NSS
|
||||
+ LIBSYSTEMCONF_CXXFLAGS += $(NSS_CFLAGS) -DSYSCONF_NSS
|
||||
+endif
|
||||
+
|
||||
+ifeq ($(OPENJDK_BUILD_OS), linux)
|
||||
+ $(eval $(call SetupNativeCompilation,BUILD_LIBSYSTEMCONF, \
|
||||
+ LIBRARY := systemconf, \
|
||||
+ OUTPUT_DIR := $(INSTALL_LIBRARIES_HERE), \
|
||||
+ SRC := $(JDK_TOPDIR)/src/$(OPENJDK_TARGET_OS_API_DIR)/native/java/security, \
|
||||
+ LANG := C, \
|
||||
+ OPTIMIZATION := LOW, \
|
||||
+ CFLAGS := $(CFLAGS_JDKLIB) $(LIBSYSTEMCONF_CFLAGS), \
|
||||
+ CXXFLAGS := $(CXXFLAGS_JDKLIB) $(LIBSYSTEMCONF_CXXFLAGS), \
|
||||
+ MAPFILE := $(JDK_TOPDIR)/make/mapfiles/libsystemconf/mapfile-vers, \
|
||||
+ LDFLAGS := $(LDFLAGS_JDKLIB) \
|
||||
+ $(call SET_SHARED_LIBRARY_ORIGIN), \
|
||||
+ LDFLAGS_SUFFIX := $(LIBDL) $(NSS_LIBS), \
|
||||
+ OBJECT_DIR := $(JDK_OUTPUTDIR)/objs/libsystemconf, \
|
||||
+ DEBUG_SYMBOLS := $(DEBUG_ALL_BINARIES)))
|
||||
+
|
||||
+ BUILD_LIBRARIES += $(BUILD_LIBSYSTEMCONF)
|
||||
+endif
|
||||
+
|
||||
diff --git openjdk.orig/jdk/make/mapfiles/libsystemconf/mapfile-vers openjdk/jdk/make/mapfiles/libsystemconf/mapfile-vers
|
||||
new file mode 100644
|
||||
--- /dev/null
|
||||
+++ openjdk/jdk/make/mapfiles/libsystemconf/mapfile-vers
|
||||
@@ -0,0 +1,35 @@
|
||||
+#
|
||||
+# Copyright (c) 2021, Red Hat, Inc.
|
||||
+# DO NOT ALTER OR REMOVE COPYRIGHT NOTICES OR THIS FILE HEADER.
|
||||
+#
|
||||
+# This code is free software; you can redistribute it and/or modify it
|
||||
+# under the terms of the GNU General Public License version 2 only, as
|
||||
+# published by the Free Software Foundation. Oracle designates this
|
||||
+# particular file as subject to the "Classpath" exception as provided
|
||||
+# by Oracle in the LICENSE file that accompanied this code.
|
||||
+#
|
||||
+# This code is distributed in the hope that it will be useful, but WITHOUT
|
||||
+# ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or
|
||||
+# FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License
|
||||
+# version 2 for more details (a copy is included in the LICENSE file that
|
||||
+# accompanied this code).
|
||||
+#
|
||||
+# You should have received a copy of the GNU General Public License version
|
||||
+# 2 along with this work; if not, write to the Free Software Foundation,
|
||||
+# Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301 USA.
|
||||
+#
|
||||
+# Please contact Oracle, 500 Oracle Parkway, Redwood Shores, CA 94065 USA
|
||||
+# or visit www.oracle.com if you need additional information or have any
|
||||
+# questions.
|
||||
+#
|
||||
+
|
||||
+# Define public interface.
|
||||
+
|
||||
+SUNWprivate_1.1 {
|
||||
+ global:
|
||||
+ DEF_JNI_OnLoad;
|
||||
+ DEF_JNI_OnUnLoad;
|
||||
+ Java_java_security_SystemConfigurator_getSystemFIPSEnabled;
|
||||
+ local:
|
||||
+ *;
|
||||
+};
|
||||
diff --git openjdk.orig/jdk/src/share/classes/java/security/SystemConfigurator.java openjdk/jdk/src/share/classes/java/security/SystemConfigurator.java
|
||||
--- openjdk.orig/jdk/src/share/classes/java/security/SystemConfigurator.java
|
||||
+++ openjdk/jdk/src/share/classes/java/security/SystemConfigurator.java
|
||||
@@ -1,5 +1,5 @@
|
||||
/*
|
||||
- * Copyright (c) 2019, 2020, Red Hat, Inc.
|
||||
+ * Copyright (c) 2019, 2021, Red Hat, Inc.
|
||||
*
|
||||
* DO NOT ALTER OR REMOVE COPYRIGHT NOTICES OR THIS FILE HEADER.
|
||||
*
|
||||
@@ -30,14 +30,9 @@
|
||||
import java.io.FileInputStream;
|
||||
import java.io.IOException;
|
||||
|
||||
-import java.nio.file.Files;
|
||||
-import java.nio.file.FileSystems;
|
||||
-import java.nio.file.Path;
|
||||
-
|
||||
import java.util.Iterator;
|
||||
import java.util.Map.Entry;
|
||||
import java.util.Properties;
|
||||
-import java.util.regex.Pattern;
|
||||
|
||||
import sun.security.util.Debug;
|
||||
|
||||
@@ -59,10 +54,21 @@
|
||||
private static final String CRYPTO_POLICIES_JAVA_CONFIG =
|
||||
CRYPTO_POLICIES_BASE_DIR + "/back-ends/java.config";
|
||||
|
||||
- private static final String CRYPTO_POLICIES_CONFIG =
|
||||
- CRYPTO_POLICIES_BASE_DIR + "/config";
|
||||
+ private static boolean systemFipsEnabled = false;
|
||||
+
|
||||
+ private static final String SYSTEMCONF_NATIVE_LIB = "systemconf";
|
||||
+
|
||||
+ private static native boolean getSystemFIPSEnabled()
|
||||
+ throws IOException;
|
||||
|
||||
- private static boolean systemFipsEnabled = false;
|
||||
+ static {
|
||||
+ AccessController.doPrivileged(new PrivilegedAction<Void>() {
|
||||
+ public Void run() {
|
||||
+ System.loadLibrary(SYSTEMCONF_NATIVE_LIB);
|
||||
+ return null;
|
||||
+ }
|
||||
+ });
|
||||
+ }
|
||||
|
||||
/*
|
||||
* Invoked when java.security.Security class is initialized, if
|
||||
@@ -171,17 +177,34 @@
|
||||
}
|
||||
|
||||
/*
|
||||
- * FIPS is enabled only if crypto-policies are set to "FIPS"
|
||||
- * and the com.redhat.fips property is true.
|
||||
+ * OpenJDK FIPS mode will be enabled only if the com.redhat.fips
|
||||
+ * system property is true (default) and the system is in FIPS mode.
|
||||
+ *
|
||||
+ * There are 2 possible ways in which OpenJDK detects that the system
|
||||
+ * is in FIPS mode: 1) if the NSS SECMOD_GetSystemFIPSEnabled API is
|
||||
+ * available at OpenJDK's built-time, it is called; 2) otherwise, the
|
||||
+ * /proc/sys/crypto/fips_enabled file is read.
|
||||
*/
|
||||
- private static boolean enableFips() throws Exception {
|
||||
+ private static boolean enableFips() throws IOException {
|
||||
boolean shouldEnable = Boolean.valueOf(System.getProperty("com.redhat.fips", "true"));
|
||||
if (shouldEnable) {
|
||||
- Path configPath = FileSystems.getDefault().getPath(CRYPTO_POLICIES_CONFIG);
|
||||
- String cryptoPoliciesConfig = new String(Files.readAllBytes(configPath));
|
||||
- if (sdebug != null) { sdebug.println("Crypto config:\n" + cryptoPoliciesConfig); }
|
||||
- Pattern pattern = Pattern.compile("^FIPS$", Pattern.MULTILINE);
|
||||
- return pattern.matcher(cryptoPoliciesConfig).find();
|
||||
+ if (sdebug != null) {
|
||||
+ sdebug.println("Calling getSystemFIPSEnabled (libsystemconf)...");
|
||||
+ }
|
||||
+ try {
|
||||
+ shouldEnable = getSystemFIPSEnabled();
|
||||
+ if (sdebug != null) {
|
||||
+ sdebug.println("Call to getSystemFIPSEnabled (libsystemconf) returned: "
|
||||
+ + shouldEnable);
|
||||
+ }
|
||||
+ return shouldEnable;
|
||||
+ } catch (IOException e) {
|
||||
+ if (sdebug != null) {
|
||||
+ sdebug.println("Call to getSystemFIPSEnabled (libsystemconf) failed:");
|
||||
+ sdebug.println(e.getMessage());
|
||||
+ }
|
||||
+ throw e;
|
||||
+ }
|
||||
} else {
|
||||
return false;
|
||||
}
|
||||
diff --git openjdk.orig/jdk/src/solaris/native/java/security/systemconf.c openjdk/jdk/src/solaris/native/java/security/systemconf.c
|
||||
new file mode 100644
|
||||
--- /dev/null
|
||||
+++ openjdk/jdk/src/solaris/native/java/security/systemconf.c
|
||||
@@ -0,0 +1,168 @@
|
||||
+/*
|
||||
+ * Copyright (c) 2021, Red Hat, Inc.
|
||||
+ * DO NOT ALTER OR REMOVE COPYRIGHT NOTICES OR THIS FILE HEADER.
|
||||
+ *
|
||||
+ * This code is free software; you can redistribute it and/or modify it
|
||||
+ * under the terms of the GNU General Public License version 2 only, as
|
||||
+ * published by the Free Software Foundation. Oracle designates this
|
||||
+ * particular file as subject to the "Classpath" exception as provided
|
||||
+ * by Oracle in the LICENSE file that accompanied this code.
|
||||
+ *
|
||||
+ * This code is distributed in the hope that it will be useful, but WITHOUT
|
||||
+ * ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or
|
||||
+ * FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License
|
||||
+ * version 2 for more details (a copy is included in the LICENSE file that
|
||||
+ * accompanied this code).
|
||||
+ *
|
||||
+ * You should have received a copy of the GNU General Public License version
|
||||
+ * 2 along with this work; if not, write to the Free Software Foundation,
|
||||
+ * Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301 USA.
|
||||
+ *
|
||||
+ * Please contact Oracle, 500 Oracle Parkway, Redwood Shores, CA 94065 USA
|
||||
+ * or visit www.oracle.com if you need additional information or have any
|
||||
+ * questions.
|
||||
+ */
|
||||
+
|
||||
+#include <dlfcn.h>
|
||||
+#include <jni.h>
|
||||
+#include <jni_util.h>
|
||||
+#include <stdio.h>
|
||||
+
|
||||
+#ifdef SYSCONF_NSS
|
||||
+#include <nss3/pk11pub.h>
|
||||
+#endif //SYSCONF_NSS
|
||||
+
|
||||
+#include "java_security_SystemConfigurator.h"
|
||||
+
|
||||
+#define FIPS_ENABLED_PATH "/proc/sys/crypto/fips_enabled"
|
||||
+#define MSG_MAX_SIZE 96
|
||||
+
|
||||
+static jmethodID debugPrintlnMethodID = NULL;
|
||||
+static jobject debugObj = NULL;
|
||||
+
|
||||
+static void throwIOException(JNIEnv *env, const char *msg);
|
||||
+static void dbgPrint(JNIEnv *env, const char* msg);
|
||||
+
|
||||
+/*
|
||||
+ * Class: java_security_SystemConfigurator
|
||||
+ * Method: JNI_OnLoad
|
||||
+ */
|
||||
+JNIEXPORT jint JNICALL DEF_JNI_OnLoad(JavaVM *vm, void *reserved)
|
||||
+{
|
||||
+ JNIEnv *env;
|
||||
+ jclass sysConfCls, debugCls;
|
||||
+ jfieldID sdebugFld;
|
||||
+
|
||||
+ if ((*vm)->GetEnv(vm, (void**) &env, JNI_VERSION_1_2) != JNI_OK) {
|
||||
+ return JNI_EVERSION; /* JNI version not supported */
|
||||
+ }
|
||||
+
|
||||
+ sysConfCls = (*env)->FindClass(env,"java/security/SystemConfigurator");
|
||||
+ if (sysConfCls == NULL) {
|
||||
+ printf("libsystemconf: SystemConfigurator class not found\n");
|
||||
+ return JNI_ERR;
|
||||
+ }
|
||||
+ sdebugFld = (*env)->GetStaticFieldID(env, sysConfCls,
|
||||
+ "sdebug", "Lsun/security/util/Debug;");
|
||||
+ if (sdebugFld == NULL) {
|
||||
+ printf("libsystemconf: SystemConfigurator::sdebug field not found\n");
|
||||
+ return JNI_ERR;
|
||||
+ }
|
||||
+ debugObj = (*env)->GetStaticObjectField(env, sysConfCls, sdebugFld);
|
||||
+ if (debugObj != NULL) {
|
||||
+ debugCls = (*env)->FindClass(env,"sun/security/util/Debug");
|
||||
+ if (debugCls == NULL) {
|
||||
+ printf("libsystemconf: Debug class not found\n");
|
||||
+ return JNI_ERR;
|
||||
+ }
|
||||
+ debugPrintlnMethodID = (*env)->GetMethodID(env, debugCls,
|
||||
+ "println", "(Ljava/lang/String;)V");
|
||||
+ if (debugPrintlnMethodID == NULL) {
|
||||
+ printf("libsystemconf: Debug::println(String) method not found\n");
|
||||
+ return JNI_ERR;
|
||||
+ }
|
||||
+ debugObj = (*env)->NewGlobalRef(env, debugObj);
|
||||
+ }
|
||||
+
|
||||
+ return (*env)->GetVersion(env);
|
||||
+}
|
||||
+
|
||||
+/*
|
||||
+ * Class: java_security_SystemConfigurator
|
||||
+ * Method: JNI_OnUnload
|
||||
+ */
|
||||
+JNIEXPORT void JNICALL DEF_JNI_OnUnload(JavaVM *vm, void *reserved)
|
||||
+{
|
||||
+ JNIEnv *env;
|
||||
+
|
||||
+ if (debugObj != NULL) {
|
||||
+ if ((*vm)->GetEnv(vm, (void**) &env, JNI_VERSION_1_2) != JNI_OK) {
|
||||
+ return; /* Should not happen */
|
||||
+ }
|
||||
+ (*env)->DeleteGlobalRef(env, debugObj);
|
||||
+ }
|
||||
+}
|
||||
+
|
||||
+JNIEXPORT jboolean JNICALL Java_java_security_SystemConfigurator_getSystemFIPSEnabled
|
||||
+ (JNIEnv *env, jclass cls)
|
||||
+{
|
||||
+ int fips_enabled;
|
||||
+ char msg[MSG_MAX_SIZE];
|
||||
+ int msg_bytes;
|
||||
+
|
||||
+#ifdef SYSCONF_NSS
|
||||
+
|
||||
+ dbgPrint(env, "getSystemFIPSEnabled: calling SECMOD_GetSystemFIPSEnabled");
|
||||
+ fips_enabled = SECMOD_GetSystemFIPSEnabled();
|
||||
+ msg_bytes = snprintf(msg, MSG_MAX_SIZE, "getSystemFIPSEnabled:" \
|
||||
+ " SECMOD_GetSystemFIPSEnabled returned 0x%x", fips_enabled);
|
||||
+ if (msg_bytes > 0 && msg_bytes < MSG_MAX_SIZE) {
|
||||
+ dbgPrint(env, msg);
|
||||
+ } else {
|
||||
+ dbgPrint(env, "getSystemFIPSEnabled: cannot render" \
|
||||
+ " SECMOD_GetSystemFIPSEnabled return value");
|
||||
+ }
|
||||
+ return (fips_enabled == 1 ? JNI_TRUE : JNI_FALSE);
|
||||
+
|
||||
+#else // SYSCONF_NSS
|
||||
+
|
||||
+ FILE *fe;
|
||||
+
|
||||
+ dbgPrint(env, "getSystemFIPSEnabled: reading " FIPS_ENABLED_PATH);
|
||||
+ if ((fe = fopen(FIPS_ENABLED_PATH, "r")) == NULL) {
|
||||
+ throwIOException(env, "Cannot open " FIPS_ENABLED_PATH);
|
||||
+ }
|
||||
+ fips_enabled = fgetc(fe);
|
||||
+ fclose(fe);
|
||||
+ if (fips_enabled == EOF) {
|
||||
+ throwIOException(env, "Cannot read " FIPS_ENABLED_PATH);
|
||||
+ }
|
||||
+ msg_bytes = snprintf(msg, MSG_MAX_SIZE, "getSystemFIPSEnabled:" \
|
||||
+ " read character is '%c'", fips_enabled);
|
||||
+ if (msg_bytes > 0 && msg_bytes < MSG_MAX_SIZE) {
|
||||
+ dbgPrint(env, msg);
|
||||
+ } else {
|
||||
+ dbgPrint(env, "getSystemFIPSEnabled: cannot render" \
|
||||
+ " read character");
|
||||
+ }
|
||||
+ return (fips_enabled == '1' ? JNI_TRUE : JNI_FALSE);
|
||||
+
|
||||
+#endif // SYSCONF_NSS
|
||||
+}
|
||||
+
|
||||
+static void throwIOException(JNIEnv *env, const char *msg)
|
||||
+{
|
||||
+ jclass cls = (*env)->FindClass(env, "java/io/IOException");
|
||||
+ if (cls != 0)
|
||||
+ (*env)->ThrowNew(env, cls, msg);
|
||||
+}
|
||||
+
|
||||
+static void dbgPrint(JNIEnv *env, const char* msg)
|
||||
+{
|
||||
+ jstring jMsg;
|
||||
+ if (debugObj != NULL) {
|
||||
+ jMsg = (*env)->NewStringUTF(env, msg);
|
||||
+ CHECK_NULL(jMsg);
|
||||
+ (*env)->CallVoidMethod(env, debugObj, debugPrintlnMethodID, jMsg);
|
||||
+ }
|
||||
+}
|
152
rh1929465-improve_system_FIPS_detection-root.patch
Normal file
152
rh1929465-improve_system_FIPS_detection-root.patch
Normal file
@ -0,0 +1,152 @@
|
||||
diff --git openjdk.orig/common/autoconf/configure.ac openjdk/common/autoconf/configure.ac
|
||||
--- openjdk.orig/common/autoconf/configure.ac
|
||||
+++ openjdk/common/autoconf/configure.ac
|
||||
@@ -212,6 +212,7 @@
|
||||
LIB_SETUP_ALSA
|
||||
LIB_SETUP_FONTCONFIG
|
||||
LIB_SETUP_MISC_LIBS
|
||||
+LIB_SETUP_SYSCONF_LIBS
|
||||
LIB_SETUP_STATIC_LINK_LIBSTDCPP
|
||||
LIB_SETUP_ON_WINDOWS
|
||||
|
||||
diff --git openjdk.orig/common/autoconf/libraries.m4 openjdk/common/autoconf/libraries.m4
|
||||
--- openjdk.orig/common/autoconf/libraries.m4
|
||||
+++ openjdk/common/autoconf/libraries.m4
|
||||
@@ -1067,3 +1067,63 @@
|
||||
BASIC_DEPRECATED_ARG_WITH([dxsdk-include])
|
||||
fi
|
||||
])
|
||||
+
|
||||
+################################################################################
|
||||
+# Setup system configuration libraries
|
||||
+################################################################################
|
||||
+AC_DEFUN_ONCE([LIB_SETUP_SYSCONF_LIBS],
|
||||
+[
|
||||
+ ###############################################################################
|
||||
+ #
|
||||
+ # Check for the NSS library
|
||||
+ #
|
||||
+
|
||||
+ AC_MSG_CHECKING([whether to use the system NSS library with the System Configurator (libsysconf)])
|
||||
+
|
||||
+ # default is not available
|
||||
+ DEFAULT_SYSCONF_NSS=no
|
||||
+
|
||||
+ AC_ARG_ENABLE([sysconf-nss], [AS_HELP_STRING([--enable-sysconf-nss],
|
||||
+ [build the System Configurator (libsysconf) using the system NSS library if available @<:@disabled@:>@])],
|
||||
+ [
|
||||
+ case "${enableval}" in
|
||||
+ yes)
|
||||
+ sysconf_nss=yes
|
||||
+ ;;
|
||||
+ *)
|
||||
+ sysconf_nss=no
|
||||
+ ;;
|
||||
+ esac
|
||||
+ ],
|
||||
+ [
|
||||
+ sysconf_nss=${DEFAULT_SYSCONF_NSS}
|
||||
+ ])
|
||||
+ AC_MSG_RESULT([$sysconf_nss])
|
||||
+
|
||||
+ USE_SYSCONF_NSS=false
|
||||
+ if test "x${sysconf_nss}" = "xyes"; then
|
||||
+ PKG_CHECK_MODULES(NSS, nss >= 3.53, [NSS_FOUND=yes], [NSS_FOUND=no])
|
||||
+ if test "x${NSS_FOUND}" = "xyes"; then
|
||||
+ AC_MSG_CHECKING([for system FIPS support in NSS])
|
||||
+ saved_libs="${LIBS}"
|
||||
+ saved_cflags="${CFLAGS}"
|
||||
+ CFLAGS="${CFLAGS} ${NSS_CFLAGS}"
|
||||
+ LIBS="${LIBS} ${NSS_LIBS}"
|
||||
+ AC_LANG_PUSH([C])
|
||||
+ AC_LINK_IFELSE([AC_LANG_PROGRAM([[#include <nss3/pk11pub.h>]],
|
||||
+ [[SECMOD_GetSystemFIPSEnabled()]])],
|
||||
+ [AC_MSG_RESULT([yes])],
|
||||
+ [AC_MSG_RESULT([no])
|
||||
+ AC_MSG_ERROR([System NSS FIPS detection unavailable])])
|
||||
+ AC_LANG_POP([C])
|
||||
+ CFLAGS="${saved_cflags}"
|
||||
+ LIBS="${saved_libs}"
|
||||
+ USE_SYSCONF_NSS=true
|
||||
+ else
|
||||
+ dnl NSS 3.53 is the one that introduces the SECMOD_GetSystemFIPSEnabled API
|
||||
+ dnl in nss3/pk11pub.h.
|
||||
+ AC_MSG_ERROR([--enable-sysconf-nss specified, but NSS 3.53 or above not found.])
|
||||
+ fi
|
||||
+ fi
|
||||
+ AC_SUBST(USE_SYSCONF_NSS)
|
||||
+])
|
||||
diff --git openjdk.orig/common/autoconf/spec.gmk.in openjdk/common/autoconf/spec.gmk.in
|
||||
--- openjdk.orig/common/autoconf/spec.gmk.in
|
||||
+++ openjdk/common/autoconf/spec.gmk.in
|
||||
@@ -312,6 +312,10 @@
|
||||
ALSA_LIBS:=@ALSA_LIBS@
|
||||
ALSA_CFLAGS:=@ALSA_CFLAGS@
|
||||
|
||||
+USE_SYSCONF_NSS:=@USE_SYSCONF_NSS@
|
||||
+NSS_LIBS:=@NSS_LIBS@
|
||||
+NSS_CFLAGS:=@NSS_CFLAGS@
|
||||
+
|
||||
PACKAGE_PATH=@PACKAGE_PATH@
|
||||
|
||||
# Source file for cacerts
|
||||
diff --git openjdk.orig/common/bin/compare_exceptions.sh.incl openjdk/common/bin/compare_exceptions.sh.incl
|
||||
--- openjdk.orig/common/bin/compare_exceptions.sh.incl
|
||||
+++ openjdk/common/bin/compare_exceptions.sh.incl
|
||||
@@ -280,6 +280,7 @@
|
||||
./jre/lib/i386/libsplashscreen.so
|
||||
./jre/lib/i386/libsunec.so
|
||||
./jre/lib/i386/libsunwjdga.so
|
||||
+./jre/lib/i386/libsystemconf.so
|
||||
./jre/lib/i386/libt2k.so
|
||||
./jre/lib/i386/libunpack.so
|
||||
./jre/lib/i386/libverify.so
|
||||
@@ -433,6 +434,7 @@
|
||||
./jre/lib/amd64/libsplashscreen.so
|
||||
./jre/lib/amd64/libsunec.so
|
||||
./jre/lib/amd64/libsunwjdga.so
|
||||
+//jre/lib/amd64/libsystemconf.so
|
||||
./jre/lib/amd64/libt2k.so
|
||||
./jre/lib/amd64/libunpack.so
|
||||
./jre/lib/amd64/libverify.so
|
||||
@@ -587,6 +589,7 @@
|
||||
./jre/lib/sparc/libsplashscreen.so
|
||||
./jre/lib/sparc/libsunec.so
|
||||
./jre/lib/sparc/libsunwjdga.so
|
||||
+./jre/lib/sparc/libsystemconf.so
|
||||
./jre/lib/sparc/libt2k.so
|
||||
./jre/lib/sparc/libunpack.so
|
||||
./jre/lib/sparc/libverify.so
|
||||
@@ -741,6 +744,7 @@
|
||||
./jre/lib/sparcv9/libsplashscreen.so
|
||||
./jre/lib/sparcv9/libsunec.so
|
||||
./jre/lib/sparcv9/libsunwjdga.so
|
||||
+./jre/lib/sparcv9/libsystemconf.so
|
||||
./jre/lib/sparcv9/libt2k.so
|
||||
./jre/lib/sparcv9/libunpack.so
|
||||
./jre/lib/sparcv9/libverify.so
|
||||
diff --git openjdk.orig/common/nb_native/nbproject/configurations.xml openjdk/common/nb_native/nbproject/configurations.xml
|
||||
--- openjdk.orig/common/nb_native/nbproject/configurations.xml
|
||||
+++ openjdk/common/nb_native/nbproject/configurations.xml
|
||||
@@ -53,6 +53,9 @@
|
||||
<in>jvmtiEnterTrace.cpp</in>
|
||||
</df>
|
||||
</df>
|
||||
+ <df name="libsystemconf">
|
||||
+ <in>systemconf.c</in>
|
||||
+ </df>
|
||||
</df>
|
||||
</df>
|
||||
<df name="jdk">
|
||||
@@ -12772,6 +12775,11 @@
|
||||
tool="0"
|
||||
flavor2="0">
|
||||
</item>
|
||||
+ <item path="../../jdk/src/solaris/native/java/security/systemconf.c"
|
||||
+ ex="false"
|
||||
+ tool="0"
|
||||
+ flavor2="0">
|
||||
+ </item>
|
||||
<item path="../../jdk/src/share/native/java/util/TimeZone.c"
|
||||
ex="false"
|
||||
tool="0"
|
Loading…
Reference in New Issue
Block a user