jasper/jasper-2.0.14-rpath.patch
Rex Dieter 0d5229d4c3 cleanup cmake usage, move to %build
%build: explicitly disable doc generation
kill hard-coded rpath
-libs: explicit soname so bumps aren't a surprise
use %license, %make_build, 'make install/fast'
2018-07-19 09:53:41 -05:00

13 lines
590 B
Diff

diff -up jasper-2.0.14/CMakeLists.txt.rpath jasper-2.0.14/CMakeLists.txt
--- jasper-2.0.14/CMakeLists.txt.rpath 2017-09-14 18:20:10.000000000 -0500
+++ jasper-2.0.14/CMakeLists.txt 2018-07-19 09:48:53.035815377 -0500
@@ -347,7 +347,7 @@ if (JAS_ENABLE_SHARED)
# (but later on when installing)
set(CMAKE_BUILD_WITH_INSTALL_RPATH FALSE)
- set(CMAKE_INSTALL_RPATH "${CMAKE_INSTALL_PREFIX}/lib")
+ #set(CMAKE_INSTALL_RPATH "${CMAKE_INSTALL_PREFIX}/lib")
# add the automatically determined parts of the RPATH
# which point to directories outside the build tree to the install RPATH