Rebuild for freeglut, new upstream.

This commit is contained in:
Gwyn Ciesla 2019-10-04 07:36:36 -05:00
parent b336cecf4c
commit dc910c246f
4 changed files with 77 additions and 7 deletions

1
.gitignore vendored
View File

@ -12,3 +12,4 @@ jasper-1.900.1.zip
/jasper-2.0.10.tar.gz /jasper-2.0.10.tar.gz
/jasper-2.0.12.tar.gz /jasper-2.0.12.tar.gz
/jasper-2.0.14.tar.gz /jasper-2.0.14.tar.gz
/jasper-version-2.0.16.tar.gz

66
jasper-freeglut.patch Normal file
View File

@ -0,0 +1,66 @@
--- src/appl/jiv.c~ 2019-03-12 13:04:35.000000000 -0500
+++ src/appl/jiv.c 2019-09-18 14:49:59.512771783 -0500
@@ -68,7 +68,7 @@
#include <math.h>
#include <inttypes.h>
#if defined(JAS_HAVE_GL_GLUT_H)
-#include <GL/glut.h>
+#include <GL/freeglut.h>
#else
#include <glut.h>
#endif
--- CMakeLists.txt~ 2019-09-18 14:56:45.000000000 -0500
+++ CMakeLists.txt 2019-09-18 14:59:20.648018137 -0500
@@ -274,21 +274,21 @@
set(JAS_HAVE_OPENGL 0)
message("OpenGL include directory: ${OPENGL_INCLUDE_DIR}")
message("OpenGL libraries: ${OPENGL_LIBRARIES}")
- find_package(GLUT ${JAS_REQUIRED})
- message("GLUT library found: ${GLUT_FOUND}")
- if (GLUT_FOUND)
- message("GLUT include directory: ${GLUT_INCLUDE_DIR}")
- message("GLUT libraries: ${GLUT_LIBRARIES}")
- set(CMAKE_REQUIRED_INCLUDES ${GLUT_INCLUDE_DIR})
- check_include_files(GL/glut.h JAS_HAVE_GL_GLUT_H)
+ find_package(FreeGLUT ${JAS_REQUIRED})
+ message("GLUT library found: ${FreeGLUT_FOUND}")
+ if (FreeGLUT_FOUND)
+ message("GLUT include directory: ${FreeGLUT_INCLUDE_DIR}")
+ message("GLUT libraries: ${FreeGLUT_LIBRARIES}")
+ set(CMAKE_REQUIRED_INCLUDES ${FreeGLUT_INCLUDE_DIR})
+ check_include_files(GL/freeglut.h JAS_HAVE_GL_GLUT_H)
check_include_files(glut.h JAS_HAVE_GLUT_H)
message("JAS_HAVE_GLUT_H: ${JAS_HAVE_GLUT_H}")
message("JAS_HAVE_GL_GLUT_H: ${JAS_HAVE_GL_GLUT_H}")
if (JAS_HAVE_GL_GLUT_H OR JAS_HAVE_GLUT_H)
set(JAS_HAVE_OPENGL 1)
- include_directories(${GLUT_INCLUDE_DIR} ${OPENGL_INCLUDE_DIR})
+ include_directories(${FreeGLUT_INCLUDE_DIR} ${OPENGL_INCLUDE_DIR})
else()
- message(WARNING "The header files GL/glut.h and glut.h both appear to be missing.")
+ message(WARNING "The header files GL/freeglut.h and glut.h both appear to be missing.")
message(WARNING "Disabling OpenGL.")
endif()
endif()
@@ -312,7 +312,7 @@
set(JAS_HAVE_OPENGL 0)
set(OPENGL_INCLUDE_DIR "")
set(OPENGL_LIBRARIES "")
- set(GLUT_INCLUDE_DIR "")
+ set(FreeGLUT_INCLUDE_DIR "")
set(GLUT_LIBRARIES "")
endif()
message("JAS_HAVE_OPENGL: ${JAS_HAVE_OPENGL}")
--- src/appl/CMakeLists.txt~ 2019-03-12 13:04:35.000000000 -0500
+++ src/appl/CMakeLists.txt 2019-09-23 08:42:35.326681243 -0500
@@ -23,8 +23,8 @@
if(JAS_HAVE_OPENGL)
add_executable(jiv jiv.c)
target_include_directories(jiv PUBLIC
- ${GLUT_INCLUDE_DIR} ${OPENGL_INCLUDE_DIR})
- target_link_libraries(jiv libjasper ${JPEG_LIBRARIES} ${GLUT_LIBRARIES}
+ ${FreeGLUT_INCLUDE_DIR} ${OPENGL_INCLUDE_DIR})
+ target_link_libraries(jiv libjasper ${JPEG_LIBRARIES} -lglut
${OPENGL_LIBRARIES} ${MATH_LIBRARY})
set(programs "${programs}" jiv)
set(man_pages "${man_pages}" jiv.1)

View File

@ -5,16 +5,16 @@
Summary: Implementation of the JPEG-2000 standard, Part 1 Summary: Implementation of the JPEG-2000 standard, Part 1
Name: jasper Name: jasper
Version: 2.0.14 Version: 2.0.16
Release: 9%{?dist} Release: 1%{?dist}
License: JasPer License: JasPer
URL: http://www.ece.uvic.ca/~frodo/jasper/ URL: http://www.ece.uvic.ca/~frodo/jasper/
Source0: http://www.ece.uvic.ca/~frodo/jasper/software/jasper-%{version}.tar.gz Source0: http://www.ece.uvic.ca/~frodo/jasper/software/jasper-version-%{version}.tar.gz
Patch1: jasper-2.0.14-CVE-2016-9396.patch
# skip hard-coded prefix/lib rpath # skip hard-coded prefix/lib rpath
Patch2: jasper-2.0.14-rpath.patch Patch2: jasper-2.0.14-rpath.patch
Patch3: jasper-freeglut.patch
# architecture related patches # architecture related patches
Patch100: jasper-2.0.2-test-ppc64-disable.patch Patch100: jasper-2.0.2-test-ppc64-disable.patch
Patch101: jasper-2.0.2-test-ppc64le-disable.patch Patch101: jasper-2.0.2-test-ppc64le-disable.patch
@ -60,12 +60,12 @@ Requires: %{name}-libs%{?_isa} = %{version}-%{release}
%prep %prep
%setup -q -n %{name}-%{version} %setup -q -n %{name}-version-%{version}
%patch1 -p1 -b .CVE-2016-9396
%patch2 -p1 -b .rpath %patch2 -p1 -b .rpath
# Need to disable one test to be able to build it on ppc64 arch # Need to disable one test to be able to build it on ppc64 arch
# At ppc64 this test just stuck (nothing happend - no exception or error) # At ppc64 this test just stuck (nothing happend - no exception or error)
%patch3 -p0 -b .freeglut
%if "%{_arch}" == "ppc64" %if "%{_arch}" == "ppc64"
%patch100 -p1 -b .test-ppc64-disable %patch100 -p1 -b .test-ppc64-disable
@ -127,6 +127,9 @@ make test -C builder
%changelog %changelog
* Tue Sep 17 2019 Gwyn Ciesla <gwync@protonmail.com> - 2.0.16-1
- New version, rebuilt for new freeglut
* Thu Jul 25 2019 Fedora Release Engineering <releng@fedoraproject.org> - 2.0.14-9 * Thu Jul 25 2019 Fedora Release Engineering <releng@fedoraproject.org> - 2.0.14-9
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild - Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild

View File

@ -1 +1 @@
SHA512 (jasper-2.0.14.tar.gz) = 9e5cffd2e899e37ba08890e2377ddfc3c2fb13d9fe00dea6b4612e4d241a6f4327de6835809b415c41ae4bf44208cf7871c1982ff5fc04ae6bc09fd376b0afc8 SHA512 (jasper-version-2.0.16.tar.gz) = b3bca227f833567c9061c4a29c0599784ed6a131b5cceddfd1696542d19add821eda445ce6d83782b454b266723b24d0f028cbc644a25c0e3a75304e615b34ee