- patch for "jpc_dec_tiledecode: Assertion `dec->numcomps == 3' failed)
(#481284, #481291)
This commit is contained in:
parent
519a20fd38
commit
9f262edbc6
15
jasper.spec
15
jasper.spec
@ -1,14 +1,13 @@
|
||||
|
||||
# NOTE: packages that can use jasper:
|
||||
# ImageMagick
|
||||
# kdelibs
|
||||
# netpbm
|
||||
|
||||
Summary: Implementation of the JPEG-2000 standard, Part 1
|
||||
Name: jasper
|
||||
Group: System Environment/Libraries
|
||||
Version: 1.900.1
|
||||
Release: 8%{?dist}
|
||||
Release: 9%{?dist}
|
||||
|
||||
License: JasPer
|
||||
URL: http://www.ece.uvic.ca/~mdadams/jasper/
|
||||
@ -21,6 +20,9 @@ Patch2: jasper-1.701.0-GL-ac.patch
|
||||
# CVE-2007-2721 (bug #240397)
|
||||
# borrowed from http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=413041;msg=88
|
||||
Patch3: patch-libjasper-stepsizes-overflow.diff
|
||||
# borrowed from http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=469786
|
||||
Patch4: jpc_dec.c.patch
|
||||
|
||||
|
||||
BuildRequires: automake
|
||||
BuildRequires: libjpeg-devel
|
||||
@ -63,6 +65,7 @@ Requires: %{name} = %{version}-%{release}
|
||||
|
||||
%patch1 -p1 -b .GL
|
||||
%patch3 -p1 -b .CVE-2007-2721
|
||||
%patch4 -p1 -b .jpc_dec_assertion
|
||||
|
||||
|
||||
%build
|
||||
@ -109,12 +112,12 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%defattr(-,root,root,-)
|
||||
%doc doc/*
|
||||
%{_includedir}/jasper/
|
||||
%{_libdir}/lib*.so
|
||||
%{_libdir}/libjasper.so
|
||||
|
||||
%files libs
|
||||
%defattr(-,root,root,-)
|
||||
%doc COPYRIGHT LICENSE NEWS README
|
||||
%{_libdir}/lib*.so.*
|
||||
%{_libdir}/libjasper.so.1*
|
||||
|
||||
%files utils
|
||||
%defattr(-,root,root,-)
|
||||
@ -124,6 +127,10 @@ rm -rf $RPM_BUILD_ROOT
|
||||
|
||||
|
||||
%changelog
|
||||
* Sun Jan 25 2009 Rex Dieter <rdieter@fedoraproject.org> 1.900.1-9
|
||||
- patch for "jpc_dec_tiledecode: Assertion `dec->numcomps == 3' failed)
|
||||
(#481284, #481291)
|
||||
|
||||
* Fri Feb 08 2008 Rex Dieter <rdieter@fedoraproject.org> 1.900.1-8
|
||||
- respin (gcc43)
|
||||
|
||||
|
18
jpc_dec.c.patch
Normal file
18
jpc_dec.c.patch
Normal file
@ -0,0 +1,18 @@
|
||||
diff -urN jasper-1.900.1/src/libjasper/jpc/jpc_dec.c jasper-1.900.1-fix/src/libjasper/jpc/jpc_dec.c
|
||||
--- jasper-1.900.1/src/libjasper/jpc/jpc_dec.c 2007-01-19 14:43:07.000000000 -0700
|
||||
+++ jasper-1.900.1-fix/src/libjasper/jpc/jpc_dec.c 2008-03-06 16:51:12.000000000 -0700
|
||||
@@ -1069,12 +1069,12 @@
|
||||
/* Apply an inverse intercomponent transform if necessary. */
|
||||
switch (tile->cp->mctid) {
|
||||
case JPC_MCT_RCT:
|
||||
- assert(dec->numcomps == 3);
|
||||
+ assert(dec->numcomps >= 3);
|
||||
jpc_irct(tile->tcomps[0].data, tile->tcomps[1].data,
|
||||
tile->tcomps[2].data);
|
||||
break;
|
||||
case JPC_MCT_ICT:
|
||||
- assert(dec->numcomps == 3);
|
||||
+ assert(dec->numcomps >= 3);
|
||||
jpc_iict(tile->tcomps[0].data, tile->tcomps[1].data,
|
||||
tile->tcomps[2].data);
|
||||
break;
|
Loading…
Reference in New Issue
Block a user