- GL patch to remove libGL dependancy (using only freeglut)
This commit is contained in:
parent
7644efe7c8
commit
89b65bb4b5
22
jasper-1.701.0-GL.patch
Normal file
22
jasper-1.701.0-GL.patch
Normal file
@ -0,0 +1,22 @@
|
||||
--- jasper-1.701.0/configure.ac.GL 2004-02-08 19:41:29.000000000 -0600
|
||||
+++ jasper-1.701.0/configure.ac 2005-10-18 08:09:24.000000000 -0500
|
||||
@@ -242,7 +242,7 @@
|
||||
OPENGL_LIBS=""
|
||||
if test $ENABLE_OPENGL = yes; then
|
||||
if test $HAVE_OPENGL = no; then
|
||||
- TMPLIBS="-lglut -lGL -lGLU $X_PRE_LIBS -lX11 -lXmu -lXi -lXext -lXt $X_EXTRA_LIBS $X_LIBS"
|
||||
+ TMPLIBS="-lglut $X_PRE_LIBS $X_EXTRA_LIBS $X_LIBS"
|
||||
AC_CHECK_LIB(glut, glutInit, [HAVE_OPENGL=yes;
|
||||
OPENGL_LIBS=$TMPLIBS], HAVE_OPENGL=no, $TMPLIBS)
|
||||
fi
|
||||
--- jasper-1.701.0/configure.GL 2004-02-08 19:44:12.000000000 -0600
|
||||
+++ jasper-1.701.0/configure 2005-10-18 08:09:38.000000000 -0500
|
||||
@@ -9465,7 +9465,7 @@
|
||||
OPENGL_LIBS=""
|
||||
if test $ENABLE_OPENGL = yes; then
|
||||
if test $HAVE_OPENGL = no; then
|
||||
- TMPLIBS="-lglut -lGL -lGLU $X_PRE_LIBS -lX11 -lXmu -lXi -lXext -lXt $X_EXTRA_LIBS $X_LIBS"
|
||||
+ TMPLIBS="-lglut $X_PRE_LIBS $X_EXTRA_LIBS $X_LIBS"
|
||||
echo "$as_me:$LINENO: checking for glutInit in -lglut" >&5
|
||||
echo $ECHO_N "checking for glutInit in -lglut... $ECHO_C" >&6
|
||||
if test "${ac_cv_lib_glut_glutInit+set}" = set; then
|
15
jasper.spec
15
jasper.spec
@ -10,7 +10,7 @@ Summary: Implementation of the JPEG-2000 standard, Part 1
|
||||
Name: jasper
|
||||
Group: System Environment/Libraries
|
||||
Version: 1.701.0
|
||||
Release: 5%{?dist}
|
||||
Release: 7%{?dist}
|
||||
|
||||
License: JasPer License Version 2.0
|
||||
URL: http://www.ece.uvic.ca/~mdadams/jasper/
|
||||
@ -19,7 +19,6 @@ BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
|
||||
BuildRequires: libjpeg-devel
|
||||
BuildRequires: freeglut-devel
|
||||
BuildRequires: libGL-devel
|
||||
|
||||
%description
|
||||
This package contains an implementation of the image compression
|
||||
@ -41,11 +40,16 @@ Requires: libjpeg-devel
|
||||
|
||||
%build
|
||||
%configure \
|
||||
--enable-shared \
|
||||
--disable-static
|
||||
|
||||
make %{?_smp_mflags}
|
||||
|
||||
|
||||
%check
|
||||
make check
|
||||
|
||||
|
||||
%install
|
||||
rm -rf $RPM_BUILD_ROOT
|
||||
|
||||
@ -83,6 +87,13 @@ rm -rf $RPM_BUILD_ROOT
|
||||
|
||||
|
||||
%changelog
|
||||
* Tue Oct 18 2005 Rex Dieter <rexdieter[AT]users.sf.net> 1.701.0-7
|
||||
- GL patch to remove libGL dependancy (using only freeglut)
|
||||
|
||||
* Tue Oct 18 2005 Rex Dieter <rexdieter[AT]users.sf.net> 1.701.0-6
|
||||
- token %%check section
|
||||
- --enable-shared
|
||||
|
||||
* Mon Oct 17 2005 Rex Dieter <rexdieter[AT]users.sf.net> 1.701.0-5
|
||||
- use %%{?dist}
|
||||
- BR: libGL-devel
|
||||
|
Loading…
Reference in New Issue
Block a user