New upstream release 4.1.0

This commit is contained in:
Josef Řídký 2023-11-20 11:43:30 +01:00
parent 6ffec5abe1
commit 83b29df32a
3 changed files with 156 additions and 7 deletions

12
jasper-4.1.0-rpath.patch Normal file
View File

@ -0,0 +1,12 @@
diff -urNp a/CMakeLists.txt b/CMakeLists.txt
--- a/CMakeLists.txt 2023-11-08 10:45:01.610146140 +0100
+++ b/CMakeLists.txt 2023-11-08 10:46:18.131824994 +0100
@@ -804,7 +804,7 @@ if(JAS_ENABLE_SHARED)
# (but later on when installing)
set(CMAKE_BUILD_WITH_INSTALL_RPATH FALSE)
- set(CMAKE_INSTALL_RPATH "${CMAKE_INSTALL_PREFIX}/lib")
+ #set(CMAKE_INSTALL_RPATH "${CMAKE_INSTALL_PREFIX}/lib")
# add the automatically determined parts of the RPATH
# which point to directories outside the build tree to the install RPATH

View File

@ -0,0 +1,130 @@
diff -urNp a/src/app/CMakeLists.txt b/src/app/CMakeLists.txt
--- a/src/app/CMakeLists.txt 2023-11-08 13:41:24.725949157 +0100
+++ b/src/app/CMakeLists.txt 2023-11-08 13:41:42.637087268 +0100
@@ -115,9 +115,6 @@ if(BASH_PROGRAM AND JAS_HAVE_ALL_NATIVE_
add_test(run_test_2
"${BASH_PROGRAM}" "${CMAKE_CURRENT_BINARY_DIR}/../../test/bin/wrapper"
"${CMAKE_CURRENT_SOURCE_DIR}/../../test/bin/run_test_2" -v)
- add_test(run_test_3
- "${BASH_PROGRAM}" "${CMAKE_CURRENT_BINARY_DIR}/../../test/bin/wrapper"
- "${CMAKE_CURRENT_SOURCE_DIR}/../../test/bin/run_test_3" -v)
if(JAS_ENABLE_CONFORMANCE_TESTS)
add_test(run_conformance_tests
"${BASH_PROGRAM}" "${CMAKE_CURRENT_BINARY_DIR}/../../test/bin/wrapper"
diff -urNp a/test/bin/run_test_3 b/test/bin/run_test_3
--- a/test/bin/run_test_3 2023-11-08 13:41:24.712949057 +0100
+++ b/test/bin/run_test_3 1970-01-01 01:00:00.000000000 +0100
@@ -1,113 +0,0 @@
-#! /usr/bin/env bash
-# Copyright (c) 2016 Michael David Adams
-################################################################################
-
-################################################################################
-
-if [ "${BASH_VERSINFO[0]}" -lt 4 ]; then
- echo "This test requires Bash 4 or greater."
- echo "This test is being skipped."
- exit 0
-fi
-
-cmd_dir=$(dirname "$0") || exit 1
-source "$cmd_dir"/utilities || exit 1
-top_dir="$cmd_dir/../.."
-sysinfo_program="$top_dir/build/sysinfo"
-
-debug_level="${JAS_DEBUG_LEVEL:-0}"
-if [ "$debug_level" -ge 1 ]; then
- set -xv
-fi
-
-################################################################################
-
-set_source_and_build_dirs || panic "cannot set source and build directories"
-
-################################################################################
-
-#abs_source_dir="$1"
-#abs_build_dir="$2"
-
-#export JAS_ABS_TOP_BUILDDIR="$abs_build_dir"
-#export JAS_TOP_BUILDDIR="$abs_build_dir"
-#export JAS_ABS_TOP_SRCDIR="$abs_source_dir"
-#export JAS_TOP_SRCDIR="$abs_source_dir"
-
-#$CMDDIR/rundectests jasper || exit 1
-
-oj_compress=$(which opj2_compress) || oj_compress=""
-oj_decompress=$(which opj2_decompress) || oj_decompress=""
-
-run_test="$cmd_dir/run_codec_test"
-
-codec_selectors=()
-codec_selectors+=(jasper_jasper)
-if [ -n "$oj_decompress" ]; then
- codec_selectors+=(jasper_oj)
-fi
-#codec_selectors+=(jasper_jj2k)
-#codec_selectors+=(jj2k_jasper)
-#codec_selectors+=(kakadu_jasper)
-#codec_selectors+=(jasper_kakadu)
-###codec_selectors+=(jasper_vm)
-###codec_selectors+=(vm_jasper)
-
-exclude_tests=()
-
-os="$("$sysinfo_program" -o)" || \
- panic "cannot get OS information"
-echo "OS: $os"
-
-if [ "$os" = windows ]; then
- eecho "WARNING: some tests disabled"
- exclude_tests+=(sgn_1)
-fi
-
-base_opts=()
-for test in "${exclude_tests[@]}"; do
- base_opts+=(-X "$test")
-done
-
-echo "STARTING AT `date`"
-
-num_errors=0
-failed_tests=()
-
-for codec_selector in "${codec_selectors[@]}"; do
- enc=$(echo "$codec_selector" | awk -v FS=_ '{print $1}' -)
- dec=$(echo "$codec_selector" | awk -v FS=_ '{print $2}' -)
- echo "############################################################"
- echo "START OF TESTS FOR ENCODER=$enc DECODER=$dec"
- echo "############################################################"
- opts=()
- opts+=(-v)
- opts+=(-e "$enc")
- opts+=(-d "$dec")
- opts+=(-E ignore)
- opts+=("${base_opts[@]}")
- #opts+=(-B)
- opts+=("$@")
- "$run_test" "${opts[@]}"
- status=$?
- if [ $status -ne 0 ]; then
- num_errors=$((num_errors + 1))
- failed_tests+=($codec_selector)
- #panic "running tests failed"
- fi
- echo "############################################################"
- echo "END OF TESTS"
- echo "############################################################"
-done
-
-echo "ENDING AT `date`"
-
-echo "############################################################"
-echo "TEST SUMMARY"
-echo "Number of codec selectors: ${#codec_selectors[@]}"
-echo "Number of errors: $num_errors"
-if [ "$num_errors" -gt 0 ]; then
- echo "STATUS: FAILED"
- exit 1
-fi
-echo "STATUS: PASSED"

View File

@ -5,19 +5,20 @@
Summary: Implementation of the JPEG-2000 standard, Part 1 Summary: Implementation of the JPEG-2000 standard, Part 1
Name: jasper Name: jasper
Version: 3.0.6 Version: 4.1.0
Release: 4%{?dist} Release: 1%{?dist}
License: JasPer-2.0 License: JasPer-2.0
URL: http://www.ece.uvic.ca/~frodo/jasper/ URL: http://www.ece.uvic.ca/~frodo/jasper/
Source0: https://github.com/jasper-software/%{name}/archive/refs/tags/version-%{version}.tar.gz Source0: https://github.com/jasper-software/%{name}/archive/refs/tags/version-%{version}.tar.gz
# skip hard-coded prefix/lib rpath # skip hard-coded prefix/lib rpath
Patch1: jasper-3.0.0-rpath.patch Patch1: jasper-4.1.0-rpath.patch
# architecture related patches # architecture related patches
Patch100: jasper-2.0.2-test-ppc64-disable.patch Patch100: jasper-2.0.2-test-ppc64-disable.patch
Patch101: jasper-2.0.2-test-ppc64le-disable.patch Patch101: jasper-2.0.2-test-ppc64le-disable.patch
Patch102: jasper-4.1.0-test-i686-disable.patch
# autoreconf # autoreconf
BuildRequires: cmake BuildRequires: cmake
@ -63,21 +64,24 @@ Requires: %{name}-libs%{?_isa} = %{version}-%{release}
%prep %prep
%setup -q -n %{name}-version-%{version} %setup -q -n %{name}-version-%{version}
%patch1 -p1 -b .rpath %patch 1 -p1 -b .rpath
# Need to disable one test to be able to build it on ppc64 arch # Need to disable one test to be able to build it on ppc64 arch
# At ppc64 this test just stuck (nothing happend - no exception or error) # At ppc64 this test just stuck (nothing happend - no exception or error)
%if "%{_arch}" == "ppc64" %if "%{_arch}" == "ppc64"
%patch100 -p1 -b .test-ppc64-disable %patch 100 -p1 -b .test-ppc64-disable
%endif %endif
# Need to disable two tests to be able to build it on ppc64le arch # Need to disable two tests to be able to build it on ppc64le arch
# At ppc64le this tests just stuck (nothing happend - no exception or error) # At ppc64le this tests just stuck (nothing happend - no exception or error)
%if "%{_arch}" == "ppc64le" %if "%{_arch}" == "ppc64le"
%patch101 -p1 -b .test-ppc64le-disable %patch 101 -p1 -b .test-ppc64le-disable
%endif %endif
%ifarch %ix86
%patch 102 -p1 -b .test-i686-disable
%endif
%build %build
mkdir builder mkdir builder
@ -118,7 +122,7 @@ make test -C builder
%files libs %files libs
%doc README.md %doc README.md
%license COPYRIGHT.txt LICENSE.txt %license COPYRIGHT.txt LICENSE.txt
%{_libdir}/libjasper.so.6* %{_libdir}/libjasper.so.7*
%files utils %files utils
%{_bindir}/jiv %{_bindir}/jiv
@ -126,6 +130,9 @@ make test -C builder
%changelog %changelog
* Mon Nov 20 2023 Josef Ridky <jridky@redhat.com> - 4.1.0-1
- New upstream release 4.1.0
* Thu Jul 20 2023 Fedora Release Engineering <releng@fedoraproject.org> - 3.0.6-4 * Thu Jul 20 2023 Fedora Release Engineering <releng@fedoraproject.org> - 3.0.6-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_39_Mass_Rebuild - Rebuilt for https://fedoraproject.org/wiki/Fedora_39_Mass_Rebuild