- revert jasper to jaspertool rename (#176773)
- actually use/apply GL patch
This commit is contained in:
parent
89b65bb4b5
commit
5564610d34
@ -1,14 +1,3 @@
|
||||
--- jasper-1.701.0/configure.ac.GL 2004-02-08 19:41:29.000000000 -0600
|
||||
+++ jasper-1.701.0/configure.ac 2005-10-18 08:09:24.000000000 -0500
|
||||
@@ -242,7 +242,7 @@
|
||||
OPENGL_LIBS=""
|
||||
if test $ENABLE_OPENGL = yes; then
|
||||
if test $HAVE_OPENGL = no; then
|
||||
- TMPLIBS="-lglut -lGL -lGLU $X_PRE_LIBS -lX11 -lXmu -lXi -lXext -lXt $X_EXTRA_LIBS $X_LIBS"
|
||||
+ TMPLIBS="-lglut $X_PRE_LIBS $X_EXTRA_LIBS $X_LIBS"
|
||||
AC_CHECK_LIB(glut, glutInit, [HAVE_OPENGL=yes;
|
||||
OPENGL_LIBS=$TMPLIBS], HAVE_OPENGL=no, $TMPLIBS)
|
||||
fi
|
||||
--- jasper-1.701.0/configure.GL 2004-02-08 19:44:12.000000000 -0600
|
||||
+++ jasper-1.701.0/configure 2005-10-18 08:09:38.000000000 -0500
|
||||
@@ -9465,7 +9465,7 @@
|
||||
@ -16,7 +5,7 @@
|
||||
if test $ENABLE_OPENGL = yes; then
|
||||
if test $HAVE_OPENGL = no; then
|
||||
- TMPLIBS="-lglut -lGL -lGLU $X_PRE_LIBS -lX11 -lXmu -lXi -lXext -lXt $X_EXTRA_LIBS $X_LIBS"
|
||||
+ TMPLIBS="-lglut $X_PRE_LIBS $X_EXTRA_LIBS $X_LIBS"
|
||||
+ TMPLIBS="-lglut"
|
||||
echo "$as_me:$LINENO: checking for glutInit in -lglut" >&5
|
||||
echo $ECHO_N "checking for glutInit in -lglut... $ECHO_C" >&6
|
||||
if test "${ac_cv_lib_glut_glutInit+set}" = set; then
|
||||
|
21
jasper.spec
21
jasper.spec
@ -1,4 +1,3 @@
|
||||
# $Id$
|
||||
|
||||
# NOTE: packages can use jasper:
|
||||
# ImageMagick
|
||||
@ -10,13 +9,15 @@ Summary: Implementation of the JPEG-2000 standard, Part 1
|
||||
Name: jasper
|
||||
Group: System Environment/Libraries
|
||||
Version: 1.701.0
|
||||
Release: 7%{?dist}
|
||||
Release: 8%{?dist}
|
||||
|
||||
License: JasPer License Version 2.0
|
||||
URL: http://www.ece.uvic.ca/~mdadams/jasper/
|
||||
Source: http://www.ece.uvic.ca/~mdadams/jasper/software/jasper-1.701.0.zip
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
|
||||
Patch1: jasper-1.701.0-GL.patch
|
||||
|
||||
BuildRequires: libjpeg-devel
|
||||
BuildRequires: freeglut-devel
|
||||
|
||||
@ -37,6 +38,8 @@ Requires: libjpeg-devel
|
||||
%prep
|
||||
%setup -q
|
||||
|
||||
%patch1 -p1 -b .GL
|
||||
|
||||
|
||||
%build
|
||||
%configure \
|
||||
@ -46,7 +49,7 @@ Requires: libjpeg-devel
|
||||
make %{?_smp_mflags}
|
||||
|
||||
|
||||
%check
|
||||
%check ||:
|
||||
make check
|
||||
|
||||
|
||||
@ -61,13 +64,17 @@ rm -f $RPM_BUILD_ROOT%{_bindir}/%{_target_platform}*
|
||||
rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.la
|
||||
|
||||
# avoid conflict(s) with tomcat
|
||||
mv $RPM_BUILD_ROOT%{_bindir}/jasper $RPM_BUILD_ROOT%{_bindir}/jaspertool
|
||||
# not needed anymore, see bz #176773
|
||||
# mv $RPM_BUILD_ROOT%{_bindir}/jasper $RPM_BUILD_ROOT%{_bindir}/jaspertool
|
||||
|
||||
|
||||
%files
|
||||
%defattr(-,root,root)
|
||||
%doc COPYRIGHT LICENSE NEWS README
|
||||
%{_bindir}/*
|
||||
%{_bindir}/imgcmp
|
||||
%{_bindir}/jiv
|
||||
%{_bindir}/imginfo
|
||||
%{_bindir}/jasper*
|
||||
%{_libdir}/lib*.so.*
|
||||
|
||||
%files devel
|
||||
@ -87,6 +94,10 @@ rm -rf $RPM_BUILD_ROOT
|
||||
|
||||
|
||||
%changelog
|
||||
* Tue Jan 31 2006 Rex Dieter <rexdieter[AT]users.sf.net> 1.701.0-8
|
||||
- revert jasper to jaspertool rename (#176773)
|
||||
- actually use/apply GL patch
|
||||
|
||||
* Tue Oct 18 2005 Rex Dieter <rexdieter[AT]users.sf.net> 1.701.0-7
|
||||
- GL patch to remove libGL dependancy (using only freeglut)
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user