New upstream release 3.0.5
This commit is contained in:
parent
d479fcdf39
commit
49fafee2dd
1
.gitignore
vendored
1
.gitignore
vendored
@ -24,3 +24,4 @@ jasper-1.900.1.zip
|
|||||||
/version-2.0.33.tar.gz
|
/version-2.0.33.tar.gz
|
||||||
/jasper-version-3.0.0.tar.gz
|
/jasper-version-3.0.0.tar.gz
|
||||||
/version-3.0.2.tar.gz
|
/version-3.0.2.tar.gz
|
||||||
|
/version-3.0.5.tar.gz
|
||||||
|
@ -1,12 +0,0 @@
|
|||||||
diff -up jasper-2.0.14/CMakeLists.txt.rpath jasper-2.0.14/CMakeLists.txt
|
|
||||||
--- jasper-2.0.14/CMakeLists.txt.rpath 2017-09-14 18:20:10.000000000 -0500
|
|
||||||
+++ jasper-2.0.14/CMakeLists.txt 2018-07-19 09:48:53.035815377 -0500
|
|
||||||
@@ -347,7 +347,7 @@ if (JAS_ENABLE_SHARED)
|
|
||||||
# (but later on when installing)
|
|
||||||
set(CMAKE_BUILD_WITH_INSTALL_RPATH FALSE)
|
|
||||||
|
|
||||||
- set(CMAKE_INSTALL_RPATH "${CMAKE_INSTALL_PREFIX}/lib")
|
|
||||||
+ #set(CMAKE_INSTALL_RPATH "${CMAKE_INSTALL_PREFIX}/lib")
|
|
||||||
|
|
||||||
# add the automatically determined parts of the RPATH
|
|
||||||
# which point to directories outside the build tree to the install RPATH
|
|
@ -1,12 +0,0 @@
|
|||||||
diff -up jasper-version-2.0.17/CMakeLists.txt.me jasper-version-2.0.17/CMakeLists.txt
|
|
||||||
--- jasper-version-2.0.17/CMakeLists.txt.me 2020-08-27 20:41:48.442787440 +0200
|
|
||||||
+++ jasper-version-2.0.17/CMakeLists.txt 2020-08-27 20:42:02.161966702 +0200
|
|
||||||
@@ -17,7 +17,7 @@ include(CheckCCompilerFlag)
|
|
||||||
# The major, minor, and micro version numbers of the project.
|
|
||||||
set(JAS_VERSION_MAJOR 2)
|
|
||||||
set(JAS_VERSION_MINOR 0)
|
|
||||||
-set(JAS_VERSION_PATCH 16)
|
|
||||||
+set(JAS_VERSION_PATCH 17)
|
|
||||||
|
|
||||||
# The project version.
|
|
||||||
set(JAS_VERSION
|
|
@ -1,48 +0,0 @@
|
|||||||
From 39047be58de0f7f1e58b9866ef7f78722fba9bf1 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Michael Adams <mdadams@ece.uvic.ca>
|
|
||||||
Date: Sat, 12 Feb 2022 07:36:21 -0800
|
|
||||||
Subject: [PATCH] Fixes #318.
|
|
||||||
|
|
||||||
Eliminated the use of "class" as an identifier, as this will clearly cause
|
|
||||||
problems if JasPer headers are used in C++ source code.
|
|
||||||
|
|
||||||
In order to catch incompatibilities with C++ in the future, a trivial C++
|
|
||||||
test program has been added.
|
|
||||||
The CMake build process was adjusted to (optionally) allow the use of a
|
|
||||||
C++ compiler.
|
|
||||||
Each use of add_compile_options that sets C compiler options was changed
|
|
||||||
to use a new function called add_c_compile_options that only sets options
|
|
||||||
for the C compiler.
|
|
||||||
Some changes to the CMake module for code sanitizers were made in order to
|
|
||||||
handle the C++ compiler case.
|
|
||||||
Several new options were added to the build script.
|
|
||||||
---
|
|
||||||
CMakeLists.txt | 61 ++++++++++++++++----------
|
|
||||||
build/build | 26 +++++++++++
|
|
||||||
build/build_all | 36 +++++++++++++++
|
|
||||||
build/cmake/modules/Sanitizers.cmake | 6 +++
|
|
||||||
src/app/CMakeLists.txt | 8 ++++
|
|
||||||
src/app/test_2.cpp | 21 +++++++++
|
|
||||||
src/libjasper/include/jasper/jas_log.h | 6 +--
|
|
||||||
7 files changed, 137 insertions(+), 27 deletions(-)
|
|
||||||
create mode 100644 src/app/test_2.cpp
|
|
||||||
|
|
||||||
diff --git a/src/libjasper/include/jasper/jas_log.h b/src/libjasper/include/jasper/jas_log.h
|
|
||||||
index e2ef5b61..dc4228b5 100644
|
|
||||||
--- a/src/libjasper/include/jasper/jas_log.h
|
|
||||||
+++ b/src/libjasper/include/jasper/jas_log.h
|
|
||||||
@@ -119,11 +119,11 @@ typedef int (jas_vlogmsgf_t)(jas_logtype_t, const char *, va_list);
|
|
||||||
/*!
|
|
||||||
@brief Create an instance of a logtype.
|
|
||||||
*/
|
|
||||||
-static inline jas_logtype_t jas_logtype_init(int class, int priority)
|
|
||||||
+static inline jas_logtype_t jas_logtype_init(int clas, int priority)
|
|
||||||
{
|
|
||||||
- assert(class >= 0 && class < JAS_LOGTYPE_NUM_CLASSES);
|
|
||||||
+ assert(clas >= 0 && clas < JAS_LOGTYPE_NUM_CLASSES);
|
|
||||||
assert(priority >= 0 && priority <= JAS_LOGTYPE_MAX_PRIORITY);
|
|
||||||
- return (class & 0xf) | (priority << 4);
|
|
||||||
+ return (clas & 0xf) | (priority << 4);
|
|
||||||
}
|
|
||||||
|
|
||||||
/*!
|
|
@ -1,29 +0,0 @@
|
|||||||
From f94e7499a8b1471a4905c4f9c9e12e60fe88264b Mon Sep 17 00:00:00 2001
|
|
||||||
From: Michael Adams <mdadams@ece.uvic.ca>
|
|
||||||
Date: Sat, 13 Mar 2021 20:04:58 -0800
|
|
||||||
Subject: [PATCH] Fixes #269. Added a check for an invalid component reference
|
|
||||||
in the JP2 decoder.
|
|
||||||
|
|
||||||
---
|
|
||||||
src/libjasper/jp2/jp2_dec.c | 8 +++++++-
|
|
||||||
1 files changed, 7 insertions(+), 1 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/src/libjasper/jp2/jp2_dec.c b/src/libjasper/jp2/jp2_dec.c
|
|
||||||
index 2863d82..fe2e29d 100644
|
|
||||||
--- a/src/libjasper/jp2/jp2_dec.c
|
|
||||||
+++ b/src/libjasper/jp2/jp2_dec.c
|
|
||||||
@@ -451,7 +451,13 @@ jas_image_t *jp2_decode(jas_stream_t *in, const char *optstr)
|
|
||||||
}
|
|
||||||
} else {
|
|
||||||
for (i = 0; i < dec->numchans; ++i) {
|
|
||||||
- jas_image_setcmpttype(dec->image, dec->chantocmptlut[i],
|
|
||||||
+ unsigned compno = dec->chantocmptlut[i];
|
|
||||||
+ if (compno >= jas_image_numcmpts(dec->image)) {
|
|
||||||
+ jas_eprintf(
|
|
||||||
+ "error: invalid component reference (%d)\n", compno);
|
|
||||||
+ goto error;
|
|
||||||
+ }
|
|
||||||
+ jas_image_setcmpttype(dec->image, compno,
|
|
||||||
jp2_getct(jas_image_clrspc(dec->image), 0, i + 1));
|
|
||||||
}
|
|
||||||
}
|
|
@ -1,66 +0,0 @@
|
|||||||
diff -urNp a/build/cmake/modules/JasOpenGL.cmake b/build/cmake/modules/JasOpenGL.cmake
|
|
||||||
--- a/build/cmake/modules/JasOpenGL.cmake 2020-10-07 10:00:16.316291325 +0200
|
|
||||||
+++ b/build/cmake/modules/JasOpenGL.cmake 2020-10-07 10:03:39.536143003 +0200
|
|
||||||
@@ -13,19 +13,19 @@ if (JAS_ENABLE_OPENGL AND OPENGL_FOUND)
|
|
||||||
set(JAS_HAVE_OPENGL 0)
|
|
||||||
message("OpenGL include directory: ${OPENGL_INCLUDE_DIR}")
|
|
||||||
message("OpenGL libraries: ${OPENGL_LIBRARIES}")
|
|
||||||
- find_package(GLUT ${JAS_REQUIRED})
|
|
||||||
- message("GLUT library found: ${GLUT_FOUND}")
|
|
||||||
- if (GLUT_FOUND)
|
|
||||||
- message("GLUT include directory: ${GLUT_INCLUDE_DIR}")
|
|
||||||
- message("GLUT libraries: ${GLUT_LIBRARIES}")
|
|
||||||
- set(CMAKE_REQUIRED_INCLUDES ${GLUT_INCLUDE_DIR})
|
|
||||||
- check_include_files(GL/glut.h JAS_HAVE_GL_GLUT_H)
|
|
||||||
+ find_package(FreeGLUT ${JAS_REQUIRED})
|
|
||||||
+ message("GLUT library found: ${FreeGLUT_FOUND}")
|
|
||||||
+ if (FreeGLUT_FOUND)
|
|
||||||
+ message("GLUT include directory: ${FreeGLUT_INCLUDE_DIR}")
|
|
||||||
+ message("GLUT libraries: ${FreeGLUT_LIBRARIES}")
|
|
||||||
+ set(CMAKE_REQUIRED_INCLUDES ${FreeGLUT_INCLUDE_DIR})
|
|
||||||
+ check_include_files(GL/freeglut.h JAS_HAVE_GL_GLUT_H)
|
|
||||||
check_include_files(glut.h JAS_HAVE_GLUT_H)
|
|
||||||
if (JAS_HAVE_GL_GLUT_H OR JAS_HAVE_GLUT_H)
|
|
||||||
set(JAS_HAVE_OPENGL 1)
|
|
||||||
- include_directories(${GLUT_INCLUDE_DIR} ${OPENGL_INCLUDE_DIR})
|
|
||||||
+ include_directories(${FreeGLUT_INCLUDE_DIR} ${OPENGL_INCLUDE_DIR})
|
|
||||||
else()
|
|
||||||
- message(WARNING "The header files GL/glut.h and glut.h both appear to be missing.")
|
|
||||||
+ message(WARNING "The header files GL/freeglut.h and glut.h both appear to be missing.")
|
|
||||||
message(WARNING "Disabling OpenGL.")
|
|
||||||
endif()
|
|
||||||
endif()
|
|
||||||
@@ -49,6 +49,6 @@ else()
|
|
||||||
set(JAS_HAVE_OPENGL 0)
|
|
||||||
set(OPENGL_INCLUDE_DIR "")
|
|
||||||
set(OPENGL_LIBRARIES "")
|
|
||||||
- set(GLUT_INCLUDE_DIR "")
|
|
||||||
+ set(FreeGLUT_INCLUDE_DIR "")
|
|
||||||
set(GLUT_LIBRARIES "")
|
|
||||||
endif()
|
|
||||||
diff -urNp a/src/appl/CMakeLists.txt b/src/appl/CMakeLists.txt
|
|
||||||
--- a/src/appl/CMakeLists.txt 2020-10-07 10:00:16.338291526 +0200
|
|
||||||
+++ b/src/appl/CMakeLists.txt 2020-10-07 10:04:58.864872143 +0200
|
|
||||||
@@ -23,8 +23,8 @@ set(man_pages "${man_pages}" imgcmp.1)
|
|
||||||
if(JAS_HAVE_OPENGL)
|
|
||||||
add_executable(jiv jiv.c)
|
|
||||||
target_include_directories(jiv PUBLIC
|
|
||||||
- ${GLUT_INCLUDE_DIR} ${OPENGL_INCLUDE_DIR})
|
|
||||||
- target_link_libraries(jiv libjasper ${JPEG_LIBRARIES} ${GLUT_LIBRARIES}
|
|
||||||
+ ${FreeGLUT_INCLUDE_DIR} ${OPENGL_INCLUDE_DIR})
|
|
||||||
+ target_link_libraries(jiv libjasper ${JPEG_LIBRARIES} -lglut
|
|
||||||
${OPENGL_LIBRARIES} ${MATH_LIBRARY})
|
|
||||||
set(programs "${programs}" jiv)
|
|
||||||
set(man_pages "${man_pages}" jiv.1)
|
|
||||||
diff -urNp a/src/appl/jiv.c b/src/appl/jiv.c
|
|
||||||
--- a/src/appl/jiv.c 2020-10-07 10:00:16.340291544 +0200
|
|
||||||
+++ b/src/appl/jiv.c 2020-10-07 10:05:35.319207658 +0200
|
|
||||||
@@ -68,7 +68,7 @@
|
|
||||||
#include <math.h>
|
|
||||||
#include <inttypes.h>
|
|
||||||
#if defined(JAS_HAVE_GL_GLUT_H)
|
|
||||||
-#include <GL/glut.h>
|
|
||||||
+#include <GL/freeglut.h>
|
|
||||||
#else
|
|
||||||
#include <glut.h>
|
|
||||||
#endif
|
|
@ -5,7 +5,7 @@
|
|||||||
|
|
||||||
Summary: Implementation of the JPEG-2000 standard, Part 1
|
Summary: Implementation of the JPEG-2000 standard, Part 1
|
||||||
Name: jasper
|
Name: jasper
|
||||||
Version: 3.0.2
|
Version: 3.0.5
|
||||||
Release: 1%{?dist}
|
Release: 1%{?dist}
|
||||||
|
|
||||||
License: JasPer
|
License: JasPer
|
||||||
@ -126,6 +126,9 @@ make test -C builder
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Jul 01 2022 Josef Ridky <jridky@redhat.com> - 3.0.5-1
|
||||||
|
- New upstream release 3.0.5
|
||||||
|
|
||||||
* Mon Mar 14 2022 Josef Ridky <jridky@redhat.com> - 3.0.2-1
|
* Mon Mar 14 2022 Josef Ridky <jridky@redhat.com> - 3.0.2-1
|
||||||
- New upstream release 3.0.2
|
- New upstream release 3.0.2
|
||||||
|
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (version-3.0.2.tar.gz) = 33a43abb6b4abcac9e5eeddf4a29f56a4cfe41cd151889e3785b6371b8af07ee96f08cfa5c85c98211aa711110c75087fa417f5d61d9460f9be317005e0afc3a
|
SHA512 (version-3.0.5.tar.gz) = bd14e5475720c7b9a86e29ffdad15fb7e725cd2750f0b41514317ab3de6c57381b956627c6e6e3a84f85e0cda9508a693c0f8a1873ae59b5080e4592ba16f982
|
||||||
|
Loading…
Reference in New Issue
Block a user