New upstream version 2.0.22 (#1876161)
This commit is contained in:
parent
09bd8c5003
commit
2c85c59035
1
.gitignore
vendored
1
.gitignore
vendored
@ -14,3 +14,4 @@ jasper-1.900.1.zip
|
|||||||
/jasper-2.0.14.tar.gz
|
/jasper-2.0.14.tar.gz
|
||||||
/jasper-version-2.0.16.tar.gz
|
/jasper-version-2.0.16.tar.gz
|
||||||
/version-2.0.17.tar.gz
|
/version-2.0.17.tar.gz
|
||||||
|
/version-2.0.22.tar.gz
|
||||||
|
@ -1,13 +0,0 @@
|
|||||||
diff -urNp old/src/libjasper/jpc/jpc_cs.c new/src/libjasper/jpc/jpc_cs.c
|
|
||||||
--- old/src/libjasper/jpc/jpc_cs.c 2018-05-30 09:01:54.160406645 +0200
|
|
||||||
+++ new/src/libjasper/jpc/jpc_cs.c 2018-05-30 09:05:24.527094308 +0200
|
|
||||||
@@ -795,6 +795,9 @@ static int jpc_cox_getcompparms(jpc_ms_t
|
|
||||||
if (compparms->numdlvls > 32) {
|
|
||||||
goto error;
|
|
||||||
}
|
|
||||||
+ if (compparms->qmfbid != JPC_COX_INS &&
|
|
||||||
+ compparms->qmfbid != JPC_COX_RFT)
|
|
||||||
+ goto error;
|
|
||||||
compparms->numrlvls = compparms->numdlvls + 1;
|
|
||||||
if (compparms->numrlvls > JPC_MAXRLVLS) {
|
|
||||||
goto error;
|
|
@ -1,17 +1,7 @@
|
|||||||
--- src/appl/jiv.c~ 2019-03-12 13:04:35.000000000 -0500
|
diff -urNp a/build/cmake/modules/JasOpenGL.cmake b/build/cmake/modules/JasOpenGL.cmake
|
||||||
+++ src/appl/jiv.c 2019-09-18 14:49:59.512771783 -0500
|
--- a/build/cmake/modules/JasOpenGL.cmake 2020-10-07 10:00:16.316291325 +0200
|
||||||
@@ -68,7 +68,7 @@
|
+++ b/build/cmake/modules/JasOpenGL.cmake 2020-10-07 10:03:39.536143003 +0200
|
||||||
#include <math.h>
|
@@ -13,19 +13,19 @@ if (JAS_ENABLE_OPENGL AND OPENGL_FOUND)
|
||||||
#include <inttypes.h>
|
|
||||||
#if defined(JAS_HAVE_GL_GLUT_H)
|
|
||||||
-#include <GL/glut.h>
|
|
||||||
+#include <GL/freeglut.h>
|
|
||||||
#else
|
|
||||||
#include <glut.h>
|
|
||||||
#endif
|
|
||||||
--- CMakeLists.txt~ 2019-09-18 14:56:45.000000000 -0500
|
|
||||||
+++ CMakeLists.txt 2019-09-18 14:59:20.648018137 -0500
|
|
||||||
@@ -274,21 +274,21 @@
|
|
||||||
set(JAS_HAVE_OPENGL 0)
|
set(JAS_HAVE_OPENGL 0)
|
||||||
message("OpenGL include directory: ${OPENGL_INCLUDE_DIR}")
|
message("OpenGL include directory: ${OPENGL_INCLUDE_DIR}")
|
||||||
message("OpenGL libraries: ${OPENGL_LIBRARIES}")
|
message("OpenGL libraries: ${OPENGL_LIBRARIES}")
|
||||||
@ -30,8 +20,6 @@
|
|||||||
+ set(CMAKE_REQUIRED_INCLUDES ${FreeGLUT_INCLUDE_DIR})
|
+ set(CMAKE_REQUIRED_INCLUDES ${FreeGLUT_INCLUDE_DIR})
|
||||||
+ check_include_files(GL/freeglut.h JAS_HAVE_GL_GLUT_H)
|
+ check_include_files(GL/freeglut.h JAS_HAVE_GL_GLUT_H)
|
||||||
check_include_files(glut.h JAS_HAVE_GLUT_H)
|
check_include_files(glut.h JAS_HAVE_GLUT_H)
|
||||||
message("JAS_HAVE_GLUT_H: ${JAS_HAVE_GLUT_H}")
|
|
||||||
message("JAS_HAVE_GL_GLUT_H: ${JAS_HAVE_GL_GLUT_H}")
|
|
||||||
if (JAS_HAVE_GL_GLUT_H OR JAS_HAVE_GLUT_H)
|
if (JAS_HAVE_GL_GLUT_H OR JAS_HAVE_GLUT_H)
|
||||||
set(JAS_HAVE_OPENGL 1)
|
set(JAS_HAVE_OPENGL 1)
|
||||||
- include_directories(${GLUT_INCLUDE_DIR} ${OPENGL_INCLUDE_DIR})
|
- include_directories(${GLUT_INCLUDE_DIR} ${OPENGL_INCLUDE_DIR})
|
||||||
@ -42,7 +30,7 @@
|
|||||||
message(WARNING "Disabling OpenGL.")
|
message(WARNING "Disabling OpenGL.")
|
||||||
endif()
|
endif()
|
||||||
endif()
|
endif()
|
||||||
@@ -312,7 +312,7 @@
|
@@ -49,6 +49,6 @@ else()
|
||||||
set(JAS_HAVE_OPENGL 0)
|
set(JAS_HAVE_OPENGL 0)
|
||||||
set(OPENGL_INCLUDE_DIR "")
|
set(OPENGL_INCLUDE_DIR "")
|
||||||
set(OPENGL_LIBRARIES "")
|
set(OPENGL_LIBRARIES "")
|
||||||
@ -50,10 +38,10 @@
|
|||||||
+ set(FreeGLUT_INCLUDE_DIR "")
|
+ set(FreeGLUT_INCLUDE_DIR "")
|
||||||
set(GLUT_LIBRARIES "")
|
set(GLUT_LIBRARIES "")
|
||||||
endif()
|
endif()
|
||||||
message("JAS_HAVE_OPENGL: ${JAS_HAVE_OPENGL}")
|
diff -urNp a/src/appl/CMakeLists.txt b/src/appl/CMakeLists.txt
|
||||||
--- src/appl/CMakeLists.txt~ 2019-03-12 13:04:35.000000000 -0500
|
--- a/src/appl/CMakeLists.txt 2020-10-07 10:00:16.338291526 +0200
|
||||||
+++ src/appl/CMakeLists.txt 2019-09-23 08:42:35.326681243 -0500
|
+++ b/src/appl/CMakeLists.txt 2020-10-07 10:04:58.864872143 +0200
|
||||||
@@ -23,8 +23,8 @@
|
@@ -23,8 +23,8 @@ set(man_pages "${man_pages}" imgcmp.1)
|
||||||
if(JAS_HAVE_OPENGL)
|
if(JAS_HAVE_OPENGL)
|
||||||
add_executable(jiv jiv.c)
|
add_executable(jiv jiv.c)
|
||||||
target_include_directories(jiv PUBLIC
|
target_include_directories(jiv PUBLIC
|
||||||
@ -64,3 +52,15 @@
|
|||||||
${OPENGL_LIBRARIES} ${MATH_LIBRARY})
|
${OPENGL_LIBRARIES} ${MATH_LIBRARY})
|
||||||
set(programs "${programs}" jiv)
|
set(programs "${programs}" jiv)
|
||||||
set(man_pages "${man_pages}" jiv.1)
|
set(man_pages "${man_pages}" jiv.1)
|
||||||
|
diff -urNp a/src/appl/jiv.c b/src/appl/jiv.c
|
||||||
|
--- a/src/appl/jiv.c 2020-10-07 10:00:16.340291544 +0200
|
||||||
|
+++ b/src/appl/jiv.c 2020-10-07 10:05:35.319207658 +0200
|
||||||
|
@@ -68,7 +68,7 @@
|
||||||
|
#include <math.h>
|
||||||
|
#include <inttypes.h>
|
||||||
|
#if defined(JAS_HAVE_GL_GLUT_H)
|
||||||
|
-#include <GL/glut.h>
|
||||||
|
+#include <GL/freeglut.h>
|
||||||
|
#else
|
||||||
|
#include <glut.h>
|
||||||
|
#endif
|
||||||
|
12
jasper.spec
12
jasper.spec
@ -5,8 +5,8 @@
|
|||||||
|
|
||||||
Summary: Implementation of the JPEG-2000 standard, Part 1
|
Summary: Implementation of the JPEG-2000 standard, Part 1
|
||||||
Name: jasper
|
Name: jasper
|
||||||
Version: 2.0.17
|
Version: 2.0.22
|
||||||
Release: 3%{?dist}
|
Release: 1%{?dist}
|
||||||
|
|
||||||
License: JasPer
|
License: JasPer
|
||||||
URL: http://www.ece.uvic.ca/~frodo/jasper/
|
URL: http://www.ece.uvic.ca/~frodo/jasper/
|
||||||
@ -15,8 +15,6 @@ Source0: https://github.com/jasper-software/jasper/archive/version-%{version}.ta
|
|||||||
# skip hard-coded prefix/lib rpath
|
# skip hard-coded prefix/lib rpath
|
||||||
Patch2: jasper-2.0.14-rpath.patch
|
Patch2: jasper-2.0.14-rpath.patch
|
||||||
Patch3: jasper-freeglut.patch
|
Patch3: jasper-freeglut.patch
|
||||||
# add correct version
|
|
||||||
Patch4: jasper-2.0.17-version.patch
|
|
||||||
|
|
||||||
# architecture related patches
|
# architecture related patches
|
||||||
Patch100: jasper-2.0.2-test-ppc64-disable.patch
|
Patch100: jasper-2.0.2-test-ppc64-disable.patch
|
||||||
@ -68,8 +66,7 @@ Requires: %{name}-libs%{?_isa} = %{version}-%{release}
|
|||||||
%patch2 -p1 -b .rpath
|
%patch2 -p1 -b .rpath
|
||||||
# Need to disable one test to be able to build it on ppc64 arch
|
# Need to disable one test to be able to build it on ppc64 arch
|
||||||
# At ppc64 this test just stuck (nothing happend - no exception or error)
|
# At ppc64 this test just stuck (nothing happend - no exception or error)
|
||||||
%patch3 -p0 -b .freeglut
|
%patch3 -p1 -b .freeglut
|
||||||
%patch4 -p1 -b .version
|
|
||||||
|
|
||||||
%if "%{_arch}" == "ppc64"
|
%if "%{_arch}" == "ppc64"
|
||||||
%patch100 -p1 -b .test-ppc64-disable
|
%patch100 -p1 -b .test-ppc64-disable
|
||||||
@ -130,6 +127,9 @@ make test -C builder
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Oct 07 2020 Josef Ridky <jridky@redhat.com> - 2.0.22-1
|
||||||
|
- New upstream release 2.0.22 (#1876161)
|
||||||
|
|
||||||
* Thu Aug 27 2020 Than Ngo <than@redhat.com> - 2.0.17-3
|
* Thu Aug 27 2020 Than Ngo <than@redhat.com> - 2.0.17-3
|
||||||
- add correct version
|
- add correct version
|
||||||
|
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (version-2.0.17.tar.gz) = adbf8920602f6e81103e65001f3642c0d6f865a1673c8f7df1037d21190da91fd04cfaa563c3733bd8dc1a3485573c582c8047b667a1a92f57c4b72813e1b104
|
SHA512 (version-2.0.22.tar.gz) = 88fd1fb1dd3a3091a3f7d0cf4a5d50f42e60d2014d548364e064f1a1bde44d4b0a3f7b9c2699506305a1e97fbc81230afbe76ccb4305839f8a80176118a795c4
|
||||||
|
Loading…
Reference in New Issue
Block a user