- jasper-1.900.1
This commit is contained in:
parent
8a381b540f
commit
0d6a03598e
@ -2,3 +2,4 @@ clog
|
||||
geojasper_src.zip
|
||||
jasper-1.701.0.zip
|
||||
jasper-1.900.0.zip
|
||||
jasper-1.900.1.zip
|
||||
|
@ -1,28 +0,0 @@
|
||||
diff -ur jasper-1.701.0/src/libjasper/base/jas_stream.c jasper-1.701.0-local/src/libjasper/base/jas_stream.c
|
||||
--- jasper-1.701.0/src/libjasper/base/jas_stream.c 2004-02-09 07:04:40.000000000 +0530
|
||||
+++ jasper-1.701.0-local/src/libjasper/base/jas_stream.c 2005-10-23 02:08:06.145589016 +0530
|
||||
@@ -361,11 +361,11 @@
|
||||
}
|
||||
obj->fd = -1;
|
||||
obj->flags = 0;
|
||||
- obj->pathname[0] = '\0';
|
||||
+ strncpy(obj->pathname, "jasXXXXXX", sizeof(obj->pathname));
|
||||
stream->obj_ = obj;
|
||||
|
||||
/* Choose a file name. */
|
||||
- tmpnam(obj->pathname);
|
||||
+ mkstemp(obj->pathname);
|
||||
|
||||
/* Open the underlying file. */
|
||||
if ((obj->fd = open(obj->pathname, O_CREAT | O_EXCL | O_RDWR | O_TRUNC | O_BINARY,
|
||||
diff -ur jasper-1.701.0/src/libjasper/jpg/jpg_enc.c jasper-1.701.0-local/src/libjasper/jpg/jpg_enc.c
|
||||
--- jasper-1.701.0/src/libjasper/jpg/jpg_enc.c 2004-02-09 07:04:41.000000000 +0530
|
||||
+++ jasper-1.701.0-local/src/libjasper/jpg/jpg_enc.c 2005-10-23 02:09:02.526017888 +0530
|
||||
@@ -331,6 +331,7 @@
|
||||
rewind(output_file);
|
||||
jpg_copyfiletostream(out, output_file);
|
||||
fclose(output_file);
|
||||
+ jas_matrix_destroy(src_mgr->data);
|
||||
output_file = 0;
|
||||
|
||||
return 0;
|
13
jasper.spec
13
jasper.spec
@ -10,8 +10,8 @@
|
||||
Summary: Implementation of the JPEG-2000 standard, Part 1
|
||||
Name: jasper
|
||||
Group: System Environment/Libraries
|
||||
Version: 1.900.0
|
||||
Release: 3%{?dist}
|
||||
Version: 1.900.1
|
||||
Release: 1%{?dist}
|
||||
|
||||
License: JasPer License Version 2.0
|
||||
%if "%{?geo:1}" == "1"
|
||||
@ -28,11 +28,6 @@ BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
Patch1: jasper-1.701.0-GL.patch
|
||||
# autoconf/automake bits of patch1
|
||||
Patch2: jasper-1.701.0-GL-ac.patch
|
||||
# memory leak, see
|
||||
# http://gyachi.sourceforge.net/download.shtml
|
||||
# http://ayttm.sourceforge.net/files.shtml
|
||||
# http://ayttm.sourceforge.net/jasper-memory-leak-1.701.0.patch.gz
|
||||
Patch3: jasper-1.701.0-memory_leak.patch
|
||||
|
||||
BuildRequires: automake
|
||||
BuildRequires: libjpeg-devel
|
||||
@ -57,7 +52,6 @@ Requires: libjpeg-devel
|
||||
%setup -q -n %{name}-%{version}%{?geo:.GEO}
|
||||
|
||||
%patch1 -p1 -b .GL
|
||||
#patch3 -p1 -b .memleak
|
||||
|
||||
%if "%{?geo:1}" == "1"
|
||||
chmod +x configure configure.ac
|
||||
@ -121,6 +115,9 @@ rm -rf $RPM_BUILD_ROOT
|
||||
|
||||
|
||||
%changelog
|
||||
* Thu Mar 29 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 1.900.1-1
|
||||
- jasper-1.900.1
|
||||
|
||||
* Fri Dec 08 2006 Rex Dieter <rexdieter[AT]users.sf.net> 1.900.0-3
|
||||
- omit deprecated memleak patch
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user