cleanup cmake usage, move to %build
%build: explicitly disable doc generation kill hard-coded rpath -libs: explicit soname so bumps aren't a surprise use %license, %make_build, 'make install/fast'
This commit is contained in:
parent
b9d8750bd1
commit
0d5229d4c3
12
jasper-2.0.14-rpath.patch
Normal file
12
jasper-2.0.14-rpath.patch
Normal file
@ -0,0 +1,12 @@
|
|||||||
|
diff -up jasper-2.0.14/CMakeLists.txt.rpath jasper-2.0.14/CMakeLists.txt
|
||||||
|
--- jasper-2.0.14/CMakeLists.txt.rpath 2017-09-14 18:20:10.000000000 -0500
|
||||||
|
+++ jasper-2.0.14/CMakeLists.txt 2018-07-19 09:48:53.035815377 -0500
|
||||||
|
@@ -347,7 +347,7 @@ if (JAS_ENABLE_SHARED)
|
||||||
|
# (but later on when installing)
|
||||||
|
set(CMAKE_BUILD_WITH_INSTALL_RPATH FALSE)
|
||||||
|
|
||||||
|
- set(CMAKE_INSTALL_RPATH "${CMAKE_INSTALL_PREFIX}/lib")
|
||||||
|
+ #set(CMAKE_INSTALL_RPATH "${CMAKE_INSTALL_PREFIX}/lib")
|
||||||
|
|
||||||
|
# add the automatically determined parts of the RPATH
|
||||||
|
# which point to directories outside the build tree to the install RPATH
|
47
jasper.spec
47
jasper.spec
@ -6,13 +6,15 @@
|
|||||||
Summary: Implementation of the JPEG-2000 standard, Part 1
|
Summary: Implementation of the JPEG-2000 standard, Part 1
|
||||||
Name: jasper
|
Name: jasper
|
||||||
Version: 2.0.14
|
Version: 2.0.14
|
||||||
Release: 6%{?dist}
|
Release: 7%{?dist}
|
||||||
|
|
||||||
License: JasPer
|
License: JasPer
|
||||||
URL: http://www.ece.uvic.ca/~frodo/jasper/
|
URL: http://www.ece.uvic.ca/~frodo/jasper/
|
||||||
Source0: http://www.ece.uvic.ca/~frodo/jasper/software/jasper-%{version}.tar.gz
|
Source0: http://www.ece.uvic.ca/~frodo/jasper/software/jasper-%{version}.tar.gz
|
||||||
|
|
||||||
Patch1: jasper-2.0.14-CVE-2016-9396.patch
|
Patch1: jasper-2.0.14-CVE-2016-9396.patch
|
||||||
|
# skip hard-coded prefix/lib rpath
|
||||||
|
Patch2: jasper-2.0.14-rpath.patch
|
||||||
# architecture related patches
|
# architecture related patches
|
||||||
Patch100: jasper-2.0.2-test-ppc64-disable.patch
|
Patch100: jasper-2.0.2-test-ppc64-disable.patch
|
||||||
Patch101: jasper-2.0.2-test-ppc64le-disable.patch
|
Patch101: jasper-2.0.2-test-ppc64le-disable.patch
|
||||||
@ -61,6 +63,7 @@ Requires: %{name}-libs%{?_isa} = %{version}-%{release}
|
|||||||
%setup -q -n %{name}-%{version}
|
%setup -q -n %{name}-%{version}
|
||||||
|
|
||||||
%patch1 -p1 -b .CVE-2016-9396
|
%patch1 -p1 -b .CVE-2016-9396
|
||||||
|
%patch2 -p1 -b .rpath
|
||||||
# Need to disable one test to be able to build it on ppc64 arch
|
# Need to disable one test to be able to build it on ppc64 arch
|
||||||
# At ppc64 this test just stuck (nothing happend - no exception or error)
|
# At ppc64 this test just stuck (nothing happend - no exception or error)
|
||||||
|
|
||||||
@ -76,41 +79,29 @@ Requires: %{name}-libs%{?_isa} = %{version}-%{release}
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
|
|
||||||
mkdir -p builder
|
|
||||||
|
|
||||||
%cmake -G "Unix Makefiles" \
|
|
||||||
-H%{_builddir}/%{name}-%{version} \
|
|
||||||
-B%{_builddir}/%{name}-%{version}/builder
|
|
||||||
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
|
mkdir builder
|
||||||
pushd builder
|
pushd builder
|
||||||
make clean all
|
%cmake .. \
|
||||||
|
-DJAS_ENABLE_DOC:BOOL=OFF
|
||||||
popd
|
popd
|
||||||
|
|
||||||
%install
|
%make_build -C builder
|
||||||
pushd builder
|
|
||||||
make install DESTDIR=%{buildroot}
|
|
||||||
|
|
||||||
#%if "%{_arch}" != "arm" && "%{_arch}" != "i386"
|
|
||||||
# mv %{buildroot}/usr/lib %{buildroot}/usr/lib64
|
%install
|
||||||
#%endif
|
make install/fast DESTDIR=%{buildroot} -C builder
|
||||||
|
|
||||||
# Unpackaged files
|
# Unpackaged files
|
||||||
rm -f doc/README
|
rm -f doc/README
|
||||||
rm -f %{buildroot}%{_libdir}/lib*.la
|
rm -f %{buildroot}%{_libdir}/lib*.la
|
||||||
popd
|
|
||||||
|
|
||||||
%check
|
%check
|
||||||
pushd builder
|
make test -C builder
|
||||||
make test
|
|
||||||
|
|
||||||
popd
|
|
||||||
|
|
||||||
%ldconfig_scriptlets libs
|
%ldconfig_scriptlets libs
|
||||||
|
|
||||||
|
|
||||||
%files
|
%files
|
||||||
%{_bindir}/imgcmp
|
%{_bindir}/imgcmp
|
||||||
%{_bindir}/imginfo
|
%{_bindir}/imginfo
|
||||||
@ -126,8 +117,9 @@ popd
|
|||||||
%{_libdir}/pkgconfig/jasper.pc
|
%{_libdir}/pkgconfig/jasper.pc
|
||||||
|
|
||||||
%files libs
|
%files libs
|
||||||
%doc COPYRIGHT LICENSE README
|
%doc README
|
||||||
%{_libdir}/libjasper.so*
|
%license COPYRIGHT LICENSE
|
||||||
|
%{_libdir}/libjasper.so.4*
|
||||||
|
|
||||||
%files utils
|
%files utils
|
||||||
%{_bindir}/jiv
|
%{_bindir}/jiv
|
||||||
@ -135,6 +127,13 @@ popd
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Jul 19 2018 Rex Dieter <rdieter@fedoraproject.org> - 2.0.14-7
|
||||||
|
- cleanup cmake usage, move to %%build
|
||||||
|
- %%build: explicitly disable doc generation
|
||||||
|
- kill hard-coded rpath
|
||||||
|
- -libs: explicit soname so bumps aren't a surprise
|
||||||
|
- use %%license, %%make_build, 'make install/fast'
|
||||||
|
|
||||||
* Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 2.0.14-6
|
* Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 2.0.14-6
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user