Install in /sbin

This commit is contained in:
John W. Linville 2009-10-01 18:50:37 +00:00
parent 3265cce81a
commit b42c256682
2 changed files with 52 additions and 5 deletions

View File

@ -0,0 +1,42 @@
From f8a9dbbbde041fca098b579c3669819e8282577a Mon Sep 17 00:00:00 2001
From: John W. Linville <linville@tuxdriver.com>
Date: Wed, 30 Sep 2009 09:17:39 -0400
Subject: [iw PATCH] default install to $(PREFIX)/sbin
The iw utility isn't generally useful to normal users, so move it to
$(PREFIX)/sbin with other system management executables.
Signed-off-by: John W. Linville <linville@tuxdriver.com>
---
As "suggested" by Johannes... :-)
Makefile | 6 +++---
1 files changed, 3 insertions(+), 3 deletions(-)
diff --git a/Makefile b/Makefile
index cb5fcc1..68bef4d 100644
--- a/Makefile
+++ b/Makefile
@@ -3,7 +3,7 @@
MAKEFLAGS += --no-print-directory
PREFIX ?= /usr
-BINDIR ?= $(PREFIX)/bin
+SBINDIR ?= $(PREFIX)/sbin
MANDIR ?= $(PREFIX)/share/man
PKG_CONFIG ?= pkg-config
@@ -85,8 +85,8 @@ check:
install: iw iw.8.gz
@$(NQ) ' INST iw'
- $(Q)$(MKDIR) $(DESTDIR)$(BINDIR)
- $(Q)$(INSTALL) -m 755 -t $(DESTDIR)$(BINDIR) iw
+ $(Q)$(MKDIR) $(DESTDIR)$(SBINDIR)
+ $(Q)$(INSTALL) -m 755 -t $(DESTDIR)$(SBINDIR) iw
@$(NQ) ' INST iw.8'
$(Q)$(MKDIR) $(DESTDIR)$(MANDIR)/man8/
$(Q)$(INSTALL) -m 644 -t $(DESTDIR)$(MANDIR)/man8/ iw.8.gz
--
1.6.2.5

15
iw.spec
View File

@ -1,6 +1,6 @@
Name: iw
Version: 0.9.17
Release: 2%{?dist}
Release: 3%{?dist}
Summary: A nl80211 based wireless configuration tool
Group: System Environment/Base
@ -13,7 +13,8 @@ BuildRequires: kernel-devel >= 2.6.24
BuildRequires: libnl-devel >= 1.0
BuildRequires: pkgconfig
Patch0: iw-avoid-section-type-conflict-on-ppc64.patch
Patch0: iw-default-install-to-PREFIX-sbin.patch
Patch1: iw-avoid-section-type-conflict-on-ppc64.patch
%description
iw is a new nl80211 based CLI configuration utility for wireless devices.
@ -23,7 +24,8 @@ only because most new wireless devices being sold are now SoftMAC.
%prep
%setup -q
%patch0 -p1 -R
%patch0 -p1
%patch1 -p1 -R
%build
@ -32,7 +34,7 @@ make %{?_smp_mflags} CFLAGS="$RPM_OPT_FLAGS"
%install
rm -rf $RPM_BUILD_ROOT
make install DESTDIR=$RPM_BUILD_ROOT
make install DESTDIR=$RPM_BUILD_ROOT PREFIX='' MANDIR=%{_mandir}
%clean
@ -41,11 +43,14 @@ rm -rf $RPM_BUILD_ROOT
%files
%defattr(-,root,root,-)
%{_bindir}/%{name}
/sbin/%{name}
%{_datadir}/man/man8/iw.*
%doc COPYING
%changelog
* Thu Oct 1 2009 John W. Linville <linville@redhat.com> 0.9.17-3
- Install in /sbin
* Fri Sep 4 2009 John W. Linville <linville@redhat.com> 0.9.17-2
- Revert "separate commands into sections", section type conflicts on ppc64