Fix segfaults resulting from incorrect memory management.
This commit is contained in:
parent
3d50023dc6
commit
9b7b361695
48
fix-segfaults.patch
Normal file
48
fix-segfaults.patch
Normal file
@ -0,0 +1,48 @@
|
|||||||
|
diff --git a/itstool.in b/itstool.in
|
||||||
|
index c1d0585..a16eba9 100755
|
||||||
|
--- a/itstool.in
|
||||||
|
+++ b/itstool.in
|
||||||
|
@@ -477,6 +477,7 @@ class Document (object):
|
||||||
|
if load_dtd:
|
||||||
|
ctxt.loadSubset(1)
|
||||||
|
if keep_entities:
|
||||||
|
+ ctxt.loadSubset(1)
|
||||||
|
ctxt.ctxtUseOptions(libxml2.XML_PARSE_DTDLOAD)
|
||||||
|
ctxt.replaceEntities(0)
|
||||||
|
else:
|
||||||
|
@@ -1043,6 +1044,7 @@ class Document (object):
|
||||||
|
if self._load_dtd:
|
||||||
|
ctxt.loadSubset(1)
|
||||||
|
if self._keep_entities:
|
||||||
|
+ ctxt.loadSubset(1)
|
||||||
|
ctxt.ctxtUseOptions(libxml2.XML_PARSE_DTDLOAD)
|
||||||
|
ctxt.replaceEntities(0)
|
||||||
|
else:
|
||||||
|
@@ -1069,7 +1071,9 @@ class Document (object):
|
||||||
|
ph_node = msg.get_placeholder(child.name).node
|
||||||
|
if self.has_child_elements(ph_node):
|
||||||
|
self.merge_translations(translations, None, ph_node, strict=strict)
|
||||||
|
- child.replaceNode(ph_node)
|
||||||
|
+ newnode = ph_node.copyNode(1)
|
||||||
|
+ newnode.setTreeDoc(self._doc)
|
||||||
|
+ child.replaceNode(newnode)
|
||||||
|
else:
|
||||||
|
repl = self.get_translated(ph_node, translations, strict=strict, lang=lang)
|
||||||
|
child.replaceNode(repl)
|
||||||
|
@@ -1084,10 +1088,15 @@ class Document (object):
|
||||||
|
(lang + ' ') if lang is not None else '',
|
||||||
|
msgstr.encode('utf-8')))
|
||||||
|
self._xml_err = ''
|
||||||
|
+ ctxt.doc().freeDoc()
|
||||||
|
return node
|
||||||
|
retnode = node.copyNode(2)
|
||||||
|
+ retnode.setTreeDoc(self._doc)
|
||||||
|
for child in xml_child_iter(trnode):
|
||||||
|
- retnode.addChild(child.copyNode(1))
|
||||||
|
+ newnode = child.copyNode(1)
|
||||||
|
+ newnode.setTreeDoc(self._doc)
|
||||||
|
+ retnode.addChild(newnode)
|
||||||
|
+
|
||||||
|
ctxt.doc().freeDoc()
|
||||||
|
return retnode
|
||||||
|
|
10
itstool.spec
10
itstool.spec
@ -1,11 +1,15 @@
|
|||||||
Name: itstool
|
Name: itstool
|
||||||
Version: 2.0.4
|
Version: 2.0.4
|
||||||
Release: 3%{?dist}
|
Release: 4%{?dist}
|
||||||
Summary: ITS-based XML translation tool
|
Summary: ITS-based XML translation tool
|
||||||
|
|
||||||
License: GPLv3+
|
License: GPLv3+
|
||||||
URL: http://itstool.org/
|
URL: http://itstool.org/
|
||||||
Source0: http://files.itstool.org/itstool/%{name}-%{version}.tar.bz2
|
Source0: http://files.itstool.org/itstool/%{name}-%{version}.tar.bz2
|
||||||
|
# An issue with libxml2 is causing segfaults for packages using
|
||||||
|
# itstool. Backported the workaround from upstream.
|
||||||
|
# https://github.com/itstool/itstool/commit/9b84c007a73e8275ca45762f1bfa3ab7c3a852e2
|
||||||
|
Patch0: fix-segfaults.patch
|
||||||
|
|
||||||
BuildArch: noarch
|
BuildArch: noarch
|
||||||
|
|
||||||
@ -20,6 +24,7 @@ how to separate it into PO file messages.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
|
%patch0 -p1
|
||||||
|
|
||||||
%build
|
%build
|
||||||
export PYTHON=%{__python3}
|
export PYTHON=%{__python3}
|
||||||
@ -37,6 +42,9 @@ make install DESTDIR=$RPM_BUILD_ROOT
|
|||||||
%doc %{_mandir}/man1/itstool.1.gz
|
%doc %{_mandir}/man1/itstool.1.gz
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Jul 16 2018 Charalampos Stratakis <cstratak@redhat.com> - 2.0.4-4
|
||||||
|
- Fix libxml2 related segfaults
|
||||||
|
|
||||||
* Mon Jul 16 2018 Miro Hrončok <mhroncok@redhat.com> - 2.0.4-3
|
* Mon Jul 16 2018 Miro Hrončok <mhroncok@redhat.com> - 2.0.4-3
|
||||||
- Switch to Python 3
|
- Switch to Python 3
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user