- Don't put DESTDIR in the isomd5sum.pc file
- New Version 1.2.2 (bcl) - Fix aligned alloc parameters and overflow on 32bit size_t (#1497458) (squimrel) - Fix memory leak (squimrel) - Add pkgconfig file (squimrel) - Remove line-breaks from error messages (squimrel) - Make library C++ compatible (squimrel) - Constify function signatures (squimrel) - Revert checkCallback function signature (squimrel)
This commit is contained in:
parent
be0ab80539
commit
caf7ff1e39
1
.gitignore
vendored
1
.gitignore
vendored
@ -4,3 +4,4 @@
|
|||||||
/1.1.0.tar.gz
|
/1.1.0.tar.gz
|
||||||
/1.2.0.tar.gz
|
/1.2.0.tar.gz
|
||||||
/1.2.1.tar.gz
|
/1.2.1.tar.gz
|
||||||
|
/1.2.2.tar.gz
|
||||||
|
25
0001-Don-t-put-DESTDIR-in-the-isomd5sum.pc-file.patch
Normal file
25
0001-Don-t-put-DESTDIR-in-the-isomd5sum.pc-file.patch
Normal file
@ -0,0 +1,25 @@
|
|||||||
|
From 8d80e470944bf10fff8645d0dd4a5860124f282d Mon Sep 17 00:00:00 2001
|
||||||
|
From: "Brian C. Lane" <bcl@redhat.com>
|
||||||
|
Date: Tue, 3 Oct 2017 12:13:31 -0700
|
||||||
|
Subject: [PATCH] Don't put DESTDIR in the isomd5sum.pc file
|
||||||
|
|
||||||
|
---
|
||||||
|
Makefile | 2 +-
|
||||||
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||||
|
|
||||||
|
diff --git a/Makefile b/Makefile
|
||||||
|
index c8ea9b6..6edda1b 100644
|
||||||
|
--- a/Makefile
|
||||||
|
+++ b/Makefile
|
||||||
|
@@ -58,7 +58,7 @@ install-devel:
|
||||||
|
install -m 0644 libcheckisomd5.h $(DESTDIR)/usr/include/
|
||||||
|
install -m 0644 libimplantisomd5.a $(DESTDIR)/usr/$(LIBDIR)
|
||||||
|
install -m 0644 libcheckisomd5.a $(DESTDIR)/usr/$(LIBDIR)
|
||||||
|
- sed "s#@VERSION@#${VERSION}#g; s#@includedir@#${DESTDIR}/usr/include#g; s#@libdir@#${DESTDIR}/usr/${LIBDIR}#g" isomd5sum.pc.in > ${DESTDIR}/usr/share/pkgconfig/isomd5sum.pc
|
||||||
|
+ sed "s#@VERSION@#${VERSION}#g; s#@includedir@#/usr/include#g; s#@libdir@#/usr/${LIBDIR}#g" isomd5sum.pc.in > ${DESTDIR}/usr/share/pkgconfig/isomd5sum.pc
|
||||||
|
|
||||||
|
clean:
|
||||||
|
rm -f *.o *.so *.pyc *.a .depend *~
|
||||||
|
--
|
||||||
|
2.13.5
|
||||||
|
|
@ -1,7 +1,7 @@
|
|||||||
Summary: Utilities for working with md5sum implanted in ISO images
|
Summary: Utilities for working with md5sum implanted in ISO images
|
||||||
Name: isomd5sum
|
Name: isomd5sum
|
||||||
Version: 1.2.1
|
Version: 1.2.2
|
||||||
Release: 4%{?dist}
|
Release: 1%{?dist}
|
||||||
Epoch: 1
|
Epoch: 1
|
||||||
License: GPLv2+
|
License: GPLv2+
|
||||||
Group: Applications/System
|
Group: Applications/System
|
||||||
@ -9,6 +9,8 @@ Group: Applications/System
|
|||||||
Url: https://github.com/rhinstaller/isomd5sum
|
Url: https://github.com/rhinstaller/isomd5sum
|
||||||
Source0: https://github.com/rhinstaller/%{name}/archive/%{version}.tar.gz
|
Source0: https://github.com/rhinstaller/%{name}/archive/%{version}.tar.gz
|
||||||
|
|
||||||
|
Patch0: 0001-Don-t-put-DESTDIR-in-the-isomd5sum.pc-file.patch
|
||||||
|
|
||||||
BuildRequires: popt-devel
|
BuildRequires: popt-devel
|
||||||
BuildRequires: python2-devel python3-devel
|
BuildRequires: python2-devel python3-devel
|
||||||
|
|
||||||
@ -43,7 +45,7 @@ an md5sum implanted into an ISO9660 image.
|
|||||||
|
|
||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%autosetup
|
||||||
|
|
||||||
rm -rf %{py3dir}
|
rm -rf %{py3dir}
|
||||||
cp -a . %{py3dir}
|
cp -a . %{py3dir}
|
||||||
@ -72,6 +74,7 @@ popd
|
|||||||
%files devel
|
%files devel
|
||||||
%{_includedir}/*.h
|
%{_includedir}/*.h
|
||||||
%{_libdir}/*.a
|
%{_libdir}/*.a
|
||||||
|
/usr/share/pkgconfig/isomd5sum.pc
|
||||||
|
|
||||||
%files -n python2-isomd5sum
|
%files -n python2-isomd5sum
|
||||||
%{python2_sitearch}/pyisomd5sum.so
|
%{python2_sitearch}/pyisomd5sum.so
|
||||||
@ -80,6 +83,17 @@ popd
|
|||||||
%{python3_sitearch}/pyisomd5sum.so
|
%{python3_sitearch}/pyisomd5sum.so
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Oct 03 2017 Brian C. Lane <bcl@redhat.com> - 1:1.2.2-1
|
||||||
|
- Don't put DESTDIR in the isomd5sum.pc file
|
||||||
|
- New Version 1.2.2 (bcl)
|
||||||
|
- Fix aligned alloc parameters and overflow on 32bit size_t (#1497458) (squimrel)
|
||||||
|
- Fix memory leak (squimrel)
|
||||||
|
- Add pkgconfig file (squimrel)
|
||||||
|
- Remove line-breaks from error messages (squimrel)
|
||||||
|
- Make library C++ compatible (squimrel)
|
||||||
|
- Constify function signatures (squimrel)
|
||||||
|
- Revert checkCallback function signature (squimrel)
|
||||||
|
|
||||||
* Sat Aug 19 2017 Zbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl> - 1:1.2.1-4
|
* Sat Aug 19 2017 Zbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl> - 1:1.2.1-4
|
||||||
- Python 2 binary package renamed to python2-isomd5sum
|
- Python 2 binary package renamed to python2-isomd5sum
|
||||||
See https://fedoraproject.org/wiki/FinalizingFedoraSwitchtoPython3
|
See https://fedoraproject.org/wiki/FinalizingFedoraSwitchtoPython3
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (1.2.1.tar.gz) = 8ad4b3db4a5e1c13445fa7e30f74b594a023410d0b5bc6d018eeaab250b5756bd644f9f72c27841bb9068b3472ae125baa1a2d8b474e0e2ba4177a5c04df66b3
|
SHA512 (1.2.2.tar.gz) = a92305c996151f6e806327305918720eb584cf16cd5a1fa3ab8eec8d2594f351a69db7c8770359c561f49097e8c068608ce88e174bcb80449b3c5e79086fa860
|
||||||
|
Loading…
Reference in New Issue
Block a user