- Don't install the unused python module (#479005)
This commit is contained in:
parent
5cfbc47c91
commit
3196ea0731
@ -1 +1 @@
|
|||||||
isomd5sum-1.0.4.tar.bz2
|
isomd5sum-1.0.5.tar.bz2
|
||||||
|
@ -1,14 +0,0 @@
|
|||||||
diff -up isomd5sum-1.0.4/Makefile.orig isomd5sum-1.0.4/Makefile
|
|
||||||
--- isomd5sum-1.0.4/Makefile.orig 2008-11-05 15:12:05.000000000 +0100
|
|
||||||
+++ isomd5sum-1.0.4/Makefile 2008-11-05 15:16:25.000000000 +0100
|
|
||||||
@@ -41,8 +41,8 @@ install: all
|
|
||||||
mkdir -p $(DESTDIR)/usr/share/man/man1
|
|
||||||
install -m 755 implantisomd5 $(DESTDIR)/usr/bin
|
|
||||||
install -m 755 checkisomd5 $(DESTDIR)/usr/bin
|
|
||||||
- install -m 755 implantisomd5.1 $(DESTDIR)/usr/share/man/man1
|
|
||||||
- install -m 755 checkisomd5.1 $(DESTDIR)/usr/share/man/man1
|
|
||||||
+ install -m 644 implantisomd5.1 $(DESTDIR)/usr/share/man/man1
|
|
||||||
+ install -m 644 checkisomd5.1 $(DESTDIR)/usr/share/man/man1
|
|
||||||
install -m 755 pyisomd5sum.so $(DESTDIR)/usr/$(LIBDIR)/$(PYTHON)/site-packages
|
|
||||||
# ln -s ../../bin/implantisomd5 $(DESTDIR)/usr/lib/anaconda-runtime/implantisomd5
|
|
||||||
# ln -s ../../bin/checkisomd5 $(DESTDIR)/usr/lib/anaconda-runtime/checkisomd5
|
|
@ -1,11 +0,0 @@
|
|||||||
--- isomd5sum-1.0.4/Makefile.BAD 2008-04-24 07:33:17.000000000 -0500
|
|
||||||
+++ isomd5sum-1.0.4/Makefile 2008-04-24 07:33:49.000000000 -0500
|
|
||||||
@@ -2,7 +2,7 @@
|
|
||||||
PYTHON = python$(PYVER)
|
|
||||||
PYTHONINCLUDE = /usr/include/$(PYTHON)
|
|
||||||
|
|
||||||
-ifneq (,$(filter ppc64 x86_64 s390x,$(shell uname -m)))
|
|
||||||
+ifneq (,$(filter ppc64 x86_64 s390x sparc64,$(shell uname -m)))
|
|
||||||
LIBDIR = lib64
|
|
||||||
else
|
|
||||||
LIBDIR = lib
|
|
@ -1,18 +1,14 @@
|
|||||||
%{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
|
|
||||||
|
|
||||||
Summary: Utilities for working with md5sum implanted in ISO images
|
Summary: Utilities for working with md5sum implanted in ISO images
|
||||||
Name: isomd5sum
|
Name: isomd5sum
|
||||||
Version: 1.0.4
|
Version: 1.0.5
|
||||||
Release: 4%{?dist}
|
Release: 1%{?dist}
|
||||||
Epoch: 1
|
Epoch: 1
|
||||||
License: GPLv2+
|
License: GPLv2+
|
||||||
Group: Applications/System
|
Group: Applications/System
|
||||||
URL: http://git.fedorahosted.org/git/?p=isomd5sum.git;a=summary
|
URL: http://git.fedorahosted.org/git/?p=isomd5sum.git;a=summary
|
||||||
Source0: http://fedorahosted.org/releases/i/s/isomd5sum/%{name}-%{version}.tar.bz2
|
Source0: http://fedorahosted.org/releases/i/s/isomd5sum/%{name}-%{version}.tar.bz2
|
||||||
Patch0: isomd5sum-1.0.4-sparc64.patch
|
|
||||||
Patch1: isomd5sum-1.0.4-manpage-permissions.patch
|
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
|
||||||
BuildRequires: python-devel popt-devel
|
BuildRequires: popt-devel
|
||||||
|
|
||||||
%description
|
%description
|
||||||
The isomd5sum package contains utilities for implanting and verifying
|
The isomd5sum package contains utilities for implanting and verifying
|
||||||
@ -30,15 +26,13 @@ implanting and checking.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
%patch0 -p1
|
|
||||||
%patch1 -p1
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
make
|
make checkisomd5 implantisomd5
|
||||||
|
|
||||||
%install
|
%install
|
||||||
rm -rf $RPM_BUILD_ROOT
|
rm -rf $RPM_BUILD_ROOT
|
||||||
make DESTDIR=$RPM_BUILD_ROOT install
|
make DESTDIR=$RPM_BUILD_ROOT install-bin install-devel
|
||||||
|
|
||||||
%clean
|
%clean
|
||||||
rm -rf $RPM_BUILD_ROOT
|
rm -rf $RPM_BUILD_ROOT
|
||||||
@ -50,7 +44,6 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
/usr/bin/implantisomd5
|
/usr/bin/implantisomd5
|
||||||
/usr/bin/checkisomd5
|
/usr/bin/checkisomd5
|
||||||
%{_mandir}/man*/*
|
%{_mandir}/man*/*
|
||||||
%{python_sitearch}/pyisomd5sum.so
|
|
||||||
|
|
||||||
%files devel
|
%files devel
|
||||||
%defattr(-,root,root,-)
|
%defattr(-,root,root,-)
|
||||||
@ -58,6 +51,9 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%{_libdir}/*.a
|
%{_libdir}/*.a
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Jan 8 2009 Jeremy Katz <katzj@redhat.com> - 1:1.0.5-1
|
||||||
|
- Don't install the unused python module (#479005)
|
||||||
|
|
||||||
* Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 1:1.0.4-4
|
* Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 1:1.0.4-4
|
||||||
- Rebuild for Python 2.6
|
- Rebuild for Python 2.6
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user