import isns-utils-0.99-1.el8
This commit is contained in:
parent
da0a368ec2
commit
b340069a1f
2
.gitignore
vendored
2
.gitignore
vendored
@ -1 +1 @@
|
|||||||
SOURCES/open-isns-0.97.tar.gz
|
SOURCES/open-isns-0.99.tar.gz
|
||||||
|
@ -1 +1 @@
|
|||||||
1973761a319e83c8872a87bc4b46de8755339ae7 SOURCES/open-isns-0.97.tar.gz
|
4302dfdc450d9a55266986033481f0fa5bc4492e SOURCES/open-isns-0.99.tar.gz
|
||||||
|
25
SOURCES/fix-openssl-argument-order-in-tests.patch
Normal file
25
SOURCES/fix-openssl-argument-order-in-tests.patch
Normal file
@ -0,0 +1,25 @@
|
|||||||
|
From 65aae761c6d1e73b1cd3c05b40b5a70ee0eb67b7 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Chris Leech <cleech@redhat.com>
|
||||||
|
Date: Fri, 22 Mar 2019 16:12:41 -0700
|
||||||
|
Subject: [PATCH 1/1] fix openssl argument order in tests
|
||||||
|
|
||||||
|
---
|
||||||
|
tests/genkey | 2 +-
|
||||||
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||||
|
|
||||||
|
diff --git a/tests/genkey b/tests/genkey
|
||||||
|
index 36c5eeee56a5..2351a65dedf4 100755
|
||||||
|
--- a/tests/genkey
|
||||||
|
+++ b/tests/genkey
|
||||||
|
@@ -123,7 +123,7 @@ if [ ! -r $dsa_parms ]; then
|
||||||
|
EOF
|
||||||
|
|
||||||
|
mkdir -p `dirname $dsa_parms`
|
||||||
|
- openssl dsaparam $dsa_bits -out $dsa_parms ||
|
||||||
|
+ openssl dsaparam -out $dsa_parms $dsa_bits ||
|
||||||
|
exit 1
|
||||||
|
|
||||||
|
# DSA parameters are public
|
||||||
|
--
|
||||||
|
2.17.2
|
||||||
|
|
@ -1,9 +0,0 @@
|
|||||||
[Unit]
|
|
||||||
Description=ISNS Server
|
|
||||||
After=network.target
|
|
||||||
|
|
||||||
[Service]
|
|
||||||
ExecStart=/usr/sbin/isnsd -f
|
|
||||||
|
|
||||||
[Install]
|
|
||||||
WantedBy=multi-user.target
|
|
27
SOURCES/test_as_installed.patch
Normal file
27
SOURCES/test_as_installed.patch
Normal file
@ -0,0 +1,27 @@
|
|||||||
|
diff --git a/tests/Makefile b/tests/Makefile
|
||||||
|
index 5b7884f319e0..f4ec3428d29b 100644
|
||||||
|
--- a/tests/Makefile
|
||||||
|
+++ b/tests/Makefile
|
||||||
|
@@ -43,3 +43,8 @@ tests-no-security:
|
||||||
|
@for test in test*.pl; do \
|
||||||
|
perl $$test -i -q; \
|
||||||
|
done
|
||||||
|
+
|
||||||
|
+tests-as-installed:
|
||||||
|
+ @for test in test*.pl; do \
|
||||||
|
+ perl $$test -q --path="/usr/sbin/"; \
|
||||||
|
+ done
|
||||||
|
diff --git a/tests/harness.pl b/tests/harness.pl
|
||||||
|
index 7ed4fa09f5b6..fc7f937a3ca0 100755
|
||||||
|
--- a/tests/harness.pl
|
||||||
|
+++ b/tests/harness.pl
|
||||||
|
@@ -858,7 +858,8 @@ sub __isns_prep_test {
|
||||||
|
GetOptions('verbose+' => \$__isns_verbose,
|
||||||
|
"quiet" => \$__isns_quiet,
|
||||||
|
"fast" => \$__isns_quick,
|
||||||
|
- "insecure" => \$__isns_insecure);
|
||||||
|
+ "insecure" => \$__isns_insecure,
|
||||||
|
+ "path=s" => \$__isns_bin);
|
||||||
|
$__isns_verbose = 0 if ($__isns_quiet);
|
||||||
|
$__isns_security = 0 if ($__isns_insecure);
|
||||||
|
|
@ -1,13 +1,14 @@
|
|||||||
Name: isns-utils
|
Name: isns-utils
|
||||||
Version: 0.97
|
Version: 0.99
|
||||||
Release: 6%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: The iSNS daemon and utility programs
|
Summary: The iSNS daemon and utility programs
|
||||||
|
|
||||||
Group: System Environment/Daemons
|
Group: System Environment/Daemons
|
||||||
License: LGPLv2+
|
License: LGPLv2+
|
||||||
URL: https://github.com/open-iscsi/open-isns
|
URL: https://github.com/open-iscsi/open-isns
|
||||||
Source0: https://github.com/open-iscsi/open-isns/archive/v%{version}.tar.gz#/open-isns-%{version}.tar.gz
|
Source0: https://github.com/open-iscsi/open-isns/archive/v%{version}.tar.gz#/open-isns-%{version}.tar.gz
|
||||||
Source1: isnsd.service
|
Patch1: fix-openssl-argument-order-in-tests.patch
|
||||||
|
Patch2: test_as_installed.patch
|
||||||
|
|
||||||
BuildRequires: openssl-devel automake pkgconfig systemd-devel systemd
|
BuildRequires: openssl-devel automake pkgconfig systemd-devel systemd
|
||||||
Requires(post): systemd-units
|
Requires(post): systemd-units
|
||||||
@ -38,7 +39,7 @@ Development files for iSNS
|
|||||||
|
|
||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q -n open-isns-%{version}
|
%autosetup -n open-isns-%{version} -p1
|
||||||
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
@ -52,21 +53,18 @@ make install_hdrs DESTDIR=%{buildroot}
|
|||||||
make install_lib DESTDIR=%{buildroot}
|
make install_lib DESTDIR=%{buildroot}
|
||||||
chmod 755 %{buildroot}%{_sbindir}/isns*
|
chmod 755 %{buildroot}%{_sbindir}/isns*
|
||||||
chmod 755 %{buildroot}%{_libdir}/libisns.so.0
|
chmod 755 %{buildroot}%{_libdir}/libisns.so.0
|
||||||
rm %{buildroot}%{_unitdir}/isnsd.service
|
|
||||||
rm %{buildroot}%{_unitdir}/isnsd.socket
|
|
||||||
install -p -m 644 %{SOURCE1} %{buildroot}%{_unitdir}/isnsd.service
|
|
||||||
|
|
||||||
|
|
||||||
%post
|
%post
|
||||||
%systemd_post isnsd.service
|
%systemd_post isnsd.service isnsd.socket
|
||||||
|
|
||||||
|
|
||||||
%postun
|
%postun
|
||||||
%systemd_postun isnsd.service
|
%systemd_postun isnsd.service isnsd.socket
|
||||||
|
|
||||||
|
|
||||||
%preun
|
%preun
|
||||||
%systemd_preun isnsd.service
|
%systemd_preun isnsd.service isnsd.socket
|
||||||
|
|
||||||
|
|
||||||
%triggerun -- isns-utils < 0.91-7
|
%triggerun -- isns-utils < 0.91-7
|
||||||
@ -94,6 +92,7 @@ install -p -m 644 %{SOURCE1} %{buildroot}%{_unitdir}/isnsd.service
|
|||||||
%{_mandir}/man5/*
|
%{_mandir}/man5/*
|
||||||
%{_mandir}/man8/*
|
%{_mandir}/man8/*
|
||||||
%{_unitdir}/isnsd.service
|
%{_unitdir}/isnsd.service
|
||||||
|
%{_unitdir}/isnsd.socket
|
||||||
%dir %{_sysconfdir}/isns
|
%dir %{_sysconfdir}/isns
|
||||||
%dir %{_var}/lib/isns
|
%dir %{_var}/lib/isns
|
||||||
%config(noreplace) %{_sysconfdir}/isns/*
|
%config(noreplace) %{_sysconfdir}/isns/*
|
||||||
@ -110,6 +109,9 @@ install -p -m 644 %{SOURCE1} %{buildroot}%{_unitdir}/isnsd.service
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Mar 22 2019 Chris Leech <cleech@redhat.com> - 0.99-1
|
||||||
|
- rebase to 0.99
|
||||||
|
|
||||||
* Wed Feb 07 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.97-6
|
* Wed Feb 07 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.97-6
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user