restore gating test boilerplate

Copied over from el9 branch
disable security tests
iSNS security has been disabled as it relies on outdated crypto

Resolves: RHEL-70744

Signed-off-by: Chris Leech <cleech@redhat.com>
This commit is contained in:
Chris Leech 2024-12-13 11:19:35 -08:00
parent eb41cdba6f
commit 7efbbd7573
4 changed files with 75 additions and 1 deletions

6
gating.yaml Normal file
View File

@ -0,0 +1,6 @@
--- !Policy
product_versions:
- rhel-10
decision_context: osci_compose_gate
rules:
- !PassingTestCaseRule {test_case_name: osci.brew-build.tier0.functional}

View File

@ -1,12 +1,13 @@
Name: isns-utils
Version: 0.101
Release: 12%{?dist}
Release: 13%{?dist}
Summary: The iSNS daemon and utility programs
License: LGPL-2.1-or-later
URL: https://github.com/open-iscsi/open-isns
Source0: https://github.com/open-iscsi/open-isns/archive/v%{version}.tar.gz#/open-isns-%{version}.tar.gz
Source1: isnsd.service
Patch1: test_as_installed.patch
BuildRequires: gcc
BuildRequires: openssl-devel automake pkgconfig systemd-devel systemd

47
test_as_installed.patch Normal file
View File

@ -0,0 +1,47 @@
From 420ae1af11fad3151b5bfa676e7218168e4e6f3f Mon Sep 17 00:00:00 2001
From: Chris Leech <cleech@redhat.com>
Date: Wed, 26 May 2021 10:00:17 -0700
Subject: [PATCH 1/1] run tests with binaries from arbitrary paths
---
tests/Makefile | 4 ++++
tests/harness.py | 4 ++++
2 files changed, 8 insertions(+)
diff --git a/tests/Makefile b/tests/Makefile
index 372572d..2c61183 100644
--- a/tests/Makefile
+++ b/tests/Makefile
@@ -48,3 +48,7 @@ quick: tests-no-security
tests-no-security:
@echo running tests without security -- takes about 2 minutes
./test-isns.py
+
+tests-as-installed:
+ @echo running tests from installed executables -- takes about 2 minutes
+ ./test-isns.py --path="/usr/sbin"
diff --git a/tests/harness.py b/tests/harness.py
index 39fc5e6..b710f5a 100644
--- a/tests/harness.py
+++ b/tests/harness.py
@@ -137,6 +137,9 @@ def new_initArgParsers(self):
self._main_parser.add_argument('-d', '--debug', dest='debug',
action='store_true',
help='Enable developer debugging')
+ self._main_parser.add_argument('--path', dest='path',
+ action='store', default='..',
+ help='Set isns bin path, to run from installed executables')
def new_parseArgs(self, argv):
"""
@@ -148,6 +151,7 @@ def new_parseArgs(self, argv):
Global.verbosity = self.verbosity
Global.security = self.security
Global.debug = self.debug
+ Global._isns_bin_dir = self.path
dprint("found: verbosity=%d, security=%s" % \
(Global.verbosity, Global.security))
--
2.31.1

20
tests/tests.yml Normal file
View File

@ -0,0 +1,20 @@
---
- hosts: localhost
roles:
- role: standard-test-source
tags:
- always
- role: standard-test-basic
tags:
- classic
required_packages:
- make
- python3
- isns-utils
- openssl
tests:
- smoke:
dir: ./source/tests/
run: make tests-as-installed