New version
- Dropped init-resize-crash-fix (upstreamed) - Fixed bogus date in changelog (best effort) - Disabled unloading static modules (by no-static-unload patch)
This commit is contained in:
parent
263e372c68
commit
e616c4c47e
1
.gitignore
vendored
1
.gitignore
vendored
@ -1 +1,2 @@
|
||||
irssi-0.8.15.tar.bz2
|
||||
/irssi-0.8.16-rc1.tar.bz2
|
||||
|
@ -1,13 +0,0 @@
|
||||
diff -up irssi-0.8.15/src/fe-text/irssi.c.old irssi-0.8.15/src/fe-text/irssi.c
|
||||
diff -up irssi-0.8.15/src/fe-text/mainwindows.c.old irssi-0.8.15/src/fe-text/mainwindows.c
|
||||
--- irssi-0.8.15/src/fe-text/mainwindows.c.old 2010-04-03 18:19:42.000000000 +0200
|
||||
+++ irssi-0.8.15/src/fe-text/mainwindows.c 2012-02-24 10:47:51.215293213 +0100
|
||||
@@ -355,7 +355,7 @@ static void mainwindows_resize_smaller(i
|
||||
int space;
|
||||
|
||||
sorted = mainwindows_get_sorted(TRUE);
|
||||
- for (;;) {
|
||||
+ for (;sorted != NULL;) {
|
||||
space = 0;
|
||||
for (tmp = mainwindows; tmp != NULL; tmp = tmp->next) {
|
||||
rec = tmp->data;
|
35
irssi-0.8.15-no-static-unload.patch
Normal file
35
irssi-0.8.15-no-static-unload.patch
Normal file
@ -0,0 +1,35 @@
|
||||
--- irssi-0.8.15/src/fe-common/core/fe-modules.c.old 2010-04-03 18:19:24.000000000 +0200
|
||||
+++ irssi-0.8.15/src/fe-common/core/fe-modules.c 2010-10-12 14:43:52.586315553 +0200
|
||||
@@ -195,6 +195,8 @@
|
||||
MODULE_FILE_REC *file;
|
||||
char *rootmodule, *submodule;
|
||||
void *free_arg;
|
||||
+ GSList *tmp;
|
||||
+ int all_dynamic;
|
||||
|
||||
g_return_if_fail(data != NULL);
|
||||
|
||||
@@ -204,12 +206,19 @@
|
||||
|
||||
module = module_find(rootmodule);
|
||||
if (module != NULL) {
|
||||
- if (*submodule == '\0')
|
||||
- module_unload(module);
|
||||
+ if (*submodule == '\0') {
|
||||
+ all_dynamic = 1;
|
||||
+ for (tmp = module->files; tmp != NULL; tmp = tmp->next)
|
||||
+ all_dynamic &= !MODULE_IS_STATIC((MODULE_FILE_REC*) tmp->data);
|
||||
+ if (all_dynamic)
|
||||
+ module_unload(module);
|
||||
+ }
|
||||
else {
|
||||
file = module_file_find(module, submodule);
|
||||
- if (file != NULL)
|
||||
- module_file_unload(file);
|
||||
+ if (file != NULL) {
|
||||
+ if (!MODULE_IS_STATIC(file))
|
||||
+ module_file_unload(file);
|
||||
+ }
|
||||
else
|
||||
module = NULL;
|
||||
}
|
23
irssi.spec
23
irssi.spec
@ -1,17 +1,18 @@
|
||||
%define perl_vendorarch %(eval "`perl -V:installvendorarch`"; echo $installvendorarch)
|
||||
|
||||
%global pretag rc1
|
||||
|
||||
Summary: Modular text mode IRC client with Perl scripting
|
||||
Name: irssi
|
||||
Version: 0.8.15
|
||||
Release: 15%{?dist}
|
||||
Version: 0.8.16
|
||||
Release: 0.1%{?pretag:.%{pretag}}%{?dist}
|
||||
|
||||
License: GPLv2+
|
||||
Group: Applications/Communications
|
||||
URL: http://irssi.org/
|
||||
Source0: http://irssi.org/files/irssi-%{version}.tar.bz2
|
||||
Source0: http://irssi.org/files/irssi-%{version}%{?pretag:-%{pretag}}.tar.bz2
|
||||
Source1: irssi-config.h
|
||||
# Bug 796457
|
||||
Patch0: irssi-0.8.15-init-resize-crash-fix.patch
|
||||
Patch0: irssi-0.8.15-no-static-unload.patch
|
||||
Patch1: irssi-0.8.15-man-fix.patch
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
|
||||
BuildRequires: ncurses-devel openssl-devel zlib-devel
|
||||
@ -38,8 +39,8 @@ being maintained.
|
||||
|
||||
|
||||
%prep
|
||||
%setup -q -n %{name}-%{version}
|
||||
%patch0 -p1 -b .init-resize-crash-fix
|
||||
%setup -q -n %{name}-%{version}%{?pretag:-%{?pretag}}
|
||||
%patch0 -p1 -b .no-static-unload
|
||||
%patch1 -p1 -b .man-fix
|
||||
|
||||
%build
|
||||
@ -91,6 +92,12 @@ rm -rf $RPM_BUILD_ROOT
|
||||
|
||||
|
||||
%changelog
|
||||
* Mon Sep 16 2013 Jaroslav Škarvada <jskarvad@redhat.com> - 0.8.16-0.1.rc1
|
||||
- New version
|
||||
- Dropped init-resize-crash-fix (upstreamed)
|
||||
- Fixed bogus date in changelog (best effort)
|
||||
- Disabled unloading static modules (by no-static-unload patch)
|
||||
|
||||
* Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8.15-15
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
|
||||
|
||||
@ -238,7 +245,7 @@ rm -rf $RPM_BUILD_ROOT
|
||||
* Mon Apr 11 2005 Michael Schwendt <mschwendt[AT]users.sf.net> 0.8.9-7
|
||||
- Two patches to fix build for GCC4 and new Perl with config.h.
|
||||
|
||||
* Fri Apr 7 2005 Michael Schwendt <mschwendt[AT]users.sf.net>
|
||||
* Thu Apr 7 2005 Michael Schwendt <mschwendt[AT]users.sf.net>
|
||||
- rebuilt
|
||||
|
||||
* Fri Dec 24 2004 Michael Schwendt <mschwendt[AT]users.sf.net> 0:0.8.9-5
|
||||
|
Loading…
Reference in New Issue
Block a user