irssi/devel: 0.8.11
This commit is contained in:
parent
25b9524c9d
commit
e30cc29e9e
@ -1 +1,2 @@
|
||||
irssi-0.8.10a.tar.bz2
|
||||
irssi-0.8.11.tar.bz2
|
||||
|
@ -1,14 +0,0 @@
|
||||
--- src/irc/dcc/dcc.c 2006-04-25 01:06:44.000000000 -0500
|
||||
+++ src/irc/dcc/dcc.c 2006-04-25 01:30:52.000000000 -0500
|
||||
@@ -58,8 +58,9 @@
|
||||
|
||||
pos = gslist_find_string(dcc_types, type);
|
||||
if (pos != NULL) {
|
||||
- dcc_types = g_slist_remove(dcc_types, pos->data);
|
||||
- g_free(pos->data);
|
||||
+ gchar *data = pos->data;
|
||||
+ dcc_types = g_slist_remove(dcc_types, pos->data);
|
||||
+ g_free(data);
|
||||
}
|
||||
}
|
||||
|
12
irssi.spec
12
irssi.spec
@ -2,14 +2,13 @@
|
||||
|
||||
Summary: Modular text mode IRC client with Perl scripting
|
||||
Name: irssi
|
||||
Version: 0.8.10
|
||||
Release: 7.a%{?dist}
|
||||
Version: 0.8.11
|
||||
Release: 1%{?dist}
|
||||
|
||||
License: GPL
|
||||
Group: Applications/Communications
|
||||
URL: http://irssi.org/
|
||||
Source0: http://irssi.org/files/irssi-%{version}a.tar.bz2
|
||||
Patch0: irssi-0.8.10-dcc-unregister.patch
|
||||
Source0: http://irssi.org/files/irssi-%{version}.tar.bz2
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
|
||||
BuildRequires: ncurses-devel openssl-devel zlib-devel
|
||||
BuildRequires: pkgconfig glib2-devel
|
||||
@ -37,7 +36,6 @@ being maintained.
|
||||
|
||||
%prep
|
||||
%setup -q -n %{name}-%{version}
|
||||
%patch0 -p0
|
||||
|
||||
%build
|
||||
%configure --enable-ipv6 --with-textui \
|
||||
@ -85,6 +83,10 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%{_includedir}/irssi
|
||||
|
||||
%changelog
|
||||
* Wed May 2 2007 Dams <anvil[AT]livna.org> - 0.8.11-1
|
||||
- Updated to 0.8.11
|
||||
- Dropped patch0
|
||||
|
||||
* Sat Apr 21 2007 Dams <anvil[AT]livna.org> - 0.8.10-7.a
|
||||
- Release bump
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user