Update to 1.2.3
This commit is contained in:
parent
5878efa946
commit
e19ad3a9f9
@ -1,38 +0,0 @@
|
||||
From a0544571a80196e5b7705f56e6e2cbcdf7b4d80e Mon Sep 17 00:00:00 2001
|
||||
From: ailin-nemui <ailin-nemui@users.noreply.github.com>
|
||||
Date: Thu, 23 Apr 2020 21:45:15 +0200
|
||||
Subject: [PATCH] manually handle NUL unicode in g_utf8_get_next_char_validated
|
||||
|
||||
A change in GLib 2.63 broke some assumptions in Irssi that the null-byte
|
||||
NUL / U+0000 is a valid Unicode character. This would occur when the
|
||||
user types Ctrl+Space. As a result, the input loop never manages to
|
||||
process the NUL-byte (and any other user input that follows, ever).
|
||||
|
||||
This patch adds a manual check that properly advances the input loop if
|
||||
GLib returns -2 (incomplete character) despite the length being positive
|
||||
and a NUL is in first position.
|
||||
|
||||
Fixes #1180
|
||||
https://gitlab.gnome.org/GNOME/glib/-/merge_requests/967
|
||||
https://gitlab.gnome.org/GNOME/glib/-/issues/2093
|
||||
---
|
||||
src/fe-text/term-terminfo.c | 6 +++++-
|
||||
1 file changed, 5 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/src/fe-text/term-terminfo.c b/src/fe-text/term-terminfo.c
|
||||
index 5235f72d2..78496a64f 100644
|
||||
--- a/src/fe-text/term-terminfo.c
|
||||
+++ b/src/fe-text/term-terminfo.c
|
||||
@@ -672,7 +672,11 @@ void term_stop(void)
|
||||
|
||||
static int input_utf8(const unsigned char *buffer, int size, unichar *result)
|
||||
{
|
||||
- unichar c = g_utf8_get_char_validated((char *)buffer, size);
|
||||
+ unichar c = g_utf8_get_char_validated((char *) buffer, size);
|
||||
+
|
||||
+ /* GLib >= 2.63 do not accept Unicode NUL anymore */
|
||||
+ if (c == (unichar) -2 && *buffer == 0 && size > 0)
|
||||
+ c = 0;
|
||||
|
||||
switch (c) {
|
||||
case (unichar)-1:
|
10
irssi.spec
10
irssi.spec
@ -2,8 +2,8 @@
|
||||
|
||||
Summary: Modular text mode IRC client with Perl scripting
|
||||
Name: irssi
|
||||
Version: 1.2.2
|
||||
Release: 8%{?dist}
|
||||
Version: 1.2.3
|
||||
Release: 1%{?dist}
|
||||
|
||||
License: GPLv2+
|
||||
URL: http://irssi.org/
|
||||
@ -21,8 +21,6 @@ Requires: perl(Symbol)
|
||||
|
||||
# rhbz#1773190
|
||||
Obsoletes: irc-otr
|
||||
# https://github.com/irssi/irssi/pull/1183
|
||||
Patch: irssi-1.2.2-ctrl-space-fix.patch
|
||||
|
||||
%package devel
|
||||
Summary: Development package for irssi
|
||||
@ -43,7 +41,6 @@ being maintained.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1 -b .ctrl-space-fix
|
||||
|
||||
|
||||
%build
|
||||
@ -92,6 +89,9 @@ chmod -R u+w $RPM_BUILD_ROOT%{perl_vendorarch}
|
||||
|
||||
|
||||
%changelog
|
||||
* Sun Apr 11 2021 Kalev Lember <klember@redhat.com> - 1.2.3-1
|
||||
- Update to 1.2.3
|
||||
|
||||
* Tue Jan 26 2021 Fedora Release Engineering <releng@fedoraproject.org> - 1.2.2-8
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (irssi-1.2.2.tar.xz) = 5444ac102ff9ad3a6399a47c967d138e181330dd226eac68886d35fee4ad455932b9306a367bee3478095158e41ba67fb46deb8f0a33512046b9b83bae37c610
|
||||
SHA512 (irssi-1.2.3.tar.xz) = 826b7bfd86a54647f2d344b6c461e1118b7382fb1637cf33c395af41a9a4ca5d8a794a415f0f0737178968cf2463bb46a0e7b7fd7014c968668b16183e0644bc
|
||||
|
Loading…
Reference in New Issue
Block a user