New version
Resolves: rhbz#1107342 - Dropped format-security patch (not needed)
This commit is contained in:
parent
480c0db0d7
commit
e164cdc819
1
.gitignore
vendored
1
.gitignore
vendored
@ -1,2 +1,3 @@
|
|||||||
irssi-0.8.15.tar.bz2
|
irssi-0.8.15.tar.bz2
|
||||||
/irssi-0.8.16-rc1.tar.bz2
|
/irssi-0.8.16-rc1.tar.bz2
|
||||||
|
/irssi-0.8.16.tar.bz2
|
||||||
|
@ -1,22 +0,0 @@
|
|||||||
diff --git a/src/core/network.c b/src/core/network.c
|
|
||||||
index d7c1017..5954d1f 100644
|
|
||||||
--- a/src/core/network.c
|
|
||||||
+++ b/src/core/network.c
|
|
||||||
@@ -356,7 +356,7 @@ int net_receive(GIOChannel *handle, char *buf, int len)
|
|
||||||
|
|
||||||
status = g_io_channel_read_chars(handle, buf, len, &ret, &err);
|
|
||||||
if (err != NULL) {
|
|
||||||
- g_warning(err->message);
|
|
||||||
+ g_warning("%s", err->message);
|
|
||||||
g_error_free(err);
|
|
||||||
}
|
|
||||||
if (status == G_IO_STATUS_ERROR || status == G_IO_STATUS_EOF)
|
|
||||||
@@ -377,7 +377,7 @@ int net_transmit(GIOChannel *handle, const char *data, int len)
|
|
||||||
|
|
||||||
status = g_io_channel_write_chars(handle, (char *) data, len, &ret, &err);
|
|
||||||
if (err != NULL) {
|
|
||||||
- g_warning(err->message);
|
|
||||||
+ g_warning("%s", err->message);
|
|
||||||
g_error_free(err);
|
|
||||||
}
|
|
||||||
if (status == G_IO_STATUS_ERROR)
|
|
15
irssi.spec
15
irssi.spec
@ -1,20 +1,17 @@
|
|||||||
%define perl_vendorarch %(eval "`perl -V:installvendorarch`"; echo $installvendorarch)
|
%define perl_vendorarch %(eval "`perl -V:installvendorarch`"; echo $installvendorarch)
|
||||||
|
|
||||||
%global pretag rc1
|
|
||||||
|
|
||||||
Summary: Modular text mode IRC client with Perl scripting
|
Summary: Modular text mode IRC client with Perl scripting
|
||||||
Name: irssi
|
Name: irssi
|
||||||
Version: 0.8.16
|
Version: 0.8.16
|
||||||
Release: 0.4%{?pretag:.%{pretag}}%{?dist}
|
Release: 1%{?dist}
|
||||||
|
|
||||||
License: GPLv2+
|
License: GPLv2+
|
||||||
Group: Applications/Communications
|
Group: Applications/Communications
|
||||||
URL: http://irssi.org/
|
URL: http://irssi.org/
|
||||||
Source0: http://irssi.org/files/irssi-%{version}%{?pretag:-%{pretag}}.tar.bz2
|
Source0: http://irssi.org/files/irssi-%{version}.tar.bz2
|
||||||
Source1: irssi-config.h
|
Source1: irssi-config.h
|
||||||
Patch0: irssi-0.8.15-no-static-unload.patch
|
Patch0: irssi-0.8.15-no-static-unload.patch
|
||||||
Patch1: irssi-0.8.15-man-fix.patch
|
Patch1: irssi-0.8.15-man-fix.patch
|
||||||
Patch2: irssi-0.8.16-format-security.patch
|
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
|
||||||
BuildRequires: ncurses-devel openssl-devel zlib-devel
|
BuildRequires: ncurses-devel openssl-devel zlib-devel
|
||||||
BuildRequires: pkgconfig glib2-devel perl-devel perl(ExtUtils::Embed)
|
BuildRequires: pkgconfig glib2-devel perl-devel perl(ExtUtils::Embed)
|
||||||
@ -40,10 +37,9 @@ being maintained.
|
|||||||
|
|
||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q -n %{name}-%{version}%{?pretag:-%{?pretag}}
|
%setup -q
|
||||||
%patch0 -p1 -b .no-static-unload
|
%patch0 -p1 -b .no-static-unload
|
||||||
%patch1 -p1 -b .man-fix
|
%patch1 -p1 -b .man-fix
|
||||||
%patch2 -p1 -b .format-security
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
autoreconf -i
|
autoreconf -i
|
||||||
@ -94,6 +90,11 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Jun 10 2014 Jaroslav Škarvada <jskarvad@redhat.com> - 0.8.16-1
|
||||||
|
- New version
|
||||||
|
Resolves: rhbz#1107342
|
||||||
|
- Dropped format-security patch (not needed)
|
||||||
|
|
||||||
* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8.16-0.4.rc1
|
* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8.16-0.4.rc1
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user