New version
Resolves: rhbz#2095992
This commit is contained in:
parent
66fa97c21e
commit
df7d643fe1
43
irssi-1.4.1-botti-perl-link-fix.patch
Normal file
43
irssi-1.4.1-botti-perl-link-fix.patch
Normal file
@ -0,0 +1,43 @@
|
|||||||
|
diff --git a/configure.ac b/configure.ac
|
||||||
|
index f03569e..53a9de6 100644
|
||||||
|
--- a/configure.ac
|
||||||
|
+++ b/configure.ac
|
||||||
|
@@ -650,6 +650,7 @@ for c in $CHAT_MODULES; do
|
||||||
|
done
|
||||||
|
|
||||||
|
FE_COMMON_LIBS="$FE_COMMON_LIBS../fe-common/core/libfe_common_core.a"
|
||||||
|
+AC_SUBST(FE_COMMON_LIBS)
|
||||||
|
|
||||||
|
dnl ** common libraries needed by frontends
|
||||||
|
COMMON_NOUI_LIBS="$CHAT_LIBS $CORE_LIBS"
|
||||||
|
diff --git a/src/fe-none/Makefile.am b/src/fe-none/Makefile.am
|
||||||
|
index bbcd63f..e8ce8d6 100644
|
||||||
|
--- a/src/fe-none/Makefile.am
|
||||||
|
+++ b/src/fe-none/Makefile.am
|
||||||
|
@@ -4,12 +4,13 @@ AM_CPPFLAGS = \
|
||||||
|
-I$(top_builddir) \
|
||||||
|
$(GLIB_CFLAGS)
|
||||||
|
|
||||||
|
-botti_DEPENDENCIES = @COMMON_NOUI_LIBS@
|
||||||
|
+botti_DEPENDENCIES = @COMMON_NOUI_LIBS@ @FE_COMMON_LIBS@
|
||||||
|
|
||||||
|
botti_LDADD = \
|
||||||
|
@COMMON_NOUI_LIBS@ \
|
||||||
|
@PERL_LINK_LIBS@ \
|
||||||
|
@PERL_LINK_FLAGS@ \
|
||||||
|
+ @FE_COMMON_LIBS@ \
|
||||||
|
@PROG_LIBS@
|
||||||
|
|
||||||
|
botti_SOURCES = \
|
||||||
|
diff --git a/src/fe-none/meson.build b/src/fe-none/meson.build
|
||||||
|
index 58df15f..8e32b94 100644
|
||||||
|
--- a/src/fe-none/meson.build
|
||||||
|
+++ b/src/fe-none/meson.build
|
||||||
|
@@ -11,6 +11,7 @@ executable('botti',
|
||||||
|
libconfig_a,
|
||||||
|
libcore_a,
|
||||||
|
libirc_a,
|
||||||
|
+ libfe_common_core_a,
|
||||||
|
],
|
||||||
|
install : true,
|
||||||
|
dependencies : dep
|
42
irssi.spec
42
irssi.spec
@ -2,8 +2,8 @@
|
|||||||
|
|
||||||
Summary: Modular text mode IRC client with Perl scripting
|
Summary: Modular text mode IRC client with Perl scripting
|
||||||
Name: irssi
|
Name: irssi
|
||||||
Version: 1.2.3
|
Version: 1.4.1
|
||||||
Release: 6%{?dist}
|
Release: 1%{?dist}
|
||||||
|
|
||||||
License: GPLv2+
|
License: GPLv2+
|
||||||
URL: http://irssi.org/
|
URL: http://irssi.org/
|
||||||
@ -11,18 +11,31 @@ Source0: https://github.com/%{name}/%{name}/releases/download/%{version}/%{name}
|
|||||||
Source1: irssi-config.h
|
Source1: irssi-config.h
|
||||||
|
|
||||||
BuildRequires: make
|
BuildRequires: make
|
||||||
BuildRequires: ncurses-devel openssl-devel zlib-devel
|
BuildRequires: ncurses-devel
|
||||||
BuildRequires: pkgconfig glib2-devel perl-devel perl-generators perl(ExtUtils::Embed)
|
BuildRequires: openssl-devel
|
||||||
BuildRequires: autoconf automake libtool utf8proc-devel libotr-devel
|
BuildRequires: zlib-devel
|
||||||
|
BuildRequires: pkgconf-pkg-config
|
||||||
|
BuildRequires: glib2-devel
|
||||||
|
BuildRequires: perl-devel
|
||||||
|
BuildRequires: perl-generators
|
||||||
|
BuildRequires: perl(ExtUtils::Embed)
|
||||||
|
BuildRequires: autoconf
|
||||||
|
BuildRequires: automake
|
||||||
|
BuildRequires: libtool
|
||||||
|
BuildRequires: utf8proc-devel
|
||||||
|
BuildRequires: libotr-devel
|
||||||
|
|
||||||
Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
|
Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
|
||||||
Requires: perl(lib)
|
Requires: perl(lib)
|
||||||
Requires: perl(Symbol)
|
Requires: perl(Symbol)
|
||||||
|
# https://github.com/irssi/irssi/issues/1374
|
||||||
|
Patch0: irssi-1.4.1-botti-perl-link-fix.patch
|
||||||
|
|
||||||
|
|
||||||
%package devel
|
%package devel
|
||||||
Summary: Development package for irssi
|
Summary: Development package for irssi
|
||||||
Requires: %{name} = %{version}-%{release}
|
Requires: %{name} = %{version}-%{release}
|
||||||
|
Requires: pkgconf-pkg-config
|
||||||
|
|
||||||
%description
|
%description
|
||||||
Irssi is a modular IRC client with Perl scripting. Only text-mode
|
Irssi is a modular IRC client with Perl scripting. Only text-mode
|
||||||
@ -38,38 +51,36 @@ being maintained.
|
|||||||
|
|
||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%autosetup -p1
|
||||||
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
autoreconf -i
|
autoreconf -fi
|
||||||
%configure --with-textui \
|
%configure --with-textui \
|
||||||
--with-proxy \
|
--with-proxy \
|
||||||
--with-bot \
|
--with-bot \
|
||||||
--with-perl=yes \
|
--with-perl=module \
|
||||||
--with-perl-lib=vendor \
|
--with-perl-lib=vendor \
|
||||||
--enable-true-color \
|
--enable-true-color \
|
||||||
--with-otr=yes
|
--with-otr=yes
|
||||||
|
|
||||||
make %{_smp_mflags} CFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing"
|
%make_build CFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing"
|
||||||
mv irssi-config.h irssi-config-$(getconf LONG_BIT).h
|
mv irssi-config.h irssi-config-$(getconf LONG_BIT).h
|
||||||
cp -p %{SOURCE1} irssi-config.h
|
cp -p %{SOURCE1} irssi-config.h
|
||||||
|
|
||||||
|
|
||||||
%install
|
%install
|
||||||
rm -rf $RPM_BUILD_ROOT
|
%make_install
|
||||||
%makeinstall PERL_INSTALL_ROOT=$RPM_BUILD_ROOT INSTALL="%{__install} -p"
|
|
||||||
install -p irssi-config-$(getconf LONG_BIT).h $RPM_BUILD_ROOT%{_includedir}/%{name}/irssi-config-$(getconf LONG_BIT).h
|
install -p irssi-config-$(getconf LONG_BIT).h $RPM_BUILD_ROOT%{_includedir}/%{name}/irssi-config-$(getconf LONG_BIT).h
|
||||||
|
|
||||||
rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/modules/lib*.*a
|
rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/modules/lib*.*a
|
||||||
rm -Rf $RPM_BUILD_ROOT/%{_docdir}/%{name}
|
rm -Rf $RPM_BUILD_ROOT/%{_docdir}/%{name}
|
||||||
|
rm -f $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod
|
||||||
find $RPM_BUILD_ROOT%{perl_vendorarch} -type f -a -name '*.bs' -a -empty -exec rm -f {} ';'
|
find $RPM_BUILD_ROOT%{perl_vendorarch} -type f -a -name '*.bs' -a -empty -exec rm -f {} ';'
|
||||||
find $RPM_BUILD_ROOT%{perl_vendorarch} -type f -a -name .packlist -exec rm {} ';'
|
find $RPM_BUILD_ROOT%{perl_vendorarch} -type f -a -name .packlist -exec rm {} ';'
|
||||||
chmod -R u+w $RPM_BUILD_ROOT%{perl_vendorarch}
|
chmod -R u+w $RPM_BUILD_ROOT%{perl_vendorarch}
|
||||||
|
|
||||||
|
|
||||||
|
|
||||||
|
|
||||||
%files
|
%files
|
||||||
%doc docs/*.txt docs/*.html AUTHORS COPYING NEWS README.md TODO
|
%doc docs/*.txt docs/*.html AUTHORS COPYING NEWS README.md TODO
|
||||||
%config(noreplace) %{_sysconfdir}/%{name}.conf
|
%config(noreplace) %{_sysconfdir}/%{name}.conf
|
||||||
@ -84,9 +95,14 @@ chmod -R u+w $RPM_BUILD_ROOT%{perl_vendorarch}
|
|||||||
|
|
||||||
%files devel
|
%files devel
|
||||||
%{_includedir}/irssi/
|
%{_includedir}/irssi/
|
||||||
|
%{_libdir}/pkgconfig/irssi-1.pc
|
||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Jun 14 2022 Jaroslav Škarvada <jskarvad@redhat.com> - 1.4.1-1
|
||||||
|
- New version
|
||||||
|
Resolves: rhbz#2095992
|
||||||
|
|
||||||
* Mon May 30 2022 Jitka Plesnikova <jplesnik@redhat.com> - 1.2.3-6
|
* Mon May 30 2022 Jitka Plesnikova <jplesnik@redhat.com> - 1.2.3-6
|
||||||
- Perl 5.36 rebuild
|
- Perl 5.36 rebuild
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user