irssi/devel: 0.8.10rc7
This commit is contained in:
parent
013e8d0332
commit
bc141cf149
@ -1 +1 @@
|
|||||||
irssi-0.8.9.tar.bz2
|
irssi-0.8.10-rc7.tar.gz
|
||||||
|
@ -1,12 +0,0 @@
|
|||||||
diff -Nur irssi-0.8.9-orig/src/perl/ui/Formats.xs irssi-0.8.9/src/perl/ui/Formats.xs
|
|
||||||
--- irssi-0.8.9-orig/src/perl/ui/Formats.xs 2003-01-25 04:30:02.000000000 +0100
|
|
||||||
+++ irssi-0.8.9/src/perl/ui/Formats.xs 2005-04-11 23:18:40.000000000 +0200
|
|
||||||
@@ -3,7 +3,7 @@
|
|
||||||
static int magic_free_text_dest(pTHX_ SV *sv, MAGIC *mg)
|
|
||||||
{
|
|
||||||
TEXT_DEST_REC *dest = (TEXT_DEST_REC *) mg->mg_ptr;
|
|
||||||
- g_free((char *) dest->target);
|
|
||||||
+ g_free(dest->target);
|
|
||||||
g_free(dest);
|
|
||||||
mg->mg_ptr = NULL;
|
|
||||||
sv_setiv(sv, 0);
|
|
@ -1,12 +0,0 @@
|
|||||||
diff -Nur irssi-0.8.9-orig/src/common.h irssi-0.8.9/src/common.h
|
|
||||||
--- irssi-0.8.9-orig/src/common.h 2002-12-10 18:45:02.000000000 +0100
|
|
||||||
+++ irssi-0.8.9/src/common.h 2005-04-11 23:15:59.000000000 +0200
|
|
||||||
@@ -14,7 +14,7 @@
|
|
||||||
#define DEFAULT_SERVER_ADD_PORT 6667
|
|
||||||
|
|
||||||
#ifdef HAVE_CONFIG_H
|
|
||||||
-#include "config.h"
|
|
||||||
+#include "../config.h"
|
|
||||||
#endif
|
|
||||||
|
|
||||||
#include <stdio.h>
|
|
40
irssi.spec
40
irssi.spec
@ -1,45 +1,51 @@
|
|||||||
%define perl_vendorarch %(eval "`perl -V:installvendorarch`"; echo $installvendorarch)
|
%define perl_vendorarch %(eval "`perl -V:installvendorarch`"; echo $installvendorarch)
|
||||||
|
|
||||||
|
%define release_candidate rc7
|
||||||
|
|
||||||
Summary: Modular text mode IRC client with Perl scripting
|
Summary: Modular text mode IRC client with Perl scripting
|
||||||
Name: irssi
|
Name: irssi
|
||||||
Version: 0.8.9
|
Version: 0.8.10
|
||||||
Release: 8
|
Release: 0.1.%{release_candidate}%{?dist}
|
||||||
|
|
||||||
License: GPL
|
License: GPL
|
||||||
Group: Applications/Communications
|
Group: Applications/Communications
|
||||||
URL: http://irssi.org/
|
URL: http://irssi.org/
|
||||||
Source0: http://irssi.org/files/%{name}-%{version}.tar.bz2
|
Source0: http://irssi.org/files/irssi-%{version}-%{release_candidate}.tar.gz
|
||||||
Source1: http://wouter.coekaerts.be/irssi/scripts/replace.pl
|
Source1: http://wouter.coekaerts.be/irssi/scripts/replace.pl
|
||||||
Source2: http://wouter.coekaerts.be/irssi/scripts/trigger.pl
|
Source2: http://wouter.coekaerts.be/irssi/scripts/trigger.pl
|
||||||
Source3: http://wouter.coekaerts.be/irssi/scripts/convert-replace-trigger.pl
|
Source3: http://wouter.coekaerts.be/irssi/scripts/convert-replace-trigger.pl
|
||||||
Patch1: convert-replace-trigger.pl-fixpath-patch
|
Patch1: convert-replace-trigger.pl-fixpath-patch
|
||||||
Patch2: irssi-0.8.9-include-config.h.patch
|
|
||||||
Patch3: irssi-0.8.9-gcc4.patch
|
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
|
||||||
BuildRequires: ncurses-devel openssl-devel zlib-devel pkgconfig gc-devel
|
BuildRequires: ncurses-devel openssl-devel zlib-devel
|
||||||
%{?_with_glib1:BuildRequires: glib-devel}
|
BuildRequires: pkgconfig gc-devel glib2-devel
|
||||||
%{!?_with_glib1:BuildRequires: glib2-devel}
|
|
||||||
|
|
||||||
Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
|
Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
|
||||||
|
|
||||||
|
%package devel
|
||||||
|
Summary: Development package for irssi
|
||||||
|
Group: Development/Libraries
|
||||||
|
Requires: %{name} = %{version}-%{release}
|
||||||
|
|
||||||
%description
|
%description
|
||||||
Irssi is a modular IRC client with Perl scripting. Only text-mode
|
Irssi is a modular IRC client with Perl scripting. Only text-mode
|
||||||
frontend is currently supported. The GTK/GNOME frontend is no longer
|
frontend is currently supported. The GTK/GNOME frontend is no longer
|
||||||
being maintained.
|
being maintained.
|
||||||
|
|
||||||
|
%description devel
|
||||||
|
This package contains headers needed to develop irssi plugins.
|
||||||
|
|
||||||
|
Irssi is a modular IRC client with Perl scripting. Only text-mode
|
||||||
|
frontend is currently supported. The GTK/GNOME frontend is no longer
|
||||||
|
being maintained.
|
||||||
|
|
||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q -n %{name}-%{version}-%{release_candidate}
|
||||||
install -m 0644 %{SOURCE3} .
|
install -m 0644 %{SOURCE3} .
|
||||||
%patch1 -p0
|
%patch1 -p0
|
||||||
%patch2 -p1 -b .include-config.h
|
|
||||||
%patch3 -p1 -b .gcc4
|
|
||||||
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%configure --enable-ipv6 --with-textui \
|
%configure --enable-ipv6 --with-textui \
|
||||||
%{?_with_glib1: --with-glib1} \
|
|
||||||
--with-proxy \
|
--with-proxy \
|
||||||
--with-bot \
|
--with-bot \
|
||||||
--with-perl=module \
|
--with-perl=module \
|
||||||
@ -82,7 +88,15 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%{perl_vendorarch}/auto/Irssi
|
%{perl_vendorarch}/auto/Irssi
|
||||||
|
|
||||||
|
|
||||||
|
%files devel
|
||||||
|
%defattr(-,root,root,-)
|
||||||
|
%{_includedir}/irssi
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Nov 15 2005 Dams <anvil[AT]livna.org> - 0.8.10-0.1.rc7
|
||||||
|
- Dropped patch 2 (seems applied upstream) and 3 (no longer needed)
|
||||||
|
- Removed conditionnal build against glib1 parts
|
||||||
|
|
||||||
* Sun Nov 13 2005 Luke Macken <lmacken@redhat.com> 0.8.9-8
|
* Sun Nov 13 2005 Luke Macken <lmacken@redhat.com> 0.8.9-8
|
||||||
- Rebuild against new openssl
|
- Rebuild against new openssl
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user