Bumping to new release which fix our xterm issue, so the patch can be
dropped.
This commit is contained in:
parent
0ee95579c1
commit
baa50da5d9
@ -1,2 +1 @@
|
||||
irssi-0.8.10a.tar.bz2
|
||||
irssi-0.8.11.tar.bz2
|
||||
irssi-0.8.12.tar.bz2
|
||||
|
@ -1,33 +0,0 @@
|
||||
--- src/fe-text/gui-readline.c.orig 2007-08-18 23:17:35.633891000 +0200
|
||||
+++ src/fe-text/gui-readline.c 2007-08-18 23:25:04.000000000 +0200
|
||||
@@ -1087,6 +1087,15 @@
|
||||
key_bind("key", NULL, "meta2-1;5D", "cleft", (SIGNAL_FUNC) key_combo);
|
||||
key_bind("key", NULL, "meta2-1;5C", "cright", (SIGNAL_FUNC) key_combo);
|
||||
|
||||
+ key_bind("key", NULL, "meta2-1;3A", "mup", (SIGNAL_FUNC) key_combo);
|
||||
+ key_bind("key", NULL, "meta2-1;3B", "mdown", (SIGNAL_FUNC) key_combo);
|
||||
+ key_bind("key", NULL, "meta2-1;3D", "mleft", (SIGNAL_FUNC) key_combo);
|
||||
+ key_bind("key", NULL, "meta2-1;3C", "mright", (SIGNAL_FUNC) key_combo);
|
||||
+ key_bind("key", NULL, "meta-up", "mup", (SIGNAL_FUNC) key_combo);
|
||||
+ key_bind("key", NULL, "meta-down", "mdown", (SIGNAL_FUNC) key_combo);
|
||||
+ key_bind("key", NULL, "meta-left", "mleft", (SIGNAL_FUNC) key_combo);
|
||||
+ key_bind("key", NULL, "meta-right", "mright", (SIGNAL_FUNC) key_combo);
|
||||
+
|
||||
/* cursor movement */
|
||||
key_bind("backward_character", "", "left", NULL, (SIGNAL_FUNC) key_backward_character);
|
||||
key_bind("forward_character", "", "right", NULL, (SIGNAL_FUNC) key_forward_character);
|
||||
@@ -1132,10 +1141,10 @@
|
||||
/* window managing */
|
||||
key_bind("previous_window", "Previous window", "^P", NULL, (SIGNAL_FUNC) key_previous_window);
|
||||
key_bind("next_window", "Next window", "^N", NULL, (SIGNAL_FUNC) key_next_window);
|
||||
- key_bind("upper_window", "Upper window", "meta-up", NULL, (SIGNAL_FUNC) key_upper_window);
|
||||
- key_bind("lower_window", "Lower window", "meta-down", NULL, (SIGNAL_FUNC) key_lower_window);
|
||||
- key_bind("left_window", "Window in left", "meta-left", NULL, (SIGNAL_FUNC) key_left_window);
|
||||
- key_bind("right_window", "Window in right", "meta-right", NULL, (SIGNAL_FUNC) key_right_window);
|
||||
+ key_bind("upper_window", "Upper window", "mup", NULL, (SIGNAL_FUNC) key_upper_window);
|
||||
+ key_bind("lower_window", "Lower window", "mdown", NULL, (SIGNAL_FUNC) key_lower_window);
|
||||
+ key_bind("left_window", "Window in left", "mleft", NULL, (SIGNAL_FUNC) key_left_window);
|
||||
+ key_bind("right_window", "Window in right", "mright", NULL, (SIGNAL_FUNC) key_right_window);
|
||||
key_bind("active_window", "Go to next window with the highest activity", "meta-a", NULL, (SIGNAL_FUNC) key_active_window);
|
||||
key_bind("next_window_item", "Next channel/query", "^X", NULL, (SIGNAL_FUNC) key_next_window_item);
|
||||
key_bind("previous_window_item", "Previous channel/query", NULL, NULL, (SIGNAL_FUNC) key_previous_window_item);
|
14
irssi.spec
14
irssi.spec
@ -2,8 +2,8 @@
|
||||
|
||||
Summary: Modular text mode IRC client with Perl scripting
|
||||
Name: irssi
|
||||
Version: 0.8.11
|
||||
Release: 5%{?dist}
|
||||
Version: 0.8.12
|
||||
Release: 1%{?dist}
|
||||
|
||||
License: GPLv2+
|
||||
Group: Applications/Communications
|
||||
@ -15,8 +15,6 @@ BuildRequires: pkgconfig glib2-devel perl-devel
|
||||
|
||||
Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
|
||||
|
||||
Patch0: irssi-support-meta-cursor-xterm.patch
|
||||
|
||||
%package devel
|
||||
Summary: Development package for irssi
|
||||
Group: Development/Libraries
|
||||
@ -38,8 +36,6 @@ being maintained.
|
||||
%prep
|
||||
%setup -q -n %{name}-%{version}
|
||||
|
||||
%patch0 -p0
|
||||
|
||||
%build
|
||||
%configure --enable-ipv6 --with-textui \
|
||||
--with-proxy \
|
||||
@ -86,11 +82,15 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%{_includedir}/irssi
|
||||
|
||||
%changelog
|
||||
* Mon Oct 08 2007 Marek Mahut <mmahut fedoraproject.org> - 0.8.12-1
|
||||
- New release
|
||||
- Fixes bug from BZ#239511, dropping patch
|
||||
|
||||
* Sun Aug 19 2007 Marek Mahut <mmahut fedoraproject.org> - 0.8.11-5
|
||||
- Fixing properly irssi-support-meta-cursor-xterm.patch
|
||||
|
||||
* Thu Aug 16 2007 Marek Mahut <mmahut redhat.com> - 0.8.11-4
|
||||
- Added irssi-support-meta-cursor-xterm.patch (#239511)
|
||||
- Added irssi-support-meta-cursor-xterm.patch (BZ#239511)
|
||||
|
||||
* Thu Aug 16 2007 Marek Mahut <mmahut redhat.com> - 0.8.11-2
|
||||
- Updating license tag
|
||||
|
Loading…
Reference in New Issue
Block a user