New version
Resolves: rhbz#2241891
This commit is contained in:
parent
933ed97b74
commit
56df7eabf6
@ -1,64 +0,0 @@
|
||||
From 41cdf31269fc0aafec7b37f6965dcc83e65b9dd4 Mon Sep 17 00:00:00 2001
|
||||
From: ailin-nemui <ailin-nemui@users.noreply.github.com>
|
||||
Date: Tue, 18 Jul 2023 22:05:28 +0000
|
||||
Subject: [PATCH] Merge pull request #1474 from ailin-nemui/perl5380
|
||||
|
||||
fix usage of $type in ExtUtils::ParseXS 3.50
|
||||
|
||||
(cherry picked from commit da49ec62e6cc949d3e5359b88abbd0b038d3e23a)
|
||||
---
|
||||
src/perl/common/typemap | 2 +-
|
||||
src/perl/irc/typemap | 2 +-
|
||||
src/perl/textui/typemap | 2 +-
|
||||
src/perl/ui/typemap | 2 +-
|
||||
4 files changed, 4 insertions(+), 4 deletions(-)
|
||||
|
||||
diff --git a/src/perl/common/typemap b/src/perl/common/typemap
|
||||
index 5b7e0c32..9b6c6668 100644
|
||||
--- a/src/perl/common/typemap
|
||||
+++ b/src/perl/common/typemap
|
||||
@@ -28,5 +28,5 @@ T_IrssiObj
|
||||
$arg = iobject_bless((SERVER_REC *)$var);
|
||||
|
||||
T_PlainObj
|
||||
- $arg = plain_bless($var, \"$type\");
|
||||
+ $arg = plain_bless($var, \"$ntype\");
|
||||
|
||||
diff --git a/src/perl/irc/typemap b/src/perl/irc/typemap
|
||||
index 9bf87647..c8a9b678 100644
|
||||
--- a/src/perl/irc/typemap
|
||||
+++ b/src/perl/irc/typemap
|
||||
@@ -36,5 +36,5 @@ T_DccObj
|
||||
$arg = simple_iobject_bless((DCC_REC *)$var);
|
||||
|
||||
T_PlainObj
|
||||
- $arg = plain_bless($var, \"$type\");
|
||||
+ $arg = plain_bless($var, \"$ntype\");
|
||||
|
||||
diff --git a/src/perl/textui/typemap b/src/perl/textui/typemap
|
||||
index 7710c2d2..e597c586 100644
|
||||
--- a/src/perl/textui/typemap
|
||||
+++ b/src/perl/textui/typemap
|
||||
@@ -18,7 +18,7 @@ T_BufferLineWrapper
|
||||
OUTPUT
|
||||
|
||||
T_PlainObj
|
||||
- $arg = plain_bless($var, \"$type\");
|
||||
+ $arg = plain_bless($var, \"$ntype\");
|
||||
|
||||
T_BufferLineWrapper
|
||||
$arg = perl_buffer_line_bless($var);
|
||||
diff --git a/src/perl/ui/typemap b/src/perl/ui/typemap
|
||||
index 4afb273d..98355191 100644
|
||||
--- a/src/perl/ui/typemap
|
||||
+++ b/src/perl/ui/typemap
|
||||
@@ -13,5 +13,5 @@ T_PlainObj
|
||||
OUTPUT
|
||||
|
||||
T_PlainObj
|
||||
- $arg = plain_bless($var, \"$type\");
|
||||
+ $arg = plain_bless($var, \"$ntype\");
|
||||
|
||||
--
|
||||
2.41.0
|
||||
|
11
irssi.spec
11
irssi.spec
@ -8,8 +8,8 @@
|
||||
|
||||
Summary: Modular text mode IRC client with Perl scripting
|
||||
Name: irssi
|
||||
Version: 1.4.4
|
||||
Release: 5%{?dist}
|
||||
Version: 1.4.5
|
||||
Release: 1%{?dist}
|
||||
|
||||
License: GPLv2+
|
||||
URL: http://irssi.org/
|
||||
@ -41,9 +41,6 @@ Requires: perl(Symbol)
|
||||
# https://github.com/irssi/irssi/issues/1374
|
||||
Patch0: irssi-1.4.1-botti-perl-link-fix.patch
|
||||
|
||||
# https://github.com/irssi/irssi/pull/1474
|
||||
Patch1: irssi-1.4.4-perl-ntype.patch
|
||||
|
||||
%package devel
|
||||
Summary: Development package for irssi
|
||||
Requires: %{name} = %{version}-%{release}
|
||||
@ -113,6 +110,10 @@ chmod -R u+w $RPM_BUILD_ROOT%{perl_vendorarch}
|
||||
|
||||
|
||||
%changelog
|
||||
* Tue Oct 10 2023 Jaroslav Škarvada <jskarvad@redhat.com> - 1.4.5-1
|
||||
- New version
|
||||
Resolves: rhbz#2241891
|
||||
|
||||
* Thu Aug 18 2023 Boudhayan Bhattacharya <bbhtt.zn0i8@slmail.me> - 1.4.4-5
|
||||
- Add irssi perl-ntype patch for perl>=5.38
|
||||
Resolves rhbz#2232750
|
||||
|
4
sources
4
sources
@ -1,2 +1,2 @@
|
||||
SHA512 (irssi-1.4.4.tar.xz) = da28ac7a527be301d0615d6d733e4cf4e09bb6d4f5c70bc33ff70e22439a01f197bb5d91b4432ca74d3ac2dbb3235f30d53efc63a4279de8664923c2ccdbdbea
|
||||
SHA512 (irssi-1.4.4.tar.xz.asc) = b6493102a9c310833da6efca97d542a2c4fd4c83f9d8a653131edaf36ac789408460cc5c32cb9ee4e95f827601da4e48b6f776fe15bf7124faea98cac3d91006
|
||||
SHA512 (irssi-1.4.5.tar.xz) = 5d80107ad625feb6d2b3ac807f517c5cfeae58986d3fbfe53ea82f2dee70396f5092abdc6ef137c5651e4515e081591079b37f0e428f69990db493cfe14e4f36
|
||||
SHA512 (irssi-1.4.5.tar.xz.asc) = 8a4df3fabdc3d96b409f2b96da752cc5c3e6912b593499bc4b55600c5a81df05a4d6b0547aae1e2e252b53f6aeae29a44a9cc27335eaa0c6cd8bb3b3ec8feacb
|
||||
|
Loading…
Reference in New Issue
Block a user