Updating irqbalance to latest version

This commit is contained in:
Neil Horman 2010-06-10 15:06:03 +00:00
parent 2d4dbcc7b9
commit f839289599
7 changed files with 8 additions and 912 deletions

View File

@ -1 +1,2 @@
irqbalance-0.55.tar.gz
irqbalance-0.56.tbz2

View File

@ -1,672 +0,0 @@
diff -up irqbalance-0.55/irqbalance-0.55/activate.c.orig irqbalance-0.55/irqbalance-0.55/activate.c
--- irqbalance-0.55/irqbalance-0.55/activate.c.orig 2006-11-22 04:23:41.000000000 -0500
+++ irqbalance-0.55/irqbalance-0.55/activate.c 2009-09-01 16:03:26.000000000 -0400
@@ -23,6 +23,7 @@
* This file contains the code to communicate a selected distribution / mapping
* of interrupts to the kernel.
*/
+#include "config.h"
#include <stdio.h>
#include <stdlib.h>
#include <unistd.h>
diff -up /dev/null irqbalance-0.55/irqbalance-0.55/AUTHORS
diff -up /dev/null irqbalance-0.55/irqbalance-0.55/autogen.sh
--- /dev/null 2009-08-23 21:38:48.579244073 -0400
+++ irqbalance-0.55/irqbalance-0.55/autogen.sh 2009-09-01 16:03:26.000000000 -0400
@@ -0,0 +1,4 @@
+#! /bin/sh
+set -x -e
+# --no-recursive is available only in recent autoconf versions
+autoreconf -fv --install
diff -up irqbalance-0.55/irqbalance-0.55/bitmap.c.orig irqbalance-0.55/irqbalance-0.55/bitmap.c
--- irqbalance-0.55/irqbalance-0.55/bitmap.c.orig 2006-11-22 08:43:17.000000000 -0500
+++ irqbalance-0.55/irqbalance-0.55/bitmap.c 2009-09-01 16:03:26.000000000 -0400
@@ -11,7 +11,7 @@ This file is taken from the Linux kernel
* This source code is licensed under the GNU General Public License,
* Version 2. See the file COPYING for more details.
*/
-
+#include "config.h"
#include <unistd.h>
#include <errno.h>
#include <stdio.h>
diff -up /dev/null irqbalance-0.55/irqbalance-0.55/Changelog
diff -up irqbalance-0.55/irqbalance-0.55/classify.c.orig irqbalance-0.55/irqbalance-0.55/classify.c
--- irqbalance-0.55/irqbalance-0.55/classify.c.orig 2006-11-24 11:11:22.000000000 -0500
+++ irqbalance-0.55/irqbalance-0.55/classify.c 2009-09-01 16:03:26.000000000 -0400
@@ -1,3 +1,4 @@
+#include "config.h"
#include <stdlib.h>
#include <stdio.h>
#include <unistd.h>
diff -up /dev/null irqbalance-0.55/irqbalance-0.55/configure.ac
--- /dev/null 2009-08-23 21:38:48.579244073 -0400
+++ irqbalance-0.55/irqbalance-0.55/configure.ac 2009-09-01 16:03:26.000000000 -0400
@@ -0,0 +1,74 @@
+dnl
+define([AC_INIT_NOTICE],
+[### Generated automatically using autoconf version] AC_ACVERSION [
+### Copyright 2009 Steve Grubb <sgrubb@redhat.com>
+###
+### Permission is hereby granted, free of charge, to any person obtaining a
+### copy of this software and associated documentation files (the "Software"),
+### to deal in the Software without restriction, including without limitation
+### the rights to use, copy, modify, merge, publish, distribute, sublicense,
+### and/or sell copies of the Software, and to permit persons to whom the
+### Software is furnished to do so, subject to the following conditions:
+###
+### The above copyright notice and this permission notice shall be included
+### in all copies or substantial portions of the Software.
+###
+### THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+### IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+### FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL
+### THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR
+### OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE,
+### ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR
+### OTHER DEALINGS IN THE SOFTWARE.
+###
+### For usage, run `./configure --help'
+### For more detailed information on installation, read the file `INSTALL'.
+###
+### If configuration succeeds, status is in the file `config.status'.
+### A log of configuration tests is in `config.log'.
+])
+
+AC_REVISION($Revision: 1.3 $)dnl
+AC_INIT(irqbalance,0.56)
+AC_PREREQ(2.12)dnl
+AM_CONFIG_HEADER(config.h)
+
+echo Configuring irqbalance $VERSION
+
+AC_CONFIG_MACRO_DIR([m4])
+AC_CANONICAL_TARGET
+AM_INIT_AUTOMAKE
+AM_PROG_LIBTOOL
+AC_SUBST(LIBTOOL_DEPS)
+
+echo .
+echo Checking for programs
+
+AC_PROG_CC
+AC_PROG_INSTALL
+AC_PROG_AWK
+
+echo .
+echo Checking for header files
+AC_HEADER_STDC
+AC_CHECK_HEADERS(linux/ethtool.h linux/sockios.h, [], [])
+
+AC_C_CONST
+AC_C_INLINE
+AM_PROG_CC_C_O
+
+PKG_CHECK_MODULES([GLIB], [glib-2.0])
+LIBCAP_NG_PATH
+
+AC_OUTPUT(Makefile)
+
+echo .
+echo "
+
+ irqbalance Version: $VERSION
+ Target: $target
+ Installation prefix: $prefix
+ Compiler: $CC
+ Compiler flags:
+`echo $CFLAGS | fmt -w 50 | sed 's,^, ,'`
+"
diff -up /dev/null irqbalance-0.55/irqbalance-0.55/COPYING
--- /dev/null 2009-08-23 21:38:48.579244073 -0400
+++ irqbalance-0.55/irqbalance-0.55/COPYING 2009-09-01 16:03:26.000000000 -0400
@@ -0,0 +1,340 @@
+ GNU GENERAL PUBLIC LICENSE
+ Version 2, June 1991
+
+ Copyright (C) 1989, 1991 Free Software Foundation, Inc.
+ 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
+ Everyone is permitted to copy and distribute verbatim copies
+ of this license document, but changing it is not allowed.
+
+ Preamble
+
+ The licenses for most software are designed to take away your
+freedom to share and change it. By contrast, the GNU General Public
+License is intended to guarantee your freedom to share and change free
+software--to make sure the software is free for all its users. This
+General Public License applies to most of the Free Software
+Foundation's software and to any other program whose authors commit to
+using it. (Some other Free Software Foundation software is covered by
+the GNU Library General Public License instead.) You can apply it to
+your programs, too.
+
+ When we speak of free software, we are referring to freedom, not
+price. Our General Public Licenses are designed to make sure that you
+have the freedom to distribute copies of free software (and charge for
+this service if you wish), that you receive source code or can get it
+if you want it, that you can change the software or use pieces of it
+in new free programs; and that you know you can do these things.
+
+ To protect your rights, we need to make restrictions that forbid
+anyone to deny you these rights or to ask you to surrender the rights.
+These restrictions translate to certain responsibilities for you if you
+distribute copies of the software, or if you modify it.
+
+ For example, if you distribute copies of such a program, whether
+gratis or for a fee, you must give the recipients all the rights that
+you have. You must make sure that they, too, receive or can get the
+source code. And you must show them these terms so they know their
+rights.
+
+ We protect your rights with two steps: (1) copyright the software, and
+(2) offer you this license which gives you legal permission to copy,
+distribute and/or modify the software.
+
+ Also, for each author's protection and ours, we want to make certain
+that everyone understands that there is no warranty for this free
+software. If the software is modified by someone else and passed on, we
+want its recipients to know that what they have is not the original, so
+that any problems introduced by others will not reflect on the original
+authors' reputations.
+
+ Finally, any free program is threatened constantly by software
+patents. We wish to avoid the danger that redistributors of a free
+program will individually obtain patent licenses, in effect making the
+program proprietary. To prevent this, we have made it clear that any
+patent must be licensed for everyone's free use or not licensed at all.
+
+ The precise terms and conditions for copying, distribution and
+modification follow.
+
+ GNU GENERAL PUBLIC LICENSE
+ TERMS AND CONDITIONS FOR COPYING, DISTRIBUTION AND MODIFICATION
+
+ 0. This License applies to any program or other work which contains
+a notice placed by the copyright holder saying it may be distributed
+under the terms of this General Public License. The "Program", below,
+refers to any such program or work, and a "work based on the Program"
+means either the Program or any derivative work under copyright law:
+that is to say, a work containing the Program or a portion of it,
+either verbatim or with modifications and/or translated into another
+language. (Hereinafter, translation is included without limitation in
+the term "modification".) Each licensee is addressed as "you".
+
+Activities other than copying, distribution and modification are not
+covered by this License; they are outside its scope. The act of
+running the Program is not restricted, and the output from the Program
+is covered only if its contents constitute a work based on the
+Program (independent of having been made by running the Program).
+Whether that is true depends on what the Program does.
+
+ 1. You may copy and distribute verbatim copies of the Program's
+source code as you receive it, in any medium, provided that you
+conspicuously and appropriately publish on each copy an appropriate
+copyright notice and disclaimer of warranty; keep intact all the
+notices that refer to this License and to the absence of any warranty;
+and give any other recipients of the Program a copy of this License
+along with the Program.
+
+You may charge a fee for the physical act of transferring a copy, and
+you may at your option offer warranty protection in exchange for a fee.
+
+ 2. You may modify your copy or copies of the Program or any portion
+of it, thus forming a work based on the Program, and copy and
+distribute such modifications or work under the terms of Section 1
+above, provided that you also meet all of these conditions:
+
+ a) You must cause the modified files to carry prominent notices
+ stating that you changed the files and the date of any change.
+
+ b) You must cause any work that you distribute or publish, that in
+ whole or in part contains or is derived from the Program or any
+ part thereof, to be licensed as a whole at no charge to all third
+ parties under the terms of this License.
+
+ c) If the modified program normally reads commands interactively
+ when run, you must cause it, when started running for such
+ interactive use in the most ordinary way, to print or display an
+ announcement including an appropriate copyright notice and a
+ notice that there is no warranty (or else, saying that you provide
+ a warranty) and that users may redistribute the program under
+ these conditions, and telling the user how to view a copy of this
+ License. (Exception: if the Program itself is interactive but
+ does not normally print such an announcement, your work based on
+ the Program is not required to print an announcement.)
+
+These requirements apply to the modified work as a whole. If
+identifiable sections of that work are not derived from the Program,
+and can be reasonably considered independent and separate works in
+themselves, then this License, and its terms, do not apply to those
+sections when you distribute them as separate works. But when you
+distribute the same sections as part of a whole which is a work based
+on the Program, the distribution of the whole must be on the terms of
+this License, whose permissions for other licensees extend to the
+entire whole, and thus to each and every part regardless of who wrote it.
+
+Thus, it is not the intent of this section to claim rights or contest
+your rights to work written entirely by you; rather, the intent is to
+exercise the right to control the distribution of derivative or
+collective works based on the Program.
+
+In addition, mere aggregation of another work not based on the Program
+with the Program (or with a work based on the Program) on a volume of
+a storage or distribution medium does not bring the other work under
+the scope of this License.
+
+ 3. You may copy and distribute the Program (or a work based on it,
+under Section 2) in object code or executable form under the terms of
+Sections 1 and 2 above provided that you also do one of the following:
+
+ a) Accompany it with the complete corresponding machine-readable
+ source code, which must be distributed under the terms of Sections
+ 1 and 2 above on a medium customarily used for software interchange; or,
+
+ b) Accompany it with a written offer, valid for at least three
+ years, to give any third party, for a charge no more than your
+ cost of physically performing source distribution, a complete
+ machine-readable copy of the corresponding source code, to be
+ distributed under the terms of Sections 1 and 2 above on a medium
+ customarily used for software interchange; or,
+
+ c) Accompany it with the information you received as to the offer
+ to distribute corresponding source code. (This alternative is
+ allowed only for noncommercial distribution and only if you
+ received the program in object code or executable form with such
+ an offer, in accord with Subsection b above.)
+
+The source code for a work means the preferred form of the work for
+making modifications to it. For an executable work, complete source
+code means all the source code for all modules it contains, plus any
+associated interface definition files, plus the scripts used to
+control compilation and installation of the executable. However, as a
+special exception, the source code distributed need not include
+anything that is normally distributed (in either source or binary
+form) with the major components (compiler, kernel, and so on) of the
+operating system on which the executable runs, unless that component
+itself accompanies the executable.
+
+If distribution of executable or object code is made by offering
+access to copy from a designated place, then offering equivalent
+access to copy the source code from the same place counts as
+distribution of the source code, even though third parties are not
+compelled to copy the source along with the object code.
+
+ 4. You may not copy, modify, sublicense, or distribute the Program
+except as expressly provided under this License. Any attempt
+otherwise to copy, modify, sublicense or distribute the Program is
+void, and will automatically terminate your rights under this License.
+However, parties who have received copies, or rights, from you under
+this License will not have their licenses terminated so long as such
+parties remain in full compliance.
+
+ 5. You are not required to accept this License, since you have not
+signed it. However, nothing else grants you permission to modify or
+distribute the Program or its derivative works. These actions are
+prohibited by law if you do not accept this License. Therefore, by
+modifying or distributing the Program (or any work based on the
+Program), you indicate your acceptance of this License to do so, and
+all its terms and conditions for copying, distributing or modifying
+the Program or works based on it.
+
+ 6. Each time you redistribute the Program (or any work based on the
+Program), the recipient automatically receives a license from the
+original licensor to copy, distribute or modify the Program subject to
+these terms and conditions. You may not impose any further
+restrictions on the recipients' exercise of the rights granted herein.
+You are not responsible for enforcing compliance by third parties to
+this License.
+
+ 7. If, as a consequence of a court judgment or allegation of patent
+infringement or for any other reason (not limited to patent issues),
+conditions are imposed on you (whether by court order, agreement or
+otherwise) that contradict the conditions of this License, they do not
+excuse you from the conditions of this License. If you cannot
+distribute so as to satisfy simultaneously your obligations under this
+License and any other pertinent obligations, then as a consequence you
+may not distribute the Program at all. For example, if a patent
+license would not permit royalty-free redistribution of the Program by
+all those who receive copies directly or indirectly through you, then
+the only way you could satisfy both it and this License would be to
+refrain entirely from distribution of the Program.
+
+If any portion of this section is held invalid or unenforceable under
+any particular circumstance, the balance of the section is intended to
+apply and the section as a whole is intended to apply in other
+circumstances.
+
+It is not the purpose of this section to induce you to infringe any
+patents or other property right claims or to contest validity of any
+such claims; this section has the sole purpose of protecting the
+integrity of the free software distribution system, which is
+implemented by public license practices. Many people have made
+generous contributions to the wide range of software distributed
+through that system in reliance on consistent application of that
+system; it is up to the author/donor to decide if he or she is willing
+to distribute software through any other system and a licensee cannot
+impose that choice.
+
+This section is intended to make thoroughly clear what is believed to
+be a consequence of the rest of this License.
+
+ 8. If the distribution and/or use of the Program is restricted in
+certain countries either by patents or by copyrighted interfaces, the
+original copyright holder who places the Program under this License
+may add an explicit geographical distribution limitation excluding
+those countries, so that distribution is permitted only in or among
+countries not thus excluded. In such case, this License incorporates
+the limitation as if written in the body of this License.
+
+ 9. The Free Software Foundation may publish revised and/or new versions
+of the General Public License from time to time. Such new versions will
+be similar in spirit to the present version, but may differ in detail to
+address new problems or concerns.
+
+Each version is given a distinguishing version number. If the Program
+specifies a version number of this License which applies to it and "any
+later version", you have the option of following the terms and conditions
+either of that version or of any later version published by the Free
+Software Foundation. If the Program does not specify a version number of
+this License, you may choose any version ever published by the Free Software
+Foundation.
+
+ 10. If you wish to incorporate parts of the Program into other free
+programs whose distribution conditions are different, write to the author
+to ask for permission. For software which is copyrighted by the Free
+Software Foundation, write to the Free Software Foundation; we sometimes
+make exceptions for this. Our decision will be guided by the two goals
+of preserving the free status of all derivatives of our free software and
+of promoting the sharing and reuse of software generally.
+
+ NO WARRANTY
+
+ 11. BECAUSE THE PROGRAM IS LICENSED FREE OF CHARGE, THERE IS NO WARRANTY
+FOR THE PROGRAM, TO THE EXTENT PERMITTED BY APPLICABLE LAW. EXCEPT WHEN
+OTHERWISE STATED IN WRITING THE COPYRIGHT HOLDERS AND/OR OTHER PARTIES
+PROVIDE THE PROGRAM "AS IS" WITHOUT WARRANTY OF ANY KIND, EITHER EXPRESSED
+OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. THE ENTIRE RISK AS
+TO THE QUALITY AND PERFORMANCE OF THE PROGRAM IS WITH YOU. SHOULD THE
+PROGRAM PROVE DEFECTIVE, YOU ASSUME THE COST OF ALL NECESSARY SERVICING,
+REPAIR OR CORRECTION.
+
+ 12. IN NO EVENT UNLESS REQUIRED BY APPLICABLE LAW OR AGREED TO IN WRITING
+WILL ANY COPYRIGHT HOLDER, OR ANY OTHER PARTY WHO MAY MODIFY AND/OR
+REDISTRIBUTE THE PROGRAM AS PERMITTED ABOVE, BE LIABLE TO YOU FOR DAMAGES,
+INCLUDING ANY GENERAL, SPECIAL, INCIDENTAL OR CONSEQUENTIAL DAMAGES ARISING
+OUT OF THE USE OR INABILITY TO USE THE PROGRAM (INCLUDING BUT NOT LIMITED
+TO LOSS OF DATA OR DATA BEING RENDERED INACCURATE OR LOSSES SUSTAINED BY
+YOU OR THIRD PARTIES OR A FAILURE OF THE PROGRAM TO OPERATE WITH ANY OTHER
+PROGRAMS), EVEN IF SUCH HOLDER OR OTHER PARTY HAS BEEN ADVISED OF THE
+POSSIBILITY OF SUCH DAMAGES.
+
+ END OF TERMS AND CONDITIONS
+
+ How to Apply These Terms to Your New Programs
+
+ If you develop a new program, and you want it to be of the greatest
+possible use to the public, the best way to achieve this is to make it
+free software which everyone can redistribute and change under these terms.
+
+ To do so, attach the following notices to the program. It is safest
+to attach them to the start of each source file to most effectively
+convey the exclusion of warranty; and each file should have at least
+the "copyright" line and a pointer to where the full notice is found.
+
+ <one line to give the program's name and a brief idea of what it does.>
+ Copyright (C) <year> <name of author>
+
+ This program is free software; you can redistribute it and/or modify
+ it under the terms of the GNU General Public License as published by
+ the Free Software Foundation; either version 2 of the License, or
+ (at your option) any later version.
+
+ This program is distributed in the hope that it will be useful,
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ GNU General Public License for more details.
+
+ You should have received a copy of the GNU General Public License
+ along with this program; if not, write to the Free Software
+ Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
+
+
+Also add information on how to contact you by electronic and paper mail.
+
+If the program is interactive, make it output a short notice like this
+when it starts in an interactive mode:
+
+ Gnomovision version 69, Copyright (C) year name of author
+ Gnomovision comes with ABSOLUTELY NO WARRANTY; for details type `show w'.
+ This is free software, and you are welcome to redistribute it
+ under certain conditions; type `show c' for details.
+
+The hypothetical commands `show w' and `show c' should show the appropriate
+parts of the General Public License. Of course, the commands you use may
+be called something other than `show w' and `show c'; they could even be
+mouse-clicks or menu items--whatever suits your program.
+
+You should also get your employer (if you work as a programmer) or your
+school, if any, to sign a "copyright disclaimer" for the program, if
+necessary. Here is a sample; alter the names:
+
+ Yoyodyne, Inc., hereby disclaims all copyright interest in the program
+ `Gnomovision' (which makes passes at compilers) written by James Hacker.
+
+ <signature of Ty Coon>, 1 April 1989
+ Ty Coon, President of Vice
+
+This General Public License does not permit incorporating your program into
+proprietary programs. If your program is a subroutine library, you may
+consider it more useful to permit linking proprietary applications with the
+library. If this is what you want to do, use the GNU Library General
+Public License instead of this License.
diff -up irqbalance-0.55/irqbalance-0.55/cputree.c.orig irqbalance-0.55/irqbalance-0.55/cputree.c
--- irqbalance-0.55/irqbalance-0.55/cputree.c.orig 2009-09-01 16:02:59.000000000 -0400
+++ irqbalance-0.55/irqbalance-0.55/cputree.c 2009-09-01 16:03:26.000000000 -0400
@@ -24,8 +24,7 @@
* cache domains and processor cores.
*/
-#define _GNU_SOURCE
-
+#include "config.h"
#include <ctype.h>
#include <fcntl.h>
#include <stdio.h>
diff -up irqbalance-0.55/irqbalance-0.55/irqbalance.c.orig irqbalance-0.55/irqbalance-0.55/irqbalance.c
--- irqbalance-0.55/irqbalance-0.55/irqbalance.c.orig 2009-09-01 16:02:59.000000000 -0400
+++ irqbalance-0.55/irqbalance-0.55/irqbalance.c 2009-09-01 16:03:26.000000000 -0400
@@ -18,6 +18,7 @@
* 51 Franklin Street, Fifth Floor,
* Boston, MA 02110-1301 USA
*/
+#include "config.h"
#include <unistd.h>
#include <stdio.h>
#include <stdlib.h>
@@ -27,7 +28,9 @@
#include <sys/time.h>
#include <sys/types.h>
#include <sys/stat.h>
-
+#ifdef HAVE_LIBCAP_NG
+#include <cap-ng.h>
+#endif
#include "irqbalance.h"
int one_shot_mode;
@@ -102,6 +105,13 @@ int main(int argc, char** argv)
close(pidf);
+#ifdef HAVE_LIBCAP_NG
+ // Drop capabilities
+ capng_clear(CAPNG_SELECT_BOTH);
+ capng_lock();
+ capng_apply(CAPNG_SELECT_BOTH);
+#endif
+
parse_proc_interrupts();
sleep(SLEEP_INTERVAL/4);
reset_counts();
diff -up irqbalance-0.55/irqbalance-0.55/irqlist.c.orig irqbalance-0.55/irqbalance-0.55/irqlist.c
--- irqbalance-0.55/irqbalance-0.55/irqlist.c.orig 2006-12-10 15:16:44.000000000 -0500
+++ irqbalance-0.55/irqbalance-0.55/irqlist.c 2009-09-01 16:03:26.000000000 -0400
@@ -22,7 +22,7 @@
/*
* This file has the basic functions to manipulate interrupt metadata
*/
-#define _GNU_SOURCE
+#include "config.h"
#include <stdio.h>
#include <stdlib.h>
#include <unistd.h>
diff -up /dev/null irqbalance-0.55/irqbalance-0.55/m4/cap-ng.m4
--- /dev/null 2009-08-23 21:38:48.579244073 -0400
+++ irqbalance-0.55/irqbalance-0.55/m4/cap-ng.m4 2009-09-01 16:03:26.000000000 -0400
@@ -0,0 +1,40 @@
+# libcap-ng.m4 - Checks for the libcap-ng support
+# Copyright (c) 2009 Steve Grubb sgrubb@redhat.com
+#
+AC_DEFUN([LIBCAP_NG_PATH],
+[
+ AC_ARG_WITH(libcap-ng,
+ [ --with-libcap-ng=[auto/yes/no] Add Libcap-ng support [default=auto]],,
+ with_libcap_ng=auto)
+
+ # Check for Libcap-ng API
+ #
+ # libcap-ng detection
+
+ if test x$with_libcap_ng = xno ; then
+ have_libcap_ng=no;
+ else
+ # Start by checking for header file
+ AC_CHECK_HEADER(cap-ng.h, capng_headers=yes, capng_headers=no)
+
+ # See if we have libcap-ng library
+ AC_CHECK_LIB(cap-ng, capng_clear,
+ CAPNG_LDADD=-lcap-ng,)
+
+ # Check results are usable
+ if test x$with_libcap_ng = xyes -a x$CAPNG_LDADD = x ; then
+ AC_MSG_ERROR(libcap-ng support was requested and the library was not found)
+ fi
+ if test x$CAPNG_LDADD != x -a $capng_headers = no ; then
+ AC_MSG_ERROR(libcap-ng libraries found but headers are missing)
+ fi
+ fi
+ AC_SUBST(CAPNG_LDADD)
+ AC_MSG_CHECKING(whether to use libcap-ng)
+ if test x$CAPNG_LDADD != x ; then
+ AC_DEFINE(HAVE_LIBCAP_NG,1,[libcap-ng support])
+ AC_MSG_RESULT(yes)
+ else
+ AC_MSG_RESULT(no)
+ fi
+])
diff -up /dev/null irqbalance-0.55/irqbalance-0.55/Makefile.am
--- /dev/null 2009-08-23 21:38:48.579244073 -0400
+++ irqbalance-0.55/irqbalance-0.55/Makefile.am 2009-09-01 16:03:26.000000000 -0400
@@ -0,0 +1,39 @@
+# Makefile.am --
+# Copyright 2009 Red Hat Inc., Durham, North Carolina.
+# All Rights Reserved.
+#
+# This library is free software; you can redistribute it and/or
+# modify it under the terms of the GNU Lesser General Public
+# License as published by the Free Software Foundation; either
+# version 2.1 of the License, or (at your option) any later version.
+#
+# This library is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# Lesser General Public License for more details.
+#
+# You should have received a copy of the GNU Lesser General Public
+# License along with this library; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
+#
+# Authors:
+# Steve Grubb <sgrubb@redhat.com>
+#
+
+AUTOMAKE_OPTIONS = no-dependencies
+EXTRA_DIST = README INSTALL COPYING autogen.sh m4/cap-ng.m4
+
+INCLUDES = -I${top_srcdir}
+LIBS = $(CAPNG_LDADD) $(GLIB_LIBS)
+AM_CFLAGS = -g -Os -W -Wall -Wshadow -Wformat -Wundef $(GLIB_CFLAGS) -D_GNU_SOURCE
+noinst_HEADERS = bitmap.h constants.h cpumask.h irqbalance.h non-atomic.h \
+ types.h
+sbin_PROGRAMS = irqbalance
+irqbalance_SOURCES = activate.c bitmap.c classify.c cputree.c irqbalance.c \
+ irqlist.c network.c numa.c placement.c powermode.c procinterrupts.c
+
+CONFIG_CLEAN_FILES = debug*.list config/*
+clean-generic:
+ rm -rf autom4te*.cache
+ rm -f *.rej *.orig *~
+
diff -up irqbalance-0.55/irqbalance-0.55/network.c.orig irqbalance-0.55/irqbalance-0.55/network.c
--- irqbalance-0.55/irqbalance-0.55/network.c.orig 2006-12-11 03:36:17.000000000 -0500
+++ irqbalance-0.55/irqbalance-0.55/network.c 2009-09-01 16:03:26.000000000 -0400
@@ -24,7 +24,7 @@
* even though the amount of work is high; this file is there to compensate for this
* by adding actual package counts to the calculated amount of work of interrupts
*/
-#define _GNU_SOURCE
+#include "config.h"
#include <stdio.h>
#include <stdlib.h>
#include <unistd.h>
diff -up /dev/null irqbalance-0.55/irqbalance-0.55/NEWS
diff -up irqbalance-0.55/irqbalance-0.55/numa.c.orig irqbalance-0.55/irqbalance-0.55/numa.c
--- irqbalance-0.55/irqbalance-0.55/numa.c.orig 2006-12-10 15:03:11.000000000 -0500
+++ irqbalance-0.55/irqbalance-0.55/numa.c 2009-09-01 16:03:26.000000000 -0400
@@ -24,7 +24,7 @@
* In addition the PCI class information is used to refine the classification
* of interrupt sources
*/
-#define _GNU_SOURCE
+#include "config.h"
#include <unistd.h>
#include <stdlib.h>
#include <stdio.h>
diff -up irqbalance-0.55/irqbalance-0.55/placement.c.orig irqbalance-0.55/irqbalance-0.55/placement.c
--- irqbalance-0.55/irqbalance-0.55/placement.c.orig 2006-11-23 05:55:26.000000000 -0500
+++ irqbalance-0.55/irqbalance-0.55/placement.c 2009-09-01 16:03:26.000000000 -0400
@@ -18,6 +18,7 @@
* 51 Franklin Street, Fifth Floor,
* Boston, MA 02110-1301 USA
*/
+#include "config.h"
#include <stdio.h>
#include <stdlib.h>
#include <unistd.h>
diff -up irqbalance-0.55/irqbalance-0.55/powermode.c.orig irqbalance-0.55/irqbalance-0.55/powermode.c
--- irqbalance-0.55/irqbalance-0.55/powermode.c.orig 2006-12-11 03:16:50.000000000 -0500
+++ irqbalance-0.55/irqbalance-0.55/powermode.c 2009-09-01 16:03:26.000000000 -0400
@@ -18,7 +18,7 @@
* 51 Franklin Street, Fifth Floor,
* Boston, MA 02110-1301 USA
*/
-#define _GNU_SOURCE
+#include "config.h"
#include <stdio.h>
#include <stdlib.h>
#include <unistd.h>
diff -up irqbalance-0.55/irqbalance-0.55/procinterrupts.c.orig irqbalance-0.55/irqbalance-0.55/procinterrupts.c
--- irqbalance-0.55/irqbalance-0.55/procinterrupts.c.orig 2006-12-10 15:11:45.000000000 -0500
+++ irqbalance-0.55/irqbalance-0.55/procinterrupts.c 2009-09-01 16:03:26.000000000 -0400
@@ -18,7 +18,7 @@
* 51 Franklin Street, Fifth Floor,
* Boston, MA 02110-1301 USA
*/
-#define _GNU_SOURCE
+#include "config.h"
#include <stdio.h>
#include <stdlib.h>
#include <unistd.h>
diff -up /dev/null irqbalance-0.55/irqbalance-0.55/README

View File

@ -1,146 +0,0 @@
diff -up irqbalance-0.55/irqbalance-0.55/cputree.c.orig irqbalance-0.55/irqbalance-0.55/cputree.c
--- irqbalance-0.55/irqbalance-0.55/cputree.c.orig 2006-12-10 15:04:59.000000000 -0500
+++ irqbalance-0.55/irqbalance-0.55/cputree.c 2007-09-28 12:43:35.000000000 -0400
@@ -26,6 +26,8 @@
#define _GNU_SOURCE
+#include <ctype.h>
+#include <fcntl.h>
#include <stdio.h>
#include <stdlib.h>
#include <unistd.h>
@@ -131,34 +133,30 @@ static void fill_cache_domain(void)
}
-static void do_one_cpu(char *path)
+static void do_one_cpu(int dfd, char *d_name)
{
struct cpu_core *cpu;
FILE *file;
char new_path[PATH_MAX];
/* skip offline cpus */
- snprintf(new_path, PATH_MAX, "%s/online", path);
- file = fopen(new_path, "r");
- if (file) {
- char *line = NULL;
- size_t size = 0;
- if (getline(&line, &size, file)==0)
+ snprintf(new_path, PATH_MAX, "%s/online", d_name);
+ int fd = openat(dfd, new_path, O_RDONLY);
+ if (fd != -1) {
+ char buf[1];
+ ssize_t n = read(fd, buf, sizeof(buf));
+ close(fd);
+ if (n != sizeof(buf))
return;
- fclose(file);
- if (line && line[0]=='0') {
- free(line);
+ if (buf[0] == '0')
return;
- }
- free(line);
}
- cpu = malloc(sizeof(struct cpu_core));
+ cpu = calloc(1, sizeof(struct cpu_core));
if (!cpu)
return;
- memset(cpu, 0, sizeof(struct cpu_core));
- cpu->number = strtoul(&path[27], NULL, 10);
+ cpu->number = strtoul(&d_name[3], NULL, 10);
cpu_set(cpu->number, cpu->mask);
@@ -170,43 +168,45 @@ static void do_one_cpu(char *path)
return;
}
+ char *line = NULL;
+ size_t size = 0;
/* try to read the package mask; if it doesn't exist assume solitary */
- snprintf(new_path, PATH_MAX, "%s/topology/core_siblings", path);
- file = fopen(new_path, "r");
+ snprintf(new_path, PATH_MAX, "%s/topology/core_siblings", d_name);
+ fd = openat(dfd, new_path, O_RDONLY);
+ file = fd == -1 ? NULL : fdopen(fd, "r");
cpu_set(cpu->number, cpu->package_mask);
if (file) {
- char *line = NULL;
- size_t size = 0;
if (getline(&line, &size, file))
cpumask_parse_user(line, strlen(line), cpu->package_mask);
fclose(file);
- free(line);
- }
+ } else if (fd != -1)
+ close(fd);
/* try to read the cache mask; if it doesn't exist assume solitary */
/* We want the deepest cache level available so try index1 first, then index2 */
cpu_set(cpu->number, cpu->cache_mask);
- snprintf(new_path, PATH_MAX, "%s/cache/index1/shared_cpu_map", path);
- file = fopen(new_path, "r");
+ snprintf(new_path, PATH_MAX, "%s/cache/index1/shared_cpu_map", d_name);
+ fd = openat(dfd, new_path, O_RDONLY);
+ file = fd == -1 ? NULL : fdopen(fd, "r");
if (file) {
- char *line = NULL;
- size_t size = 0;
if (getline(&line, &size, file))
cpumask_parse_user(line, strlen(line), cpu->cache_mask);
fclose(file);
- free(line);
- }
- snprintf(new_path, PATH_MAX, "%s/cache/index2/shared_cpu_map", path);
- file = fopen(new_path, "r");
+ } else if (fd != -1)
+ close(fd);
+
+ snprintf(new_path, PATH_MAX, "%s/cache/index2/shared_cpu_map", d_name);
+ fd = openat(dfd, new_path, O_RDONLY);
+ file = fd == -1 ? NULL : fdopen(fd, "r");
if (file) {
- char *line = NULL;
- size_t size = 0;
if (getline(&line, &size, file))
cpumask_parse_user(line, strlen(line), cpu->cache_mask);
fclose(file);
- free(line);
- }
+ } else if (fd != -1)
+ close(fd);
+
+ free(line);
/*
blank out the banned cpus from the various masks so that interrupts
@@ -311,18 +311,19 @@ void parse_cpu_tree(void)
{
DIR *dir;
struct dirent *entry;
+ int dfd;
cpus_complement(unbanned_cpus, banned_cpus);
dir = opendir("/sys/devices/system/cpu");
if (!dir)
return;
+ dfd = dirfd(dir);
do {
entry = readdir(dir);
- if (entry && strlen(entry->d_name)>3 && strstr(entry->d_name,"cpu")) {
- char new_path[PATH_MAX];
- sprintf(new_path, "/sys/devices/system/cpu/%s", entry->d_name);
- do_one_cpu(new_path);
+ if (entry && strlen(entry->d_name)>3 && memcmp(entry->d_name,"cpu",3) == 0
+ && isdigit(entry->d_name[3])) {
+ do_one_cpu(dfd, entry->d_name);
}
} while (entry);
closedir(dir);

View File

@ -1,65 +0,0 @@
diff -up irqbalance-0.55/irqbalance-0.55/irqbalance.c.orig irqbalance-0.55/irqbalance-0.55/irqbalance.c
--- irqbalance-0.55/irqbalance-0.55/irqbalance.c.orig 2006-11-23 14:53:22.000000000 -0500
+++ irqbalance-0.55/irqbalance-0.55/irqbalance.c 2008-03-18 06:33:03.000000000 -0400
@@ -22,7 +22,11 @@
#include <stdio.h>
#include <stdlib.h>
#include <malloc.h>
+#include <fcntl.h>
+#include <string.h>
#include <sys/time.h>
+#include <sys/types.h>
+#include <sys/stat.h>
#include "irqbalance.h"
@@ -52,6 +56,9 @@ void sleep_approx(int seconds)
int main(int argc, char** argv)
{
+ int pidf;
+ char buf[16];
+
if (argc>1 && strstr(argv[1],"debug"))
debug_mode=1;
if (argc>1 && strstr(argv[1],"oneshot"))
@@ -67,9 +74,9 @@ int main(int argc, char** argv)
if (getenv("IRQBALANCE_DEBUG"))
debug_mode=1;
+ /* Initial parse to get correct core count */
parse_cpu_tree();
-
/* On single core UP systems irqbalance obviously has no work to do */
if (core_count<2)
exit(EXIT_SUCCESS);
@@ -82,6 +89,19 @@ int main(int argc, char** argv)
if (daemon(0,0))
exit(EXIT_FAILURE);
+ pidf = open("/var/run/irqbalance.pid",O_RDWR|O_CREAT|O_EXCL,0666);
+ if (pidf < 0)
+ exit(EXIT_FAILURE);
+
+ snprintf(buf, 16, "%d", getpid());
+ if (write(pidf, buf, strlen(buf)) < strlen(buf)) {
+ close(pidf);
+ unlink("/var/run/irqbalance.pid");
+ exit(EXIT_FAILURE);
+ }
+
+ close(pidf);
+
parse_proc_interrupts();
sleep(SLEEP_INTERVAL/4);
reset_counts();
@@ -134,5 +154,8 @@ int main(int argc, char** argv)
break;
counter++;
}
+
+ unlink("/var/run/irqbalance.pid");
+
return EXIT_SUCCESS;
}

View File

@ -1,17 +0,0 @@
diff -up irqbalance-0.55/irqbalance-0.55/Makefile.orig irqbalance-0.55/irqbalance-0.55/Makefile
--- irqbalance-0.55/irqbalance-0.55/Makefile.orig 2006-12-05 08:15:23.000000000 -0500
+++ irqbalance-0.55/irqbalance-0.55/Makefile 2007-09-28 14:10:01.000000000 -0400
@@ -1,11 +1,11 @@
-CFLAGS+=-g -Os -D_FORTIFY_SOURCE=2 -Wall -W `pkg-config --cflags glib-2.0`
+CFLAGS+=-g -Os -Os -pie -fpie -D_FORTIFY_SOURCE=2 -Wall -W `pkg-config --cflags glib-2.0`
all: irqbalance
LIBS=bitmap.o irqbalance.o cputree.o procinterrupts.o irqlist.o placement.o activate.o network.o powermode.o numa.o classify.o
irqbalance: .depend $(LIBS)
- gcc -g -O2 -D_FORTIFY_SOURCE=2 -Wall `pkg-config --libs glib-2.0` $(LIBS) -o irqbalance
+ gcc -g -D_FORTIFY_SOURCE=2 -Wall -Os -Wl,-z,relro,-z,now -pie -fpie `pkg-config --libs glib-2.0` $(LIBS) -o irqbalance
clean:
rm -f irqbalance *~ *.o .depend

View File

@ -1,12 +1,12 @@
Summary: IRQ balancing daemon
Name: irqbalance
Version: 0.55
Release: 25%{?dist}
Version: 0.56
Release: 1%{?dist}
Epoch: 2
Group: System Environment/Base
License: GPLv2
Url: http://irqbalance.org/
Source0: http://www.irqbalance.org/releases/irqbalance-%{version}.tar.gz
Source0: http://irqbalance.googlecode.com/files/irqbalance-%{version}.tbz2
Source1: irqbalance.init
Source2: irqbalance.sysconfig
Source3: irqbalance.1
@ -20,10 +20,6 @@ ExclusiveArch: %{ix86} x86_64 ia64 ppc ppc64
Obsoletes: kernel-utils
BuildRequires: glib2-devel pkgconfig imake libcap-ng-devel
Patch0: irqbalance-pie.patch
Patch1: irqbalance-0.55-cputree-parse.patch
Patch2: irqbalance-0.55-pid-file.patch
Patch3: irqbalance-0.55-config-capng.patch
%description
irqbalance is a daemon that evenly distributes IRQ load across
@ -32,10 +28,6 @@ multiple CPUs for enhanced performance.
%prep
%setup -q -c -a 0
#%patch0 -p1
%patch1 -p1
%patch2 -p1
%patch3 -p1
touch %{name}-%{version}/NEWS
touch %{name}-%{version}/AUTHORS
touch %{name}-%{version}/README
@ -82,6 +74,9 @@ exit 0
%changelog
* Thu Jun 10 2010 Neil Horman <nhorman@redhat.com> - 2:0.56-1
- Updated to latest upstream version
* Wed Sep 09 2009 Neil Horman <nhorman@redhat.com> - 2:0.55-25
- Fixing BuildRequires

View File

@ -1 +1 @@
9f6b314ff1fdc14173abeb40592d4edf irqbalance-0.55.tar.gz
cd0c4d3b2bb84778a04fc594ad83949a irqbalance-0.56.tbz2