import irqbalance-1.8.0-4.el9
This commit is contained in:
commit
b5bfc66599
1
.gitignore
vendored
Normal file
1
.gitignore
vendored
Normal file
@ -0,0 +1 @@
|
||||
SOURCES/irqbalance-1.8.0.tar.gz
|
1
.irqbalance.metadata
Normal file
1
.irqbalance.metadata
Normal file
@ -0,0 +1 @@
|
||||
b4446192904bafcaf32dd8d389d2b7502fa9fd09 SOURCES/irqbalance-1.8.0.tar.gz
|
@ -0,0 +1,159 @@
|
||||
From 4342acd8d7862e862e0b661135b10671ffeac119 Mon Sep 17 00:00:00 2001
|
||||
From: Kairui Song <kasong@redhat.com>
|
||||
Date: Thu, 22 Jul 2021 03:05:59 +0800
|
||||
Subject: [PATCH] Disable the communication socket when UI is disabled
|
||||
|
||||
The communication socket is added to support the UI, when UI is not
|
||||
built, also disable the socket.
|
||||
|
||||
Signed-off-by: Kairui Song <kasong@redhat.com>
|
||||
---
|
||||
configure.ac | 11 +++++++----
|
||||
cputree.c | 4 ++++
|
||||
irqbalance.c | 23 ++++++++++++++++-------
|
||||
3 files changed, 27 insertions(+), 11 deletions(-)
|
||||
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index 92a5113..c45b9ce 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -41,10 +41,13 @@ AC_C_INLINE
|
||||
AM_PROG_CC_C_O
|
||||
|
||||
AC_ARG_WITH([irqbalance-ui],
|
||||
- [AC_HELP_STRING([--without-irqbalance-ui],
|
||||
- [Dont build the irqbalance ui component])],
|
||||
- [with_irqbalanceui=$withval], [with_irqbalanceui=yes])
|
||||
-
|
||||
+ [AS_HELP_STRING([--without-irqbalance-ui],
|
||||
+ [Dont build the irqbalance ui component])],
|
||||
+ [with_irqbalanceui=$withval], [with_irqbalanceui=yes])
|
||||
+AS_IF(
|
||||
+ [test "x$with_irqbalanceui" = "xyes"], [
|
||||
+ AC_DEFINE([HAVE_IRQBALANCEUI], 1, [Build irqbalance ui component.])
|
||||
+])
|
||||
AM_CONDITIONAL([IRQBALANCEUI], [test x$with_irqbalanceui = xyes])
|
||||
|
||||
AC_ARG_WITH([systemd],
|
||||
diff --git a/cputree.c b/cputree.c
|
||||
index e4695f2..b716a8f 100644
|
||||
--- a/cputree.c
|
||||
+++ b/cputree.c
|
||||
@@ -39,7 +39,9 @@
|
||||
|
||||
#include "irqbalance.h"
|
||||
|
||||
+#ifdef HAVE_IRQBALANCEUI
|
||||
extern char *banned_cpumask_from_ui;
|
||||
+#endif
|
||||
extern char *cpu_ban_string;
|
||||
|
||||
GList *cpus;
|
||||
@@ -113,12 +115,14 @@ static void setup_banned_cpus(void)
|
||||
cpumask_t isolated_cpus;
|
||||
char *env = NULL;
|
||||
|
||||
+#ifdef HAVE_IRQBALANCEUI
|
||||
/* A manually specified cpumask overrides auto-detection. */
|
||||
if (cpu_ban_string != NULL && banned_cpumask_from_ui != NULL) {
|
||||
cpulist_parse(banned_cpumask_from_ui,
|
||||
strlen(banned_cpumask_from_ui), banned_cpus);
|
||||
goto out;
|
||||
}
|
||||
+#endif
|
||||
|
||||
/*
|
||||
* Notes:
|
||||
diff --git a/irqbalance.c b/irqbalance.c
|
||||
index 3f94847..07a245f 100644
|
||||
--- a/irqbalance.c
|
||||
+++ b/irqbalance.c
|
||||
@@ -31,22 +31,21 @@
|
||||
#include <time.h>
|
||||
#include <sys/types.h>
|
||||
#include <sys/stat.h>
|
||||
-#include <sys/socket.h>
|
||||
-#include <sys/un.h>
|
||||
#include <fcntl.h>
|
||||
#include <inttypes.h>
|
||||
#ifdef HAVE_GETOPT_LONG
|
||||
#include <getopt.h>
|
||||
#endif
|
||||
-
|
||||
#ifdef HAVE_LIBCAP_NG
|
||||
#include <cap-ng.h>
|
||||
#endif
|
||||
+#ifdef HAVE_IRQBALANCEUI
|
||||
+#include <sys/un.h>
|
||||
+#include <sys/socket.h>
|
||||
+#endif
|
||||
#include "irqbalance.h"
|
||||
|
||||
volatile int keep_going = 1;
|
||||
-int socket_fd;
|
||||
-char socket_name[64];
|
||||
int one_shot_mode;
|
||||
int debug_mode;
|
||||
int foreground_mode;
|
||||
@@ -67,9 +66,14 @@ int last_interval;
|
||||
GMainLoop *main_loop;
|
||||
|
||||
char *cpu_ban_string = NULL;
|
||||
-char *banned_cpumask_from_ui = NULL;
|
||||
unsigned long migrate_ratio = 0;
|
||||
|
||||
+#ifdef HAVE_IRQBALANCEUI
|
||||
+int socket_fd;
|
||||
+char socket_name[64];
|
||||
+char *banned_cpumask_from_ui = NULL;
|
||||
+#endif
|
||||
+
|
||||
static void sleep_approx(int seconds)
|
||||
{
|
||||
struct timespec ts;
|
||||
@@ -405,6 +409,7 @@ void get_object_stat(struct topo_obj *object, void *data)
|
||||
}
|
||||
}
|
||||
|
||||
+#ifdef HAVE_IRQBALANCEUI
|
||||
gboolean sock_handle(gint fd, GIOCondition condition, gpointer user_data __attribute__((unused)))
|
||||
{
|
||||
char buff[500];
|
||||
@@ -585,6 +590,7 @@ int init_socket()
|
||||
g_unix_fd_add(socket_fd, G_IO_IN, sock_handle, NULL);
|
||||
return 0;
|
||||
}
|
||||
+#endif
|
||||
|
||||
int main(int argc, char** argv)
|
||||
{
|
||||
@@ -688,10 +694,12 @@ int main(int argc, char** argv)
|
||||
parse_proc_interrupts();
|
||||
parse_proc_stat();
|
||||
|
||||
+#ifdef HAVE_IRQBALANCEUI
|
||||
if (init_socket()) {
|
||||
ret = EXIT_FAILURE;
|
||||
goto out;
|
||||
}
|
||||
+#endif
|
||||
main_loop = g_main_loop_new(NULL, FALSE);
|
||||
last_interval = sleep_interval;
|
||||
g_timeout_add_seconds(sleep_interval, scan, NULL);
|
||||
@@ -707,11 +715,12 @@ out:
|
||||
/* Remove pidfile */
|
||||
if (!foreground_mode && pidfile)
|
||||
unlink(pidfile);
|
||||
+#ifdef HAVE_IRQBALANCEUI
|
||||
/* Remove socket */
|
||||
if (socket_fd > 0)
|
||||
close(socket_fd);
|
||||
if (socket_name[0])
|
||||
unlink(socket_name);
|
||||
-
|
||||
+#endif
|
||||
return ret;
|
||||
}
|
||||
--
|
||||
2.31.1
|
||||
|
@ -0,0 +1,32 @@
|
||||
From efab2725ea5165732c5e98c0e083a4eec6e355e3 Mon Sep 17 00:00:00 2001
|
||||
From: Kairui Song <kasong@redhat.com>
|
||||
Date: Fri, 24 Sep 2021 17:43:30 +0800
|
||||
Subject: [PATCH] Drop CapabilityBoundingSet from irqbalance service
|
||||
|
||||
libcapng is issuing an error in the system log when irqbalance attempts
|
||||
to drop capabilities, but systemd service unit has already done dropped
|
||||
all capabilities. commit 43751df tried to fix this but it didn't fix it
|
||||
completely. CapabilityBoundingSet also need to be dropped.
|
||||
|
||||
Fixes #182
|
||||
|
||||
Signed-off-by: Kairui Song <kasong@redhat.com>
|
||||
---
|
||||
misc/irqbalance.service | 1 -
|
||||
1 file changed, 1 deletion(-)
|
||||
|
||||
diff --git a/misc/irqbalance.service b/misc/irqbalance.service
|
||||
index 014798c..fcc29c2 100644
|
||||
--- a/misc/irqbalance.service
|
||||
+++ b/misc/irqbalance.service
|
||||
@@ -8,7 +8,6 @@ ConditionVirtualization=!container
|
||||
EnvironmentFile=-/usr/lib/irqbalance/defaults.env
|
||||
EnvironmentFile=-/path/to/irqbalance.env
|
||||
ExecStart=/usr/sbin/irqbalance --foreground $IRQBALANCE_ARGS
|
||||
-CapabilityBoundingSet=
|
||||
ReadOnlyPaths=/
|
||||
ReadWritePaths=/proc/irq
|
||||
RestrictAddressFamilies=AF_UNIX
|
||||
--
|
||||
2.31.1
|
||||
|
@ -0,0 +1,31 @@
|
||||
From 43751dfc7f29fbf2c46ffcd4fdb6d3f6db291927 Mon Sep 17 00:00:00 2001
|
||||
From: Neil Horman <nhorman@gmail.com>
|
||||
Date: Wed, 12 May 2021 09:26:10 -0400
|
||||
Subject: [PATCH] drop NoNewPrivs from irqbalance service
|
||||
|
||||
A recent update to libcapng is issuing an error in the system log,
|
||||
caused by the fact that irqbalance attempts to drop capabilities when
|
||||
the systemd service unit has already done so for us. Since irqbalance
|
||||
drops the caps correctly, theres really no need for us to do so via
|
||||
systemd as well. So lets drop NoNewCaps in the service unit.
|
||||
|
||||
Signed-off-by: Neil Horman <nhorman@tuxdriver.com>
|
||||
---
|
||||
misc/irqbalance.service | 1 -
|
||||
1 file changed, 1 deletion(-)
|
||||
|
||||
diff --git a/misc/irqbalance.service b/misc/irqbalance.service
|
||||
index e7a3336..014798c 100644
|
||||
--- a/misc/irqbalance.service
|
||||
+++ b/misc/irqbalance.service
|
||||
@@ -9,7 +9,6 @@ EnvironmentFile=-/usr/lib/irqbalance/defaults.env
|
||||
EnvironmentFile=-/path/to/irqbalance.env
|
||||
ExecStart=/usr/sbin/irqbalance --foreground $IRQBALANCE_ARGS
|
||||
CapabilityBoundingSet=
|
||||
-NoNewPrivileges=yes
|
||||
ReadOnlyPaths=/
|
||||
ReadWritePaths=/proc/irq
|
||||
RestrictAddressFamilies=AF_UNIX
|
||||
--
|
||||
2.31.1
|
||||
|
28
SOURCES/irqbalance.sysconfig
Normal file
28
SOURCES/irqbalance.sysconfig
Normal file
@ -0,0 +1,28 @@
|
||||
# irqbalance is a daemon process that distributes interrupts across
|
||||
# CPUS on SMP systems. The default is to rebalance once every 10
|
||||
# seconds. This is the environment file that is specified to systemd via the
|
||||
# EnvironmentFile key in the service unit file (or via whatever method the init
|
||||
# system you're using has.
|
||||
#
|
||||
# ONESHOT=yes
|
||||
# after starting, wait for a minute, then look at the interrupt
|
||||
# load and balance it once; after balancing exit and do not change
|
||||
# it again.
|
||||
#IRQBALANCE_ONESHOT=
|
||||
|
||||
#
|
||||
# IRQBALANCE_BANNED_CPUS
|
||||
# 64 bit bitmask which allows you to indicate which cpu's should
|
||||
# be skipped when reblancing irqs. Cpu numbers which have their
|
||||
# corresponding bits set to one in this mask will not have any
|
||||
# irq's assigned to them on rebalance
|
||||
#
|
||||
#IRQBALANCE_BANNED_CPUS=
|
||||
|
||||
#
|
||||
# IRQBALANCE_ARGS
|
||||
# append any args here to the irqbalance daemon as documented in the man page
|
||||
#
|
||||
#IRQBALANCE_ARGS=
|
||||
|
||||
|
410
SPECS/irqbalance.spec
Normal file
410
SPECS/irqbalance.spec
Normal file
@ -0,0 +1,410 @@
|
||||
Name: irqbalance
|
||||
Version: 1.8.0
|
||||
Release: 4%{?dist}
|
||||
Epoch: 2
|
||||
Summary: IRQ balancing daemon
|
||||
|
||||
License: GPLv2
|
||||
Url: https://github.com/Irqbalance/irqbalance
|
||||
Source0: https://github.com/Irqbalance/irqbalance/archive/irqbalance-%{version}.tar.gz
|
||||
Source1: irqbalance.sysconfig
|
||||
|
||||
BuildRequires: autoconf automake libtool libcap-ng
|
||||
BuildRequires: glib2-devel pkgconf libcap-ng-devel
|
||||
BuildRequires: systemd ncurses-devel
|
||||
BuildRequires: make
|
||||
Requires: ncurses-libs
|
||||
%ifnarch %{arm}
|
||||
BuildRequires: numactl-devel
|
||||
Requires: numactl-libs
|
||||
%endif
|
||||
|
||||
%define _hardened_build 1
|
||||
|
||||
ExcludeArch: s390 s390x
|
||||
|
||||
Patch1: irqbalance-1.8.0-drop-NoNewPrivs-from-irqbalance-service.patch
|
||||
Patch2: irqbalance-1.8.0-Disable-the-communication-socket-when-UI-is-disabled.patch
|
||||
Patch3: irqbalance-1.8.0-Drop-CapabilityBoundingSet-from-irqbalance-service.patch
|
||||
|
||||
%description
|
||||
irqbalance is a daemon that evenly distributes IRQ load across
|
||||
multiple CPUs for enhanced performance.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch1 -p1
|
||||
%patch2 -p1
|
||||
%patch3 -p1
|
||||
|
||||
%build
|
||||
./autogen.sh
|
||||
%configure --without-irqbalance-ui
|
||||
CFLAGS="%{optflags}" make %{?_smp_mflags}
|
||||
|
||||
%install
|
||||
install -D -p -m 0755 %{name} %{buildroot}%{_sbindir}/%{name}
|
||||
install -D -p -m 0644 ./misc/irqbalance.service %{buildroot}/%{_unitdir}/irqbalance.service
|
||||
install -D -p -m 0644 %{SOURCE1} %{buildroot}%{_sysconfdir}/sysconfig/%{name}
|
||||
|
||||
install -d %{buildroot}%{_mandir}/man1/
|
||||
install -p -m 0644 ./irqbalance.1 %{buildroot}%{_mandir}/man1/
|
||||
|
||||
%check
|
||||
make check
|
||||
|
||||
%files
|
||||
%doc COPYING AUTHORS
|
||||
%{_sbindir}/irqbalance
|
||||
%{_unitdir}/irqbalance.service
|
||||
%{_mandir}/man1/*
|
||||
%config(noreplace) %{_sysconfdir}/sysconfig/irqbalance
|
||||
|
||||
%post
|
||||
%systemd_post irqbalance.service
|
||||
|
||||
%preun
|
||||
%systemd_preun irqbalance.service
|
||||
|
||||
%postun
|
||||
%systemd_postun_with_restart irqbalance.service
|
||||
|
||||
%triggerun -- irqbalance < 2:0.56-3
|
||||
if /sbin/chkconfig --level 3 irqbalance ; then
|
||||
/bin/systemctl enable irqbalance.service >/dev/null 2>&1 || :
|
||||
fi
|
||||
/sbin/chkconfig --del irqbalance >/dev/null 2>&1 || :
|
||||
|
||||
%changelog
|
||||
* Mon Sep 27 2021 Kairui Song <kasong@redhat.com> - 2:1.8.0-4
|
||||
- Drop CapabilityBoundingSet from irqbalance service. Resolves: rhbz1963152
|
||||
|
||||
* Mon Aug 09 2021 Mohan Boddu <mboddu@redhat.com> - 2:1.8.0-3
|
||||
- Rebuilt for IMA sigs, glibc 2.34, aarch64 flags
|
||||
Related: rhbz#1991688
|
||||
|
||||
* Fri Aug 06 2021 Kairui Song <kasong@redhat.com> - 2:1.8.0-2
|
||||
- Disable the communication socket when UI is disabled. Resolves: rhbz1951292
|
||||
- drop NoNewPrivs from irqbalance service. Resolves: rhbz1963152
|
||||
|
||||
* Fri Jul 30 2021 Kairui Song <kasong@redhat.com> - 2:1.8.0-1
|
||||
- Rebase to latest upstream release
|
||||
|
||||
* Fri Apr 16 2021 Mohan Boddu <mboddu@redhat.com> - 2:1.7.0-6
|
||||
- Rebuilt for RHEL 9 BETA on Apr 15th 2021. Related: rhbz#1947937
|
||||
|
||||
* Tue Jan 26 2021 Fedora Release Engineering <releng@fedoraproject.org> - 2:1.7.0-5
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
|
||||
|
||||
* Wed Aug 05 2020 Peter Robinson <pbrobinson@fedoraproject.org> - 2:1.7.0-4
|
||||
- Epoch never can go backwards
|
||||
|
||||
* Tue Aug 04 2020 Neil Horman <nhorman@redhat.com> - 2:1.7.0-1
|
||||
- Update to latest upstream (bz 1866002)
|
||||
|
||||
* Tue Jul 28 2020 Fedora Release Engineering <releng@fedoraproject.org> - 2:1.6.0-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
|
||||
|
||||
* Thu Jun 04 2020 Adam Williamson <awilliam@redhat.com> - 2:1.6.0-2
|
||||
- Restore environment file patch and fix service start (thanks Ondřej Lysoněk)
|
||||
|
||||
* Wed Jun 03 2020 Neil Horman <nhorman@redhat.com> - 2:1.6.0-1
|
||||
- Update to latest upstream (bz1712908)
|
||||
|
||||
* Wed Jan 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 2:1.4.0-5
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
|
||||
|
||||
* Thu Jul 25 2019 Fedora Release Engineering <releng@fedoraproject.org> - 2:1.4.0-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
|
||||
|
||||
* Fri Feb 01 2019 Fedora Release Engineering <releng@fedoraproject.org> - 2:1.4.0-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
|
||||
|
||||
* Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 2:1.4.0-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
|
||||
|
||||
* Mon May 14 2018 Neil Horman <nhorman@redhat.com> 2:1.4.0-1
|
||||
- Update to latest upstream release
|
||||
- Add CI harness
|
||||
|
||||
* Wed Feb 07 2018 Fedora Release Engineering <releng@fedoraproject.org> - 2:1.3.0-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
||||
|
||||
* Tue Nov 14 2017 Neil Horman <nhorman@redhat.com> - 2:1.3.0-1
|
||||
- Update to latest upstream
|
||||
* Wed Aug 02 2017 Fedora Release Engineering <releng@fedoraproject.org> - 2:1.2.0-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
|
||||
|
||||
* Wed Jul 26 2017 Fedora Release Engineering <releng@fedoraproject.org> - 2:1.2.0-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
|
||||
|
||||
* Fri Feb 10 2017 Fedora Release Engineering <releng@fedoraproject.org> - 2:1.2.0-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
|
||||
|
||||
* Fri Jan 13 2017 Petr Holasek <holasekp@gmail.com> - 2:1.2.0-1
|
||||
- Rebased to v1.2.0 (bz1411554)
|
||||
|
||||
* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 2:1.1.0-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
||||
|
||||
* Tue Dec 15 2015 Marcin Juszkiewicz <mjuszkiewicz@redhat.com> - 2:1.1.0-2
|
||||
- Fixed AArch64 support.
|
||||
|
||||
* Mon Dec 07 2015 Petr Holasek <pholasek@redhat.com> - 2:1.1.0-1
|
||||
- Rebased to v1.1.0 (bz1288674)
|
||||
|
||||
* Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2:1.0.9-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
|
||||
|
||||
* Wed Mar 18 2015 Petr Holasek <pholasek@redhat.com> - 2:1.0.9-1
|
||||
- Rebased to v1.0.9
|
||||
|
||||
* Mon Jan 05 2015 Petr Holasek <pholasek@redhat.com> - 2:1.0.8-1
|
||||
- Rebased to v1.0.8 (bz1176898)
|
||||
|
||||
* Sat Aug 16 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2:1.0.7-8
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
|
||||
|
||||
* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2:1.0.7-7
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
|
||||
|
||||
* Sun May 11 2014 Peter Robinson <pbrobinson@fedoraproject.org> 2:1.0.7-6
|
||||
- Switch ExclusiveArch to ExcludeArch as all but s390 is supported (also build for aarch64)
|
||||
|
||||
* Thu May 08 2014 Petr Holasek <pholasek@redhat.com> - 2:1.0.7-5
|
||||
- Fixed memory leak (bz1095915)
|
||||
|
||||
* Mon Feb 10 2014 Petr Holasek <pholasek@redhat.com> - 2:1.0.7-4
|
||||
- Missing autogen.sh call fixed
|
||||
|
||||
* Mon Feb 10 2014 Petr Holasek <pholasek@redhat.com> - 2:1.0.7-3
|
||||
- Irqbalance website address was fixed
|
||||
|
||||
* Fri Jan 10 2014 Petr Holasek <pholasek@redhat.com> - 2:1.0.7-2
|
||||
- ppc64le architecture support was enabled
|
||||
|
||||
* Fri Oct 11 2013 Petr Holasek <pholasek@redhat.com> - 2:1.0.7-1
|
||||
- Rebased to version 1.0.7
|
||||
|
||||
* Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2:1.0.6-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
|
||||
|
||||
* Mon Jul 22 2013 Peter Robinson <pbrobinson@fedoraproject.org> 2:1.0.6-3
|
||||
- Fix FTBFS on ARM, minor spec cleanups
|
||||
|
||||
* Thu Jul 18 2013 Petr Holasek <pholasek@redhat.com> - 2:1.0.6-2
|
||||
- Hardened build
|
||||
|
||||
* Mon Jun 10 2013 Petr Holasek <pholasek@redhat.com> - 2:1.0.6-1
|
||||
- Rebased to version 1.0.6
|
||||
|
||||
* Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2:1.0.5-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
|
||||
|
||||
* Mon Jan 21 2013 Petr Holasek <pholasek@redhat.com> - 2:1.0.5-1
|
||||
- Rebased to version 1.0.5
|
||||
|
||||
* Wed Aug 29 2012 Petr Holasek <pholasek@redhat.com> - 2:1.0.4-2
|
||||
- Env file path edited
|
||||
|
||||
* Mon Aug 27 2012 Petr Holasek <pholasek@redhat.com> - 2:1.0.4-1
|
||||
- Rebased to version 1.0.4
|
||||
|
||||
* Wed Aug 22 2012 Petr Holasek <pholasek@redhat.com> - 2:1.0.3-5
|
||||
- Make irqbalance scan for new irqs when it detects new irqs (bz832815)
|
||||
- Fixes SIGFPE crash for some banning configuration (bz849792)
|
||||
- Fixes affinity_hint values processing (bz832815)
|
||||
- Adds banirq and bansript options (bz837049)
|
||||
- imake isn't needed for building any more (bz844359)
|
||||
- Fixes clogging of syslog (bz837646)
|
||||
- Added IRQBALANCE_ARGS variable for passing arguments via systemd(bz837048)
|
||||
- Fixes --hint-policy=subset behavior (bz844381)
|
||||
|
||||
* Sun Apr 15 2012 Petr Holasek <pholasek@redhat.com> - 2:1.0.3-4
|
||||
- Updated libnuma dependencies
|
||||
|
||||
* Sun Feb 5 2012 Peter Robinson <pbrobinson@fedoraproject.org> - 2:1.0.3-3
|
||||
- Build on ARM
|
||||
|
||||
* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2:1.0.3-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
|
||||
|
||||
* Fri Dec 02 2011 Neil Horman <nhorman@redhat.com> - 2:1.0.3-1
|
||||
- Updated to latest upstream release
|
||||
|
||||
* Fri Nov 04 2011 Neil Horman <nhorman@redhat.com> - 2:1.0.2-1
|
||||
- Updated to latest upstream release
|
||||
|
||||
* Wed Oct 26 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2:1.0-4
|
||||
- Rebuilt for glibc bug#747377
|
||||
|
||||
* Fri Oct 21 2011 Neil Horman <nhorman@redhat.com> - 2:1.0-3
|
||||
- Fix another crash on non-numa systems (bz 748070)
|
||||
|
||||
* Mon Oct 17 2011 Neil Horman <nhorman@redhat.com> - 2:1.0-2
|
||||
- Fix crash for systems with no numa node support
|
||||
|
||||
* Wed Oct 12 2011 Neil Horman <nhorman@redhat.com> - 2:1.0-1
|
||||
- Update irqbalance to latest upstream version
|
||||
|
||||
* Fri May 6 2011 Bill Nottingham <notting@redhat.com> - 2:0.56-4
|
||||
- fix upgrade trigger
|
||||
|
||||
* Fri Apr 8 2011 Peter Robinson <pbrobinson@gmail.com> - 2:0.56-3
|
||||
- Fix build in rawhide
|
||||
- Add license file to rpm
|
||||
- Cleanup spec file
|
||||
|
||||
* Fri Mar 25 2011 Anton Arapov <anton@redhat.com> - 2:0.56-3
|
||||
- rework init in order to respect systemd. (bz 659622)
|
||||
|
||||
* Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2:0.56-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
|
||||
|
||||
* Thu Jun 10 2010 Neil Horman <nhorman@redhat.com> - 2:0.56-1
|
||||
- Updated to latest upstream version
|
||||
|
||||
* Wed Sep 09 2009 Neil Horman <nhorman@redhat.com> - 2:0.55-25
|
||||
- Fixing BuildRequires
|
||||
|
||||
* Fri Sep 04 2009 Neil Horman <nhorman@redhat.com> - 2:0.55-24
|
||||
- Fixing irqbalance initscript (bz 521246)
|
||||
|
||||
* Wed Sep 02 2009 Neil Horman <nhorman@redhat.com> - 2:0.55-23
|
||||
- Fixing BuildRequires for new config script
|
||||
|
||||
* Tue Sep 01 2009 Neil Horman <nhorman@redhat.com> - 2:0.55-22
|
||||
- Fixing BuildRequires for new config script
|
||||
|
||||
* Tue Sep 01 2009 Neil Horman <nhorman@redhat.com> - 2:0.55-21
|
||||
- Fixing BuildRequires for new config script
|
||||
|
||||
* Tue Sep 01 2009 Neil Horman <nhorman@redhat.com> - 2:0.55-20
|
||||
- Fixing BuildRequires for new config script
|
||||
|
||||
* Tue Sep 01 2009 Neil Horman <nhorman@redhat.com> - 2:0.55-19
|
||||
- Incorporate capng (bz 520699)
|
||||
|
||||
* Fri Jul 31 2009 Peter Lemenkov <lemenkov@gmail.com> - 2:0.55-18
|
||||
- Added back accidentaly forgotten imake
|
||||
|
||||
* Fri Jul 31 2009 Peter Lemenkov <lemenkov@gmail.com> - 2:0.55-17
|
||||
- Cosmetic fixes in spec-file
|
||||
- Fixed rpmlint error in the init-script
|
||||
|
||||
* Tue Jul 28 2009 Peter Lemenkov <lemenkov@gmail.com> - 2:0.55-16
|
||||
- Many imrovements in spec-file
|
||||
|
||||
* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2:0.55-15
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
|
||||
|
||||
* Fri Mar 6 2009 Neil Horman <nhorman@redhat.com>
|
||||
- Update spec file to build for i586 as per new build guidelines (bz 488849)
|
||||
|
||||
* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2:0.55-13
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
|
||||
|
||||
* Fri Dec 12 2008 Neil Norman <nhorman@redhat.com> - 2:0.55-12
|
||||
- Remove odd Netorking dependence from irqbalance (bz 476179)
|
||||
|
||||
* Fri Aug 01 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 2:0.55-11
|
||||
- fix license tag
|
||||
|
||||
* Wed Jun 04 2008 Neil Horman <nhorman@redhat.com> - 2:0.55-10
|
||||
- Update man page to explain why irqbalance exits on single cache (bz 449949)
|
||||
|
||||
* Tue Mar 18 2008 Neil Horman <nhorman@redhat.com> - 2:0.55-9
|
||||
- Rediff pid-file patch to not remove initial parse_cpu_tree (bz 433270)
|
||||
|
||||
* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 2:0.55-8
|
||||
- Autorebuild for GCC 4.3
|
||||
|
||||
* Thu Nov 01 2007 Neil Horman <nhorman@redhat.com> - 2:0.55-7
|
||||
- Update to properly hadndle pid files (bz 355231)
|
||||
|
||||
* Thu Oct 04 2007 Neil Horman <nhorman@redhat.com> - 2:0.55-6
|
||||
- Fix irqbalance init script (bz 317219)
|
||||
|
||||
* Fri Sep 28 2007 Neil Horman <nhorman@redhat.com> - 2:0.55-5
|
||||
- Install pie patch
|
||||
- Grab Ulis cpuparse cleanup (bz 310821)
|
||||
|
||||
* Wed Aug 29 2007 Fedora Release Engineering <rel-eng at fedoraproject dot org> - 2:0.55-4
|
||||
- Rebuild for selinux ppc32 issue.
|
||||
|
||||
* Thu Jul 05 2007 Neil Horman <nhorman@redhat.com> - 0.55.3
|
||||
- Fixing LSB requirements (bz 246959)
|
||||
|
||||
* Tue Dec 12 2006 Neil Horman <nhorman@redhat.com> - 0.55-2
|
||||
- Fixing typos in spec file (bz 219301)
|
||||
|
||||
* Tue Dec 12 2006 Neil Horman <nhorman@redhat.com> - 0.55-1
|
||||
- Updating to version 0.55
|
||||
|
||||
* Mon Dec 11 2006 Neil Horman <nhorman@redhat.com> - 0.54-1
|
||||
- Update irqbalance to new version released at www.irqbalance.org
|
||||
|
||||
* Wed Nov 15 2006 Neil Horman <nhorman@redhat.com> - 1.13-8
|
||||
- Add ability to set default affinity mask (bz 211148)
|
||||
|
||||
* Wed Nov 08 2006 Neil Horman <nhorman@redhat.com> - 1.13-7
|
||||
- fix up irqbalance to detect multicore (not ht) (bz 211183)
|
||||
|
||||
* Thu Nov 02 2006 Neil Horman <nhorman@redhat.com> - 1.13-6
|
||||
- bumping up MAX_INTERRUPTS to support xen kernels
|
||||
- rediffing patch1 and patch3 to remove fuzz
|
||||
|
||||
* Tue Oct 17 2006 Neil Horman <nhorman@redhat.com> - 1.13-5
|
||||
- Making oneshot mean oneshot always (bz 211178)
|
||||
|
||||
* Wed Sep 13 2006 Peter Jones <pjones@redhat.com> - 1.13-4
|
||||
- Fix subsystem locking
|
||||
|
||||
* Fri Aug 18 2006 Jesse Keating <jkeating@redhat.com> - 1.13-2
|
||||
- rebuilt with latest binutils to pick up 64K -z commonpagesize on ppc*
|
||||
(#203001)
|
||||
- Remove hack to use cvs checkin ID as release as it doesn't follow
|
||||
packaging guidelines
|
||||
|
||||
* Tue Aug 01 2006 Neil Horman <nhorman@redhat.com>
|
||||
- Change license to GPL in version 0.13
|
||||
|
||||
* Sat Jul 29 2006 Dave Jones <davej@redhat.com>
|
||||
- identify a bunch more classes.
|
||||
|
||||
* Fri Jul 14 2006 Jesse Keating <jkeating@redhat.com>
|
||||
- rebuild
|
||||
|
||||
* Tue Jul 11 2006 Dave Jones <davej@redhat.com>
|
||||
- Further lazy rebalancing tweaks.
|
||||
|
||||
* Sun Feb 26 2006 Dave Jones <davej@redhat.com>
|
||||
- Don't rebalance IRQs where no interrupts have occured.
|
||||
|
||||
* Sun Feb 12 2006 Dave Jones <davej@redhat.com>
|
||||
- Build for ppc[64] too.
|
||||
|
||||
* Thu Feb 09 2006 Dave Jones <davej@redhat.com>
|
||||
- rebuild.
|
||||
|
||||
* Fri Dec 16 2005 Jesse Keating <jkeating@redhat.com>
|
||||
- rebuilt for new gcj
|
||||
|
||||
* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
|
||||
- rebuilt
|
||||
|
||||
* Tue Mar 1 2005 Dave Jones <davej@redhat.com>
|
||||
- Rebuild with gcc4
|
||||
|
||||
* Tue Feb 8 2005 Dave Jones <davej@redhat.com>
|
||||
- Build as pie, also -D_FORTIFY_SOURCE=2
|
||||
|
||||
* Tue Jan 11 2005 Dave Jones <davej@redhat.com>
|
||||
- Add missing Obsoletes: kernel-utils.
|
||||
|
||||
* Mon Jan 10 2005 Dave Jones <davej@redhat.com>
|
||||
- Start irqbalance in runlevel 2 too. (#102064)
|
||||
|
||||
* Sat Dec 18 2004 Dave Jones <davej@redhat.com>
|
||||
- Initial packaging, based on kernel-utils.
|
||||
|
Loading…
Reference in New Issue
Block a user