RHEL integration
Include bugfix and configuration patches from RHEL Disable cross compilation on RHEL Signed-off-by: Paolo Bonzini <pbonzini@redhat.com>
This commit is contained in:
parent
06872636a9
commit
027a024fae
@ -1,27 +0,0 @@
|
|||||||
From b20b539a701c14af82d94b8ff7c22282fe5454d3 Mon Sep 17 00:00:00 2001
|
|
||||||
Message-Id: <b20b539a701c14af82d94b8ff7c22282fe5454d3.1480892146.git.crobinso@redhat.com>
|
|
||||||
From: Cole Robinson <crobinso@redhat.com>
|
|
||||||
Date: Tue, 17 Nov 2015 11:56:06 -0500
|
|
||||||
Subject: [PATCH ipxe] build: Enable IPv6 for in qemu config
|
|
||||||
|
|
||||||
---
|
|
||||||
A fedora user requested it here:
|
|
||||||
https://bugzilla.redhat.com/show_bug.cgi?id=1280318
|
|
||||||
|
|
||||||
src/config/qemu/general.h | 3 +++
|
|
||||||
1 file changed, 3 insertions(+)
|
|
||||||
|
|
||||||
diff --git a/src/config/qemu/general.h b/src/config/qemu/general.h
|
|
||||||
index a084497..e94eee2 100644
|
|
||||||
--- a/src/config/qemu/general.h
|
|
||||||
+++ b/src/config/qemu/general.h
|
|
||||||
@@ -13,3 +13,6 @@
|
|
||||||
* without unrestricted_guest support
|
|
||||||
*/
|
|
||||||
#undef TIVOLI_VMM_WORKAROUND
|
|
||||||
+
|
|
||||||
+/* Enable IPv6 */
|
|
||||||
+#define NET_PROTO_IPV6
|
|
||||||
--
|
|
||||||
2.9.3
|
|
||||||
|
|
17
0001-build-customize-configuration.patch
Normal file
17
0001-build-customize-configuration.patch
Normal file
@ -0,0 +1,17 @@
|
|||||||
|
From: Paolo Bonzini <pbonzini@redhat.com>
|
||||||
|
Date: Tue, 17 Nov 2015 11:56:06 -0500
|
||||||
|
Subject: [PATCH ipxe] build: customize configuration
|
||||||
|
|
||||||
|
diff --git a/src/config/local/general.h b/src/config/local/general.h
|
||||||
|
index 5814511..47d0e1a 100644
|
||||||
|
--- a/src/config/local/general.h
|
||||||
|
+++ b/src/config/local/general.h
|
||||||
|
@@ -0,0 +1,5 @@
|
||||||
|
+#undef ROM_BANNER_TIMEOUT
|
||||||
|
+#define ROM_BANNER_TIMEOUT 0
|
||||||
|
+
|
||||||
|
+/* Enable IPv6. */
|
||||||
|
+#define NET_PROTO_IPV6
|
||||||
|
--
|
||||||
|
2.9.3
|
||||||
|
|
16
ipxe.spec
16
ipxe.spec
@ -1,3 +1,6 @@
|
|||||||
|
%if 0%{?fedora}
|
||||||
|
%global cross 1
|
||||||
|
%endif
|
||||||
|
|
||||||
# Resulting binary formats we want from iPXE
|
# Resulting binary formats we want from iPXE
|
||||||
%global formats rom
|
%global formats rom
|
||||||
@ -20,7 +23,11 @@
|
|||||||
#
|
#
|
||||||
# We do cross-compilation for 32->64-bit, but not for other arches
|
# We do cross-compilation for 32->64-bit, but not for other arches
|
||||||
# because EDK II does not support big-endian hosts.
|
# because EDK II does not support big-endian hosts.
|
||||||
|
%if 0%{?cross}
|
||||||
%global buildarches %{ix86} x86_64
|
%global buildarches %{ix86} x86_64
|
||||||
|
%else
|
||||||
|
%global buildarches x86_64
|
||||||
|
%endif
|
||||||
|
|
||||||
# debugging firmwares does not go the same way as a normal program.
|
# debugging firmwares does not go the same way as a normal program.
|
||||||
# moreover, all architectures providing debuginfo for a single noarch
|
# moreover, all architectures providing debuginfo for a single noarch
|
||||||
@ -53,7 +60,7 @@ Source0: %{name}-%{version}-git%{hash}.tar.xz
|
|||||||
|
|
||||||
# Enable IPv6 for qemu's config
|
# Enable IPv6 for qemu's config
|
||||||
# Sent upstream: http://lists.ipxe.org/pipermail/ipxe-devel/2015-November/004494.html
|
# Sent upstream: http://lists.ipxe.org/pipermail/ipxe-devel/2015-November/004494.html
|
||||||
Patch0001: 0001-build-Enable-IPv6-for-in-qemu-config.patch
|
Patch0001: 0001-build-customize-configuration.patch
|
||||||
Patch0002: 0002-Use-spec-compliant-timeouts.patch
|
Patch0002: 0002-Use-spec-compliant-timeouts.patch
|
||||||
Patch0003: 0003-Strip-802.1Q-VLAN-0-priority-tags.patch
|
Patch0003: 0003-Strip-802.1Q-VLAN-0-priority-tags.patch
|
||||||
|
|
||||||
@ -67,7 +74,9 @@ BuildRequires: edk2-tools
|
|||||||
BuildRequires: xz-devel
|
BuildRequires: xz-devel
|
||||||
|
|
||||||
BuildRequires: binutils-devel
|
BuildRequires: binutils-devel
|
||||||
|
%if 0%{?cross}
|
||||||
BuildRequires: binutils-x86_64-linux-gnu gcc-x86_64-linux-gnu
|
BuildRequires: binutils-x86_64-linux-gnu gcc-x86_64-linux-gnu
|
||||||
|
%endif
|
||||||
|
|
||||||
Obsoletes: gpxe <= 1.0.1
|
Obsoletes: gpxe <= 1.0.1
|
||||||
|
|
||||||
@ -138,7 +147,9 @@ make_ipxe() {
|
|||||||
make %{?_smp_mflags} \
|
make %{?_smp_mflags} \
|
||||||
NO_WERROR=1 V=1 \
|
NO_WERROR=1 V=1 \
|
||||||
GITVERSION=%{hash} \
|
GITVERSION=%{hash} \
|
||||||
|
%if 0%{?cross}
|
||||||
CROSS_COMPILE=x86_64-linux-gnu- \
|
CROSS_COMPILE=x86_64-linux-gnu- \
|
||||||
|
%endif
|
||||||
"$@"
|
"$@"
|
||||||
}
|
}
|
||||||
|
|
||||||
@ -225,7 +236,8 @@ done
|
|||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
* Tue Nov 21 2017 Paolo Bonzini <pbonzini@redhat.com> - ipxe-20170710-2.git0600d3ae
|
* Tue Nov 21 2017 Paolo Bonzini <pbonzini@redhat.com> - ipxe-20170710-2.git0600d3ae
|
||||||
- Include bugfix patches from RHEL
|
- Include bugfix and configuration patches from RHEL
|
||||||
|
- Disable cross compilation on RHEL
|
||||||
|
|
||||||
* Thu Aug 03 2017 Cole Robinson <crobinso@redhat.com> - ipxe-20170710-1.git0600d3ae
|
* Thu Aug 03 2017 Cole Robinson <crobinso@redhat.com> - ipxe-20170710-1.git0600d3ae
|
||||||
- Update to ipxe 0600d3ae for qemu-2.10.0
|
- Update to ipxe 0600d3ae for qemu-2.10.0
|
||||||
|
Loading…
Reference in New Issue
Block a user