Update to 1.28
This commit is contained in:
parent
389892b152
commit
9eea89e552
1
.gitignore
vendored
1
.gitignore
vendored
@ -1,3 +1,4 @@
|
||||
ipvsadm-1.25.tar.gz
|
||||
/ipvsadm-1.26.tar.gz
|
||||
/ipvsadm-1.27.tar.gz
|
||||
/ipvsadm-1.28.tar.gz
|
||||
|
@ -1,27 +0,0 @@
|
||||
--- ipvsadm.c.orig 2013-09-06 04:37:27.000000000 -0400
|
||||
+++ ipvsadm.c 2014-02-21 03:10:36.117000000 -0500
|
||||
@@ -1240,14 +1240,13 @@
|
||||
char *argv[] = { "/sbin/modprobe", "--", "ip_vs", NULL };
|
||||
int child;
|
||||
int status;
|
||||
- int rc;
|
||||
|
||||
if (!(child = fork())) {
|
||||
execv(argv[0], argv);
|
||||
exit(1);
|
||||
}
|
||||
|
||||
- rc = waitpid(child, &status, 0);
|
||||
+ waitpid(child, &status, 0);
|
||||
|
||||
if (!WIFEXITED(status) || WEXITSTATUS(status)) {
|
||||
return 1;
|
||||
@@ -1429,7 +1428,7 @@
|
||||
static void print_largenum(unsigned long long i, unsigned int format)
|
||||
{
|
||||
char mytmp[32];
|
||||
- size_t len;
|
||||
+ int len;
|
||||
|
||||
if (format & FMT_EXACT) {
|
||||
len = snprintf(mytmp, 32, "%llu", i);
|
@ -1,30 +0,0 @@
|
||||
From cd824937ad6588be2ec701ee87fba6ee2626e515 Mon Sep 17 00:00:00 2001
|
||||
From: Ryan O'Hara <rohara@redhat.com>
|
||||
Date: Fri, 17 Jan 2014 11:53:46 -0600
|
||||
Subject: [PATCH] libipvs: Initialize ipvs_service_t variable
|
||||
|
||||
The ipvs_get_service function declares an ipvs_service_t type variable
|
||||
and initializes some of the values, but should really start by
|
||||
initializing the entire structure.
|
||||
|
||||
Signed-off-by: Ryan O'Hara <rohara@redhat.com>
|
||||
Signed-off-by: Jesper Dangaard Brouer <brouer@redhat.com>
|
||||
---
|
||||
libipvs/libipvs.c | 1 +
|
||||
1 file changed, 1 insertion(+)
|
||||
|
||||
diff --git a/libipvs/libipvs.c b/libipvs/libipvs.c
|
||||
index d2fec49..8baafed 100644
|
||||
--- a/libipvs/libipvs.c
|
||||
+++ b/libipvs/libipvs.c
|
||||
@@ -942,6 +942,7 @@ ipvs_get_service(__u32 fwmark, __u16 af, __u16 protocol, union nf_inet_addr addr
|
||||
if (!svc)
|
||||
return NULL;
|
||||
|
||||
+ memset(&tsvc, 0, sizeof(tsvc));
|
||||
tsvc.fwmark = fwmark;
|
||||
tsvc.af = af;
|
||||
tsvc.protocol= protocol;
|
||||
--
|
||||
1.9.0
|
||||
|
@ -1,33 +0,0 @@
|
||||
From 8ca22ba019c0b4d72a54a0954fcc04848dba4579 Mon Sep 17 00:00:00 2001
|
||||
From: Ryan O'Hara <rohara@redhat.com>
|
||||
Date: Tue, 20 May 2014 22:04:09 -0500
|
||||
Subject: [PATCH] ipvsadm: Fix list daemon to show backup daemon
|
||||
|
||||
The list_daemon function in ipvsadm.c will show the master daemon
|
||||
twice, but never the backup daemon. This patch replaces the redundant
|
||||
check for IP_VS_STATE_MASTER with a check for IP_VS_STATE_BACKUP, then
|
||||
prints the appropriate message.
|
||||
|
||||
Signed-off-by: Ryan O'Hara <rohara@redhat.com>
|
||||
---
|
||||
ipvsadm.c | 4 ++--
|
||||
1 file changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/ipvsadm.c b/ipvsadm.c
|
||||
index 4c83a8b..755827f 100644
|
||||
--- a/ipvsadm.c
|
||||
+++ b/ipvsadm.c
|
||||
@@ -1732,8 +1732,8 @@ static void list_daemon(void)
|
||||
if (u[i].state & IP_VS_STATE_MASTER)
|
||||
printf("master sync daemon (mcast=%s, syncid=%d)\n",
|
||||
u[i].mcast_ifn, u[i].syncid);
|
||||
- if (u[i].state & IP_VS_STATE_MASTER)
|
||||
- printf("master sync daemon (mcast=%s, syncid=%d)\n",
|
||||
+ if (u[i].state & IP_VS_STATE_BACKUP)
|
||||
+ printf("backup sync daemon (mcast=%s, syncid=%d)\n",
|
||||
u[i].mcast_ifn, u[i].syncid);
|
||||
}
|
||||
free(u);
|
||||
--
|
||||
1.9.0
|
||||
|
14
ipvsadm.spec
14
ipvsadm.spec
@ -1,7 +1,7 @@
|
||||
Name: ipvsadm
|
||||
Summary: Utility to administer the Linux Virtual Server
|
||||
Version: 1.27
|
||||
Release: 7%{?dist}
|
||||
Version: 1.28
|
||||
Release: 1%{?dist}
|
||||
License: GPLv2+
|
||||
URL: https://kernel.org/pub/linux/utils/kernel/ipvsadm/
|
||||
|
||||
@ -9,10 +9,6 @@ Source0: https://kernel.org/pub/linux/utils/kernel/ipvsadm/%{name}-%{version}.ta
|
||||
Source1: ipvsadm.service
|
||||
Source2: ipvsadm-config
|
||||
|
||||
Patch0: ipvsadm-fix-warnings.patch
|
||||
Patch1: ipvsadm-init-variable.patch
|
||||
Patch2: ipvsadm-list-daemon.patch
|
||||
|
||||
Buildrequires: libnl3-devel
|
||||
Buildrequires: popt-devel
|
||||
BuildRequires: systemd
|
||||
@ -37,9 +33,6 @@ services. Supported Features include:
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p0
|
||||
%patch1 -p1
|
||||
%patch2 -p1
|
||||
|
||||
%build
|
||||
CFLAGS="%{optflags}" make
|
||||
@ -78,6 +71,9 @@ CFLAGS="%{optflags}" make
|
||||
%{_mandir}/man8/%{name}-save.8*
|
||||
|
||||
%changelog
|
||||
* Mon Feb 09 2015 - 1.28-1
|
||||
- Update to 1.28
|
||||
|
||||
* Sat Aug 16 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.27-7
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user