diff --git a/ipvsadm-1.25-activeconns.patch b/ipvsadm-1.25-activeconns.patch
new file mode 100644
index 0000000..5ce871d
--- /dev/null
+++ b/ipvsadm-1.25-activeconns.patch
@@ -0,0 +1,12 @@
+diff -Naupr ipvsadm-1.25.orig/libipvs/libipvs.c ipvsadm-1.25/libipvs/libipvs.c
+--- ipvsadm-1.25.orig/libipvs/libipvs.c 2008-09-23 18:13:56.000000000 +0200
++++ ipvsadm-1.25/libipvs/libipvs.c 2010-04-29 16:47:11.924157647 +0200
+@@ -747,7 +747,7 @@ static int ipvs_dests_parse_cb(struct nl
+ d->entrytable[i].l_threshold = nla_get_u32(dest_attrs[IPVS_DEST_ATTR_L_THRESH]);
+ d->entrytable[i].activeconns = nla_get_u32(dest_attrs[IPVS_DEST_ATTR_ACTIVE_CONNS]);
+ d->entrytable[i].inactconns = nla_get_u32(dest_attrs[IPVS_DEST_ATTR_INACT_CONNS]);
+- d->entrytable[i].activeconns = nla_get_u32(dest_attrs[IPVS_DEST_ATTR_PERSIST_CONNS]);
++ d->entrytable[i].persistconns = nla_get_u32(dest_attrs[IPVS_DEST_ATTR_PERSIST_CONNS]);
+ d->entrytable[i].af = d->af;
+
+ if (ipvs_parse_stats(&(d->entrytable[i].stats),
diff --git a/ipvsadm.spec b/ipvsadm.spec
index d20f6b4..e2b0516 100644
--- a/ipvsadm.spec
+++ b/ipvsadm.spec
@@ -1,7 +1,7 @@
Summary: Utility to administer the Linux Virtual Server
Name: ipvsadm
Version: 1.25
-Release: 4
+Release: 5%{?dist}
License: GPLv2+
Group: Applications/System
URL: http://www.linuxvirtualserver.org/software/ipvs.html
@@ -9,6 +9,7 @@ Source0: http://www.linuxvirtualserver.org/software/kernel-2.6/ipvsadm-%{version
Source1: ipvsadm.init
Patch0: ipvsadm-1.24-Makefile.patch
Patch1: ipvsadm-1.25-popt.patch
+Patch2: ipvsadm-1.25-activeconns.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
Buildrequires: libnl-devel
Buildrequires: popt-devel
@@ -24,6 +25,7 @@ offered by the Linux kernel.
%setup -q
%patch0 -p1
%patch1 -p1
+%patch2 -p1
%build
@@ -65,6 +67,9 @@ fi
%changelog
+* Thu Apr 29 2010 Matthias Saou 1.25-5
+- Include patch to fix activeconns when using the netlink interface (#573921).
+
* Fri Jul 24 2009 Fedora Release Engineering - 1.25-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild