Update to 1.27
This commit is contained in:
parent
b3398e3e3a
commit
703eb82cf4
1
.gitignore
vendored
1
.gitignore
vendored
@ -1,2 +1,3 @@
|
||||
ipvsadm-1.25.tar.gz
|
||||
/ipvsadm-1.26.tar.gz
|
||||
/ipvsadm-1.27.tar.gz
|
||||
|
@ -1,29 +0,0 @@
|
||||
diff -Naupr ipvsadm-1.26.orig/ipvsadm.c ipvsadm-1.26/ipvsadm.c
|
||||
--- ipvsadm-1.26.orig/ipvsadm.c 2011-02-06 20:38:57.000000000 -0600
|
||||
+++ ipvsadm-1.26/ipvsadm.c 2012-03-26 16:58:42.796919112 -0500
|
||||
@@ -1631,16 +1631,19 @@ void list_timeout(void)
|
||||
static void list_daemon(void)
|
||||
{
|
||||
ipvs_daemon_t *u;
|
||||
+ int i;
|
||||
|
||||
if (!(u = ipvs_get_daemon()))
|
||||
exit(1);
|
||||
|
||||
- if (u[0].state & IP_VS_STATE_MASTER)
|
||||
- printf("master sync daemon (mcast=%s, syncid=%d)\n",
|
||||
- u[0].mcast_ifn, u[0].syncid);
|
||||
- if (u[1].state & IP_VS_STATE_BACKUP)
|
||||
- printf("backup sync daemon (mcast=%s, syncid=%d)\n",
|
||||
- u[1].mcast_ifn, u[1].syncid);
|
||||
+ for (i = 0; i < 2; i++) {
|
||||
+ if (u[i].state & IP_VS_STATE_MASTER)
|
||||
+ printf("master sync daemon (mcast=%s, syncid=%d)\n",
|
||||
+ u[i].mcast_ifn, u[i].syncid);
|
||||
+ if (u[i].state & IP_VS_STATE_BACKUP)
|
||||
+ printf("backup sync daemon (mcast=%s, syncid=%d)\n",
|
||||
+ u[i].mcast_ifn, u[i].syncid);
|
||||
+ }
|
||||
free(u);
|
||||
}
|
||||
|
@ -1,20 +0,0 @@
|
||||
diff -Naupr ipvsadm-1.26.orig/Makefile ipvsadm-1.26/Makefile
|
||||
--- ipvsadm-1.26.orig/Makefile 2011-02-08 01:24:23.000000000 +0100
|
||||
+++ ipvsadm-1.26/Makefile 2011-07-09 23:22:54.834017156 +0200
|
||||
@@ -63,15 +63,7 @@ RPMBUILD = $(shell \
|
||||
fi )
|
||||
|
||||
ifeq (,$(FORCE_GETOPT))
|
||||
-LIB_SEARCH = /lib64 /usr/lib64 /usr/local/lib64 /lib /usr/lib /usr/local/lib
|
||||
-POPT_LIB = $(shell for i in $(LIB_SEARCH); do \
|
||||
- if [ -f $$i/libpopt.a ]; then \
|
||||
- if nm $$i/libpopt.a | fgrep -q poptGetContext; then \
|
||||
- echo "-lpopt"; \
|
||||
- break; \
|
||||
- fi; \
|
||||
- fi; \
|
||||
-done)
|
||||
+POPT_LIB = "-lpopt"
|
||||
endif
|
||||
|
||||
ifneq (,$(POPT_LIB))
|
26
ipvsadm.spec
26
ipvsadm.spec
@ -1,21 +1,22 @@
|
||||
Summary: Utility to administer the Linux Virtual Server
|
||||
Name: ipvsadm
|
||||
Version: 1.26
|
||||
Release: 9%{?dist}
|
||||
Summary: Utility to administer the Linux Virtual Server
|
||||
Version: 1.27
|
||||
Release: 1%{?dist}
|
||||
License: GPLv2+
|
||||
URL: https://kernel.org/pub/linux/utils/kernel/ipvsadm/
|
||||
Group: Applications/System
|
||||
URL: http://www.linuxvirtualserver.org/software/ipvs.html
|
||||
Source0: http://www.linuxvirtualserver.org/software/kernel-2.6/ipvsadm-%{version}.tar.gz
|
||||
|
||||
Source0: https://kernel.org/pub/linux/utils/kernel/ipvsadm/%{name}-%{version}.tar.gz
|
||||
Source1: ipvsadm.service
|
||||
Source2: ipvsadm-config
|
||||
Patch0: ipvsadm-1.26-popt.patch
|
||||
Patch1: ipvsadm-1.26-list-daemon.patch
|
||||
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
|
||||
Buildrequires: libnl-devel
|
||||
Buildrequires: popt-devel
|
||||
Requires(post): systemd-units
|
||||
Requires(preun): systemd-units
|
||||
Requires(postun): systemd-units
|
||||
BuildRequires: systemd
|
||||
Requires(post): systemd
|
||||
Requires(preun): systemd
|
||||
Requires(postun): systemd
|
||||
# For triggerun
|
||||
Requires(post): systemd-sysv
|
||||
|
||||
@ -26,8 +27,6 @@ offered by the Linux kernel.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1
|
||||
%patch1 -p1
|
||||
|
||||
|
||||
%build
|
||||
@ -84,6 +83,9 @@ rm -rf %{buildroot}
|
||||
|
||||
|
||||
%changelog
|
||||
* Fri Sep 06 2013 Ryan O'Hara <rohara@redhat.com> - 1.27-1
|
||||
- Update to 1.27
|
||||
|
||||
* Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.26-9
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user