Use CFLAGS and LDFLAGS environment variables (#1543790)
This commit is contained in:
parent
fd6cbda552
commit
1f290eadb3
@ -0,0 +1,52 @@
|
||||
From 25d7aa2faef0c36f053ee1ba418fe14022ef6f7c Mon Sep 17 00:00:00 2001
|
||||
From: Ryan O'Hara <rohara@redhat.com>
|
||||
Date: Tue, 27 Feb 2018 11:49:44 -0600
|
||||
Subject: [PATCH] ipvsadm: use CFLAGS and LDFLAGS environment variables
|
||||
|
||||
Signed-off-by: Ryan O'Hara <rohara@redhat.com>
|
||||
---
|
||||
Makefile | 6 +++---
|
||||
libipvs/Makefile | 2 +-
|
||||
2 files changed, 4 insertions(+), 4 deletions(-)
|
||||
|
||||
diff --git a/Makefile b/Makefile
|
||||
index 91a2991..2a1d179 100644
|
||||
--- a/Makefile
|
||||
+++ b/Makefile
|
||||
@@ -46,9 +46,9 @@ INSTALL = install
|
||||
STATIC_LIBS = libipvs/libipvs.a
|
||||
|
||||
ifeq "${ARCH}" "sparc64"
|
||||
- CFLAGS = -Wall -Wunused -Wstrict-prototypes -g -m64 -pipe -mcpu=ultrasparc -mcmodel=medlow
|
||||
+ CFLAGS += -Wall -Wunused -Wstrict-prototypes -g -m64 -pipe -mcpu=ultrasparc -mcmodel=medlow
|
||||
else
|
||||
- CFLAGS = -Wall -Wunused -Wstrict-prototypes -g
|
||||
+ CFLAGS += -Wall -Wunused -Wstrict-prototypes -g
|
||||
endif
|
||||
|
||||
|
||||
@@ -87,7 +87,7 @@ libs:
|
||||
make -C libipvs
|
||||
|
||||
ipvsadm: $(OBJS) $(STATIC_LIBS)
|
||||
- $(CC) $(CFLAGS) -o $@ $^ $(LIBS)
|
||||
+ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $^ $(LIBS)
|
||||
|
||||
install: all
|
||||
if [ ! -d $(SBIN) ]; then $(MKDIR) -p $(SBIN); fi
|
||||
diff --git a/libipvs/Makefile b/libipvs/Makefile
|
||||
index f845c8b..780f3f3 100644
|
||||
--- a/libipvs/Makefile
|
||||
+++ b/libipvs/Makefile
|
||||
@@ -1,7 +1,7 @@
|
||||
# Makefile for libipvs
|
||||
|
||||
CC = gcc
|
||||
-CFLAGS = -Wall -Wunused -Wstrict-prototypes -g -fPIC
|
||||
+CFLAGS += -Wall -Wunused -Wstrict-prototypes -g -fPIC
|
||||
ifneq (0,$(HAVE_NL))
|
||||
CFLAGS += -DLIBIPVS_USE_NL
|
||||
CFLAGS += $(shell \
|
||||
--
|
||||
2.14.3
|
||||
|
@ -1,7 +1,7 @@
|
||||
Name: ipvsadm
|
||||
Summary: Utility to administer the Linux Virtual Server
|
||||
Version: 1.29
|
||||
Release: 7%{?dist}
|
||||
Release: 8%{?dist}
|
||||
License: GPLv2+
|
||||
URL: https://kernel.org/pub/linux/utils/kernel/ipvsadm/
|
||||
|
||||
@ -11,6 +11,7 @@ Source2: ipvsadm-config
|
||||
|
||||
Patch1: 0001-ipvsadm-catch-the-original-errno-from-netlink-answer.patch
|
||||
Patch2: 0002-libipvs-discrepancy-with-libnl-genlmsg_put.patch
|
||||
Patch3: 0003-ipvsadm-use-CFLAGS-and-LDFLAGS-environment-variables.patch
|
||||
|
||||
BuildRequires: gcc
|
||||
Buildrequires: libnl3-devel
|
||||
@ -39,10 +40,11 @@ services. Supported Features include:
|
||||
%setup -q
|
||||
%patch1 -p1
|
||||
%patch2 -p1
|
||||
%patch3 -p1
|
||||
|
||||
%build
|
||||
%set_build_flags
|
||||
CFLAGS="%{optflags}" make
|
||||
%{__make}
|
||||
|
||||
%install
|
||||
%{__rm} -rf %{buildroot}
|
||||
@ -75,6 +77,9 @@ CFLAGS="%{optflags}" make
|
||||
%{_mandir}/man8/%{name}-save.8*
|
||||
|
||||
%changelog
|
||||
* Tue Feb 27 2018 Ryan O'Hara <rohara@redhat.com> - 1.29-8
|
||||
- Use CFLAGS and LDFLAGS environment variables (#1543790)
|
||||
|
||||
* Fri Feb 23 2018 Ryan O'Hara <rohara@redhat.com> - 1.29-7
|
||||
- Add %set_build_flags (#1543790)
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user