38 lines
1.2 KiB
Diff
38 lines
1.2 KiB
Diff
--- iputils-s20140519-dist/Makefile 2014-05-19 23:35:28.000000000 +0200
|
|
+++ iputils-s20140519-new/Makefile 2014-05-20 10:51:07.388527442 +0200
|
|
@@ -26,7 +26,7 @@ USE_CAP=yes
|
|
# sysfs support (with libsysfs - deprecated) [no|yes|static]
|
|
USE_SYSFS=no
|
|
# IDN support (experimental) [no|yes|static]
|
|
-USE_IDN=no
|
|
+USE_IDN=yes
|
|
|
|
# Do not use getifaddrs [no|yes|static]
|
|
WITHOUT_IFADDRS=no
|
|
@@ -34,7 +34,7 @@ WITHOUT_IFADDRS=no
|
|
ARPING_DEFAULT_DEVICE=
|
|
|
|
# GNU TLS library for ping6 [yes|no|static]
|
|
-USE_GNUTLS=yes
|
|
+USE_GNUTLS=no
|
|
# Crypto library for ping6 [shared|static|no]
|
|
USE_CRYPTO=shared
|
|
# Resolv library for ping6 [yes|static]
|
|
@@ -49,7 +49,7 @@ ENABLE_RDISC_SERVER=no
|
|
# What a pity, all new gccs are buggy and -Werror does not work. Sigh.
|
|
# CFLAGS+=-fno-strict-aliasing -Wstrict-prototypes -Wall -Werror -g
|
|
CFLAGS?=-O3 -g
|
|
-CFLAGS+=-fno-strict-aliasing -Wstrict-prototypes -Wall
|
|
+CFLAGS+=$(RPM_OPT_FLAGS) -fno-strict-aliasing -Wstrict-prototypes -Wall -Werror
|
|
CPPFLAGS+=-D_GNU_SOURCE
|
|
LDLIB=
|
|
|
|
@@ -188,6 +188,7 @@ tftpd.o tftpsubs.o: tftp.h
|
|
|
|
# -------------------------------------
|
|
# ninfod
|
|
+ninfod: CFLAGS:=$(filter-out -Werror,$(CFLAGS))
|
|
ninfod:
|
|
@set -e; \
|
|
if [ ! -f ninfod/Makefile ]; then \
|