40 lines
1.2 KiB
Diff
40 lines
1.2 KiB
Diff
Fedora-specific makefile patch.
|
|
|
|
--- iputils-s20121205/Makefile.orig 2012-12-05 15:46:14.000000000 +0100
|
|
+++ iputils-s20121205/Makefile 2012-12-06 11:38:14.752414482 +0100
|
|
@@ -46,7 +46,7 @@
|
|
# -------------------------------------
|
|
# What a pity, all new gccs are buggy and -Werror does not work. Sigh.
|
|
# CCOPT=-fno-strict-aliasing -Wstrict-prototypes -Wall -Werror -g
|
|
-CCOPT=-fno-strict-aliasing -Wstrict-prototypes -Wall -g
|
|
+CCOPT=-fno-strict-aliasing -Wstrict-prototypes -Wall -g -Werror
|
|
CCOPTOPT=-O3
|
|
GLIBCFIX=-D_GNU_SOURCE
|
|
DEFINES=
|
|
@@ -73,7 +73,7 @@
|
|
endif
|
|
|
|
# USE_IDN: DEF_IDN, LIB_IDN
|
|
-ifneq ($(USE_IDN),no)
|
|
+ifneq ($(USE_IDN),yes)
|
|
DEF_IDN = -DUSE_IDN
|
|
LIB_IDN = $(call FUNC_LIB,$(USE_IDN),$(LDFLAG_IDN))
|
|
endif
|
|
@@ -101,7 +101,7 @@
|
|
IPV6_TARGETS=tracepath6 traceroute6 ping6
|
|
TARGETS=$(IPV4_TARGETS) $(IPV6_TARGETS)
|
|
|
|
-CFLAGS=$(CCOPTOPT) $(CCOPT) $(GLIBCFIX) $(DEFINES)
|
|
+CFLAGS+=$(RPM_OPT_FLAGS) $(CCOPTOPT) $(CCOPT) $(GLIBCFIX) $(DEFINES)
|
|
LDLIBS=$(LDLIB) $(ADDLIB)
|
|
|
|
UNAME_N:=$(shell uname -n)
|
|
@@ -178,6 +178,7 @@
|
|
|
|
# -------------------------------------
|
|
# ninfod
|
|
+ninfod: CFLAGS:=$(filter-out -Werror,$(CFLAGS))
|
|
ninfod:
|
|
@set -e; \
|
|
if [ ! -f ninfod/Makefile ]; then \
|